Jump to content

Url friendly e nome errato


polocut
 Share

Recommended Posts

Buonasera a tutti, l'altro giorno ho attivato l'url friendly, creato nuovamente l' .htaccess e il file robot.txt , creato la sitemap e indirizzata tramite google.Il problema è che guardando bene gli url alcuni sono errati e fanno una descrizione sbagliata del prodotto. In pratica a me sembra sia successo questo:

Ogni volta che dovevo mettere un nuovo prodotto, per non stare a scrivere nuovamente certe cose, facevo la copia di un prodotto poi lo modificavo a seconda dell'oggetto, ora mi ritrovo ad esempio per un url contagiri l'url : miosito/11-contachilometri quando invece dovrebbe essere miosito/11-contagiri e l'url originale dove tratta veramente il contachilometri e ho fatto la copia  si chiama correttamente miosito/10-contachilometri, a causa di questo moltissimi url sono errati,descrivono sempre il prodotto di cui ho fatto la copia,cambiandone solamente il numero identificativo, c'è una soluzione senza dover cancellare questi prodotti "doppiati" e riscriverli da zero?

Ho provato varie volte a fare un nuovo file htaccess ma nulla non cambia proprio niente.Ho cercato in giro sul forum ma non ho trovato niente di simile al mio.

Grazie a chi mi vorrà aiutare

 

Aggiorno che ho trovato come modificare gli url per i prodotti copiati, dalla scheda prodotto risulta errato l url semplificato , cliccando su crea per l'indirizzamento SEO, tutto torna alla normalità e tutto corrisponde al prodotto, solo ora dovrei ricreare gli url per ogni prodotto errato °_° , qualcuno conosce qualche modulo che ricrea in automatico gli url semplificati di tutti i prodotti?????????

Grazie

Edited by pologaso (see edit history)

Share this post


Link to post
Share on other sites

Buonasera a tutti, l'altro giorno ho attivato l'url friendly, creato nuovamente l' .htaccess e il file robot.txt , creato la sitemap e indirizzata tramite google.Il problema è che guardando bene gli url alcuni sono errati e fanno una descrizione sbagliata del prodotto. In pratica a me sembra sia successo questo:

Ogni volta che dovevo mettere un nuovo prodotto, per non stare a scrivere nuovamente certe cose, facevo la copia di un prodotto poi lo modificavo a seconda dell'oggetto, ora mi ritrovo ad esempio per un url contagiri l'url : miosito/11-contachilometri quando invece dovrebbe essere miosito/11-contagiri e l'url originale dove tratta veramente il contachilometri e ho fatto la copia  si chiama correttamente miosito/10-contachilometri, a causa di questo moltissimi url sono errati,descrivono sempre il prodotto di cui ho fatto la copia,cambiandone solamente il numero identificativo, c'è una soluzione senza dover cancellare questi prodotti "doppiati" e riscriverli da zero?

Ho provato varie volte a fare un nuovo file htaccess ma nulla non cambia proprio niente.Ho cercato in giro sul forum ma non ho trovato niente di simile al mio.

Grazie a chi mi vorrà aiutare

 

Aggiorno che ho trovato come modificare gli url per i prodotti copiati, dalla scheda prodotto risulta errato l url semplificato , cliccando su crea per l'indirizzamento SEO, tutto torna alla normalità e tutto corrisponde al prodotto, solo ora dovrei ricreare gli url per ogni prodotto errato °_° , qualcuno conosce qualche modulo che ricrea in automatico gli url semplificati di tutti i prodotti?????????

Grazie

Risolto rinominando uno per uno i prodotti :( dopo un giorno intero sono riuscito a correggere tutti gli url errati.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More