Jump to content
Mastrolind0

(gelöst)iframe im CMS

Recommended Posts

Hallo zusammen.

 

Kann mir bitte jemand erklären wie ich in den CMS "iframe" aktivieren (einfügen) kann. Ich habe es nach dieser Anleitung versucht.

 

http://mypresta.eu/en/art/know-how/tinymce-editor-full-options-all-html-tags.html

 

http://mypresta.eu/en/art/developer/prestashop-product-page-full-rich-editor.html#validate_class_change

 

Die erste funkt auch. Der Editor hat dann mehr Knöpfe aber wenn ich validate.php ändere und meine Seite neu lade bleibt diese leer.

 

Mein Prestashop ist 1.5.6

 

Vielen Dank im vorraus!

 

Gruß Peter

 

Hallo zusammen.

 

Kann mir bitte jemand erklären wie ich in den CMS "iframe" aktivieren (einfügen) kann. Ich habe es nach dieser Anleitung versucht.

 

http://mypresta.eu/en/art/know-how/tinymce-editor-full-options-all-html-tags.html

 

http://mypresta.eu/en/art/developer/prestashop-product-page-full-rich-editor.html#validate_class_change

 

Die erste funkt auch. Der Editor hat dann mehr Knöpfe aber wenn ich validate.php ändere und meine Seite neu lade bleibt diese leer.

 

Mein Prestashop ist 1.5.6

 

Vielen Dank im vorraus!

 

Gruß Peter

Edited by Mastrolind0 (see edit history)

Share this post


Link to post
Share on other sites

Das scheint mir aber wohl nicht an der Auskommentierung in der validate.php zu liegen. Wie sind denn deine Änderung der form.tpl aus? Denn die Funktion ist ja in 1.5.6 nicht ganz genauso, wie sie vekia zitiert.

 

Man kann es immer noch so machen wie seit 1.5.3, und zwar in ADMIN_DIR/themes/default/template/controllers/product/helpers/form/form.tpl

{if isset($tinymce) && $tinymce}
    <script type="text/javascript">

    var iso = '{$iso}';
    var pathCSS = '{$smarty.const._THEME_CSS_DIR_}';
    var ad = '{$ad}';

    $(document).ready(function(){
        {block name="autoload_tinyMCE"}
            tinySetup({
                editor_selector :"autoload_rte",
                theme_advanced_buttons1 : "newdocument,|,bold,italic,underline,strikethrough,|,justifyleft,justifycenter,justifyright,justifyfull,styleselect,formatselect,fontselect,fontsizeselect",
                theme_advanced_buttons2 : "cut,copy,paste,pastetext,pasteword,|,search,replace,|,bullist,numlist,|,outdent,indent,blockquote,|,undo,redo,|,link,unlink,anchor,image,cleanup,help,code,,|,forecolor,backcolor",
                theme_advanced_buttons3 : "tablecontrols,|,hr,removeformat,visualaid,|,sub,sup,|,charmap,media,|,ltr,rtl,
                theme_advanced_buttons4 : "styleprops,|,cite,abbr,acronym,del,ins,attribs,pagebreak"
            });
        {/block}
    });
    </script>
{/if}
Edited by eleazar (see edit history)

Share this post


Link to post
Share on other sites

Hallo eleazar!

 

Vielen Dank für deine Antwort!

 

Meine Änderungen in der form.tpl (_ADMIN_DIR_/themes/default/template/helpers/form/form.tpl) sehen so aus:

$(document).ready(function(){
        {block name="autoload_tinyMCE"}
            tinySetup({
                editor_selector :"autoload_rte",
                                  theme_advanced_buttons1 : "save,newdocument,bold,italic,underline,strikethrough,justifyleft,justifycenter,justifyright,justifyfull,styleselect,formatselect, fontselect,fontsizeselect",
                                  theme_advanced_buttons2 : "cut,copy,paste,pastetext,pasteword,search,replace,bullist,numlist,outdent,indent,blockquote,undo,redo,link,unlink,anchor,image,cleanup,help,codemagic,insertdate,inserttime,preview,forecolor,backcolor",
                                  theme_advanced_buttons3 : "code,tablecontrols,hr,removeformat,visualaid,sub,sup,charmap,emotions,iespell,media,advhr,print,ltr,rtl,fullscreen",
                                  theme_advanced_buttons4 : "styleprops,cite,abbr,acronym,del,ins,attribs,visualchars,nonbreaking,template,pagebreak,restoredraft,visualblocks",
                                  theme_advanced_toolbar_location : "top",
                                  theme_advanced_toolbar_align : "left",
                                  theme_advanced_statusbar_location : "bottom",
                                  theme_advanced_resizing : false,
                                                    extended_valid_elements: 'pre[*],script[*],style[*]',
                                                    valid_children: "+body[style|script],pre[script|div|p|br|span|img|style|h1|h2|h3|h4|h5],*[*]",
                                                    valid_elements : '*[*]',
                                                    force_p_newlines : false,
                                                    cleanup: false,
                                                    forced_root_block : false,
                                                    force_br_newlines : true
            });
        {/block}
    });

Ich habe zwar die von dir angegebene .tpl gefunden weiß aber nicht genau wo ich den Code einfügen soll.

Share this post


Link to post
Share on other sites

Ich ziehe meinen Vorschlag wieder zurück, weil der ebenso wie deiner nur ines bewirken würde - dass das gesamte Menü des Editors in allen Programmteilen verschwindet. Offenbar ist der Fehler der verschwundenen Bearbeitungs-Icons in 1.5.6.1 auch so behoben, wenn es vermutlich auch nicht so viele sind, wie du gern haben möchtest.. Ich rate daher, bei der ursprünglichen Fassung

	$(document).ready(function(){
		{block name="autoload_tinyMCE"}
			tinySetup({
				editor_selector :"autoload_rte"
			});
		{/block}

zu bleiben.

Share this post


Link to post
Share on other sites

Problem gelöst!!

 

Ich war nur zu dumm die iframes in Prestashop Einstellungen zu aktivieren.

 

Vielen Dank für deine Bemühungen!!

 

Gruß Peter

Share this post


Link to post
Share on other sites

Seltsam, ich hatte sie nämlich die ganze Zeit über aktiviert. :wacko:

 

EDIT: Nur hatte ich demgegenüber vergessen, die Zeilen 402-403 der /classes/validate.php auszukommentieren:

//if (preg_match('/<[\s]*script/ims', $html) || preg_match('/('.$events.')[\s]*=/ims', $html) || preg_match('/.*script\:/ims', $html))
//	return false;

Problem ebenfalls gelöst. :)

Edited by eleazar (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More