en Jump to content
  • 0
Mehdib92

[SOLVED] Error when installing a module

Question

Hi,

 

I'm developing a module and when I wanted to install it, I had an message

 

Module(s) installed successfully.

 

and under the message, I have the error 

 

You do not have permission to configure this module.

 

So I changed the user from SuperAdmin to Admin and whien i try to install the module, I have the following error :

 

No access reference in table module_access for id_module .
at line 1814 in file classes/module/Module.php.

 

I don't really understand where the error come from...

 

Thanks

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Do you try to go directly from the install function to a configuration screen?

If so: Seems that the installation goes OK, but that moving to the configuration goes too early for the admin test procedure, as if the module is not 'Okay-ed' for the superuser yet at this point. Maybe make it  two steps. First just install, then click on configure in the module list, and see if that works.

 

If this is not it, then, as Vekia suggested, showing some code would indeed help here...

My 2 cents,

pascal.

Share this post


Link to post
Share on other sites
  • 0

hello

 

thank you for information where the problem was and how you solved it :)

it will be helpful for other developers with similar problems 

 

i marked whole topic as [solved]

 

with regards,

Milos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More