Jump to content
designer13

1045 - Access denied for user 'w0112c80'@'localhost' (using password: NO) [MOD SQL Error]

Recommended Posts

Hallo,

 

ich habe mir heute Prestashop runtergeladen und bereits auf meinen ALL-INKL.COM Account geladen.

Installation habe ich auch bereits ausgeführt, Datenbank neu angelegt.

 

Die Standart-Seite mit "YourLogohere" wird auch schon angezeigt und funktioniert auch problemlos.

 

Das Problem ist, dass immer wenn ich mich versuche einzuloggen unter www.shop.meineseite.de/admin

kommt folgender Fehler:

 

1045 - Access denied for user 'w0112c80'@'localhost' (using password: NO)

[MOD SQL Error]

 

Ich weiß nicht woran das liegen könnte, ich hoffe Sie/Ihr könnt mir weiter helfen!

 

Viele Grüße und Danke vorab!

designer13

Share this post


Link to post
Share on other sites

Falsches Passwort in der Config.php für den SQL Server?

 

 

Grüsse

 

Hallo,

 

Danke erstmal für Ihre Hilfe!

Leider habe ich absolut keine Ahnung wie ich das Überprüfen kann.

 

Über eine kurze Erklärung würde ich mich freuen!

 

Viele Grüße

designer13

Share this post


Link to post
Share on other sites

Also die Angaben zur Datenbank des Shop finden sich in /config/settings.inc.php ca in den zeilen 10 -15

 

Aber, die oben angeführte Fehlermeldung kenne ich nur von "mysqldump". Das ist ein Programm auf dem Webserver mit dem in der Shell oder in Shell-Skripten die Datenbanken auslesen kann.

Ich verwende das zum Beispiel bei mehreren Kundenservern zum automatischen erstellen von Backups ( Ein Cronjob ruft ein Shellskript auf, das dann wiederum mysqldump aufruft...)

Dieses Tool mag es allerdings manchmal nicht, wenn die Datenbankpasswörter Sonderzeichen beinhalten.

Im Shop und auch beim manuellen Aufrufen meines Backupskriptes mit manueller Eingabe des Passwortes war immer alles in Ordnung. Nur bei automatischen Aufruf mag er die Sonderzeichen nicht.

 

Eigentlich sollte es sich bei Deinem Problem aber eher weniger um diesen Fehler handeln.

 

LG Klaus / Lockesoft

  • Like 1

Share this post


Link to post
Share on other sites

Hallo,

 

Danke erstmal für die Hilfe.

Jetzt stellt sich aber ein neues Problem heraus, wenn ich nämlich auf die LogIn Seite des PrestaShops gehen möchte, bekomme ich folgende Fehlermeldung:

 

Es ist ein Fehler aufgetreten!
There was an error!
Il y avait une erreur!

 

Dabei handelt es sich nicht um eine Fehlermeldung des Servers, deshalb muss es sich um einen Fehler von Prestashop handeln.

 

Viele Grüße

designer13

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More