Jump to content
AllSmart

Producten niet meer beschikbaar na verkoop

Recommended Posts

Ik heb een serieus probleem met Prestashop 1.5.6.

 

Nadat een product is verkocht en betaald, is deze niet meer beschikbaar. Het product is wel te zien in de winkel en in de categorieen, maar als je er op klikt, ga je rechtstreeks naar de "Oops, something went wrong" pagina.

 

Ik heb error reporting aangezet, zie hieronder:

 

[PrestaShopException]

Invalid product vars
at line 104 in file classes/Link.php

98. 			if (is_array($product) && isset($product['id_product']))
99. 				$product = new Product($product['id_product'], false, $id_lang, $id_shop);
100. 			elseif ((int)$product)
101. 				$product = new Product((int)$product, false, $id_lang, $id_shop);
102. 			else
103. 				throw new PrestaShopException('Invalid product vars');
104. 		}
105. 
106. 		// Set available keywords
107. 		$params = array();
108. 		$params['id'] = $product->id;

 

Het adres van mijn winkel is allsmart.nl

 

Onderstaande producten heb ik zelf gekocht als test

- Aeon Labs Z-Wave Panic Button (https://allsmart.nl/...e-panic-button/)

- Aeon Labs Z-Wave Key-fob (https://allsmart.nl/...tandsbediening/)

 

Wat ik al heb geprobeerd is:

- cache verwijderd

- 1 product per bestelling / meerdere producten per bestelling

- verschillende betaalmethodes

 

Ieder product wat gekocht is, eindigt op de "Oops" pagina.

Zelf proberen kan (gebruik land Belgie en betaalmethode "Mister Cash") Dan kun je een order "kopen" met een test-betaling. Het product wat je hebt gekocht is vervolgens niet meer beschikbaar.

 

Het vreemde is dat als ik de order annuleer of geld terug geef, dan is het product weer beschikbaar zoals het hoort...

 

Help aub!

Dit is urgent, zo kan ik mijn winkel niet live zetten. Wie kan me helpen, waar kan evt. terecht?

Share this post


Link to post
Share on other sites

Ik heb een serieus probleem met Prestashop 1.5.6.

 

Nadat een product is verkocht en betaald, is deze niet meer beschikbaar. Het product is wel te zien in de winkel en in de categorieen, maar als je er op klikt, ga je rechtstreeks naar de "Oops, something went wrong" pagina.

 

Ik heb error reporting aangezet, zie hieronder:

 

 

Het adres van mijn winkel is allsmart.nl

 

Onderstaande producten heb ik zelf gekocht als test

- Aeon Labs Z-Wave Panic Button (https://allsmart.nl/...e-panic-button/)

- Aeon Labs Z-Wave Key-fob (https://allsmart.nl/...tandsbediening/)

 

Wat ik al heb geprobeerd is:

- cache verwijderd

- 1 product per bestelling / meerdere producten per bestelling

- verschillende betaalmethodes

 

Ieder product wat gekocht is, eindigt op de "Oops" pagina.

Zelf proberen kan (gebruik land Belgie en betaalmethode "Mister Cash") Dan kun je een order "kopen" met een test-betaling. Het product wat je hebt gekocht is vervolgens niet meer beschikbaar.

 

Het vreemde is dat als ik de order annuleer of geld terug geef, dan is het product weer beschikbaar zoals het hoort...

 

Help aub!

Dit is urgent, zo kan ik mijn winkel niet live zetten. Wie kan me helpen, waar kan evt. terecht?

En hoe zit het met de voorraad van de betreffende producten en de instellingen voor verkoop indien niet op voorraad?

Share this post


Link to post
Share on other sites

@scorpionsworld: Voorraadbeheer is uitgeschakeld.

 

Nu komt het weer voor, ik word hier helemaal gek van.

Kan iemand mij helpen, ben bereid te betalen. Ik kan niet de hele tijd producten blijven kopieren, dat is zo slecht voor seo / google.

 

Please help.. :(

Share this post


Link to post
Share on other sites

Voor alle zekerheid heb ik voorraadbeheer ingeschakeld. Nog steeds niet opgelost...

En als je de crossselling module eens uitschakelt?

  • Like 1

Share this post


Link to post
Share on other sites

Dat heeft inderdaad het probleem verholpen. Dit is zonet ook op het US forum geadviseerd, was nog niet zover om deze post bij te werken. Mijn eigen theme heeft een eigen cross selling module, dit veroorzaakte wellicht het probleem.

 

Alsnog super bedankt voor de correcte oplossing die je hebt aangedragen, TOP!

Share this post


Link to post
Share on other sites

Dat heeft inderdaad het probleem verholpen. Dit is zonet ook op het US forum geadviseerd, was nog niet zover om deze post bij te werken. Mijn eigen theme heeft een eigen cross selling module, dit veroorzaakte wellicht het probleem.

 

Alsnog super bedankt voor de correcte oplossing die je hebt aangedragen, TOP!

Graag gedaan :)

Ik vraag me dan alleen af wat er dan mis gaat in die crossselling module, maar dat is mijn debugging mind...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More