Jump to content

Recommended Posts

bonjour,

j'ai un souci, j'ai mis à jour mon site via le module one click and....

et maintenat j'ai une page blanche quand je veux ouvrir le front ou le back.

que dois je faire?

merci.

Share this post


Link to post
Share on other sites

j'ai déjà lu ce topic et je n'ai pas trouvé de solution, c'est pourquoi j'ai créer celui-ci afin d'avoir une personne généreuse, qui pourrais prendre un peu de son temps afin de m'aider à trouver une solution.

Share this post


Link to post
Share on other sites

Ok deuxième étape il est difficile de dire quel est la cause d'une page blanche, ça peut être à cause d'un fichier altéré, un fichier manquant

ou selon l'hébergeur il faut activé le php5 en mettant une ou de lignes spécifiques dans le .htaccess

 

Avez-vous fait un ctrl+F5 pour vider le cache du navigateur et videz le cache smarty et compile ?

 

La ligne sur une 1.4 dans config/config.inc.php
@ini_set('display_errors', 'off'); << mettez off à on >> @ini_set('display_errors', 'on');

La ligne sur une 1.5 dans config/defines.inc.php
define('_PS_MODE_DEV_', false); << mettez false à true >> define('_PS_MODE_DEV_', true);
 

Si c'est un problème d'interprétation d'un fichier vous aurez un message d'erreur copier-coller ici, si le nom de votre dossier d'administration apparait remplacez le par des *******

Share this post


Link to post
Share on other sites

oui j'ai vidé le cache, mais je ne trouve pas cette ligne dans config.inc.php, par contre maintenat j'ai :Error: "install" directory is missing quand je veux accéder sur mon site.

www.street-of-shop.com

Share this post


Link to post
Share on other sites

Bonjour

 

oui sur la 1.5 dans config/defines.inc.php
define('_PS_MODE_DEV_', false); << mettez false à true >> define('_PS_MODE_DEV_', true);

 

Je pense que vous avez un fichier qui est altéré ne sachant pas lequel, supprimer le dossier /classes/ et prenez un dossier classes dans un zip il se peut aussi que ce soit dans le dossier controllers, j'ai eu un cas où après avoir remis un dossier classes et controllers le problème s'était résolu

Share this post


Link to post
Share on other sites

je crois que j'ai fais une bêtise , au début quand j'avais juste la page blanche j'avais supprimé le dossier config ,puis j'ai remis un nouveau.

y avait il des fichiers important dedans?

quand j'ai fais ça, j'ai ce message qui c'est affiché.

Edited by tonyxxl (see edit history)

Share this post


Link to post
Share on other sites

Vous ne pouvez pas récupérer le setting.inc que vous aviez en local et modifier les accès de base de donnée ?

C'est le fichier qui manque et que se génère à l'installation.

 

Si vous ne l'avez pas, je vous conseille de faire une installation en local et de récupérer le fichier setting.inc, puis de modifier les accès à la base de donnée.

Edited by Bondaty and Co (see edit history)

Share this post


Link to post
Share on other sites

Désolé, mais il un peu tard pour entrer dans les détail.

 

En local, vous installez presta ( si vous ne savez pas faire, pas mal de topics en parlent)

Ensuite, vous récupérez votre setting dans le dossier config

Vous remplacez les paramètres de base de donnée par ceux de votre site

nom de la base

user

mot de passe

Puis vous envoyez le fichier dans votre dossier config de votre site

Videz bien tous les caches

Share this post


Link to post
Share on other sites

Plusieurs solutions à tester :

 

un dossier /config/

 

1° la meilleur avoir la copie du settings.inc.php

2° Prendre un autre settings.inc.php mais là faudra recommencer avec les mots de passe

3° faire une nouvelle installation avec une autre base de donnée, une fois le site créer récupérer le settings.inc.php et la table employée avec le mot de passe de l'administrateur (s'il y a que lui) et remplacez l'ancienne table employée.

 

Théoriquement ça devrait fonctionner :)

Share this post


Link to post
Share on other sites

j'ai essayé de faire une nouvelle installation mais maintenant j'ai :Oops, something went wrong.

Try to refresh this page or feel free to contact us if the problem persists. avec en haut your logo here , je ne comprend plus rien j'ai l'impression de m'enfoncer toujours plus

Share this post


Link to post
Share on other sites

donc j'ai télécharger la version 1.5.6.1 que j'ai mis en local afin de l'installer.

cependant quand j'ai fais ceci j'avais un message:(You don't have permission to access / on this server.)

donc j'ai lu sur un forum qu'il fallait renommer le htaccess en htaccess_old.

ce qui ma fait le message que j'ai mis plus haut

Share this post


Link to post
Share on other sites

donc j'ai un nouveau message quand je tape www.street-of-shop.com à la fin il y a www.street-of-shop.com/fr qui s'inscrit et j'ai ce message:

The requested URL /fr/ was not found on this server.

Apache/2.2.16 (Debian) Server at www.street-of-shop.com Port 80

Share this post


Link to post
Share on other sites

donc j'ai télécharger la version 1.5.6.1 que j'ai mis en local afin de l'installer.

cependant quand j'ai fais ceci j'avais un message:(You don't have permission to access / on this server.)

donc j'ai lu sur un forum qu'il fallait renommer le htaccess en htaccess_old.

ce qui ma fait le message que j'ai mis plus haut

Ce message vous l'avez où ? en local ou en ligne.

 

la base de donnée avant que vous changiez le module en avez-vous une sauvegarde ?

 

De ce que je disais pour une nouvelle installation était sous-entendue dans un autre dossier avec une autre base de donnée, vu que c'était pour récupérer une table dans la base de donnée et le fichier settings.inc.php

 

Je n'ai hélas pas préciser autre dossier, mais c'est expliquer sur plusieurs topics au sujet du dossier /config/ et settings.inc.php combien de fois j'ai écris de sauvegarder au minimum ce fichier et le dossier /img/

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

Oui parce qu'il cherche un dossier install, est-ce que vous avez laissé le dossier install sur le FTP ?

Vous avez vider le cache :

/cache/smarty/cache & /cache/smarty/compile
Supprimer tous les fichiers et dossiers sauf le index.php s'il y est.
 

et un bon ctrl+F5 pour vider le cache de votre navigateur.

Share this post


Link to post
Share on other sites

je l'ai en ligne, si vous allez sur mon site www.street-of-shop.com la j'ai mis le htaccess en old .

j'ai une sauvegarde qui date un peu, mais oui j'en ai une

ok donc tout n'est pas perdu, les images vous en avez une sauvegarde (le dossier /img/) vous avez combien de produits ?

Share this post


Link to post
Share on other sites

je l'ai mis, j'ai remis le htaccess normal mais j'ai toujours page blanche

autant pour moi j'ai toujours le message d'erreur:

You don't have permission to access / on this server.

Apache/2.2.16 (Debian) Server at www.street-of-shop.com Port 80

pour ce qui est du dossier img je suppose que c'est le img old, c'est bien ça?

Share this post


Link to post
Share on other sites

juste une question , si je remets l'ancienne version (celle avant la mise à jour raté), ca peut marcher ou je vais tout perdre?

Si vous avez une sauvegarde de la base de donnée d'avant et que vous remettez les fichiers de l'ancienne version + le settings.inc.php qui correspond et le dossier /img/

 

Oui ça marche à part les produits que vous avez mis par après, ou les clients qui se sont inscris après.

 

Pour votre dossier /img.old  ou img_old c'est ce qu'on mets quand on veut ne pas utiliser ou qu'on a mis un nouveau dossier, ou qu'on garde comme sauvegarde. old ou bak

Share this post


Link to post
Share on other sites

 

autant pour moi j'ai toujours le message d'erreur:

You don't have permission to access / on this server.

Apache/2.2.16 (Debian) Server at www.street-of-shop.com Port 80

 

Vérifiez si vous avez tous les fichiers, si le index.php y est, et selon l'hébergeur il faut ajouter une ou deux lignes dans le .htaccess

Il vous manque quelque chose ce qui provoque cette page d'erreur une sécurité qui indique que vous n'avez pas la permission de visualiser et/ou exécuter.

 

Sous conditions que vous n'avez pas fait de modification dans le panel de gestion de votre Hébergement

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

j'ai réussi à installer denouveau prestashop, cependant il est vierge .

comment puis remettre tout ce que j'avais?

Bonjour

 

Vous avez le dossier /img/ avec les photos/images des produits ? donc ok

Votre base de donnée avec les produits vous 'importer dans une base de donnée vide créer en une deuxième ou en local

via phpmyadmin

Puis vous faites une exportation des produits en cochant la table des produits et un export en fichier *.csv

Puis vous importer dans la nouvelle base de donnée, si vous avez le dossier /img/ vous le remplacez.

 

Idem pour le reste qui est nécessaire export en fichier csv

 

Vous avez des clients ? combien ? dans la base de donnée ?

 

Attention avant toute action Sauvegarde Sauvegarde nommer les bien de quoi date heure exemple : produit-12-12-2013-13_40.csv

 

Avant d'importer dans la nouvelle base Sauvegarde basededonne-vierge-12-12-2013-13_40.csv 13_40 = 13:40 = 13h40

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More