Jump to content

problem przy tłumaczeniu szablonu na 1.5.6.1


Recommended Posts

witam

zainstalowałem skrypt sklepu w wersji 1.5.6.1 na serwerze az.pl, zaimportowałem język polski i zrobiłem tłumaczenie domyślnego szablonu na polski przy użyciu Lokalizacja>>Tłumaczenia no i wszystko pięknie się uzupełniło.

 

problem pojawił się po zakupie i próbie tłumaczenia szablonu:

 

http://addons.prestashop.com/pl/moda-odziez-obuwie/7189-fashionate-multilingual-html5-responsive-premium-theme.html

 

próbując analogicznie go przetłumaczyć brakuje ponad 200 fraz i pytanie z czego to wynika? jakaś niekompatybilność szablonu (na stronie z szablonem jest adnotacja iż nadaje się do wersji 1.5.6.1 lecz przy instalacji wyskakuje info This theme is for Prestashop v1.5.1.0 -> v1.5.5.0)  i trzeba będzie to ręcznie dogrywać czy gdzieś coś pominąłem i można to z automatu wczytać i uzupełnić?

 

 

ostatecznie próbowałem przekopiować dane z domyślnego szablonu po polsku na nowy PL szablon lecz też to nie poskutkowało... 

 

z ciekawości zrobiłem też tłumaczenie na inne języki (w szablonie były dodatkowe pliki tłumaczeń de.php, it.php...) i też brakowało wielu standardowych fraz...

 

duże braki występują również przy tłumaczeniu modułów

 

szukałem na forum podobnych wątków lecz żadne sugestie nie pomogły rozwiązać mojego problemu

 

z góry dziękuje za podpowiedzi

 

pozdr.

Piotr

Share this post


Link to post
Share on other sites

tłumaczeń jest więcej bo być może ten szablon wykorzystuje więcej fraz? To samo dotyczy plików .tpl modułów znajdujących się w szablonie.

Jeżeli tak jest... to całkowicie normalna sprawa, że tych tłumaczeń brakuje, że tak powiem - z powietrza się nie wezmą ;)

Share this post


Link to post
Share on other sites

też o tym pomyślałem na początku ale po szybkim sprawdzeniu wyszło ze domyślny szablon ma 1341 wyrażeń tłumaczonych też na PL a zakupiony szablon 783 z czego ponad 1/4 nie "złapało" i wysypały się np wyrażenia ze strony "404" która w default jest.

Share this post


Link to post
Share on other sites

Miałem ten sam  problem po zmianie szablonu zaraz poszukam rozwiązania było to opisane na forum przezemnie.

 

Kurde pech chciał że nie opisałem tego problemu generalnie musisz pokombinowac w miejscu gdzie można samemu wpisać tłumaczenia tam poklikałem i cała lista mi się zainportowała i może nie przetłumaczone były tylko 3- 4 teksty....

Edited by kaczor18 (see edit history)

Share this post


Link to post
Share on other sites

też o tym pomyślałem na początku ale po szybkim sprawdzeniu wyszło ze domyślny szablon ma 1341 wyrażeń tłumaczonych też na PL a zakupiony szablon 783 z czego ponad 1/4 nie "złapało" i wysypały się np wyrażenia ze strony "404" która w default jest.

 

pytanie czy te frazy odpowiadają frazom z standardowej templatki.

np. "categories" to nie to samo co "categories block"

warto sprawdzić pod tym kątem

Share this post


Link to post
Share on other sites

global $_LANG;
$_LANG = array();

$_LANG['live_edit_d3d2e617335f08df83599665eef8a418'] = 'Close';
$_LANG['live_edit_ea4788705e6873b424c65e91c2846b19'] = 'Cancel';
$_LANG['live_edit_da87eac3848a0d55560bdd129a0e134b'] = 'Unable to unregister the hook';
$_LANG['live_edit_79030d996976f29a5e986a42d8f026e5'] = 'Unable to save the module\'s position';
$_LANG['live_edit_c9cc8cce247e49bae79f15173ce97354'] = 'Save';
$_LANG['live_edit_d8dcfab18b3a6eba56d617dd1dcb1ba7'] = 'Close LiveEdit';
$_LANG['404_8cf04a9734132302f96da8e113e80ce5'] = 'Home';
$_LANG['404_13348442cc6a27032d2b4aa28b75a5d3'] = 'Search';
$_LANG['addresses_06933067aafd48425d67bcb01bba5cb6'] = 'Update';
$_LANG['addresses_729a51874fe901b092899e9e8b31c97a'] = 'Are you sure?';
$_LANG['addresses_f2a6c498fb90ee345d997f888fce3b18'] = 'Delete';
$_LANG['addresses_b15e1100a6196acba01ef7aaa5b2a9e5'] = 'Add a new address';
$_LANG['addresses_8cf04a9734132302f96da8e113e80ce5'] = 'Home';

 

Share this post


Link to post
Share on other sites

$_LANG['404_44b1d05764b093cb00c25b8228cb87d3'] = 'Strona niedostępna';

$_LANG['404_6554aae881e40036cac1f5710a4c52c1'] = 'Niestety podany przez ciebie adres strony nie jest dostępny';

$_LANG['404_9bec38acab82302a8cf6fbb9182da21f'] = 'Aby wyszukać produkt wpisz jego nazwę w polu poniżej';

$_LANG['404_a68ba7d969d1294a35138fa501dfb078'] = 'Przeszukaj katalog naszych produktĂłw:';

$_LANG['404_8cf04a9734132302f96da8e113e80ce5'] = 'Strona główna';

$_LANG['404_13348442cc6a27032d2b4aa28b75a5d3'] = 'Szukaj';

 

 

i wychodzi na to że przy jakimkolwiek tłumaczeniu nowego szablonu dane do tłumaczenia są pobierane właśnie jako wzorzec z tej EN paczki i brakujące frazy są pomijane pomimo ich spolszczenia..

nie wiem czy dobrych miejscach kopie ale to jedyne co mi się udało ustalić, walczę już z tym 2 dzień i jak tak dalej pójdzie to będę wyglądał jak yeti

zrobiłem też świeżą instalkę bez żadnych nowych szablonów i default theme przy analizie tłumaczenia na EN pokazuje właśnie wiele braków

Share this post


Link to post
Share on other sites

 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More