en Jump to content
El Patron

[Free Module] Admin Alerts Email For New Customer Registration

Recommended Posts

Any idea why it is always showing me the same country?, so basicly new customer from UK, but then email arrive with "Netherlands" as country while it is set to UK in the actual new account.

 

it's possible I made a mistake in code

 

please try:

//change this line in modules/registeredmailonly/registeredmailonly.php

,'{country}' => $country_name

//to this:

,'{country}' => $custInfo['country']


//I did not test this, so please make sure to make back up copy of file first.
//let me know if this sovles

Share this post


Link to post
Share on other sites

Im having trouble to make it work. My shop is in spanish AR. 

How can i copy and paste the lenguage files or folder in order to make it work?

Thanks

 

from original posting, use ftp or your hosting control panel,  download ES-->rename to AR-->re-upload to mails folder....good luck and  happy selling.

NOTE: modules/registermailonly/mails/ has ONLY DE EN ES FR IT Languages, if your shop has different languages,  then copy one of the existing and rename to your language, then use PrestaShop translation in back office for actual translation!

Share this post


Link to post
Share on other sites

from original posting, use ftp or your hosting control panel,  download ES-->rename to AR-->re-upload to mails folder....good luck and  happy selling.

NOTE: modules/registermailonly/mails/ has ONLY DE EN ES FR IT Languages, if your shop has different languages,  then copy one of the existing and rename to your language, then use PrestaShop translation in back office for actual translation!

Thanks! It worked perfect! One of the most usefull modules on presta ever! How can i rate it?

Share this post


Link to post
Share on other sites

Thanks! It worked perfect! One of the most usefull modules on presta ever! How can i rate it?

 

Thank you for kind words, you can just click the like button anywhere you see me post. :)  

 

Happy selling, Fred

Share this post


Link to post
Share on other sites

So, it does not work in Prestashop 1.6.1.5 :(

Could you fix it, please?

 

Hi,  this works in 1.6.1.5...I blame you....lol

 

What is problem exactly?

 

Happy day, el

Share this post


Link to post
Share on other sites

Hi,

the module was installed correctly. I specified email for notices in settings.

But nothing occurs at registration of the new buyer, the notice does not send.
Of course, I checked spam folder, there is empty.

Prestashop 1.6.1.5 (russian localization)

Share this post


Link to post
Share on other sites

Hi,

the module was installed correctly. I specified email for notices in settings.

But nothing occurs at registration of the new buyer, the notice does not send.

Of course, I checked spam folder, there is empty.

Prestashop 1.6.1.5 (russian localization)

 

 

Hi 

Have you got rs mail folder in modül?

l use its work perfect.

 

askinjew is correct, there is no translation for rs included, please add one and you should be fine!

Share this post


Link to post
Share on other sites

Hi i just installed htis module on my 1.6.1.12..italian version .does not work....

 

stefano

 

Hi stefano, how does it not work?  Make sure module mails folder has .it email, if not create one.

Share this post


Link to post
Share on other sites

Hi El Patron,

 

Good day!

 

I already downloaded and installed your registermailonly.zip addons and configure by putting my Sender Email and tried to register but the New Registered User did not receive any email. May I ask for your kind help why or what is really the issue. My Default Language is "English", set Language from Browser is "Yes", my Default Country is "Philippines", also as a Default Country. Language Identifier is "EN" .

 

Really hoping for your kind help....

Share this post


Link to post
Share on other sites

Hi El Patron,

 

Good day!

 

I already downloaded and installed your registermailonly.zip addons and configure by putting my Sender Email and tried to register but the New Registered User did not receive any email. May I ask for your kind help why or what is really the issue. My Default Language is "English", set Language from Browser is "Yes", my Default Country is "Philippines", also as a Default Country. Language Identifier is "EN" .

 

Really hoping for your kind help....

 

Hi, the only thing that ever caused the module not to send email is lack of translated email but if you are using en, I cannot guess what  might be issue.  If you visit my shop and click the contact us button and send infos, (need access to admin) I would be happy to take a look.

 

Happy PrestaShopping, el

Share this post


Link to post
Share on other sites

Hi there, thanks for module at first,

 

I have some issue related to other module install, then i cant receive registration email anymore, im looking for the thing overrided, i see module not have overrides, how i can be able to include resgistermailonly.php in the prestashop core?

Is it posible? or modify overrides?

 

Hope you can help me, is a very usefull module. Thanks, best regards.

Share this post


Link to post
Share on other sites

Hello, The client must receive an alert ? if this is the case it does not work. This alert BackOffice exists on version 1.6? 

 

Thank you 

Edited by Soyons zen

Share this post


Link to post
Share on other sites

Hello, The client must receive an alert ? if this is the case it does not work. This alert BackOffice exists on version 1.6? 

 

Thank you 

 

Hi, the  customer does not received additional registration alert just the admin.

 

happy selling, el

Share this post


Link to post
Share on other sites

Hi, the  customer does not received additional registration alert just the admin.

 

happy selling, el

 

Hi there, you have reason, im able to receive admin email, but i have installed a module that send verification email to customer, and i didnt receive admin mail again.

Anyway if customer account is activated or not.

Ive reinstalled, turn off-on different options, and ive see is an Authcontroller.php override, in some part this one is "blocking" or something like this the registeremailonly emails. (Can i share this part and you try to help me running both at the same time? Please?)

Nothing in Register/Logs showing any problem. 

 

Thanks anyway, best regards.

Share this post


Link to post
Share on other sites

Hi, not at this time.  We are  working to upgrade modules to 1.7 and will post back here when completed.

 

Hello.

 

Could you tell me when this module would be available in 1.7.0.5?
 
Thank you

Share this post


Link to post
Share on other sites
8 hours ago, Steve Vandenbossche said:

Hi El Patron, thanks a lot for this module

 

You are very welcome and thanks for taking time to write.  I need to do the 1.7 version I know but I still have paid modules yet to upgrade, in-house client work keeps us 'very' busy if you can imagine.  Happy selling, el

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More