Jump to content

Recommended Posts

Bonjour la communauté.

 

Tout d'abord je tiens à dire que j'ai parcouru l'aide du forum sans trouver de réponse à mon problème ou du moins pas exactement.

 

Voilà, je suis en train de mettre à jour manuellement une boutique version 1.4.3 vers 1.5.4. J'ai suivi chaque étape précisément. Après avoir transféré le nouveau dossier prestashop sur mon serveur, je me suis rendu sur ma boutique mais j'ai obtenu la fameuse page blanche ainsi qu'un non accès au back office. 

Après avoir ajouter la ligne de debug, j'arrive à visualiser :
 

Fatal error: Uncaught Table 'coffinrock.cr_shop_url' doesn't exist<br /><br /><pre>SELECT s.id_shop, CONCAT(su.physical_uri, su.virtual_uri) AS uri, su.domain, su.main FROM cr_shop_url su LEFT JOIN cr_shop s ON (s.id_shop = su.id_shop) WHERE (su.domain = 'www.coffinrock.com' OR su.domain_ssl = 'www.coffinrock.com') AND s.active = 1 AND s.deleted = 0 ORDER BY LENGTH(uri) DESC</pre> thrown in/vdir/www.coffinrock.com/var/www/vhosts/www.coffinrock.com/web/coffinrock/classes/db/Db.php on line 607

 

Par ailleurs, le préfixe de mes tables est cr_ au lieu de ps_ est-ce lié au problème ? Mon fichier setting.inc.php du nouveau dossier indique tout de même cr_

 

Merci pour votre aide précieuse !

 

 

Share this post


Link to post
Share on other sites

Bonjour,

 

La mise à jour manuelle est dépréciée et déconseillée. Utilisez le module d'upgrade svp http://addons.prestashop.com/fr/outils-administration-modules-prestashop/5496-1-click-upgrade-autoupgrade.html

 

Votre base n'est pas à jour par rapport à la version des fichiers. C'est normal que rien ne marche.

 

Cordialement

Share this post


Link to post
Share on other sites

Le problème c'est que l'archive que j'ai téléchargée depuis votre lien est endommagée. Je ne peux pas la dézipée, je ne peux pas l'ajouter via le back-office et depuis mon ordinateur et quand je fais rechercher un module, je ne le trouve pas. En gros je suis dans l'impossibilité d'installer ce module... comment faire ?

 

Merci

Share this post


Link to post
Share on other sites

Bonjour,

 

La mise à jour manuelle est dépréciée et déconseillée. Utilisez le module d'upgrade svp http://addons.prestashop.com/fr/outils-administration-modules-prestashop/5496-1-click-upgrade-autoupgrade.html

 

Votre base n'est pas à jour par rapport à la version des fichiers. C'est normal que rien ne marche.

 

Cordialement

 

Pourquoi d'ailleurs, passer par ce module alors que sur le tuto de prestashop est indiqué que l'on doit faire la mise à jour manuellement dans mon cas ?

 

"En cas de mise à jour à partir d'une version entre la 1.3 et la 1.4.3

Aucune version de PrestaShop inférieure à la 1.4.4 ne dispose de la mise à jour automatique. De fait, vous ne pourrez lancer de mise à jour automatique avec une telle version, et devrez passer par la mise à jour manuelle."

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More