Jump to content

Email tartalom hiba


dudikpal
 Share

Recommended Posts

Eddig működött rendesen az értesítő mail rendszer, de a mai napon azon kívül, hogy megnyitottam a bo-ban a mail templétek fordítását, nem csináltam semmi mást. Nem szerkesztettem semmit, csak megnyitottam az egyiket, nem mentettem rá, semmi.

Azóta mégis az alábbi hibával küzdök:

 post-527581-0-43812000-1385860611_thumb.jpg

 

Minden rendelési státusznál ilyen hiba van.

Egyszer már volt ilyen, csak nem emlékszem akkor hogyan sikerült helyreraknom. A telepítő mail könnyvtárával is felülírtam a mappát, még az angollal is, az sem segített.

 

Tudnátok segíteni, mivel tudom helyrehozni?

Share this post


Link to post
Share on other sites

Komolyan mondom én már nem tudom mi van itt...

Személyes átvételnél meg utánvétnél nem látok hibát. Futár utalásnál, és postai utalásnál van ez a hiba, ami azért érdekes, mert 2 napja utóbbival rendelt egy vevő, és neki meg jól ment ki a mail, monden adat flottul ott van benne.

 

Nem frissítettem semmit a motoron, ezt telepítettem fel, és a gépen levő telepítő mail mappájával írtam felül, utána meg tettem egy próbát az 1-2 hetes biztonsági mentésből való felülírással is.

Közben eszembe jutott, hogy annyi szerkesztés történt, hogy a mail/hu/lang.php-t egészítettem ki notepadban, mert elég hiányos volt a fordítás.

 

Mailalertet már reinstalltam, az sem segített.

Share this post


Link to post
Share on other sites

A compile most ki van kapcsolva, de amikor dolgozom, akkor mindig bekapcsolom.

 

Nem igazán értem a kérdést. A fizetési moduloknál van utalás meg utánvét, a szállítóknál meg a szállítók :), és akkor a restrictionsnál össze vannak rendelve.

Share this post


Link to post
Share on other sites

Azért kérdeztem, mert megpróbáltam kideríteni ezáltal hogy azok a modulok használhatnak-e külön mail sablonokat.

Sajnos nem jöttem rá... ha esetleg adsz egy admint szívesen megnézem.

Vagy ha bármilyen más módon tudjuk látványosan reprodukálni a hibát, az is jó Nekem.

Edited by pattila01 (see edit history)

Share this post


Link to post
Share on other sites

Mailalerts modul van fent, úgy látom hogy az "Új rendelés" mail, ami jól jelenik meg, az a modulból jön, van neki külön.

A státusz változtatásnál van hiba, ezek szerint akkor a shop/mail mappában levők a rosszak.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

A paymentmodule.php-ban csak ennyi van az order_conf-nál:

Mail::Send((int)$order->id_lang, 'order_conf', Mail::l('Order confirmation', (int)$order->id_lang), $data, $customer->email, $customer->firstname.' '.$customer->lastname, NULL, NULL, $fileAttachment);
        }
$this->currentOrder = (int)$order->id;
return true;

Nem kéne itt lennie a többi megjelenítendő változónak is?!(szlázási-szállítási-terméka adatok)

Share this post


Link to post
Share on other sites

  • 5 months later...

Sziasztok!

 

Nekem olyan kérdésem lenn, ami félig ide kapcsolódik, a rendelés vissza igazoló emailben és a többiben is a változók működnek rendesen! De nem mindegyik. pl szerettem volna a törlés értesítőbe bele tenni, hogy ekkor rendeltél de nem történt semmi stb... ezért töröltem a rendelésed. Az ekkor helyére a dátumot. {date} igy, de nem jó. :/ ugyan így van a rendelés visszaigazolóban és ott meg jó. Ugyan ez a bajom a {product}-al is, mert egy pár emailben működik de amibe még bele szeretném tenni abban nem. Az érdekesség hogy közben ugyan ezekben az emailekebna más változó meg működik pl: {order_name}.

 

Van valakinek ötlete mi lehet a gond?

Köszi! 

Enikő

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More