Jump to content

(Résolu) Prb configuration URL de la boutique chez o2switch


Recommended Posts

Bonjour

 

Tout d'abord supprimer HELP! 1° 100% des membres ont et/ou eu besoin d'aide au moins une fois. 2° Majuscule = crier depuis que la communication électronique/virtuel existe

 

 

Pourquoi vous n'arrivez pas qu'est-ce qui se passe ?

Share this post


Link to post
Share on other sites

Je ne sais pas comment on modifie le titre du poste

j'ai les problème suivant sur mon serveur de mon hébergeur o2switch je n'arrivais pas à avoir mon site mais c'était dû au problème de sous domaine 1 - 2 - 3 j'aurai bien aimé les utiliser afin de rendre l'affichage de mes pages plus rapide.

Mais actuellement j'ai 2 problème qui me font devenir Fou !!! (oui je crie j'en suis là :(

1- pas d'affichage de mes image produit sur mon sitee, alors quelles s'apparaissent bien dans mon BO

2- pas d'accès à des pages qui n'existe plus sur la version du site qui est sur mon hébergeur et pourtant elles existe bien sur mon site de développement sur mon pc et le truc c'est que c'est le même puisque j'ai transféré tout mon site sur le serveur ainsi que ma BDD puis configuré mon fichier config/setting.inc.php et aussi l'URL de la boutique dans BO > Préférences > SEO & URLs.

3- même le menu, les lien infos des produits et du footer ne fonctionne pas car lorsque je clique dessus, ils m'envoient vers la page me disant que cette page n'existe pas. 

J'utilise la dernière version 1.5.6.1 et à jour.

Je ne vois pas d'ou cela peut venir ??? 

Manque t'il des tables ou données de ma BD, lors de l'importation je n'ai pas eu de prb tout 'est bien passé, le seul truc c'est que chez cette hébergeur, on créée la BD séparément et on importe le fichier .SQL de la BD et on met en commantaire la création de la DATABASE si elle n'existe pas puis on importe et cela à été sans problème pour cette partie.

J'ai essayer de réduire le chemin de remonté de _PS_DIRECTORY_ du fichier setting.inc.php mais sans changement, hélas !

Donc je pensais qu'avec tout cela mon site devrai tourner mais non...

Pourquoi ???? je m'arrage les cheveux en plus de tournér en rond, je vais devenir OUF !!

 

Merci de vos lumière !!!

Edited by reaman (see edit history)

Share this post


Link to post
Share on other sites

zen zen :) je suis sur toutes les réponses sont déjà sur le forum :)

 

1- pas d'affichage de mes image produit sur mon sitee, alors quelles s'apparaissent bien dans mon BO

 

Régénération des images vous avez essayé ?

 

2- pas d'accès à des pages qui n'existe plus sur la version du site qui est sur mon hébergeur et pourtant elles existe bien sur mon site de développement sur mon pc et le truc c'est que c'est le même puisque j'ai transféré tout mon site sur le serveur ainsi que ma BDD puis configuré mon fichier config/setting.inc.php et aussi l'URL de la boutique dans BO > Préférences > SEO & URLs.

Est-ce que vous aviez créer le .htaccess en activant l'url rewriting ? si vous l'aviez refaites le sur le serveur en ligne.

 

le seul truc c'est que chez cette hébergeur, on créée la BD séparément et on importe le fichier .SQL de la BD et on met en commantaire la création de la DATABASE si elle n'existe pas puis on importe et cela à été sans problème pour cette partie.

 

Quand vous créer le site sur un autre poste que le serveur en ligne, c'est normal on exporte en format *.sql ou dans un fichier .zip d'une base de donnée et on l'importe dans l'autre base de donnée.

 

Par contre cette histoire de mettre en commentaire ?? est-ce vraiment une particularité à cet hébergeur ?

Je n'ai jamais rien mis en commentaire pourtant j'ai exporter/importer des bases de données sur de nombreux hébergement et serveur dédié.

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

1- comment fait-on une regénération de mes images ?

J'ai essayé la regénération des miniatures depuis le BO > Préférences > Images > Regénérer les miniatures mais sans succès.

2- J'ai activé l'URL rewriting mais je ne sais pas si cela à créer ou modifier le .htaccess

3- chez o2switch on crée un Bd depuis leur interface, puis avec phph my admin depuis leur interace, j'ai sélecctionné ma Bd que j'ai créer précédement puis envoyé le fichier ma base.sql que j'ai exporter depuis mon phpmyadmin sur mon server de prod, le seul truc que j'ai modifier sur ce fichier et la mise en commentaire de la ligne du début de la création de la  DATABASE.

Dans mon fichier .htaccess j'ai bien la mention en bas :

#If rewrite mod isn't enabled
ErrorDocument 404 /index.php?controller=404

Quand au autres ligne avant je ne sais pas si elle sont bonne et ne peut pas l'afficher ici pour une raison de sécurité pour mon site.

Donc comment faire ?

Edited by reaman (see edit history)

Share this post


Link to post
Share on other sites

Bonjour

 

 

 

et la mise en commentaire de la ligne du début de la création de la  DATABASE.

c'est eux qui conseil de faire ça ?

 

Pouvez-vous donner le lien de votre site afin de voir directement ?

Share this post


Link to post
Share on other sites

Bonjour,

J'ai résolu le problème :-)

 

Merci de votre aide !!

Bonjour

 

Merci de partage avec la communauté comment vous avez résolu le problème, afin que d'autres membres ayant le même problèmes puissent trouver cette information.

Share this post


Link to post
Share on other sites

OUPS !!! 

Bon alors pour les résoudres, j'ai fait cela :

1- J'ai réactivé les images depuis le  BO > Préférences > Images > Régénérer des miniatures

2- J'ai désactivé URL simplifiée puis réactivé afin de réécrire le bon chemin dans le fichier .htaccess 

3- J'ai supprimer les chemins dans le fichier config/setting.inc.php des 3 sous domaines.

J'aurai bien aimé exploter cette fonction afin de pouvoir accélérer le chargement de mes pages mais visiblement si on ne l'as pas exploité lors de la création en mode production cela pose un problème lorsque l'on décide de l'exploiter sur le serveur une fois le site

fini, enfin c'est le cas pour moi.... si vous avez la solution, j'suis preneur ;-)

 

Voilà et mainenant ça fonctionne.

Edited by reaman (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More