Jump to content

Recommended Posts

Bonjour à tous,

 

j'ai un peu bidouillé le plugin 2.0.1 et cela semble fonctionner sur Presta 1.6 avec le module configurer en mode Widget.

 

Je n'ai pas tout testé mais avec ces modifications le module permet :

sur le front : de sélectionner un Mondial Relay à la page de paiement (testé avec le mode de paiement en 1 page)

sur l'admin : de générer les etiquettes de livraison

 

Evidement tout ça fonctionne après avoir bien configuré le plugin et ajouté un mode de livraison Mondial Relay avec le plugin.

 

Ne trouvant pas comment attacher le zip du module à jour voici la liste des modifications apportés, j'espère n'avoir rien oublié :

 

- /mondialrelay.php : problème dans la consultation de la variable PS_VERSION et MR_Data ligne 642. Ce n'est pas très propre car doublon de déclaration de variable. J'optimiserai après.

		$this->context->smarty->assign(array(
			'address' => $address,
			'account_shop' => $this->account_shop,
			'country' => $country,
			'PS_VERSION' => _PS_VERSION_
			)
		);
		if( Configuration::get('MONDIAL_RELAY_MODE') == 'widget' ){

			$this->context->smarty->assign(
				array(
					'MR_Data'=> json_encode(
						array(
							'carrier_list' => $carriersList,
							'carrier' => $carrier,
							'PS_VERSION' => _PS_VERSION_,										
							'pre_selected_relay' => isset($preSelectedRelay['MR_selected_num']) ? $preSelectedRelay['MR_selected_num'] : 0,
						)
					)
				)
			);
			return $this->fetchTemplate('/tpl/', 'checkout_process_widget');
		}
		else{
			$this->context->smarty->assign(array(
				
					'MR_Data'=> json_encode(
							array(
							'carrier_list' => $carriersList,
							'carrier' => $carrier,
							'PS_VERSION' => _PS_VERSION_,			
							'pre_selected_relay' => isset($preSelectedRelay['MR_selected_num']) ? $preSelectedRelay['MR_selected_num'] : 0,
							)),
					'carrier'=> $carrier
			));			
			return $this->fetchTemplate('/tpl/', 'checkout_process');
		}

 

- tpl/checkout_process.tpl

(L.38) {if $PS_VERSION >= '1.5' && !$carrier}

- classes/MRCreateTickets.php : ajout de la ligne suivante dans __construct() 

 (L.253) $this->_insuranceList = $params['insuranceList'];

- AdminMondialRelay.php : dans function displayOrdersTable... ajout dans new MRCreateTickets :

(L.56) 'insuranceList' => NULL

                                            mis en commentaire une ligne de code pas terminé ... 

(L.61) //if(is_array($orders) && count($count)) => $count n'existe pas...

J'espère n'avoir rien oublié...

 

Bon courage !

Edited by joe42 (see edit history)

Share this post


Link to post
Share on other sites

heu, je ne comprend pas pour checkout_process et checkout_process_widget.. Il faut qu'il n'y ai que la ligne que tu as écrite ? ou faut il modifier une ligne existante, car tu n'as pas mis de numéro de ligne, et pour checkout_process_widget, je ne trouve aucune ligne en rapport...

 

pour  (L.253) $this->_insuranceList = $params['insuranceList'];

la ligne existe déja dans le fichier et au bon endroit

 

Parce qu'après les modifs j'ai cette erreur :

 

[PrestaShop] Fatal error in module mondialrelay:
syntax error, unexpected 'public' (T_PUBLIC)

Edited by Jean Francois G (see edit history)

Share this post


Link to post
Share on other sites

Peut être devrais tu envoyer dans un fichier zip directement ton dossier "mondial relais" ?

Nous n'aurions plus qu'a l'extraire et le transferer par ftp sur nos back office..

Share this post


Link to post
Share on other sites

Parce qu'après les modifs j'ai cette erreur :

 

[PrestaShop] Fatal error in module mondialrelay:

syntax error, unexpected 'public' (T_PUBLIC)

Pour éviter le Fatal Error, il faut ajouter le signe } en ligne 679 dans mondialrelay.php

Share this post


Link to post
Share on other sites

ok plus le fatal error avec la modif en 679.

Mais message d'erreur a la création d'un nouveau transporteur.

 

Pour checkout_process.tpl et checkout_process_widget.tpl, il faudrait donner plus de précisions. Faut il modifier une ligne ou que le fichier ne contienne QUE cette ligne ?

 

(L'idée de poster le zip du dossier mondial relay serait également plus simple)

Share this post


Link to post
Share on other sites

Voila j'ai trouvé comment ajouter le fichier zip, il est donc en pièce jointe.

 

Encore une fois les modifications apportés ne résolvent que les problèmes rencontrés sur Prestashop 1.6.0.6 avec le module configuré en mode widget.

 

Bonne journée à tous !

 

ps : désolé pour la réponse tardive ;)

mondialrelay.zip

  • Like 2

Share this post


Link to post
Share on other sites

Absolument parfait !

 

le module est opérationnel en mode widget !

 

Tu veux pas te faire engager comme développeur chez mondial relais ??

 

Parce que la, eux ils dépensent une fortune pour refaire le module depuis 1 mois et toi tu le répare en quelques heures.

L'argent du développement devrais te revenir de plein droit ..

en tous les cas tu devrais ouvrir un don paypal, tu le mérite

 

Nota : Il faut impérativement réinitialiser le module avant de le reconfigurer et effacer le cache smarty.

 

@xavier du terte : Mondial relais a été écrasé par la puissance de joe42 qui arrive 1er toute catégorie et relègue les technicien de mondial relais au rang de bidouilleurs débutants loooool ! En quelques heures, faire mieux qu'une équipe complète en un mois : Chapeau !

 

@joe42 : Aurais tu un début de piste pour ce post sur les règles en 1.6 ? http://www.prestashop.com/forums/topic/337043-toujours-le-m%C3%AAme-probl%C3%A8me-de-regles-panier-que-sur-15/  Juste pour une idée. Pas plus ..

Edited by Jean Francois G (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites

Bien d'accord avec toi Jean François !!  :)

 

Gros gros travail de joe42. Attendons de voir le module officiel (peut-être, un jour ?) pour comparer. En attendant, ça a l'air de bien tourner avec les patchs de Joel. 

Share this post


Link to post
Share on other sites

Bjr,

Pour ma part cela ne fonctionne pas, le pop s'ouvre puis se retrouve avec des dimensions tres petites donc impossible de voir les points relais et de les choisir.

Share this post


Link to post
Share on other sites

Machpro,

 

cela m'est arrivé que quand j'avais la fenêtre de debug ouverte, en fermant le problème n'est pas réapparu.

 

Sinon je pense que la taille de la fenêtre dépend de la taille globale de la fenêtre du navigateur. Essaye de changer la taille de ta fenêtre ou regarde avec le debuger pour vérifier qu'il y a bien quelque chose dans la fenêtre. 

 

Good luck !

Share this post


Link to post
Share on other sites

Merci Joel,

J'ai passé le debug sur false et change de navigateur, ca semble fonctionner,la fenêtre s'ouvre correctement , je vais faire d'autres tests.

Share this post


Link to post
Share on other sites

Bon! je ne comprends plus, j'ai modifie le transporteur, crée d'autres zomes , le widjet ne s'ouvre plus quelque soit le navigateur!!

Share this post


Link to post
Share on other sites

Bon... on reste toujours dans l'impasse, des commandes continuent à tomber avec le transporteur Mondial Relay (Normal, les tarifs sont moins onéreux) mais il faut toujours contacter le client pour lui demander quel point relais il a sélectionné, ce qui ne fait pas trop sérieux... On devait avoir le module refait à neuf et sans bug début Juin, on commence à être à la mi-Juin...

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

Toujours rien sur ce nouveau module ?

Si ça continue, je vais supprimer de mon site, ce transporteur et ça sera plus simple !  :wacko:

Share this post


Link to post
Share on other sites

Bonjour

 

Nous aussi nous sommes dans l'attente  :(, nous faisons tout ce que nous pouvons pour qu'il soit livré rapidement. 

 

Vous serez de toute façon prévenus les premiers de sa sortie.

 

 

Bon week-end à tous ! 

Share this post


Link to post
Share on other sites

Perso, sur mon mag, le module corrigé de joel fonctionne très bien.

Le widget s'affiche imppec, les adresses des points relais selectionnés s'affiche dans la commande du back office, et les etiquettes s'impriment sans problème..

 

Par contre pour que tout soit ok, il à fallut impérativement que je réinitialise le module une fois transféré, que je clique à nouveau sur "installer", la il y a eu un bug d'install alors j'ai rafraichi la page, puis installé à nouveau le module.

Ensuite il faut vider le cache de presta.

Une fois fait, je go pour configurer le module et la bien sur je re-crée un transporteur mondial relais (puisque la reinit à tout effacé), je le configure en tarif dans la rubrique transporteur et je configure mes articles pour qu'ils l'acceptent.

 

Une fois tout ça fait : Nickel, tout est ok..

 

Seul bug que je n'ai pas compris (mais je ne pense pas que ce soit le module de joel mais plutot la  presta 1.6 qui fasse ça), si je configure le transporteur par défaut comme 'le moins cher', j'ai une erreur 500 server juste après la sélection de l'adresse. Si je défini un transporteur précis par défaut, alors plus d'erreur 500..

Edited by Jean Francois G (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Si j'ai bien compris les options d'assurance, il faut faire un transporteur MR par niveau d'assurance ?

Ce qui empêche de mettre MR par défaut s'il y a plusieurs MR.

C'est bien ça ?

Share this post


Link to post
Share on other sites

Je vais passer pour un bleu mais où trouver le module car sur la boutique de Prestashop, je ne le trouve pas !

Share this post


Link to post
Share on other sites

Si j'ai bien compris les options d'assurance, il faut faire un transporteur MR par niveau d'assurance ?

Ce qui empêche de mettre MR par défaut s'il y a plusieurs MR.

C'est bien ça ?

 

C'est bien ca :)

Si tu veux mettre MR comme transporteur par défaut, il te suffit de donner la meilleure note/vitesse à tous tes transporteurs MR et de choisir comme transporteur par défaut le mieux noté. Tes transporteurs MR seront sélectionnés par défaut.

Share this post


Link to post
Share on other sites

Je vais passer pour un bleu mais où trouver le module car sur la boutique de Prestashop, je ne le trouve pas !

 

Le module MR ne fonctionnant pas correctement, il a été retiré de addons. Une nouvelle version est censée sortir sous peu... Sinon tu peux toujours tester la version retouchée par Joe42 (voir post #107 ci-dessus)

Share this post


Link to post
Share on other sites

Le module MR ne fonctionnant pas correctement, il a été retiré de addons. Une nouvelle version est censée sortir sous peu... Sinon tu peux toujours tester la version retouchée par Joe42 (voir post #107 ci-dessus)

Merci, 

Par contre, ne maîtrisant pas du tout Prestashop et donc ne voulant pas faire de bêtises, sur quel fichier doit on cliquer, après avoir cliqué sur "ajouter un module" ? :)

Share this post


Link to post
Share on other sites

sur le fichier zip que tu auras téléchargé au post 107. Attention c'est une solution provisoire en attendant la sortie d'une version officielle du module Mondial Relay. Elle n'est pas exempte de bugs (mode widget obligatoire par ex.)

Edited by Hobbes (see edit history)

Share this post


Link to post
Share on other sites

J'ai bien téléchargé le fichier zip mais une fois décompressé et après être dans le répertoire pour "mondial relay", je clique sur quel fichier pour l'install ?

Share this post


Link to post
Share on other sites

Houla, non ce n'est pas comme ça qu'il faut s'y prendre pour installer un module sous Prestashop. Va falloir bosser le manuel : http://doc.prestashop.com/display/PS15/Guide+de+l%27utilisateur  ;)  

 

Pour installer un module, tu fais "ajouter un module", tu sélectionnes ton fichier zip (sans le dézipper) puis "charger le module". Il va s'installer tout seul comme un grand. Ensuite dans la liste de tes modules, tu retrouveras le fameux module qu'il restera à installer/activer/paramétrer.

 

Si un module ne s'installe pas correctement (qu'il n’apparaît pas ensuite dans la liste des modules), alors seulement tu le dézippes et tu installes le dossier qu'il contient dans le dossier "modules" en utilisant un logiciel de FTP comme Filezilla. Mais à mon avis il faudra te faire épauler si tu n'as jamais fait... ou bien lire les docs.

 

Mon conseil : commence par lire la notice de Prestashop qui est très explicite pour débuter, sinon tu vas passer ton temps sur les forums.

Share this post


Link to post
Share on other sites

Merci pour ces précieuses informations... Le module MR est installé.

 

 

Je vais penser à télécharger la notice de Prestashop ! :)

Share this post


Link to post
Share on other sites

Aprés install, reinstall... le navigateur mouline "en attente de widjet mondial relay" et rien ne se passe.Fatiguant ce module!!

Share this post


Link to post
Share on other sites

Et de mon coté, une suite d'erreurs :

 

Notice à la ligne 919 du fichier /home/aquarios/www/modules/mondialrelay/mondialrelay.php
[8] Undefined offset: 0

Notice à la ligne 920 du fichier /home/aquarios/www/modules/mondialrelay/mondialrelay.php
[8] Undefined offset: 0

 

Et ça va jusqu'à la ligne 939.... grhhhh

Share this post


Link to post
Share on other sites

Et de mon coté, une suite d'erreurs :

 

Notice à la ligne 919 du fichier /home/aquarios/www/modules/mondialrelay/mondialrelay.php

[8] Undefined offset: 0

 

Notice à la ligne 920 du fichier /home/aquarios/www/modules/mondialrelay/mondialrelay.php

[8] Undefined offset: 0

 

Et ça va jusqu'à la ligne 939.... grhhhh

 

Les "notices" sont des remarques, ça signale qu'il peut y avoir un problème à cette ligne, mais le programme continue. Quand on est consciencieux, effectivement, on les corrige. Le nombre de notice montre l'état général du programme.

Share this post


Link to post
Share on other sites

Si le module que vous êtes en train de tester est celui de Joel, il me semble évident qu'il ne s'amuse pas à corriger entièrement le module de Mr Mondial relais (celui qui à engagé le petit de 8 ans pour ceux qui ont tout lu..)

 

C'est déja Enorme avec un grand E, qu'il se soit penché sur le dossier sans être rémunéré pour son travail..

 

Maintenant je pense que ce module corrigé ne fonctionnera peut être pas avec tous les magasins en 1.6 car les possibilités d’interaction avec les autres modules sont si importantes que cette correction ne peut pas être parfaite non plus (surtout en ayant réagi et mis en dispo aussi vite cette correction)..

 

Seule possibilité si le module corrigé pose soucis sur votre presta : Attendre la version officielle (.. on l'espère dans 15, 20 ans à peut prêt ..)

Share this post


Link to post
Share on other sites

Oui, je pense désinstaller le module MR car pour le moment, ayant fait une simulation, le client ne peut même pas choisir son point relay.

 

Si ça marche chez certaines, c'est que j'ai peut-être mal paramétré le module...

Qu'en pensez-vous ?

Share this post


Link to post
Share on other sites

@quicksilver

 

Bonjour, quelle est ta version de prestashop, et utilise tu la commande en 1 page ou en 5 pages ?

Share this post


Link to post
Share on other sites

C'est bien ca :)

Si tu veux mettre MR comme transporteur par défaut, il te suffit de donner la meilleure note/vitesse à tous tes transporteurs MR et de choisir comme transporteur par défaut le mieux noté. Tes transporteurs MR seront sélectionnés par défaut.

 

Merci encore, ça marche ! Je n'avais pas réalisé que le champ vitesse du transporteur correspondait à l'option de tri par meilleure note - ça ne s'appelle pas vraiment pareil d'ailleurs ... Ton astuce m'a permis de remettre mondial relay par défaut.

 

Et je pense aussi avoir résolu le problème de l'assurance qui est fixe en fonction de la tranche de poids (c'est moi qui ai découpé comme ça, j'aurais pu aussi faire des tranches de valeur, mais la règle générale du transport, c'est que c'est facturé au poids, pas à la valeur). Je vais tout simplement mettre un poids plus faible aux articles qui sont lourds par rapport à leur valeur (en les considérant comme des exception). Ca me permettra de les faire retomber dans une  catégorie d'assurance plus faible. Au moment de la création d'étiquettes, les paquets sont pesés avec leur emballage et le poids sera corrigé.

Share this post


Link to post
Share on other sites

Si le module que vous êtes en train de tester est celui de Joel, il me semble évident qu'il ne s'amuse pas à corriger entièrement le module de Mr Mondial relais (celui qui à engagé le petit de 8 ans pour ceux qui ont tout lu..)

 

C'est déja Enorme avec un grand E, qu'il se soit penché sur le dossier sans être rémunéré pour son travail..

 

Maintenant je pense que ce module corrigé ne fonctionnera peut être pas avec tous les magasins en 1.6 car les possibilités d’interaction avec les autres modules sont si importantes que cette correction ne peut pas être parfaite non plus (surtout en ayant réagi et mis en dispo aussi vite cette correction)..

 

Seule possibilité si le module corrigé pose soucis sur votre presta : Attendre la version officielle (.. on l'espère dans 15, 20 ans à peut prêt ..)

 

Ne me faites pas dire ce que je n'ai pas dit. Je ne parlais bien sûr pas de Joe dont je loue les mérites comme tout le monde, mais de la bande de bras cassés qui ont osé faire sortir un logiciel non terminé buggé de partout.

Share this post


Link to post
Share on other sites

Oki PBo34.

 

Petit rappel pour tous, le module corrigé n'est que pour la 1.6

Si vous êtes en 1.5.x.. Ne l'installez pas !

Share this post


Link to post
Share on other sites

La version 1.8.13 ne semble pas être compatible avec le format des numéros de téléphone de Presta 1.5.6.2. J'ai bricolé le fichier suivant, fonction getFormatedPhone, pour changer le format du numéro passé à MR. Ce n'est qu'un bricolage. La conception de cette fonction est erronée car le format du numéro accepté n'est pas déduit proprement du pays, et il faudrait donc la refaire entièrement. Il va encore recracher certains numéros de téléphones étrangers, mais pour l'instant ça passe avec les numéros français.

 

MRTools.php

Share this post


Link to post
Share on other sites

Petit rappel pour tous, le module corrigé n'est que pour la 1.6

Si vous êtes en 1.5.x.. Ne l'installez pas !

 

Si vous êtes en 1.5, vous pouvez essayer la version 1.8.13 corrigée avec le fichier ci-dessus. Pas de widget, moins de problèmes.

Mais il reste certainement encore des surprises à venir.

Share this post


Link to post
Share on other sites

Ils ont dit juin.... mais ils n'ont pas précisé l'année:ph34r:

Share this post


Link to post
Share on other sites

D'autant que c'est même pas mondial relais qui pédale dans la semoule, mais bien le sous traitant Webincolor   - > http://www.webincolor.fr/portfolio/mondial-relay/

 

 

Leur programmeur de 8 ans à quitté Counter Stryke pour passer à Watch Dogs.. L'a pas l' temps de réfléchir à mondial relais, faut le comprendre ....

Edited by Jean Francois G (see edit history)

Share this post


Link to post
Share on other sites

Salut tout le monde ! 

 

Le module est en cours de livraison, c'est pour bientôt :)

 

Bonne journée

Share this post


Link to post
Share on other sites

Salut tout le monde ! 

 

Le module est en cours de livraison, c'est pour bientôt :)

 

Bonne journée

Haaa  enfin ! :)

 

Merci Samyha.

 

Merci 

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour, je suis en 1.5.6 et je ne arrive pas à créer l'etiquette de Mondial Relay, même problème avec le module version 1.8.9 et 2.0.1 de MR, pourriez vous m'aider s'il vous plait?

Share this post


Link to post
Share on other sites

Bonjour, je suis en 1.5.6 et je ne arrive pas à créer l'etiquette de Mondial Relay, même problème avec le module version 1.8.9 et 2.0.1 de MR, pourriez vous m'aider s'il vous plait?

Bonjour, tu as installé et réinstallé le module mondial relay et à chaque fois le transporteur mondial relay à changé de numéro. Ta commande en préparation est enregistrée avec un ancien numéro de transporteur, donc l'étiquette mondial relay ne peux pas être éditée.

 

Sur PS 1.5.6.2, personnellement j'utilise la version MR 1.8.9, en mode commande 5 etapes et ça fonctionne...

 

Dans ton BO, dans transporteurs tu relèves le numéro de ton transporteur mondial relay et il faut ensuite aller dans la base de données modifier le transporteur de ta commande id_carrier dans ps_orders et dans ps_order_carrier si mes souvenirs sont bons (à ne faire qu'après une sauvegarde de la base de donnée et si tu connais phpmyadmin...).

Share this post


Link to post
Share on other sites

C'est normal c'est le bug, le coup des étiquettes. On attend le nouveau module ! le seul moyen que j'employe en attendant c'est de faire l'envoi par leur site comme un particulier !

Share this post


Link to post
Share on other sites

Oui mais pour l'envoyer manuellement depuis le site officiel, il nous faut l'adresse du point relais choisi, comment peut on le rettrouver sur une commande, il m'affiche toujours l'adresse du client, même dans le bon de commande

 

Une idée?

Edited by Steeve.c (see edit history)

Share this post


Link to post
Share on other sites

Salut tout le monde ! 

 

Le module est en cours de livraison, c'est pour bientôt :)

 

Bonne journée

bonsoir Samyha,

Juste pour savoir, bientot dans le langage mondial relay, le langage prestashop, le langage module ebay ? ou alors bientot c est demain a 14 heure 33 exactement ( par exemple).

Merci pour ton suivi et tes reponses toujours justes.

Cordialement

Olivier

Share this post


Link to post
Share on other sites

Bonjour freepie,

 

Je comprends ton impatience. Cependant, le module nous ayant été livré avec du retard de la part de Mondial Relay, et ce pour des raisons indépendantes de notre volonté, nous n'avons pas de date de sortie exacte pour le moment.

Ce que je peux vous dire c'est qu'il est en cours de validation avec les deux équipes de développeurs de Mondial Relay et PrestaShop.

 

Nous sommes également impatients que le module retrouve sa place dans vos boutiques :)

 

Merci encore pour votre patience. Bonne journée à tous ! 

Share this post


Link to post
Share on other sites

En attendant, personne pour me dire comment retrouver l'adresse du point relais choisi par le client pour envoyer manuellement son colis ?

Share this post


Link to post
Share on other sites

La fois ou cela m'est arrivée, j'ai écris au client après avoir fait comme pour un envoi particulier sur mondial relay. je lui ai dis que j'avais eu un problème informatique et qu'il veuille bien me reprécisé parmi les différents points que j'avais copier-coller celui qui lui convenait.

Share this post


Link to post
Share on other sites

Ha oui ok je comprends mieux, je pensais que vous arriviez tous a trouver le point relais du client, merci beaucoup pour cette précision Tricot Fils

Share this post


Link to post
Share on other sites

de rien. petite precision, Mondial relay ma répondu qu'il est possible en allant sur leur site dans la rubrique "Espace Enseigne" et en se connectant avec ses identifiants, de créer des envoi et des étiquettes de colis avec facturation contractuelle à 30 jours au lieu de le faire comme les particuliers.

 

J'ai testé et cela fonctionne. Certes c'est moins fluide que par la boutique vu qu'il faut ressaisir les coordonnées client et le point relais chois mais au moins c'est mieux pour la facturation.

Share this post


Link to post
Share on other sites

de toute façon, à moins que le nouveau module soit "révolutionnaire", celui de Joel fonctionne tellement bien sur 1.6 que je suis pas sure de faire la mise à jour dès reception.

Actuellement je n'ai vraiment plus aucun bug que ce soit pour le client ou pour le BO..

Un gros thanks à joel sur ce coup d'ailleurs.

Share this post


Link to post
Share on other sites

Bonjour,

 

En attendant le grand jour, quelqu'un peut-il mettre à dispo la version 1.8.13 ?

Merci d'avance

Share this post


Link to post
Share on other sites

Mondial relay 1.8.13 tel que téléchargé sur Github juin 2014 :

mondialrelay1.8.13_2014-juin.zip

 

Pour que les numéros de téléphone passent, il y a un fichier à remplacer par celui que j'ai mis dans un post un peu plus haut.

 

Je n'ai pas de problème majeur avec cette version. Elle n'a pas de widget : les point relais dispo autour de l'adresse viennent sous forme de liste. De temps en temps il est un peu capricieux au moment de faire l'étiquette : pas de message disant que l'étiquette est faite, mais elle est faite quand même.

 

Il y a une autre chose que j'ai corrigée, le message << mondial relay n'a pas pu ... à cause de prestashop >>, quand on choisit un autre transporteur dans le FO. C'est normal de ne pas lister les points relais quand le client ne prend pas MR. Ils sont gonflés, la bande de bras cassés, pressés de balancer la faute sur quelqu'un d'autre. Donc ce message, je l'ai remplacé par une chaine vide dans le fichier des traductions.

 

 

 

Share this post


Link to post
Share on other sites

Avec ce logiciel, il ne faut jamais dire que ça marche, parce que ça s'arrête aussitot de marcher. Aujourd'hui, j'ai un client qui a réussi à passer au travers du choix du relais. Donc la commande n'apparait pas dans la liste des étiquettes à imprimer. Ils ne savent pas vérifier que le choix est fait quand il faut, mais il savent le faire avant d'être eux-mêmes emm...és, de manière que ça retombe sur nous. Que c'est pénible de travailler avec des gens qui nous méprisent.

 

J'ai constaté que la page du choix du transporteur ne demande rien lorsque javascript est désactivé. Il est possible de sélectionner MR, les relais ne s'affichent pas, et de continuer sans être bloqué.

 

Ca serait bien si c'était possible de modifier order-carrier.tpl. Quelqu'un saurait-il comment tester si javascript est inactif dans le fichier tpl ? Auquel cas renvoyer un message d'erreur si le client choisit MR, "Pour choisir MR, veuillez activer javascript dans votre navigateur". Ca colmaterait la brèche. En attendant, je désactive encore une fois MR.

Share this post


Link to post
Share on other sites

Avec ce logiciel, il ne faut jamais dire que ça marche, parce que ça s'arrête aussitot de marcher. Aujourd'hui, j'ai un client qui a réussi à passer au travers du choix du relais. Donc la commande n'apparait pas dans la liste des étiquettes à imprimer. Ils ne savent pas vérifier que le choix est fait quand il faut, mais il savent le faire avant d'être eux-mêmes emm...és, de manière que ça retombe sur nous. Que c'est pénible de travailler avec des gens qui nous méprisent.

 

J'ai constaté que la page du choix du transporteur ne demande rien lorsque javascript est désactivé. Il est possible de sélectionner MR, les relais ne s'affichent pas, et de continuer sans être bloqué.

 

Ca serait bien si c'était possible de modifier order-carrier.tpl. Quelqu'un saurait-il comment tester si javascript est inactif dans le fichier tpl ? Auquel cas renvoyer un message d'erreur si le client choisit MR, "Pour choisir MR, veuillez activer javascript dans votre navigateur". Ca colmaterait la brèche. En attendant, je désactive encore une fois MR.

 

J'ai eu exactement le même soucis! Le client a réussi à commander sans choisir de relai. Peut-être que le webservice MR était down à ce moment là, et permettait d'outrepasser cette étape?

Share this post


Link to post
Share on other sites

Bonjour 

J'ai installer le module de Joel Mais j'ai encore un BUG mais d'affichage.

Le Widget s'affiche en petit et non en grand dans le navigateur 

 

Si je le ferme change de transporteur et le ré-ouvre il est en grand 

 

Une idée ?

Share this post


Link to post
Share on other sites

Hello ameunier,

 

je n'ai pas eu le temps de regarder le code JS d'affichage du widget.

Les seuls fois que la taille de la fenêtre est devenu toute petite c'est quand j'avais le debugger de mon navigateur ouvert ou que j'avais rétrécis ma fenêtre. Essaye de faire un test avec la fenêtre ouverte à la taille normale. Si ça le fait toujours c'est que le code javascript s'execute mal ou que le contenu n'est pas récupéré convenablement.

 

bon courage.

Share this post


Link to post
Share on other sites

@ Joe42:

 

Voilà le résultat de mes tests il y a quelques semaines au sujet de l'affichage format timbre-poste du widget :

 

 

La petite boite semble n'apparaitre ni sur IE ni sur Chrome, ni sur Firefox quand la fenetre est maximisée.

Elle apparait avec firefox quand la fenetre n'est pas maximisée, et de manière aléatoire.

Ce n'est pas dépendant des plugins de firefox (testé avec 3 firefox differents sur 2 pcs differents), ni du serveur (site de test comme site live affectés également).

Et quand j'active firebug, c'est à tous les coups, comme si c'était un problème de vitesse relative.

Une fois, la fenetre s'est élargie mais n'a pas grandi en hauteur, elle s'est arrêtée au milieu du redimensionnement.

Quand le widget est petit (100x100 en dimension intérieure), il suffit de redimensionner le navigateur pour que le widget prenne la bonne dimension, ou de cliquer sur alt qui fait apparaitre la barre de menu, ce qui redimensionne donc la partie affichage du navigateur.

 

Ce bug apparaît aléatoirement : problème de vitesse relative entre l'exécution du javascript, et les réponses des serveurs MR et google ?

C'est ce bug qui m'a fait abandonner la version 2.x en mode widget.

Quand la fenêtre widget est petite, autant que je me souvienne, son contenu est correct. On peut le voir en scrollant. Seul son format est mauvais, et elle n'est pas redimensionnable. Par contre, elle se met toute seule à la bonne taille si on redimensionne la fenêtre du navigateur (redraw).

Share this post


Link to post
Share on other sites

Effectivement même constat mais avec chrome 

 

Je suis revenu au 1.8.13 qui fonctionne bien mais ou la personne peut ne pas valider son point relais sans que le système ne dise rien !!!

 

Pour info je suis en 1.6

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Je vois que je suis pas le seule avec ce problème. Franchement ca fait pas très pro, de rappeler la cliente pour sa première commande  pour lui demander  de choisir un point relais. Je suis vraiment déçu et en plus ce bug dur depuis plusieurs mois...

  • Like 1

Share this post


Link to post
Share on other sites

Effectivement même constat mais avec chrome 

 

Je suis revenu au 1.8.13 qui fonctionne bien mais ou la personne peut ne pas valider son point relais sans que le système ne dise rien !!!

 

Pour info je suis en 1.6

Bonsoir,

j ai le meme probleme avec ce module,que tous le monde. pouvez vous me dire comment installer le 1.8.13 sur presta 1.6.

J avais installé envoi moins cher mais le module mondial relay n est alors pas compatible avec ebay????

merci a vous

cordialement

Olivier

Share this post


Link to post
Share on other sites

Effectivement même constat mais avec chrome 

 

Je suis revenu au 1.8.13 qui fonctionne bien mais ou la personne peut ne pas valider son point relais sans que le système ne dise rien !!!

 

Pour info je suis en 1.6

 

Avec MR 1.8.13 sur presta 1.5 (1.6 je ne sais pas), je n'ai jamais constaté qu'on pouvait dépasser la page du transport sans avoir choisi un point relais SAUF si javascript est désactivé. J'ai testé avec Firefox nouvelle et ancienne version, 32 et 64 bits, IE, et Chrome.

Comme je l'ai dit plus haut, la solution serait d'empêcher le client de choisir MR si son javascript est désactivé. Mais je ne sais pas comment le faire. Si quelqu'un peut me dire comment faire ce test dans un template, ça permettrait peut-être d'avoir une version qui fonctionne.

Share this post


Link to post
Share on other sites

J avais installé envoi moins cher mais le module mondial relay n est alors pas compatible avec ebay????

 

Quel est l'intérêt d'installer MR en plus de envoi moins cher ?

Share this post


Link to post
Share on other sites

Quel est l'intérêt d'installer MR en plus de envoi moins cher ?

En fait je vais etre obligé d enlever envoi moins cher , car l offre MR n est pas exportable vers ebay via leur module. Entre temps j ai installé MR 1.8.13 et il fonctionne pour le moment . un grand merci .

cordialement

OL

Share this post


Link to post
Share on other sites

J'ai également un soucis avec Mondial Relay: si le poids de ma commande dépasse les 70kg, le webservice Mondial Relay me renvoi une erreur 99 au moment d'afficher la liste des points relais.

 

Quelqu'un d'autre est-il dans le même cas que moi?

Share this post


Link to post
Share on other sites

J'ai testé version la 1.8.13 postée récemment, et visiblement le serveur "plante".

L'écran reste blanc; sans doute lié à php...pas plus d'info; je ne connais pas le serveur.
Installée sur PS 1.5.5.0.

 

J'ai réitéré sur un mutualisé 1&1 avec un PS 1.5.2.0, idem.

 

Je viens trouver en regardant le contenu des dossiers; le dossier "backward_compatibility" est vide.

J'y ai mis les fichiers d'une autre version et c'est ok

Edited by Svend_1 (see edit history)

Share this post


Link to post
Share on other sites

Suite test:

- 1.8.13 sur PS 1.5.5.0, pas de choix de point relais : "Mondial Relay ne peut...du à une erreur de Prestashop"

- 1.8.13 sur PS 1.5.2.0, ok tout fonctionne.

Share this post


Link to post
Share on other sites

10 pages de message, de probleme, de constats tous dans le meme sens "CA MARCHE PAS"

Ca commence mal avec ce fournisseur, si il est incapâble de fournir un  module

C'est pareil chez kiala, incapable de vous aider !!!!!

Share this post


Link to post
Share on other sites

Bonjour,

 

Nous sommes aujourd'hui le 4 juillet et donc le moi de juin est entériné !

 

Comme il l'est si bien dit dans le post  du 20 Juin 2014 - 11:12 AM, ils nous ont bien parlé de la fin de mois de Juin mais pas de l'année !  :angry:

 

Je me dis que pour faire avancer les choses, il serait, peut-être bien, de boycotter le module MR et faire appel à d'autres prestataires de transport.

 

Qu'en pensez-vous ?

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour tout le monde ! 

 

Si tout va bien, le module devrait être remis en service dés la semaine prochaine. Notre équipe de développeurs l'a validé, il ne reste plus qu'à effectuer un dernier petit check de sécurité.

 

Bon week-end à tous.

Share this post


Link to post
Share on other sites

Tant que nous n'avons rien de factuel, on attend !

Pour ma part, je suis comme St Thomas, je crois que ce que je vois... Mais merci de nous faire espérer ! ;-)

Share this post


Link to post
Share on other sites

Bjr,

Je viens de télécharger et d'installer le nouveau module mondial relay mis sur add-on, il ne fonctionne pas chez moi, les points relais ne s'affichent pas et j'ai remarque qu'il n'y avait pas de choix entre widget et affichage classique.

Si ça fonctionne chez quelqu'un??

Share this post


Link to post
Share on other sites

Bjr,

Je viens de télécharger et d'installer le nouveau module mondial relay mis sur add-on, il ne fonctionne pas chez moi, les points relais ne s'affichent pas et j'ai remarque qu'il n'y avait pas de choix entre widget et affichage classique.

Si ça fonctionne chez quelqu'un??

 

S'il a été mis, il a été retiré car il n'y est pas sur addons. Attendons l'annonce officielle de sa sortie.

Share this post


Link to post
Share on other sites

Bonsoir GoldRazor

 

c'est ce que j'ai fait mais toujours impossible de sélectionner un relay .

 

je vais essayer en avec le FTP et réinstaller après 

Share this post


Link to post
Share on other sites

Bonjour,

j'ai suivi le process de désinstallation.

Cette version, la 2.0.3, fonctionne sans souci sur un PS 1.5.5.0 (1&1 mutu et template PS) et le pop-up fait apparaitre la liste des points relais. :)

Même process sur un autre PS 1.5.5.0 (je ne connais pas le serveur et template développé) , et rien ne se passe...

 

Qu'est ce qui bloque ?! est-ce lié au template, au javascript, au serveur ?

Share this post


Link to post
Share on other sites

Bonjour,

 

Ca fonctionne pour moi ouf !

J'ai juste fait la mise à jour et hop.

Il faut surtout vérifier (et c'est noté) de désactiver le cache et de forcer les completations smarty.

Share this post


Link to post
Share on other sites

 

Bonjour à tous,

Moi mon bug intervient encore plus tôt, à savoir que je ne peux même pas paramétrer l'affichage des points relais car l'onglet paramètres avancés du module m'affiche ça : 

 
  th_850444846_bug_mr_122_49lo.JPG
     ce qui veux dire que mon client peut sélectionner mondial relay mais ne peux pas choisir de relais pour récupérer sa commande... :wacko:
je l'ai donc désactivé pour le moment.
Merci d'avance de vos lumières. 

 

Bonjour,

Je viens d'installer cette nouvelle version et j'ai toujours le problème décrit ci-dessus.

presta 1.5.6.2

merci encore.

Share this post


Link to post
Share on other sites

Bon finalement ça marchait et j'ai recréé mes tranches et ça ne fonctionne plus ! 

Quand je vais dans mon catalogue produit du coup j'ai 2 fois Mondial Relay, je pense que c'est ça qui bug, non ?

Comment faire pour retirer un Mondial relay ?

Merci

Share this post


Link to post
Share on other sites

Bonjour tout le monde,

 

Si vous rencontrez un problème avec la nouvelle version du module, merci de créer des topics indépendants à celui-ci pour que l'on puisse s'y retrouver et traiter chaque topic au cas par cas, ce sera plus simple pour tout le monde :)

 

Merci et bonne journée.

Share this post


Link to post
Share on other sites

Bonsoir GoldRazor

 

c'est ce que j'ai fait mais toujours impossible de sélectionner un relay .

 

je vais essayer en avec le FTP et réinstaller après 

Bonjour as tu résoud le soucis car toujours le meme probleme pour moi impossible de sélectionner un point relais merci .

Share this post


Link to post
Share on other sites

Mais cette version, elle fonctionne en 1.6 ou pas ?

 

sinon, au niveau de créer des topics à chaque bug, vu comme c'est parti, il serait pas mieux de créer carrement un forum spécial bug mondial relais ? (Je plaisante, bien sur..)

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour as tu résoud le soucis car toujours le meme probleme pour moi impossible de sélectionner un point relais merci .

 

Bonsoir Laslaa62

 

Non pas encore mais le problème viens que lorsque je supprime le module avec le Back office les fichiers ne sont pas supprimé du serveur  , donc en réinstallant le nouveau module ça reprends également les anciens fichier et ce mets le bazar .

Edited by Eric72 (see edit history)

Share this post


Link to post
Share on other sites

Eric72 est ce qu'en installant en ftp ça fonctionne? Merci

Share this post


Link to post
Share on other sites

Eric72 est ce qu'en installant en ftp ça fonctionne? Merci

 

Non  :unsure:  je viens tout juste de fair le teste et toujours pas fausse piste pour moi . :unsure:  :unsure:

Share this post


Link to post
Share on other sites

Je viens de mettre à jour MR 2.0.1 > 2.0.3 : Plus de widget "choisissez votre point relais" alors que la version 2.0.1 fonctionnait :(

 

Y a t il une solution ?

Share this post


Link to post
Share on other sites

Bonjour,

 

Si vous constatez quelques bugs persistants, merci d'en notifier notre équipe de développeurs en créant un ticket sur la forge: http://forge.prestashop.com.

 

Merci !

Share this post


Link to post
Share on other sites