Jump to content

Problème pour passer de 1.5.6 à 1.5.6.1


Go to solution Solved by Agence Webinti,

Recommended Posts

Bonjour à tous,

Mon problème survient quand je souhaite upgradé de la version 1.5.6 à 1.5.6.1 grâce au module 1click to upgrade, car j'ai erreur qui revient sans cesse.
"Erreur Javascript (parseJSON) détectée pour l'action"backupFiles".Début de la restauration ..."

Même en mettant le zip dans admin/autoupgrade/download et en passant en mode expert.
J'ai toujours su upgrader les versions précédentes, mais j'ai des erreur à chaque fois avec celle-ci.

Si quelqu'un sait comment régler cela, je suis preneur.

 

A bientôt,

Tim

Share this post


Link to post
Share on other sites

Bonjour,

 

Quelle version du module ?

 

Il y a un problème lors du backup des fichiers. Rien avoir avec le zip ou le mode "expert".

 

Regardez vos logs d'erreurs Apache ou activez les erreurs dans /config/defines.inc.php, puis en activant les erreurs en bas du module d'upgrade puis en regardant la réponse avec Firebug  http://www.morefnu.org/post/2010/08/30/D%C3%A9bugger-de-l-Ajax-avec-firebug

 

C'est surement un problème de droit ou de fichiers trop gros. Regardez vers quel fichiers il s’arrête et regardez les fichiers après les derniers fichiers backupés. Par exemple le dossier downloads souvent.

 

Cordialement

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Bonjour à tous,

 

Mon problème survient quand je souhaite upgradé de la version 1.5.6 à 1.5.6.1 grâce au module 1click to upgrade, car j'ai erreur qui revient sans cesse.

"Erreur Javascript (parseJSON) détectée pour l'action"backupFiles".Début de la restauration ..."

Même en mettant le zip dans admin/autoupgrade/download et en passant en mode expert.

J'ai toujours su upgrader les versions précédentes, mais j'ai des erreur à chaque fois avec celle-ci.

 

Si quelqu'un sait comment régler cela, je suis preneur.

 

A bientôt,

Tim

j'ai le mme pb au moment de l'extraction : Téléchargement terminé. Extraction ...

 

[Ajax / Server Error for action unzip] textStatus: "error " errorThrown:"Service Unavailable " jqXHR: " "

Share this post


Link to post
Share on other sites

Bonjour,

 

Les messages sont différents, ce n’est pas le même problème. Votre serveur renvoie "Service Unavailable" lors de l'extraction.

 

Uploadez une 1.5.6.1 dézippée dans /admin/autoupgrade/latest/ mais vous aurez probablement le même souci ensuite si il n'arrive pas à dezipper l'archive. Essayez de faire une mise à jour sur un serveur local dans un premier temps. Assurez vous bien de faire un back up manuel des fichiers et de la base et assurez vous d’être en mesure de les restaurer manuellement.

 

Cordialement

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Bonjour Gregory,

En fait la version de mon module est 1.2.5 je viens encore de réessayer à l'instant et exactement la même erreur.

Ce qui est étrange, c'est qu'elle n'intervient pas au même endroit, c'est variable, parfois c'est juste après le dézippage du fichier, parfois plus tard.

Je peux vous donner des accès admin pour regarder cela en MP si vous le souhaitez.
 

Merci pour votre aide :-)

Share this post


Link to post
Share on other sites

Bonjour,

 

Il dézippe l'archive de prestashop, mais il zippe votre back up.

 

Regardez vos logs Apache d'erreurs. les erreurs y son consignées.

 

Ou il faut activer le mode_dev dans /config/defines.inc.php et regarder la réponse des requêtes ajax http://www.morefnu.org/post/2010/08/30/D%C3%A9bugger-de-l-Ajax-avec-firebug qui contient l'erreur PHP si vous n'avez pas accès à vos logs.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

Il dézippe l'archive de prestashop, mais il zippe votre back up.

 

Regardez vos logs Apache d'erreurs. les erreurs y son consignées.

 

Ou il faut activer le mode_dev dans /config/defines.inc.php et regarder la réponse des requêtes ajax http://www.morefnu.org/post/2010/08/30/D%C3%A9bugger-de-l-Ajax-avec-firebug qui contient l'erreur PHP si vous n'avez pas accès à vos logs.

 

Cordialement

 

Je vais essayer cela, je viens d'essayer autre chose, vider mon dossier download + latest qui contenait tous deux des backups et dossier prestashop. puis j'ai uploadé la dernière version de PS. J'ai retenté un upgrade en prenant archive local, cette fois l'installation a été beaucoup plus loin, il restait moins de 4000 fichiers, et là l'erreur.

 

j'ai tout filmé, mais je ne crois pas que ça soit utile. je vais essayer avec les logs, même si je ne suis pas pro avec tout cela

Share this post


Link to post
Share on other sites

Bonjour,

 

Ces deux dossiers ne sont pas concernés. Ce ne sont pas des backups. Les backups sosnt dans admin/autoupgrade/backups/

 

Quand vous dites installation ? C'est le backup des fichiers ou le remplacement des fichiers ? Ce sont deux choses différentes. L'erreur que vous mettez dans le post initial parle de backup. Il a un soucis a faire le backup du site, souvent c'est un problème de droit ou de taille du backup.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

Ces deux dossiers ne sont pas concernés. Ce ne sont pas des backups. Les backups sosnt dans admin/autoupgrade/backups/

 

Quand vous dites installation ? C'est le backup des fichiers ou le remplacement des fichiers ? Ce sont deux choses différentes. L'erreur que vous mettez dans le post initial parle de backup. Il a un soucis a faire le backup du site, souvent c'est un problème de droit ou de taille du backup.

 

Cordialement

 

Oui excusez-moi en regardant la vidéo, il plante à la sauvegarde des fichiers. 

J'ai activé le mode_dev dans define.inc.php et quand je réessaye il est juste marqué 

[DEV] ajax request : unzip

 

Dans la console firebug dans script j'ai ceci:

 

 
<script type="text/javascript" src="/js/jquery/plugins/cluetip/jquery.cluetip.js"></script>

<script type="text/javascript" src="/js/admin.js"></script>
<script type="text/javascript" src="/js/toggle.js"></script>
<script type="text/javascript" src="/js/tools.js"></script>
<script type="text/javascript" src="/js/ajax.js"></script>
<script type="text/javascript" src="/js/jquery/plugins/chosen/jquery.chosen.js"></script>
<link rel="shortcut icon" href="/img/favicon.ico" />
<!--[if IE]>
<link type="text/css" rel="stylesheet" href="/css/admin-ie.css" />
<![endif]-->
<style type="text/css">
div#header_infos, div#header_infos a#header_shopname, div#header_infos a#header_logout, div#header_infos a#header_foaccess {
color:white
}
</style>
<script type="text/javascript">
function getPush()
{
$.post("ajax.php",{"getNotifications" : "1"}, function(data) {
if (data)
{
json = jQuery.parseJSON(data);
// Add orders notifications to the list
html = "";
nb_notifs = 0;
$.each(json.order, function(property, value) {
html += "<li>A new order has been made on your shop.<br />Order number : <strong>#" + parseInt(value.id_order) + "</strong><br />Total : <strong>" + value.total_paid_real + "</strong><br />From : <strong>" + value.customer_name + "</strong><br /><a href=\"index.php?tab=AdminOrders&token=fadea2d3e933dd2b32e9c749b1628204&vieworder&id_order=" + parseInt(value.id_order) + "\">Click here to see that order</a></li>";
});
if (html != "")
{
$("#list_orders_notif").prev("p").hide();
$("#list_orders_notif").empty().append(html);
nb_notifs = $("#list_orders_notif li").length;
$("#orders_notif_value").text(nb_notifs);
$("#orders_notif_number_wrapper").show();
}
else
{
$("#orders_notif_number_wrapper").hide();
}
// Add customers notifications to the list
html = "";
nb_notifs = 0;
$.each(json.customer, function(property, value) {
html += "<li>Un nouveau client s'est inscrit sur votre boutique<br />Customer name : <strong>" + value.customer_name + "</strong><br /><a href=\"index.php?tab=AdminCustomers&token=e39bfaf918054066d615b372ff57be5c&viewcustomer&id_customer=" + parseInt(value.id_customer) + "\">Click here to see that customer</a></li>";
});
if (html != "")
{
$("#list_customers_notif").prev("p").hide();
$("#list_customers_notif").empty().append(html);
nb_notifs = $("#list_customers_notif li").length;
$("#customers_notif_value").text(nb_notifs);
$("#customers_notif_number_wrapper").show();
}
else
{
$("#customers_notif_number_wrapper").hide();
}
// Add messages notifications to the list
html = "";
nb_notifs = 0;
$.each(json.customer_message, function(property, value) {
html += "<li>Un nouveau message a été posté sur votre boutique<br />From : <strong>" + value.customer_name + "</strong><br /><a href=\"index.php?tab=AdminCustomerThreads&token=5d6362634d321e47b1f19a605dde6ef4&viewcustomer_thread&id_customer_thread=" + parseInt(value.id_customer_thread) + "\">Click here to see that message</a></li>";
});
if (html != "")
{
$("#list_customer_messages_notif").prev("p").hide();
$("#list_customer_messages_notif").empty().append(html);
nb_notifs = $("#list_customer_messages_notif li").length;
$("#customer_messages_notif_value").text(nb_notifs);
$("#customer_messages_notif_number_wrapper").show();
}
else
{
$("#customer_messages_notif_number_wrapper").hide();
}
}
setTimeout("getPush()",60000);
});
}
$().ready(function()
{
var hints = $('.translatable span.hint');
var html = "";
var nb_notifs = 0;
var wrapper_id = "";
var type = new Array();
$(".notifs").live("click", function(){
wrapper_id = $(this).attr("id");
type = wrapper_id.split("s_notif")
$.post("ajax.php",{"updateElementEmployee" : "1", "updateElementEmployeeType" : type[0]}, function(data) {
if(data)
{
if(!$("#" + wrapper_id + "_wrapper").is(":visible"))
{
$(".notifs_wrapper").hide();
$("#" + wrapper_id + "_number_wrapper").hide();
$("#" + wrapper_id + "_wrapper").show();
}else

{
$("#" + wrapper_id + "_wrapper").hide();
}
}
});
});
$("#main").click(function(){
$(".notifs_wrapper").hide();
});
 

Edited by Gregory Roussac (see edit history)

Share this post


Link to post
Share on other sites

Ok mais comme l'erreur n'intervient pas toujours au même moment je ne sais pas du tout de où elle provient.

Aussi, j'ai tenté de faire la mise à jour en désactivant la sauvegarde des fichiers et bdd mais toujours pareil.
J'ai tenté votre méthode avec le débogage etc, mais je ne comprends pas où chercher et comment cela fonctionne.

Il n'y a pas un expert qui puissent intervenir sur mon site ?

Sachant que je n'ai jamais eu de difficultés avec les versions précédentes.

D'avance merci

Share this post


Link to post
Share on other sites

Oui la mise à jour a fonctionnée en passant tout le site en 777 enfin ! 

mais mon thème a perdu tout son CSS je vais essayer de réuploadé l'ancien dossier du thème.

Ce n'est pas grave d'avoir tout mon site en 777 maintenant ?

 

Merci pour votre aide

 

EDIT: J'ai réuplaodé mais mon site est apparemment toujours sans style. C'est un thème acheté sur addons.prestashop.

 

Cordialement,

Share this post


Link to post
Share on other sites
  • Solution

J'ai réuploadé ma sauvegarde de bdd dans phpMyadmin, et l'affichage du site redevient correct, mais du coup pas de 1.5.6.1.

Peut être que le thème ne supporte pas cette version.

En tous cas le problème de mise à jour venait des droits CHMOD.

Je vais devoir rester en 1.5.60 on dirait, et malheureusement mon backup de bdd daté du 5/12 alors j'ai perdu des produits, quel noob que je suis..

BRef, on apprend tous les jours

 

EDIt: problème résolu, j'ai supprimé ma bdd, et remis la sauvegarde du 5/12 tout en gardant mon site sur version 1.5.6.1.

Mon thème marche désormais nickel, et je suis sur la dernière version.

 

J'ai juste perdu quelques produits et quelques clients (plus embêtant).

Merci pour m'avoir aidé et à bientôt.

Edited by tservices (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More