Jump to content
patrmich

Problème d'affichage des déclinaisons dans le FO de Prestashop 1.5.6

Recommended Posts

Bonjour,

Je viens de faire (à l'essai) la mise à jour de 1.4.7.0 vers 1.5.6.0

Je rencontre le problème suivant pour certains articles :
- les articles comportent un jeu de déclinaisons se rapportant à un seul attribut (attribut "Taille")
- cet attribut n'est pas du type "Couleur", mais du type "Liste déroulante"

Or, dans le FO, les articles correspondants s'affichent avec 2 options apparentes :
- une option anormalement présente : option "Choisissez un coloris"
    - tous les éléments de la palette correspondante sont des carrés noirs
    - au survol des carrés, s'affiche chacune des valeurs des tailles de l'attribut "Taille"
    - le clic sur l'un ou l'autre de ces carrés est sans effet
- une option normalement présente :
    - contenant, dans un menu déroulant, chacune des valeurs des tailles de l'attribut "Taille"

Par ailleurs, dans Catalogue  > Attributs et groupes, pour un attribut, si je modifie le Type d'attribut (de Liste déroulante en Bouton radio, par exemple), dans le FO, l'affichage reste sous forme de  Liste déroulante.

Merci par avance pour toute aide.

Cordialement,

Patrick

Share this post


Link to post
Share on other sites

Bonjour Patrmich,

 

Ça m'a tout l'air d'être un problème lié à votre thème, peut-être celui-ci n'est-il pas compatible PrestaShop 1.5.x.

 

Pouvez-vous faire le test avec le thème défaut?

 

 

Bien cordialement,

Share this post


Link to post
Share on other sites

Bonjour,

Merci à Vincent pour la réponse.

1- L'utilisation du thème par défaut au lieu de mon thème ne permettait pas de résoudre le problème.

2- J'ai trouvé une solution partielle ici :
- http://www.prestashop.com/forums/topic/191378-remove-color-picker-in-v15/

Donc, dans controllers/front/ProductController.php
j'ai remplacé :
                if ((isset($row['attribute_color']) && $row['attribute_color']) || (file_exists(_PS_COL_IMG_DIR_.$row['id_attribute'].'.jpg')))
par
                if ((isset($row['is_color_group']) && $row['is_color_group']) || (file_exists(_PS_COL_IMG_DIR_.$row['id_attribute'].'.jpg')))

Le problème n'est que partiellement résolu, car il reste au mojns deux problèmes :

Dans mon thème :
- dans le menu déroulant du choix de la couleur, la sélection d'une couleur permet bien l'affichage de l'image article correspondante (car dans Prestashop 1.4, j'avais fait les assignations déclinaison-image)
- MAIS, en cliquant sur une des couleurs du color picker, il ne se passe rien  :
    - l'image assignée à la couleur ne s'affiche pas
    - la couleur n'est pas modifiée dans la boîte de sélection

Dans le thème par défaut :
- le menu déroulant du choix de la couleur ne s'affiche pas (je suppose que c'est normal dans Prestashop 1.5.6, mais cela ne me paraît pas très ergonomique, car le nom des couleurs disponibles n'est ainsi visible qu'au survol de la souris)
- l'affichage de l'image est bien modifié par le clic sur une couleur de la palette de coloris du color picker

3- Dans mon thème, comme dans le thème par défaut :
- le prix affiché de certains articles, dans le Front office (sur la page produit seulement), est égal à 0
- alors que :
    - si on ajoute l'article au panier, son prix est correctement pris en compte
    - dans l'admin, le prix est correct
J'ai essayé de modifier le prix dans l'admin, puis de cliquer sur "Enregistrer et rester"
    - j'ai un message "Mise à jour réussie"
    - MAIS, la roue sur fond gris tourne indéfiniment
        - si j'actualise, dans le navigateur, plus de roue, et le nouveau prix semble pris en compte dans l'admin, mais l'affichage du prix dans le FO reste à 0.

4
- dans d'admin de Prestashop 1.4.7.0, lorsque je saisissais la référence d'un article dans le moteur de recherche, le temps nécessaire à la recherche était de l'ordre de 1 seconde
- dans l'admin de Prestashop 1.5.6.0, pour la même référence article, le temps nécessaire à la recherche était de l'ordre de 60 secondes !


Je suis désolé de signaler plusieurs problèmes dans un même Post, mais comme il me ne paraît pas impossible que tous ces problèmes soient liées entre eux, j'ai pensé qu'il serait peut être utile de les rassembler.

Merci encore par avance pour toute aide.

Patrick

Edited by patrmich (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Problème de sélection déclinaison résolu ?

 

Car actuellement j'ai un soucis, le problème est que sur smartphone ou tablette sous chrome la liste déroulante pour changer de déclinaison apparait puis disparait aussitot donc changement de déclinaison impossible :(  si quelqu'un à une idée ça serait top je perds beaucoup de client
 
Cordialement
 
www.dine-style.fr

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More