Jump to content
Ich Bins

1.5.5. Texteditor ist verschwunden (weg)

Recommended Posts

Hallo an alle,

der Texteditor ist verschwunden, die Kurzbeschreibung der Produkte und auch die Texte im CMS-Bereich werden nur noch in html dargestellt. Ich habe keine externen Module installiert. Neulich ging es noch. :(

 

Viele Grüße

Ich Bins

 

Share this post


Link to post
Share on other sites

Welche Änderungen hast du denn durchgeführt ? Irgendwelche /deinadmin/theme Datei geändert ?

Share this post


Link to post
Share on other sites

Ich habe im Admin-Bereich ein Override für die Lieferscheinnummern, damit sie numerisch sind und eines, dass die Firmennamen anzeigt im Bestellbereich. Ich habe beide Overrides rausgenommen, keine Besserung. Bei der Rechnung war es ja nur eine Änderung im tpl, das kann doch keine Auswirkung auf den Editor haben? Aber ich habe es ausprobiert. Doch auch hier ist keine Besserung zu sehen. Und im Textfenster selbst gibt es ja keinen Editor, und da habe ich mich ganz bewusst nur auf linebreaks und Absätze beschränkt, weil ich schon gelesen hatte, dass 1.5.5 in dieser Hinsicht sehr kritisch sein soll. Aber meinst Du wirklich, dass ein beim freien Text der Rechnung falsch eingegebener Text dazu führen kann, dass beim Menüpunkt Katalog/Produkte kein Editor erscheint? Das wäre ja gruselig.

 

Vielleicht ist der Editor ja auch noch da, nur die Features werden nicht mehr angezeigt.

Konnte man nicht irgendwo im BO den Editor auswählen - oder erinnere ich das vollkommen falsch? Ich finde die Stelle nicht mehr. Da meine Kundin auch im BO arbeitet, kann es auch immer sein, dass sie irgendwo eine Einstellung ändert, an die ich gar nicht denke.

Edited by Ich Bins (see edit history)

Share this post


Link to post
Share on other sites

OK, der HTML-Code kann es dann nicht sein, overrides aber leider schon. sonst würde ich alle Anpassungen rückgängig machen. Dann jede einzelne wieder aktivieren und immer wieder den Cache dazwischen leeren und probieren, bis der Übeltäter ausgeforscht ist... 

 

Wenn du Debug-Modus aktivierst, kommt keinerlei Fehlermeldung auf der Produktseite im Bacfk-Office? http://www.prestashop.com/forums/topic/281317-tippfehlermeldungen-aktivieren-debug-modus/

Share this post


Link to post
Share on other sites

Also, ich habe folgende Fehlermeldungen:

Warning: file_put_contents(/www/htdocs/w00f974f/2013/config/xml/default_country_modules_list.xml) [function.file-put-contents]: failed to open stream: Permission denied in /www/htdocs/w00f974f/2013/classes/controller/AdminController.php on line 1540

Warning: simplexml_load_file() [function.simplexml-load-file]: I/O warning : failed to load external entity "/www/htdocs/w00f974f/2013/config/xml/default_country_modules_list.xml" in /www/htdocs/w00f974f/2013/classes/controller/AdminController.php on line 1542

Warning: Invalid argument supplied for foreach() in /www/htdocs/w00f974f/2013/classes/controller/AdminController.php on line 1544

Warning: file_put_contents(/www/htdocs/w00f974f/2013/config/xml/tab_modules_list.xml) [function.file-put-contents]: failed to open stream: Permission denied in /www/htdocs/w00f974f/2013/classes/controller/AdminController.php on line 2957

 

Das dreht sich fast alles um CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST

 

Ich werde weiter suchen, wie ich den AdminController.php so verägert habe.

 

Aber ich habe noch ein Phänomen, vielleicht hängt das damit zusammen. Die grünen "Speichern"-Knöpfe funktionieren nicht mehr.

Edited by Ich Bins (see edit history)

Share this post


Link to post
Share on other sites

permission denied, was mehrfach in den Fehlermeldungen vorkommt klingt etwas nach mangelnden Datei- oder und Benutzerrechten.

"Ich kann die Datei nicht öffnen, weil ich nicht das Recht dazu habe"

Im Konkreten Fall würde ich mir auch den übergeordneten Ordner noch ansehen, da die Funktion oben "file_put_contents" auch dann nicht wirken kann, wenn der Ordner / das Verzeichnis nicht beschreibbar ist.

 

LG Klaus / Lockesoft

Share this post


Link to post
Share on other sites

Ich danke Euch sehr für Eure guten Tipps und die stets freundliche und schnelle Hilfe, die Ihr mir habt zukommen lassen.

Die Wege von meiner Kundin und mir haben sich getrennt. Ich bin für den Shop nicht länger zuständig.

Ich verabschiede mich also hiermit aus diesem Forum und wünsche Euch alles Gute.

Ihr könnt diesen Thread löschen, wenn Ihr wollt.

 

Viele Grüße

Ich Bins

Share this post


Link to post
Share on other sites

Bitter gerne. Falls du wieder einen Prestashop einrichten solltest und Fragen hast, dann weisst du ja wohin du dich wenden kannst.

Dir auch alles Liebe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More