Jump to content
mareblu

[gelöst] Keine Übersetzungen möglich

Recommended Posts

Hallo,

 

ich kann keine Übersetzungen vornehmen, bekomme immer die Meldung:

 

Diese Datei muss bearbeitbar sein: /home/seasons/public_html/themes/default2/lang//de.php

 

und

 

Achtung! Ihre PHP-Konfiguration schränkt die maximal erlaubte Anzahl von Feldern in einem Formular ein 1000 für die maximale Anzahl (Nummer) an Feldern.
Fordern Sie bitte Ihren Hosting-Provider auf, dieses Limit zu erhöhen Zumindest 1433. Sie können die Übersetzungsdatei aber auch manuell bearbeiten.

 

Wie kann ich das ändern?

 

LG,

mare

Edited by mareblu (see edit history)

Share this post


Link to post
Share on other sites

Danke, ich hatte gesucht, Suche hat aber keine Ergebnisse gezeigt.

 

Geht auch nicht, wenn ich die Änderungen speichern will, kommt folgende Meldung:

Datei kann nicht geschrieben werden: "/home/seasons/public_html/themes/default2/lang/de.php"

 

Was jetzt?

Share this post


Link to post
Share on other sites

Setze die Dateiberechtigung der de.php (themes/default2/lang/de.php) VORÜBERGEHEND mal auf 777

Share this post


Link to post
Share on other sites

Bitte überprüfe auch deine Dateiberechtigung, wie hier beschrieben: http://www.prestashop.com/forums/topic/134187-tippserver-mindestanforderung-und-minimal-konfiguration-fur-prestashop  Absatz Schreibrechte. Nicht nur in der /lang/de.php werden Übersetzungen gespeichert, sondern auch in anderen de.php-Dateien in anderen Unterordnern.

 

In der Regel reichen auch Schreibrechte CHMOD 0750. CHMOD 0777 sind übertrieben und öffnen nach außen Tür und Tor. Solche offenen Rechte sollte man auch vorübergehend nicht setzen, wenn nicht unbedingt nötig.

Share this post


Link to post
Share on other sites

Hallo Mare

 

normalerweise müssen die Zugriffsberechtigungen bei Prestashop bei den Ordnern bei chmod 755 und bei den Dateien bei chmod 644 liegen.

 

Nun sind zwei Möglichkeiten denkbar die den von dir beschriebenen Fehler auslösen könnten:

1. dein Server ist so konfiguriert, das er von vornherein höhhere Berechtigungen benötigt. Das könnte gewollt sein oder aber ein Konfigurationsfehler (ist uns leider auch schon passiert)

2. beim kopieren des Themes default nach default2 sind die ursprünglichen Berechtigungs-Einstellungen verlorengegangen.

 

Um den möglichen Fehler einzugrenzen setze mal kurzzeitig die Berechtigungen für die Ordner "themes/default2", "themes/default2/lang" und die Datei  "themes/default2/lang/de.php" auf chmod 777. (zum Beispiel mit Filezilla mit der rechten Maustaste auf den Ordner bzw. auf die Datei klicken und dann unter Dateiberechtigung den Wert numerisch eintragen).

Anschließend nochmal probieren die de.php zu erzeugen, falls es geklappt hat  kannst du die Berechtigungen gleich wieder zurücksetzen.

 

Lass dich durch den post#6 von cd2500 nicht verunsichern, im offiziellen Wiki von Prestashop wird das auch nicht so eng gesehen:

 

CHMOD

Icon

Changing file/folder permission on a Unix/Linux system is called a "CHMOD", after the command of the same name – you can find an explanation of file permissions here). Giving them "write permission" is called "doing a CHMOD 755" or "a CHMOD 775", depending on the host.

Icon

Some hosts might require you to use CHMOD 777, although it is not recommended for anything more than a one-time need.
If you have to use CHMOD 777 in order to install PrestaShop, make sure to switch to a safer setting (775, 755 or even 644) once you are done installing.

 

Von "Tür und Tor öffnen" kann keine Rede sein, bei einem Shared Server (der ungünstigste Fall) liegt die Wahscheinlichkeit das etwas passiert weit geringer als die Chance bei einem einmaligen Lotto-Tipp einen  "Sechser" zu haben.

 

Wenn garnichts gehen sollte könntest du die de.php auch lokal bearbeiten und dann in das entsprechende Verzeichnis deines Servers kopieren.

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Hallo Mare

 

normalerweise müssen die Zugriffsberechtigungen bei Prestashop bei den Ordnern bei chmod 755 und bei den Dateien bei chmod 644 liegen.

 

Dein Beitrtag hat einen kleinen Schönheitsfehler.

a ) Du verweist auf die Wiki für Prestashop 1.4. Die offizielle Wiki für Prestashop 1.5. findet man hier: http://doc.prestashop.com/display/PS15/Installing+PrestaShop. Prestashop verweist aber auch selbst auf Wikipedia

(Changing file/folder permission on a Unix/Linux system is called a "CHMOD", after the command of the same name (see: http://en.wikipedia.org/wiki/Chmod – you can find an explanation of file permissions here: http://www.elated.com/articles/understanding-permissions/).),

wo CHMOD genauer beschrieben ist. Umso höher die Zahl, umso unsicherer wird der Zugriff, sprich die Sperren von außen auf deinen Server. Umso höher die Zahl umso mehr erlaubt man. Das sollte jeden bewusst sein. Deshalb empfehle ich erst mit einer kleineren Zahl wie CHMOD 0750 zu versuchen, wenn der Fehler weiterhin besteht, dann bleibt einem sowieso nichts anderes über, als 0755 oder 0777 zu setzen. Lieber vorsichtiger vorgehen, als zu großzügig in so einem Fall. Ich hatte schon einen gehackten Host und weiss wovon ich spreche. Bin daher eher vorsichtiger.

 

b ) es steht bei beiden offizeillen Wikis, dass das Setzen der Schreibrechte auch Hosting abhängig ist. In der Regel reicht CHMOD 0750, weil einige Hoster Zwischenrechte wie 0755 auch garnicht erlauben. Man muss/sollte sich selbst damit herumspielen.

 

@ marbelu - ich bin sicher, dass dein CMS-Problem auch mit falsch gesetzen Rechten zu tun hat. Halte dich an den Link, welchen ich dir im Topic #6 genannt habe. Dur fährst aus langjänhriger Erfahrung sehr gut damit.

Share this post


Link to post
Share on other sites

Dann setze bitte wieder auf CHMOD 0750 oder weniger, wenn du alle Übersetzungen erledigt hast.Das Problem liegt am Provider selbst, welcher die Zwischenregeln nicht erlaubt. Ich hoffe das Problem mit dem CMS hast du auch schon in den Griff bekommen ?

Share this post


Link to post
Share on other sites

Ja, mach ich - Danke! Nein, das mit der CMS klappt noch nicht, ich muss mich heute nochmal dransetzen, hatte noch keine Zeit.

 

Danke nochmal und LG,

mare

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More