Jump to content

Problèmes de droits sur certains repertoires [résolu]


Recommended Posts

  Bonsoir,

  Je suis en train d' installer Prestashop sur un serveur Linux, qui tourne en local sur mon pc, et j' ai un problème de droit avec certains repertoires. (config, cache, log...)

  Je fais un tour sur la doc, il faut donc faire un chmod 755 -R ou 775 (je n' ai pas essayé le 777) sur chacun de ces fichiers, mais j' ai toujours ce message d' erreur.

  Merci d' avance pour votre aide.

Edited by ungars (see edit history)

Share this post


Link to post
Share on other sites

Bonjour

 

Comme vous êtes en local vous n'aurez pas de risque mettez en 777 tous les fichiers en même temps en passant par le mode console.

C'est un serveur qui tourne sur un système d'exploitation linux ou en simulation sur un pc windows ?

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

  Bonjour et merci pour votre réponse.

  Je suis en local sur un serveur Linux. Oui effectivement, je ne risque pas grand chose. Mais lorsque je vais le mettre en ligne, sur un serveur Linux, j' ai bien peur d' être confronté au problème.

  Bonne journée.

Share this post


Link to post
Share on other sites

  Bonjour et merci pour votre réponse.

  Je suis en local sur un serveur Linux. Oui effectivement, je ne risque pas grand chose. Mais lorsque je vais le mettre en ligne, sur un serveur Linux, j' ai bien peur d' être confronté au problème.

  Bonne journée.

Non quand vous mettez en ligne sur un autre serveur les fichiers vont reprendre les droits accordé par le serveur, c'est pas les fichiers qui décident mais le serveur qui impose :) gentillement.

 

Vous pouvez changer à tout moment le chmod

Il faut tester si vous vous bloquez sur tel ou tel point vous n'avancerez pas et il s'agit seulement lors de l'installation.

 

Vous utilisez quoi pour la gestion de l'hébergement ou vous le faites à la mano ?

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

  En fait,

  J' ai déjà fait plusieurs installation sur un mutualisé, je n' avais pas eu ce problème. La je vais installer prestashop sur un serveur Ubuntu Lucid, et là je suis en local sur une Ubuntu Lucid, donc je pense que je vais être confronté également à un problème de chmod.

  Je le fais en ligne de commande, je regarderai ce soir avec gedit si je peux changer les permissions graphiquement, je vous dirais ce que cela donne.

  Bon après midi.

Share this post


Link to post
Share on other sites

  Re,

  Même avec Nautilus, je ne peux changer les permissions. Quand je le fais, et que je valide, elles reviennent comme elle l' étaient au départ. Et là je suis coincé, je ne peux continuer l' installation.

  Bonne soirée.

 

  Edit : je viens de faire un essai, seul le chmod 777 semble être accepté. J' ai essayé un chmod 766, la page d' installation ne s' affiche pas.

Edited by ungars (see edit history)

Share this post


Link to post
Share on other sites

  Re,

  Même avec Nautilus, je ne peux changer les permissions. Quand je le fais, et que je valide, elles reviennent comme elle l' étaient au départ. Et là je suis coincé, je ne peux continuer l' installation.

  Bonne soirée.

Vous modifier les permissions en tant que root ou avec sudo ?

Sinon il faut voir à quel groupe les fichiers appartiennent il et possible qu'ils sont dans le groupe apache

Share this post


Link to post
Share on other sites

  J' avais édité mon message, j' ai fait plusieurs essais avec différents chmod. Seul le chmod 777 fonctionne. Avec le chmod 766, les pages ne s' affichent plus.  Sauf que lorsque je vais mettre prestashop sur mon vrai serveur, cela peut etre risqué de tout laisser comme ça.

  Je modifie les permissions avec sudo,

Share this post


Link to post
Share on other sites

Ok, je fais ça, et je rechange les permissions après. Ceux sont tous les dossiers en 755 et tous les fichiers en 644 ?

Bonne soirée.

Oui normalement 755 le propriétaire doit avoir tous les droits Lire Ecrire Executer

le groupe et les visiteurs Lire et Executer

Share this post


Link to post
Share on other sites

Bonjour

 

Il faut voir au niveau de votre serveur mais là ce n'est pas sur le forum de prestashop que vous aurez la réponse, votre problème ne concernent pas le fonctionnement de prestashop.

 

Regardez sur les forums Ubuntu.

Share this post


Link to post
Share on other sites

  Bonjour,

  J' ai posté sur le forum d' Ubuntu. Le problème s' est résolu apparament de lui même, même si je ne suis pas tout à fait dans la même configuration que quand mes pages blanches apparaissaient, mais je ne pense pas que cela influe grand chose (A voir quand même plus tard).

  Vu qu' on a évoqué une éventualité, je mets le lien ici, car quelqu' un pourrait y être confronté.

 

  Merci pour votre aide.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More