Jump to content

Prix spécifiques -> total commande / panier faux


Recommended Posts

Bonjour,

 

J'ai un soucis avec des règles de prix. 

 

Sur ma boutique, je propose un prix en CHF (53.40 chf HT = 55 chf TTC) et je crée une règle de prix spécifiques pour les euros (40 € euros TTC). 

Voyez en pièce jointe ma règle. 

 

Bien qu'en Front-office les prix s'affichent correctement et le bon montant de 40 euros est envoyé vers ma plateforme de paiement, le total du panier et de la commande reprennent le 53.40 chf HT et par conséquent le shop m'indique que le paiement est erroné. 40 CHF au lieu de 53.ch CHF (au passage, il change la devise du montant de 40 euros. 

 

Le problème ne vient pas de la plateforme de paiement qui reçoit bien 40€ et qui retourne la bonne devise, le bon montant au shop après le paiement. 

 

Le problème se situe au niveau du shop. Dans le détail de ma commande ainsi que du panier, le produit est indiqué à 53.40 chf et non pas 40€.

 

Je pense que dans la mesure où il y a des conditions qui dépendent du compte client, le shop est incapable de comprendre quelle(s) règle(s) il doit appliquer. 

 

Y a-t-il un moyen de faire en sorte que les montants soient bons ?

 

Merci d'avance pour votre aide.

post-76189-0-72816900-1383299210_thumb.png

post-76189-0-67538500-1383299218_thumb.png

post-76189-0-73361500-1383299224_thumb.png

Edited by SamXIV (see edit history)

Share this post


Link to post
Share on other sites
  • 1 year later...

Bonjour,

 

je rencontre le même problème.

Aviez vous pu trouver une solution ?

 

Merci par avance pour votre aide !

Bonjour,

 

si vous n'utilisez pas la même version que le créateur du topic il serait préférable de créer votre propre topic en indiquant toutes les informations concernant votre soucis.

Share this post


Link to post
Share on other sites

Quel est le module paiement?

Est-ce un module 1.5+ ou utilise-t-il backward compatibility ?

 

Lors de la validation par le service/section du module, le context n'est pas correctement rétabli. La device, le pays, le client ne sont pas vus à cette étape.

 

Ce bug 1001x reporté, documenté à été classé non reproduit par le team et les devs de certains modules ne cherchent pas a envisager les scénarios des vrais boutiques.

 

Perso == gueulante.

 

Comme d'hab dirons certains

Share this post


Link to post
Share on other sites

Merci pour votre réponse.

 

Pour le module de détection du pays par l'IP, nous utilisons Geo Targeting Pro (il nous permet d'afficher en front office un prix spécifique au pays)

Pour le module de paiement, nous utilisons PayBox

Le montant payé par PayBox est conforme au montant attendu mais le montant affiché par le détail de la commande correspond au prix français (alors que la commande est à l'étranger)

Share this post


Link to post
Share on other sites

Nous avons des prix différents en France et dans le reste du monde.
L'affichage des prix à l'étranger est OK mais lorsqu'une commande est passée (achat à l'étranger avec IP étrangère, adresse de facturation à l'étranger et livraison à l'étranger), dans le back-office, c'est le prix français qui est affiché dans le résumé de la commande et non pas le prix étranger (et cela déclenche l'affichage d'une erreur de paiement dans le back-office).

Par exemple :
en France, notre produit est à 320 €. A l'étranger, le produit est à 340 €.
Il y a 15 € de frais de transport.
La commande a lieu au Japon et le montant payé est bien de 355 € (340+15).
Par contre, dans le back-office, il est affiché que le montant de la commande est de 335 € (320 + 15)

 

Share this post


Link to post
Share on other sites

Et sinon répondre au questions de base en disant les version que vous utilisez car là vous nous faites du blabla sans inbtérêt sur un topic qui n'est pas le votre.

 

Je suis dur dans mes propos mais ayez au moins la politesse de respecter les problèmes des autres et aussi de répondre aux questions que l'on vous pose !

Share this post


Link to post
Share on other sites

Bien sur vous avez raison, désolé d'avoir posé ma question sur ce topic, mais le problème me semblait être identique et n'avait pas reçu de réponse depuis Novembre 2013.

Aucune volonté malveillante de ma part...

Sinon, il s'agit de PS 1.6.0.9

 

Merci beaucoup^pour votre aide

Share this post


Link to post
Share on other sites

... n'avait pas reçu de réponse depuis Novembre 2013.

Heu 2014? ou alors ce n'était pas la 1.6.0.9...

 

---

 

 

Sinon ce ticket me semble correspondre au problème du module de paiement voyant un prix et la commande créée avec un autre montant dans le cas de prix spécifique -

http://forge.prestashop.com/browse/PSCSX-1506

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

A priori, 2013 pour l'absence de réponse.

Effectivement, la version 1.6.0.9 n'existait pas à l'époque mais c'est la version que j'utilise actuellement :)

 

Merci pour pour votre réponse : une idée comment corriger ce problème ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More