Jump to content
  • 0
kjean

Problème règle de taxes HT / TTC ne s'applique pas dans la fiche produit

Question

Bonjour,

 

Alors voila, j'utilise la version de prestashop 1.5.3.1 et voici le souci que je rencontre depuis plusieurs jours et pour lequel je ne trouve vraiment aucune solution.

 

Quelle que soit la règle de taxe que je sélectionne dans le menu déroulant d'une fiche produit, le prix Final affiché reste invariable! (ceci depuis le début de l'installation de PS, ça n'a jamais été autrement...)

 

Exemple

-----------

prix de vente HT : 10

règle de taxe : FR Taux standard (19.6%)

prix de vente TTC : 10

PRIX FINAL : 10

 

Je sais pourtant que le prix de vente TTC ainsi que le prix final devrait se mettre à jour en temps réel lors de la saisie en tenant compte de la règle de taxe sélectionnée mais non, c'est comme si aucune règle ne s'appliquait ??

 

Je sais que bien souvent il s'agit d'un petit détail tout bête qui échappe et qu'il peut avoir ce type d'incidence mais là vraiment je ne comprends pas... qu'est ce que je ne fais pas ou mal, s'agit-il d'un bug auquel cas comment le contourner ?

 

Comment faire pour que lorsque je sélectionne une règle de taxes dans le menu déroulant d'une fiche produit le prix TTC et FINAL prennent en compte cette taxe et s'ajustent en conséquence plutôt que de rester invariable ?

 

Voir pièce jointe SVP

 

Merci beaucoup pour votre précieuse aide!

Jean

post-631029-0-47235800-1383477279_thumb.jpg

Edited by kjean

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

J'ai enfin trouvé la solution! :)

Je finalise ce que j'ai à faire car ce travail est urgent et reviendrai ici poster la marche à suivre.

En souhaitant que tous ceux qui rencontrent cette difficulté puisse lire ce post!

Share this post


Link to post
Share on other sites
  • 0

Bonsoir!

J'aimerai bien savoir comment vous avez réglé votre problème, j'ai un peu le même souci avec une règle de taxe hors Europe.

Share this post


Link to post
Share on other sites
  • 0

Bonsoir!

 

J'aimerai bien savoir comment vous avez réglé votre problème, j'ai un peu le même souci avec une règle de taxe hors Europe.

 

Bonsoir Valencey,

 

J'avais l'intention de poster des copies écran mais l'heure étant quelque peu tardive je me vois contraint d'être un peu plus bref :)

 

En fait, il m'a fallu modifier la règle de taxe afin de résoudre le problème. C'est-à-dire me rendre dans:

Localisation > Règles

puis éditer la règle concernée en cliquant sur l'icône "modifier" à gauche de la petite corbeille

A ce stade, vous serez alors situé dans "Localisation > Règles > Modifier". Il est fort probable que tout comme moi vous n'ayez aucun pays de listé sous la section "règle" contenant exclusivement le champs dédié au nom de cette dernière (ex: FR taux standard (19.6%)) et en dessous "active"... il vous faut donc impérativement créer une nouvelle règle de taxe à partir de cet endroit en cliquant en haut à gauche sur "Ajouter une nouvelle règle de taxe" ... alors apparaît une nouvelle section dans laquelle il faut sélectionner le ou les pays concerné(s) ... en ce qui me concerne il s'agissait de "tous", puis valider l'ensemble en cliquant sur "enregistrer". Ne pas oublier de s'assurer que la règle est activée, bien entendu (dans la section supérieure, le V vert).

 

En espérant que ces indications vous soient utiles. Au besoin n'hésitez pas!

Edited by kjean

Share this post


Link to post
Share on other sites
  • 0

Merci pour votre réponse! Mais non, j'ai toujours mon problème, les pays sont pourtant bien indiqués en dessous de la règle de taxe... :(

Share this post


Link to post
Share on other sites
  • 0

Merci pour votre réponse! Mais non, j'ai toujours mon problème, les pays sont pourtant bien indiqués en dessous de la règle de taxe... :(

 

De rien. J'en suis sincèrement désolé mais je ne connais pas la solution à cette problématique. J'espère que vous avez pu résoudre le problème depuis votre dernier post. Bon courage en tous les cas!

Share this post


Link to post
Share on other sites
  • 0

Vérifier si dans les options de ton transporteur, la taxe est sélectionné, car il me semnle avoir eu un soucis similaire. On ne sait jamais.

 

Intéressant, merci pour cette information VincentMobile

Share this post


Link to post
Share on other sites
  • 0

Bonsoir Valencey,

 

J'avais l'intention de poster des copies écran mais l'heure étant quelque peu tardive je me vois contraint d'être un peu plus bref :)

 

En fait, il m'a fallu modifier la règle de taxe afin de résoudre le problème. C'est-à-dire me rendre dans:

Localisation > Règles

puis éditer la règle concernée en cliquant sur l'icône "modifier" à gauche de la petite corbeille

A ce stade, vous serez alors situé dans "Localisation > Règles > Modifier". Il est fort probable que tout comme moi vous n'ayez aucun pays de listé sous la section "règle" contenant exclusivement le champs dédié au nom de cette dernière (ex: FR taux standard (19.6%)) et en dessous "active"... il vous faut donc impérativement créer une nouvelle règle de taxe à partir de cet endroit en cliquant en haut à gauche sur "Ajouter une nouvelle règle de taxe" ... alors apparaît une nouvelle section dans laquelle il faut sélectionner le ou les pays concerné(s) ... en ce qui me concerne il s'agissait de "tous", puis valider l'ensemble en cliquant sur "enregistrer". Ne pas oublier de s'assurer que la règle est activée, bien entendu (dans la section supérieure, le V vert).

 

En espérant que ces indications vous soient utiles. Au besoin n'hésitez pas!

 

Merci ça marche super !!

Share this post


Link to post
Share on other sites
  • 0

Bonjour, 

 

J'ai besoin de votre aide, je suis en train de migrer ma boutique de Shopify vers Prestashop, tout se passait bien jusqu'a maintenant ... Je bloque sur le paramétrage des taxes (une des raisons de ma migration). Prestashop c'est du nouveau donc je ne sais pas comment faire. J'utilise la dernière version (v1.6.0.11). 

 

Afin que les taxes soient calculées en fonction de l'adresse de livraison, essentiel car je suis en Corse et sur l'alimentaire notamment, nous avons un taux de TVA réduit à 2.1 % au lieu de 5.5 % voir même sur le vin 0% contre 20% si livraison hors Corse. 

 

J'ai donc créé une règle de taxe comme il se doit pour les produits d'épicerie (Cf. pièce jointe), j'ai testé et ça fonctionne. Mon problème est que les prix affichés pour la catégorie visiteur (aucune adresse renseignée) s'affichent en HT. 
Vous me direz, c'est logique prestashop attend l'adresse de la personne, seulement cela ne me convient pas du tout car cela peut surprendre un prospect et pourrait même le rebuter. 

 

Je vois trois solutions : 

 

1. Masquer les prix pour la catégorie visiteur (ce qui pourrait les pousser à repartir du site) et mettre un message expliquant qu'il faut être connecté pour voir les prix (comment faire ?). 

 

2. Faire un encadré dans lequel il serait expliqué que les prix sont en HT en tant que visiteur et que les prix TTC s'affichent une fois connecté en tant que client (pas très pro). 

 

3. Faire en sorte que le prix affiché soit le prix TTC le plus important (5.5%) et qu'une fois connecté la taxe soit recalculée  ou pas en fonction de l'adresse. (Il vaut mieux un prix à la baisse qu'un prix à la hausse)

 

Y aurait il parmi vous des personnes qui ont rencontré ce problème ? Comment le régler ? 

 

Merci d'avance

 

post-915687-0-41428700-1423677420_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More