Jump to content
Sign in to follow this  
chiconus

Bloqué à l'étape 3 de l'installation (v1.2.4)

Recommended Posts

Et pourtant j'ai déjà pas mal cherché !!

config de l'hébergeur :
Platform Type
Windows 2003 Server Enterprise

MySQL Version
5.0.45

Perl Version
5.8.8

PHP Version
5.2.0

J'ai aussi mis le display error à "on" dans le fichier de config. (mais ça n'a rien affiché en plus)


Quand je lance une installation from scratch à l'étape 3 :
- check de la DB. résultat dans firebug : OK

- click sur "suivant", le gif animate démarre, le bouton est désactivé. Puis après de longues secondes, le gif disparait, le bouton est réactivé .... et rien d'autre. Firebug n'a rien ajouté. Bizarre, il n'a pas noté la request createDB.

- à ce moment, la db contient de nouvelles tables mais pas toutes. Et le nombre de tables créées après mes tentatives est variable ... comme si un process ne s'est pas terminé... mais pas toujours au même endroit.

- alors désespéré, je reclique sur "suivant" et là j'ai une trace dans firebug :
GET model.php method=createDB
Et le résultat est "fail", error code 14. mmap cache can't open .....\settings.inc.php

help help et re-help ;) Si vous avez besoin de plus d'info pour comprendre le problème, je suis dispo !!

Pour info, j'avais installé la version 1.2.2 sans problème sur chez cet hébergeur.

Merci

Share this post


Link to post
Share on other sites

oui j'ai mis tous en 777 récursivement.

J'ai testé l'installation en mode simple.
J'ai eu le résultat suivant :
result OK
mais avec un warning : [warn-phpd] mmap cache can't open \\boswinfs02\home\users\web\b2540\ywh.monsite\mondirectory\config\settings.inc.php (pid 9580 th 10752)

Share this post


Link to post
Share on other sites

WORKAROUND : Est-ce que ça pauserait un problème si j’installais prestashop 1.2.4 en local, et ensuite j’exporterais la DB vers mon hébergeur.

En imaginant que la tentative infructueuse d’install précédemment cité a tout de même bien configuré le path db. Ce qui semble le cas car une partie des table est tout de même créée.
=> Est-ce qu’il y a d’autres fichiers à changer manuellement?

Share this post


Link to post
Share on other sites

Bonjour

Est-ce que chmod 777 est bien le droit d'écriture chez cet hébergeur ou il diffère à vérifier tous les hébergeurs n'acceptent pas le 777.

Ou en nettoyant le cache de smarty via le ftp /tools/smarty/cache

Share this post


Link to post
Share on other sites

Pas toujours :

Si votre hébergement est chez OVH, il faut savoir que leurs serveurs n'acceptent pas les chmod 777 sur les dossiers. Il faut mettre un chmod 755. dixit : formation-joomla

Chez OVH, le chmod 777 est interdit, d'ou l'erreur 404.
Le chmod max autorisé est 755


Et chiconus à mis tout récursivement je suppose le dossier et les fichiers

C'est juste une suggestion

Share this post


Link to post
Share on other sites

Ou en nettoyant le cache de smarty via le ftp /tools/smarty/cache


J'ai refait l'install sur un tout nouveau directory : donc pas de cache
Et tout les droits en récursif. Les directory ont bien 777 mais les fichiers restent en 02767. (tous les droits sauf exécution dans les permissions de groupe)

En local pas de problème.

Share this post


Link to post
Share on other sites

Comme je ne vois pas d'autre solution pour faire marcher le site chez cet hébergeur ... Je voudrais faire ceci :

WORKAROUND : Est-ce que ça pauserait un problème si j’installais prestashop 1.2.4 en local, et ensuite j’exporterais la DB vers mon hébergeur.

En imaginant que la tentative infructueuse d’install précédemment cité a tout de même bien configuré le path db. Ce qui semble le cas car une partie des table est tout de même créée.
=> Est-ce qu’il y a d’autres fichiers à changer manuellement?

Share this post


Link to post
Share on other sites

Bonjour

Si la DB en local et la DB de l'hébergeur que celui-çi n'a mis aucune restriction, qu'elles ont la même version
Le même login d'accès, mot de passe. Ça devrait logiquement fonctionner sans problème, suffira de la récupérer dans la bonne version sql ou zip ou autre.
Et de faire l'import. Maintenant au pire que l'hébergeur n'as pas fait la mise à jour et a une version MySql 4 version en arrière et que vous avez la plus récente là il y a risque que ça ne fonctionne pas.

Il faut essayer, si vous avez déjà un prestashop en ligne fonctionnel, faites le test dans un répertoire ou un sous-domaine et si une seule base de donnée, mettre un préfixe differents et tester.

Tester c'est comme la pratique en forgeant on deviens forgeront.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More