Jump to content

[RESOLU] Mails automatiques considérés comme des spams à haut risque...


Recommended Posts

Bonjour à toutes et à tous

 

Depuis 2 jours, les mails automatiques générés par ma boutique sont considérés comme des spams à haut risque et sont systématiquement bloqué par le serveur de mon hébergeur.

 

Je suis sous prestashop 1.5.3.1

Hébergé chez ikoula sur serveur mutualisé.

 

Ma boutique est hébergée sous un nom de domaine chez ikoula que j'appelle ici mon-domaine1.com

Au moment où j'ai créé ma boutique, mon-domaine1.com me convenait très bien.

Puis j'ai décidé de prendre un nom de domaine plus approprié.

 

J'ai déposé ce deuxième nom de domaine chez 1and1 : mon-domaine2.com

J'ai associé une adresse mail à ce nom de domaine : contact@mon-domaine2.com

Pour ne pas m'embarquer dans un changement de nom de domaine sur mon serveur ikoula, j'ai ensuite fait une simple redirection http depuis www.mon-domaine2.com de chez 1and1 vers www.mon-domaine1.com de chez ikoula.

 

Jusqu'à présent, tout fonctionnait sans aucun problème. J'avais renseigné mon adresse mail contact@mon-domaine2.com dans les paramètres email et les préférences coordonnées, j'avais défini les envois depuis ma page de contact et tout roulait.

Je recevais des mails automatiques à l'inscription d'un client, lors d'une commande, lors d'un changement de statut de commande, depuis le formulaire de contact, etc... sur contact@mon-domaine2.com

 

Le dernier mail automatique généré date du 12/10.

 

Le 13, deux client se sont inscrits et ont commandé.

 

Les inscriptions et les commandes ont fonctionné normalement.

 

Mais j'ai reçu à chaque fois sur contact@mon-domaine2.com des messages d'erreur, pour l'inscription et la commande, identiques à celui-ci :

 

 

This is the mail system at host vmheb62092.ikoula.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<contact@mon-domaine2.com>: The message was rejected due to classification
as Spam, Virus, High bulk ratio or High-risk; Reference ID:
str=0001.0A0C0204.525BDDD7.014A,ss=3,re=0.000,recu=0.000,reip=0.000,cl=3,cld=1,fgs=0

 
Reporting-MTA: dns; vmheb62092.ikoula.com
X-Postfix-Queue-ID: 5F03E1AA1FF
X-Postfix-Sender: rfc822; <contact@mon-domaine2.com>
Arrival-Date: Mon, 14 Oct 2013 14:04:12 +0200 (CEST)

Final-Recipient: rfc822; contact@mon-domaine2.com
Action: failed
Status: 5.7.1
Diagnostic-Code: X-Postfix; The message was rejected due to classification as
Spam, Virus, High bulk ratio or High-risk; Reference ID:
str=0001.0A0C0204.525BDDD7.014A,ss=3,re=0.000,recu=0.000,reip=0.000,cl=3,cld=1,fgs=0

 
Return-Path: <contact@mon-domaine2.com>
Received: by vmheb62092.ikoula.com (Postfix, from userid 10133)
    id 5F03E1AA1FF; Mon, 14 Oct 2013 14:04:12 +0200 (CEST)
To: contact@mon-domaine2.com
Subject: Message de test - Prestashop
X-PHP-Originating-Script: 10133:MailSend.php
From: contact@mon-domaine2.com
Reply-To: contact@mon-domaine2.com
Date: Mon, 14 Oct 2013 14:04:12 +0200
X-LibVersion: 3.3.2
MIME-Version: 1.0
Content-Type: text/html; charset=iso-8859-1; format=flowed
Content-Transfer-Encoding: 8bit
Message-ID: <20131014120412.6748.77229547.swift@mon-domaine1.com>
X-CTCH-SenderID: 127.0.0.1
X-CTCH-SenderID-TotalMessages: 1667
X-CTCH-SenderID-TotalSpam: 2
X-CTCH-SenderID-TotalSuspected: 0
X-CTCH-SenderID-TotalBulk: 2
X-CTCH-SenderID-TotalConfirmed: 0
X-CTCH-SenderID-TotalRecipients: 0
X-CTCH-SenderID-TotalVirus: 0

 

Je vérifie tout, fait plusieurs tests et effectivement, plus rien ne fonctionne.

 

Je me rapproche d'ikoula, je reste 1/2 heure au téléphone avec un opérateur qui me raconte des trucs assez fumeux et qui finit par me proposer la solution suivante : créer une adresse mail directement sur mon serveur ikoula et renseigner le bo prestashop avec cette adresse. Voici son message par mail :

 

 

Comme discuté avec vous, il faudrait que vous créiez une boite de messagerie (avec mot de passe) sur le plesk de votre domaine pour l'adresse contact@mon-domaine1.com
Ensuite, dans la configuration de votre back-office renseigner l'adresse précédemment créer en indiquant que le serveur smtp requiert une authentification (login et mot de passe, le login étant l'adresse mail).

 

Je crée donc une adresse contact@mon-domaine1.com sur mon serveur ikoula, je me bats pour trouve les paramètres smtp, je les trouve, je renseigne, je teste : rien ne fonctionne et cette fois, c'est sur l'adresse contact@mon-domaine1.com du serveur ikoula que le même message d'erreur est arrivé. Un comble, non ?

 

Au moment où j'écris ces lignes, j'ai informé ikoula qui ne m'a pas encore répondu.

 

Pourquoi tout d'un coup mes mails sont considérés comme des spams alors que tout marchait bien depuis plusieurs semaines ? Mystère...

 

Visiblement, chez ikoula ils sont incapables d'expliquer ce problème et encore moins de le résoudre.

 

A priori, il semblerait que la seule solution serait de carrément changer d'hébergeur, avec tous les ennuis que ça risque de comporter.

 

J'ai écumé le forum à la recherche d'une solution. J'ai bien trouvé plusieurs post traitant de problèmes avec l'envoi automatique de mails, j'ai testé quatre solutions au cas où, mais rien n'y a fait.

 

Avant de me résoudre à changer d'hébergeur, je poste ici pour savoir si quelqu'un a déjà eu le même problème et a pu le résoudre.

 

Si oui, de quelle manière ?

Si non, un utilisateur expérimenté de prestashop aurait-il la gentillesse de me donner son sentiment, ou peut-être même un début de piste de solution ?

 

D'avance merci infiniment pour vos réponses.

 

Très cordialement à toutes et tous

 

Snatch

Edited by Sn4tcHz (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Pour un email pro, j'ai eu le meme soucis a la difference prêt que je suis sur un dedié kimsufi.

J'ai installé DKIM pour Gmail / Yahoo, SPF pour hotmail et cie., j'ai ajouté deux champs TXT correspondant dans les DNS du domaine.

Cela n'a pas été très simple a mettre en place mais cela a résolu mon problème en -24h.

 

Ce n'est pas forcement votre faute, vous etes sur un mutu, il suffit qu'il y est un seul spammeur sur le serveur pour que touts les domaine soient bannis.

Dans mon cas, j'ai du faire partie d'une plage IP bannie car j'ai le controle de tout les mail sortant du serveur et aucune trace de spam dans mes logs.

 

J'ai utilisé cet outil http://www.mail-tester.com/ principalement mais mes recherches mon amené a en utilisé plusieurs. Aujourd'hui, j'ai un 10/10 :)

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci pour votre réponse.

Je suis en lien avec ikoula, et il apparait maintenant clairement que le problème vient de chez eux.

J'ai testé avec différente adresse mail, y compris une créée spécialement sur le serveur qui héberge le site, et ça ne passe toujours pas.

Le problème SPF / TXT a été évoqué et des solutions ont été testées, mais là aussi rien.

 

Ce n'est pas forcement votre faute, vous etes sur un mutu, il suffit qu'il y est un seul spammeur sur le serveur pour que touts les domaine soient bannis.

Dans mon cas, j'ai du faire partie d'une plage IP bannie car j'ai le controle de tout les mail sortant du serveur et aucune trace de spam dans mes logs.

 

J'ai utilisé cet outil http://www.mail-tester.com/ principalement mais mes recherches mon amené a en utilisé plusieurs. Aujourd'hui, j'ai un 10/10 :)

 

L'idée d'un spammeur sur le même serveur est une bonne piste. Je vais brancher ikoula dessus, je m'étonne qu'il n'y ait pas pensé. A priori, ils me disent qu'il n'y a pas de black list sur ce serveur, mais je vais les retitiller la dessus.

 

Je vais utiliser le mail-tester et continuer à chercher.

 

Merci beaucoup d'avoir pris le temps de me répondre :)

Share this post


Link to post
Share on other sites

Oui, suite à votre post, j'ai creusé dans cette direction et effectivement il y en a pas mal.

En tout cas http://www.mail-tester.com/ , vraiment très bien, ça m'a permis de bien faire avancer l'histoire.

 

Au final :

Je viens d'avoir un mail d'Ikoula :

 

 

Nous avons dû désactiver une option du serveur de mail à l'origine du dysfonctionnement.

 

Et effectivement, tout remarche...

Le problème venait donc bien de chez eux, suite à un upgrade effectué sur leurs serveurs en général, et le mutu sur lequel je suis en particulier.

 

Moralité 1 : j'ai bien fait de ne pas lâcher le morceau devant les premiers "c'est pas nous c'est 1and1" lourdement servis par ikoula, en insistant sur le peu de logique de leurs arguments en regard du contenu des messages d'erreur.

 

Moralité 2 : à force de les harceler de mails et après 3 coups de fil (payants, certes, mais...) musclés, j'ai fini par obtenir que ce soit la même personne qui s'occupe de mon cas, au lieu de chaque fois tomber sur un opé qui reprenne tout à zéro en perdant un temps et une efficacité précieux.

 

Moralité 3 : une fois de plus j'ai posté un message sur ce forum et j'ai obtenu réponses et pistes de solution. Vive le forum Prestashop. Et un immense merci à vous, 2FR3,  pour votre concours.

 

Je marque donc ce post en RESOLU, en espérant qu'il pourra servir à d'autres prestashoppers à l'avenir.

 

Bien à toutes et tous

 

Snatch

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More