Jump to content
Sign in to follow this  
fe1lho

PS 1.2 : Utilisation de fichier .htaccess

Recommended Posts

Bonjour,

J'utilise Apache 2 et je n'ai pas d'autentification dans le dossier Admin, ce qui me fait dire que la fonction htaccess n'est pas fonctionnelle...
Je n'ai rien vu dans les fichiers logs d'apache.
Avez vous une idée ?

Merci de votre aide.

Share this post


Link to post
Share on other sites

En fait le terme exact, est que je n'ai pas de fenetre pour acceder à la page login.
C'est à dire que j'arrive directement sur la page de login, alors que le .htaccess me fait dire que je devrai avoir une fenêtre pour accéder au site admin (le BO)

Share this post


Link to post
Share on other sites

Je ne comprends pas.

En fait le terme exact, est que je n'ai pas de fenetre pour acceder à la page login.


Tu t'attends à quoi ?

alors que le .htaccess me fait dire que je devrai avoir une fenêtre pour accéder au site admin (le BO)


Qu'est-ce qui te fait dire ça ?

La procédure normale :
* tu tapes l'URL de ton BO
* tu rentres l'e-mail et le mot de passe et tu valides.

Share this post


Link to post
Share on other sites

Si je ne me trompe pas, cette mécanique demande une authentification pour acceder au dossier, avec un login/password qui est défini dans ledit fichier, compte qui peuvent être différent des comptes employés.
C'est seulement sur validation de l'authentification Apache, qu'ensuite l'utilisateur peut se logger sur son compte

Share this post


Link to post
Share on other sites

Quelle mécanique ?... Si tu veux définir une identification supplémentaire par un htacces, libre à toi.

Mais la marche normale de PS, c'est : tu tapes l'URL de ton BO, tu atterris sur une page comme ça :
http://www.prestashop.com/demo/demo/login.php?redirect=index.php
tu loggues et tu rentres. Rien d'autre.

Evidemment si tu t'es pas déloggué lors de la dernière visite récente, tu rentres directement.

Share this post


Link to post
Share on other sites

Pourtant, sur le wiki
http://www.prestashop.com/wiki/FR-guide_de_ladministrateur_systeme/
nous avons une information sur la Mise en place d’une authentification basique (htaccess)

C'est ce que j'aurais voulu mettre en place, mais apparemment cela ne fonctionne pas.
C'est aussi ce qui me fait dire que le fichier .htaccess généré pour le URL simplifiée ne fonctionne pas ...

Share this post


Link to post
Share on other sites

Salut a tous

Quel sont les étapes que tu as entreprises pour mettre en place l'authentification par le fichier htaccess.

Si tu veux je re explique le procédé.

voici mon htaccess donc la restriction ce fait par User et MDP et IP

alors c'est très simple et très efficace tu crées un nouveau répertoire a la racine de ton site pour y ajouter ton HTPASSWD qui contiendra l'user et le Mot de passe exemple crée un reperetoir BAD ensuite tu génère le MDP ici

http://aspirine.org/htpasswd.html en MD5

ton fichier HTPASSWD contiendra donc Cte ligne

TOTO:$apr1$aEUEwFE5$4ZjstidRZ1FCXMfnY8TjU1.



Toto est l'user et $apr1$aEUEwFE5$4ZjstidRZ1FCXMfnY8TjU1. est le mot de passe Encyrpter MD5 qui correspond a Pg5EnP4GEa-

tu mets le fichier .HTPASSWD dans ton nouveau répertoire,ici dénommé BAD.

Ensuite le fichier .htaccess

ou tu ajoutes ces lignes

AuthUserFile /repertoire/user/www/bad/.htpasswd
AuthGroupFile /dev/null
AuthName "Accès sécurisé, au site Lafouillasse "
AuthType Basic
Order Deny,Allow
Deny from all
Satisfy all
Allow from 82.2xxx.xxx.xx
Require user Toto



Attention a bien définir la valeur AuthUserFile cette ligne indique ou trouver le fichier .htpasswd, Require user indique le nom d'utilisateur ,Allow from 82.2xxx.xxx.xx indique une IP qui elle seule a les autorisations d'aller dans le répertoire bloquer par le htaccess.

Une chose supplémentaire de restriction serais donc d'ajouter un fichier htaccess dans le répertoire BAD afin que personne ne puisse lire ton fichier Htpasswd avec Cte ligne

AuthGroupFile /dev/null
AuthName "Accès protégé"
AuthType Basic
deny from all




Voila ce devrait fonctionner
j'espère avoir étais a peu prés clair :)

Bye Yannick

Share this post


Link to post
Share on other sites

Oui tout est très clair...
C'est d'ailleurs ce que j'ai mis en place à quelques détails près...
J'ai mis en place les sécurités comme ceux que tu as indiqué mais cela ne me donne pas satisfaction...

Je regarde coté configuration Apache si il faut activer un module en particulier...

Merci de ton aide.

Share this post


Link to post
Share on other sites

Re
Au faite, tu test sur quel système d'exploitation? quel message d'erreur rencontre tu?
bye

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More