Jump to content
machomaaan

[gelöst] 1.5.5.0 - Ladezeit 13.149s ?

Recommended Posts

Hallo Prestashop-Gemeinde.

 

Ich habe den Shop installiert und befülle Ihn gerade mit Produkten.

Allerdings es ist extrem mühsam, da der Shop sowohl im Frontend als auch im Backend extrem langsam ist.

 

Hat einer Tipps, was alles aktiviert bzw. deaktiviert werden sollte, um den Shop wenigstens brauchbar zu machen?

Ich habe jetzt einige Zeit investiert um die ganzen Artikel an zu legen, aber mit dieser Geschwindigkeit wird wohl kein Besucher auch nur annähern bleiben und stöbern...

 

Ich bitte um eure Hilfe und Tipps.

 

Zu meinem Shop:

 

Version: 1.5.5.0

Theme: Sellya

Ladezeit im Backend ist immer unterschiedlich, kürzlich hatte ich 13,149s...da wird man bei über 200 Artikel alt beim anlegen...

 

Shop-URL: www.womens-world.at/index.php  (index.php ist derzeit wichtig, da die Seite noch mit einer .html-Datei verdeckt wird)

 

Vielen Dank für eure Mühe im Vorhinein!

Share this post


Link to post
Share on other sites
Ladezeit im Backend ist immer unterschiedlich, kürzlich hatte ich 13,149s...da wird man bei über 200 Artikel alt beim anlegen...

 

Gerade hatte ich 24,141s im Backend...so kann man nicht arbeiten :(

Share this post


Link to post
Share on other sites

Dann frage ich einfach mal nach den Basics, die ja eigentlich als unbedingt anzugeben, sehr wichtig bereits in den Forumsregeln erwähnt werden ....

 

Wie sieht Deine PHP / Serverkonfiguration aus?

Die Kurzfassung ist einsehbar in Deinem Back-Office ---> Erweiterte Einstellungen ---> Konfiguration

 

Wo ist der Shop gehostet?

Evtl. auch mit welchem Tarif?

 

Ist evtl. im Back-Office ---> Erweiterte Einstellungen ---> Leistung ---> Kompilierung erzwingen

noch eingeschaltet?

 

LG Klaus / Lockesoft

Edited by Lockesoft (see edit history)

Share this post


Link to post
Share on other sites
Ist evtl. im Back-Office ---> Erweiterte Einstellungen ---> Leistung ---> Kompilierung erzwingen

noch eingeschaltet?

 

Ich habe gerade den Template-Cache auf "Nie neu kompilieren" gestellt.

Dabei ist mir eine Fehlermeldung aufgefallen:

"Verzeichnis benötigt Schreibrechte für die Nutzung von Smart Cache."

 

Welchen Ordner muss ich Schreibrechte erteilen?

Den normalen Cache Ordner? Oder wo finde ich den Smart Cache Ordner?

 

PHP-Einstellungen habe ich an meinen Provider weitergeleitet... mal sehen was sich tut...

 

Danke auf jeden Fall erstmal für eure Hilfe und Mühe!

Share this post


Link to post
Share on other sites

Smart Cache bezieht sich auf die CCC Optionen etwas weiter unten auf der Seite. Sobald eine der Checkboxen auf etwas anderem als "Konventionelle Funktionsweise beibehalten" gesetzt wird braucht man das Verzeichnis /cache/ in Deinem Templateverzeichnis und es muss dann eben auch beschreibbar sein.

 

LG Klaus / Lockesoft

Share this post


Link to post
Share on other sites

Ich habe gerade den Template-Cache auf "Nie neu kompilieren" gestellt.

Dabei ist mir eine Fehlermeldung aufgefallen:

"Verzeichnis benötigt Schreibrechte für die Nutzung von Smart Cache."

 

Welchen Ordner muss ich Schreibrechte erteilen?

Den normalen Cache Ordner? Oder wo finde ich den Smart Cache Ordner?

 

PHP-Einstellungen habe ich an meinen Provider weitergeleitet... mal sehen was sich tut...

 

Danke auf jeden Fall erstmal für eure Hilfe und Mühe!

Guckst du bitte in dem Tutorial nach, welches ich dir verlinkt habe. Dort sind die Schreibrechte ebenso beschrieben.

Share this post


Link to post
Share on other sites

Smart Cache bezieht sich auf die CCC Optionen etwas weiter unten auf der Seite. Sobald eine der Checkboxen auf etwas anderem als "Konventionelle Funktionsweise beibehalten" gesetzt wird braucht man das Verzeichnis /cache/ in Deinem Templateverzeichnis und es muss dann eben auch beschreibbar sein.

 

LG Klaus / Lockesoft

Da muss ich dir leider wiedersprechen Klaus. CCC hat nichts mit dem cache von smarty zu tun. Das ist ein php-Modul welches am Server läuft. CCC sollte nicht eingeschaltet sein, wenn es nicht am Sever aktiviert ist. Man kan es daran erkennen, dass es nicht aktiviert ist, wenn z.B. das Theme zerschossen ist. Smarty Cache ist ein default Feature von Prestashop und benötigt keine extra Einstellungen am Server. PHP ist eine Skriptsprache die immer eine Compiler benötigt. Das hat aber nichts mit CCC zu tun.

Share this post


Link to post
Share on other sites

Da hast du wohl nicht richtig gelesen, Conny. ^_^

 

Klaus hat von Smart Cache gesprochen und der hat nichts mit Smarty Cache zu tun. Mithilfe von Smart Cache werden die CSS-Datein komprimiert. Du kannst das gern in der PrestaShop-Dokumentation nachlesen: http://doc.prestashop.com/display/PS15/Understanding+The+Advanced+Parameters (leider nur auf Englisch).

 

Es verhält sich genau so, wie Klaus dargestellt hat. Die CCC-Cache-Daten werden im Unterverzeichnis /cache des jeweiligen Templates abgelegt. Daher bringen die Schreibrechte für den Cache-Ordner im Hauptverzeichnis in diesem Fall überhaupt nichts.

Share this post


Link to post
Share on other sites

Sorry, aber die Option CCC ist die falsche Stelle. CCC wird die Seite kaum beschleunigen. die 13 Sekunden zeigen, das der Server a) schlecht für Prestashop konfiguriert ist und b ) absolut keinen Cache verwendet, außer die Cache Kompilierung und Caching die standardmäßig jedes moderne PHP-Skript verwendet.

 

Smart Cache ist was anderes und legt wie du nennst den Cache unter /cache ab, damit die Seite etwas schneller geladen wird. wird der Cache gelöscht wird die Seite komplett neu aufgebaut, was natürlich länger dauert.

 

Der User sollte seinen Server besser konfigurieren lassen und eine Cache-Option wie memcache verwenden.

Edited by cd2500 (see edit history)

Share this post


Link to post
Share on other sites

@CD2500

 

Bitte lies doch zunächst mal genau, bevor du Ratschläge erteilst! Anders sind sachkundige Antworten kaum möglich.

 

 

Ich habe gerade den Template-Cache auf "Nie neu kompilieren" gestellt.

Dabei ist mir eine Fehlermeldung aufgefallen:

"Verzeichnis benötigt Schreibrechte für die Nutzung von Smart Cache."

 

Welchen Ordner muss ich Schreibrechte erteilen?

Den normalen Cache Ordner? Oder wo finde ich den Smart Cache Ordner?

 

Hier geht es um eine konkrete Fehlermeldung und nicht um deine Meinung, wie man CCC einsetzt oder auch nicht. Und diese Fehlermeldung bezieht sich offenkundig nicht auf den Smarty Cache, sondern auf eine aktivierte CCC-Option.

 

@machomaan

Der Grund für die lange Ladezeit ist die Verlinkung mit Googleapis und kostenlosen Google Webfonts, die über fonts.googleapis.com/css bezogen werden und im Quelltext meiner Meinung nach auch noch falsch verlinkt sind:

<link type="text/css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Open+Sans">

Es muss heißen:

<link type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Open+Sans">

In jedem Fall aber würde ich von solchen Umwegen bei einem Online-Shop abraten. Denn deine Ladezeiten sind auf diese Weise wirklich grottenschlecht. Ich hoffe, dein Webdesigner hat dafür nicht auch noch Geld bekommen.

Share this post


Link to post
Share on other sites

In jedem Fall aber würde ich von solchen Umwegen bei einem Online-Shop abraten. Denn deine Ladezeiten sind auf diese Weise wirklich grottenschlecht. Ich hoffe, dein Webdesigner hat dafür nicht auch noch Geld bekommen.

 

Hallo!

 

Vielen Dank für die Informationen und Tipps.

Leider muss ich zugeben, dass ich dieses Theme gekauft habe... Ich verwalte nur die Seite für eine Freundin bzw. habe ihr den Prestashop empfohlen und installiert bzw. konfiguriert.

 

Ich werde mich auch einmal mit dem Theme-Ersteller in Verbindung setzen - warum soll ich seine Mist-Codierung ausbessern...

 

Danke nochmals für die Tipps und Infos, sobald es News gibt, werde ich hier berichten!

Share this post


Link to post
Share on other sites

Vielleicht noch als Nachsatz. Ich hab es gerade mal getestet, die Verlinkung ohne den Zusatz "http:" funktioniert. Das ändert aber nichts ander Tatsache, dass erst bei Aufruf des von dir betreuten Shops Skripts, Ajax-Routinen und CSS-Styles von Google-Seiten nachgeladen werden müssen. Das verzögert dann den Seitenaufbau.

 

Und das "Beste" zum Schluss: Verzögerte Ladezeiten bestraft Google seit 2010 mit einem schlechten Ranking.

Share this post


Link to post
Share on other sites

Zum Problem: Mit dem Standard-Theme und ohne Anpassungen ist der Server schnell, oder das gleiche Problem mit längerer Ladezeit ? Falls Ja, dann liegt es am Server und Module die nicht korrekt programmiert sind, machen noch zusätzlich ein Problem.

Share this post


Link to post
Share on other sites

Teste deine Seite mal mit: www.webpagetest.or

 

Du wirst jede Menge Probleme mit deinem Server erkennen. Compression und Cache, sowie keep-alive ist am Server garnicht installiert, bzw. schlecht konfiguriert. Cache bringt dir nichts mit 35% und bezieht sich vermutlich nur auf den Smart Cache in den Skripten von Prestashop gecodet. Das ist aber viel zu wenig, um einen schnellen Shop zu betreiben.

Edited by cd2500 (see edit history)

Share this post


Link to post
Share on other sites

Dein Time to first byte mit 34 Sekunden ist ja grottenschlecht. Dein Server könnte wesentlich besser sein, wenn korrekt konfiguriert für Prestashop. Die Server-Module gzip und keep-alive sind auf dem Server nicht installiert oder nicht aktiviert/konfiguriert.

Edited by cd2500 (see edit history)

Share this post


Link to post
Share on other sites

Lass es doch jetzt einfach gut sein, ja? Der User hat bereits zu erkennen gegeben, dass er weiß, worum es geht und demnächst berichten wird.

 

Und nur zur Info:

Die Apache-Einstellung Keep-Alive ist längst nicht überall verfügbar und macht auch nichts weiter, als dem Server zu sagen, dass die Clients die Verbindung offen halten dürfen und nicht, wie bei HTML erforderlich, für jeden Request (Skripte, CSS, Grafiken etc.) eine neue Verbindung aufgebaut werden soll. Das haben die meisten Server schon deswegen nicht aktiviert, weil die meisten Internetprojekte auf Shared Servern liegen. Wenn man daher versuchen würde, für jedes Web-Projekt automatisch für alle Clients die Verbindungen offen zu halten, geht irgendwann die Performance des Servers in die Knie. Dann leiden alle.

Das heißt, theoretisch bekäme zwar ein Client einen Performanceschub, aber die Kapazitäten des Servers reichen irgendwann nicht mehr aus, um ihm den auch zu gewährleisten. Interessant ist das Ganze ohnehin mehr fürs Suchmaschinenranking.

 

Wer auf Keep-Alive also nicht verzichten möchte, muss sich nach einem anderen Hoster oder eben einem eigenen dedizierten Server umschauen. Aber das macht man doch nicht für einen kleinen Shop mit 200 Produkten!

Share this post


Link to post
Share on other sites

Ja, keep-alive bringt aber auch speed, vor allem dann wenn man mit Cache arbeitet. Und ja der Server ist Schuld, die Abfragen schwanken von 12 bis 34 Sekunden. Das wäre für mich, egal wie billig der Webspace auch ist, keine Option einen Shop zu betreiben. Schliesslich will man ja verkaufen und nicht potentielle Kunden verärgern. Wer an dieser Stelle spart, sollte sich das Geld sparen und auf einen Onlineshop zur Gänze verzichten. Damit ist man besser beraten.

Share this post


Link to post
Share on other sites

Hm... interessant, dass mein letzter Beitrag nicht erscheint....

 

Ja, aber auch auch keep-alive bringt Speed, und 90% der korrekt eingestellten Server (auch geteilte Server, deiner im Übrigen auch) haben dieses Modul installiert und auf open konfiguriert und arbeiten mit load-balance.

Im Endeffekt wird der User mit diesem Server nicht glücklich werden und er sollte, wenn nicht anpassbar, sich einen besseren Provider suchen, denn Speed verkauft und wie du selbst auch zustimmst, werden langsame Shops im Google abbestraft.

Was möchte denn ein Verkäufer mit einem Onlineshop ? Verkaufen. Sonst wäre es doch verlorene Zeit, nur weil man am falschen Platz spart.

Edited by cd2500 (see edit history)

Share this post


Link to post
Share on other sites

:(

 

Also der Theme-Hersteller meint, dass es mehr als 150 Shops gibt, die mit diesem Theme problemlos laufen.

 

Mit dem Provider habe ich jetzt auch Kontakt aufgenommen, dieser kann mir erst ab einem höheren Server das MemoryLimit auf 260MB setzen...

Ich persönlich hätte damit überhaupt kein Problem, es soll ja ordentlich funktionieren - aber meine Freundin (der Inhaber dieser Seite) wird stink sauer sein, da ich Ihr diesen Provider empfohlen habe. Habe schon mehrere Seiten (normale Websites) dort gehostet und nie Probleme gehabt.

Und da der Provider als "Zubehör" auch den Prestashop anbietet, bin ich schon davon ausgegangen, dass der dann auch ordentlich läuft auf dem Server...

 

werde da mal nach haken!

 

Aber es besteht immer noch ein Problem mit dem Cache scheinbar!

Ich habe folgende Einstellungen:

 

Template-Cache: Templates nach Datei-Änderungen neu kompilieren.

Cache: aktiviert

Test-Konsole: nicht öffnen

 

Kombinationen: aktiviert (kann ich aber auch nicht ändern)

Produktmerkmale: aktiviert

 

"Smart Cache" für CSS: CCC für CSS verwenden

"Smart Cache" für JS: CCC verwenden

Reduzierung des HTML-Codes: HTML-Code nach Ausführung des Smarty-Kompilierung reduzieren

Kompression von JS im HTML: JS nach Ausführung der Smarty-Kompilierung im HTML-Code einbetten.

Apache-Optimierung: aktiviert

 

Algorithmus: Rijndael mit der Bibliothek mcrypt verwenden

 

Verwenden Sie den Cache: aktiviert

Cache-System: Dateisystem (keine andere Auswahl vorhanden!!)

 

Darunter steht eine Warnmeldung mit

"Das CacheFS-System kann nur dann genutzt werden, wenn der Shop auf einem Front-End-Server aufsetzt. Wenn Sie sich nicht sicher sind, fragen Sie Ihren Hoster."

und unter dieser ist ein INPUT-Feld ohne Bezeichnung und mit einer 1 eingetragen. Was das ist, habe ich keine Ahnung?!?

 

Außerdem, auch wenn ich jetzt keine Änderung gemacht habe und auf "Speichern" klicke, bekomme ich eine Fehlermeldung

"Verzeichnis benötigt Schreibrechte für die Nutzung von Smart Cache."

 

Der Ordner Cache im Root steht auf 0755?!

 

Nochmals vielen Dank für eure Mühe!

Share this post


Link to post
Share on other sites

Datei-Cache macht nur Probleme, du solltest diese Option lieber garnicht verwenden. Besser ist eine Cache-Option am Server selbst. memcache, e-accelerator.

 

Dein großes handycap ist: der Server wird von vielen anderen geteilt. Dein loadingtime schwankt zu sehr von 12 bis 34 Sekunden. Time to first byte ist auch horrend. Sorry, aber damit kannst du wirklich keinen Prestashop betreiben, der auch verkaufen soll. Die Kunden laufen dir davon, wenn sie die Seite irgendwann mal in der Suchmaschine gefunden haben. Ich würde da doch tiefer in die Tasche greifen und einen Server nehmen, der für Prestashop optimiert ist. Bin bei Edis in Graz, wenn es ein Server in AT sein soll. Sicher ist der Preis ein anderer, aber es zahlt sich aus.

Share this post


Link to post
Share on other sites

Template-Cache: Templates nach Datei-Änderungen neu kompilieren.

Cache: aktiviert

Test-Konsole: nicht öffnen

 

Kombinationen: aktiviert (kann ich aber auch nicht ändern)

Produktmerkmale: aktiviert

 

"Smart Cache" für CSS: CCC für CSS verwenden

"Smart Cache" für JS: CCC verwenden

Reduzierung des HTML-Codes: HTML-Code nach Ausführung des Smarty-Kompilierung reduzieren

Kompression von JS im HTML: JS nach Ausführung der Smarty-Kompilierung im HTML-Code einbetten.

Apache-Optimierung: aktiviert

 

Algorithmus: Rijndael mit der Bibliothek mcrypt verwenden

 

Verwenden Sie den Cache: aktiviert

Cache-System: Dateisystem (keine andere Auswahl vorhanden!!)

 

Ok, damit kommen wir der Sache schon näher. Da bei der überschaubaren Größe deines Shop der Cache sich nicht sonderlich auswirken dürfte, solltest du folgende Einstellungen verwenden:

  • Smarty-Cache deaktivieren
  • Alle 4 CCC-Optionen auf "Konventionelle Funktionsweise beibehalten" setzen

    (einzig Reduzierung des HTML-Codes könnte später versuchsweise wieder aktiviert werden)

  • Apache-Optimierung deaktivieren

    (eventuell später versuchsweise wieder einschalten)

  • Cache: Verwenden Sie Cache deaktivieren

    Da offenbar weder memcache noch irgendein anderes Cache-System auf deinem Server installiert ist, bekommt du auch die Meldung: 'Dateisystem (keine andere Auswahl vorhanden!!)'

Die Fehlermeldung in Bezug auf Smart-Cache rührt von den CCC-Optionen her. Daher auch mein Vorschlag, hier die konventionelle Funktionsweise beizubehalten, damit es keine Probleme gibt.

 

 

Außerdem, auch wenn ich jetzt keine Änderung gemacht habe und auf "Speichern" klicke, bekomme ich eine Fehlermeldung

"Verzeichnis benötigt Schreibrechte für die Nutzung von Smart Cache."

 

Der Ordner Cache im Root steht auf 0755?!

 

Wie dir Lockesoft und ich weiter oben schon erklärt haben, bezieht sich diese Meldung auf einen gleichnamigen Ordner 'cache', der sich im Verzeichnis deines Templates befindet.

Edited by eleazar (see edit history)

Share this post


Link to post
Share on other sites

Ich glaube, das ist wenig hilfreich, denn dieser Beitrag von dh42 bezieht sich leider auf die Einrichtung eines eigenen (virtuellen) Servers, genauer gesagt eines Dynamic Cloud Servers - daher die vielen detaillierten Einstellungen.

 

Immer erst lesen ... ;)

Share this post


Link to post
Share on other sites

Die Werte und was ein Server leisten sollte, sind die gleichen und ohne zusätzlichen Cache (dort beschrieben) ist ein Prestashop nicht einmal mit wenigen Artikeln optimal zu betreiben. Man nehme sich einfach das heraus, was auf einen zutrifft...

Share this post


Link to post
Share on other sites

Vielen, vielen Dank!

Ich habe die Performance-Einstellungen jetzt angepasst und mein Provider hat mir die Werte auf Kulanz etwas erhöht, jetzt funktionierts ganz gut, zumindest die ersten paar Tests!

Einzig das Abspeichern eines Artikels im Backend (also übertragen in die Datenbank) dauert noch etwas. Aber das kann man schlucken...

 

Wichtig ist, dass der Kunde im Frontend nicht gleich die Nerven verliert und einen Rückzieher macht.

 

Danke an die Community und eure Hilfe und Tipps!

Ich denke, man kann dieses Thema jetzt schließen, mir wurde auf jeden Fall geholfen ;) DANKESCHÖN!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More