Jump to content
rvkvino

Enable Social network login in my shop

Recommended Posts

I have create website for book seller and integrated with basic free modules. My problem is i integrated Social login settings with the help of  OneAll Social Login. And also i followed and created secrete keys and saved the settings. But when i used to login with these social networks getting problem in URL.

 

My shop URL is :www.rahmath.org

 

But when i use social network login my URL getting  like,

http://http//www.rahmath.org/oneallsociallogin.php?back=http%3A%2F%2Fwww.rahmath.org%2Findex.php%3F

 

How to solve this problem, Please help any one, Thanks in advance

Share this post


Link to post
Share on other sites

i don't know how the  OneAll Social Login plugin works, is there some module for this? if so, can you share url to it? i will test it on my own demo store

 

btw. have tried with login radius?

Share this post


Link to post
Share on other sites

Here you are http://docs.oneall.com/plugins/guide/social-login-prestashop/

Tutorial and module.

I've have some problems with it when trying to enter the website via http://mysite.com/authentication?back=my-account there's a pop up window that says that authorization has been successfully completed. Аnd then there's redirection to the following unknown page http://mysite.com/%2fauthentication%3fback%3dmy-account =(

Share this post


Link to post
Share on other sites

wow,they have a module for prestashop, iam fed up of login radius, it just dont work for me well. I will give this a try and let you know > thanks for sharing. !

 

Btw. @vekia, here is the module http://docs.oneall.com/plugins/guide/social-login-prestashop/

 

 

rkvino, have to created the apps on facebook and other networks or you missed that step? Just installing the module wont log you in.

Edited by indus (see edit history)

Share this post


Link to post
Share on other sites

Hi, i resume this old thread...

I've correctly setup all account in oneall, installed last version of prestashop module (for 1.6) on my 1.6.0.8...

But i've a problem: after login (correct) the user see blank page...

 

Can you help me?

thanks,

GL

Share this post


Link to post
Share on other sites

blank page = errors

turn on error reporting then instead of blank page you will see information what doesnt work

  • Like 1

Share this post


Link to post
Share on other sites

Guys I found a solution to this.

 

If you were redirected to a blank page OR If you get an error like PHP Fatal error: Class 'OneAllSocialLoginController' not found then you might have to refresh the PrestaShop class cache.

 

Simply delete the file /cache/class_index.php from your PrestaShop folder. PrestaShop will automatically create a new, updated version of that file. (keep a backup of the file just in case)

  • Like 1

Share this post


Link to post
Share on other sites

blank page = errors

turn on error reporting then instead of blank page you will see information what doesnt work

 

yes, there was an errore but i've solved, thanks for your help, you are always extremely helpful vekia!!!

 

Guys I found a solution to this.

 

If you were redirected to a blank page OR If you get an error like PHP Fatal error: Class 'OneAllSocialLoginController' not found then you might have to refresh the PrestaShop class cache.

 

Simply delete the file /cache/class_index.php from your PrestaShop folder. PrestaShop will automatically create a new, updated version of that file. (keep a backup of the file just in case)

 

thanks man, this is the way!

I've renamed class_index.php and i've activate the module... It works! 

 

Thanks guys!

Giovanni

Share this post


Link to post
Share on other sites

anyone getting an error trying to purchase goods when logged in through facebook / twitter using one all and purchasing through paypal?

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator at webmaster@this.domain to inform them of the time this error occurred, and the actions you performed just before this error.

 

More information about this error may be available in the server error log.

 

http://url.com/modules/paypal/express_checkout/payment.php?token=EC-123&PayerID=456

Share this post


Link to post
Share on other sites

trun on error reporting and then reproduce the issue

you will see detailed log information

share it here

  • Like 1

Share this post


Link to post
Share on other sites

okay

if you will know somethig more please share log here

this will be first step in debug process

Share this post


Link to post
Share on other sites

thanks @vekia. i have got onto oneall and gave me a change (to ask for all info from social networks). i will check and let people know. also twitter apparently give email address so that is problem. lastly the server said erro , as in the time took to long , could have been server. when i get reply i wil post up here no prob. have a nice week folks, trev

Share this post


Link to post
Share on other sites

hey @wayann no havent had time yet. i will post up reply when i try however :) have you any problems with it or got it working? trev

Share this post


Link to post
Share on other sites

@trevorgilligan I got it working, but just in case I'm facing your issue with my customers I'd like to know how to properly address that, anyway thanks for sharing with us.

Share this post


Link to post
Share on other sites

hey @wayann for now just so you know i am using the "OneAll" network log in. if you are in back end, set the require email and other info button to yes. see twitter doesnt give out the email address automatically. i tried with twitter and it may work with facebook. im pretty busy but as soon as i get time i will post this back up here no problem. but the only solution i have is to require all info from twitter, facebook when they log in through them. if you have more questions let me know, trev

Share this post


Link to post
Share on other sites

this module is worked with my website.  please check " www.uthmart.com " module hooked on second page of website. I am using PS 1.4.8.3.

After login its open allone website & after few second its redirect on your own site. I am not sure about that they take any data from you or not. Please confirm if anybody idea about this. Also please confirm that is it safe or not.

 

Thanks & Regards

Devendra

  • Like 1

Share this post


Link to post
Share on other sites

hi devandra and wayann. i was told in config to ask user for all info from social networking site is a setting in config. i didnt try it myself but was told it would work. in the end i removed one all as it slowed down site. also another issue was that i had changed the name of some of the statuses (paid, delivered, pending) from default values, i changed them back to default and hey presto (or presta) it worked. trev

  • Like 1

Share this post


Link to post
Share on other sites

Guys I found a solution to this.

 

If you were redirected to a blank page OR If you get an error like PHP Fatal error: Class 'OneAllSocialLoginController' not found then you might have to refresh the PrestaShop class cache.

 

Simply delete the file /cache/class_index.php from your PrestaShop folder. PrestaShop will automatically create a new, updated version of that file. (keep a backup of the file just in case)

 

Thank u mate,,,it works for me...!!!

Share this post


Link to post
Share on other sites

So trevorgilligan, you recommand to delete the module onesociallogin of oneall?

  • Like 1

Share this post


Link to post
Share on other sites

hi @mynewborn. for me, it slows the shop down, im on shared hosting. if i change to dedicated then i would use it but for me, a new shop, customers wont wait to long so i removed it. on the plus side using it, gives customers more trust as they can log in with social networks, so you have to decide :)

Share this post


Link to post
Share on other sites

The module works wonderfully but what if the customer wants to change details? For example his birthday. Prestashop asks for password to confirm details and therefore does not allow the change since there is no password.

 

Edit: The problem can be solved: The customer needs to use password recovery to generate a password.

Edited by kamppa (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More