Jump to content
Sign in to follow this  
EE533

JavaScript est requis pour lancer cette application [Résolu en partie]

Recommended Posts

[Résolu en partie]Résolut en partie
Bonjour,

Nous sommes en train de chercher une nouvelle plateforme pour notre site ecomerce qui marche depuis trois ans sur Cybershop ASP, openSource si possible.
Nous avons mis en place un serveur de test sur gandi.net, installé Magento sans problème (un modèle du genre) et avons chargé hier la version 1.2.3 de Prestashop pour réaliser les mêmes tests.

d'abord, je trouve vraiment galère (pour pas dire antinomique) le fait d'avoir à charger un .zip sur windows, de le dezipper pour après faire un ftp de tous les fichiers sur un serveur Linux, avec tous les problèmes potentiels de droits sur les fichiers et de type de transfert (ASCII ou BIN) qui peut provoquer des coruptions de fichiers sans aucun controle...
Pourquoi ne pas créer un package linux directement, vous pouvez vous inspirer de la procédure Magento, c'est limpide et sans histoire.

Bref, après avoir galéré avec les droits avec l'upload et le changement des droits sur les fichiers, j'essaie l'install en tapant maboutique.eu/prestashop/install et j'obtient un beau message (maboutique.eu est bien entendu un pseudo):

"JavaScript est requis pour lancer cette application." sur IE7 et IE8/XP
ou bien au choix
"This application need you to activate Javascript to correctly work." sur Safari 4 /XP

Donc pas un prolème de "client side javascript" (j'ai vérifié qu'ils etaient bien activés) même si ça en a l'odeur.

Pour aller jusqu'au bout des choses, j'ai fait un chmod a+rx sur tous les fichiers .js pour être certain qu'il ne sagissait pas d'un pb de droits (on est sur un serveur de test - y a pas de problème de sécurité), même topo...

Par ailleurs, il y a un point qui pose aussi problème c'est la librairie "extension=php_gd2.dll", j'imagine qu'elle doit s'appeler "extension=php_gd2.so" sous linux (merci pour eux:), problème, elle est dans aucun fichier php.ini sur mon serveur, ni d'ailleurs sur le disque en tant que librairie.

Comme j'ai skippé cette étape, j'espère que le message javascript n'est pas lié ?????

HELP.

Si des gentils developpeurs de Prestashop veulent l'accès à mon serveur, c'est possible.

Merci.

Eric.

Share this post


Link to post
Share on other sites

Bon,

pour faire vite, il y a vraiment un problème de droits sur les fichiers Prestashop lorsque on installe sous Linux.
Après avoir relu tous les posts sur ce sujet (je suis pas le seul à avoir le pb), j'ai gentillement tenté un deuxième upload sur mon serveur, changement des droits en fonction de la doc d'install, etc... -> même pb!

Sur windows, y a pas de notion de UID/GID, et de RWX, c'est pas géré pareil, donc quand on dézipe sur windows et qu'on charge le tout sur un serveur Linux, il suffit pas de changer les droits sur les repertoires (de manière récursive pour certains) pour que ça marche.

Apache tournant en mode root/root, il faut que les fichiers .php et .js ET les repertoires qui les contiennent soient en mode a+rx, donc que apache puisse les executer.

j'ai pas pu faire le tri de ce qui devait ou pas etre en mode a+rx mais en faisant à la racine de prestashop un chmod -R a+rx *
Le problème est résolu !!!

D'accord, c'est pas très cool d'un point de vue sécurité, mais moi je teste seulement, donc pas de pb.

Messieurs de Prestashop, y a un bug. A vous la main.

Eric.

Share this post


Link to post
Share on other sites

Je ne comprend pas où il y a un bug. Si en affectant les droits qu'il faut là où il faut ça marche, où est le problème ?

Quoi qu'il en soit, les bugs doivent être postés dans le Bug Tacker pour être pris en compte.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More