Jump to content

Problema up di ogni genere, dalle immagini al salvataggio del backup


loomloom
 Share

Recommended Posts

Buongiorno a tutti voi, ho un problema, oggi stavo vedendo il sito quando ho notato che due immagini mi venivano caritate male (circa il 30% dell'immagine). Allora sono entrato nel pannello di controllo e molto semplicemente ho pensato : "forse l'aveva caricata male", ho cancellato la vecchia immagine (che nel pannello di controllo pero' appariva intera al 100%) ed ho provato ad upparne una nuova (e con il nome del file anche leggermente differente)... ma non ci sono storie, non uppa nulla, ho fatto molte prove e non mi fa proprio uppare immagini da nessuna parte. Ho dato una letta ai precedenti post qui messi, e vi posso dire che : le cartelle utilizzano correttamente come impostazioni 755 la versione di php dal pannello di controllo di Tophost mi permette solo una scelta generale come php 4 o php 5, non mi pare di avere ulteriori possibilita'.



ah cosa importante quando faccio l'up non mi appare un normale messaggio di errore, ma mi appare tutto il codice (lo posto qui sotto, ne metto solo una piccolissima parte, perche' non ho caratteri a sufficenza per metter tutto il codice ) Non so che fare... se volete vedere la parte "incriminata di sito" http://www.pandamannaro.com/category.php?id_category=6 come notate ora su "serie Joker" mi appare l'immagine mancante, mentre prima l'errore che avevo era quello che notate nella "serie Queen".


Infine ho anche provato a fare un backup di sicurezza del sistema, ed anche li mi e' apparso un errore di sistema.


Help me... che mi consigliate di fare ?
(es qui sotto del codice che mi appare quando uppo le immagini)(e' solo una piccola parte)
tks Lorenzo



--- Array

---- (

---- [0] => Array

---- (

---- [file] => /home/mhd-01/www.pandamannaro.com/htdocs/classes/AdminTab.php

--- [line] => 655

-- [function] => displayError

-- [class] => Tools

-- [type] => ::

-- [args] => Array

-- (

-- [0] => an error occurred while uploading image

-- )



-- )

Share this post


Link to post
Share on other sites

L'htacess lo posto qui sotto, Fino a qualche giorno fa tutto funzionava correttamente e da oggi... puff.. tutto e' impazzito.

Io direttamente non ho fatto nulla, se serve fare qualcosa cmq (o caricare qualche cosa) son pronto ad eseguire ogni genere di controllo.

Share this post


Link to post
Share on other sites

Rimbambimento di mezza giornata ! no quello non era il file Htacess, ma una piccola porzione della schermata di errore che mi appare quando provo a fare un up (la schermata e' davvero lunghissima). per quanto riguarda il file htacess.txt e' questo qui :

# URL rewriting module activation
RewriteEngine on

# URL rewriting rules
RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$2$4 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ product.php?id_product=$1$3 [L,E]
RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ category.php?id_category=$1 [QSA,L,E]
RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ cms.php?id_cms=$1 [QSA,L,E]
RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ supplier.php?id_supplier=$1$3 [QSA,L,E]
RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ manufacturer.php?id_manufacturer=$1$3 [QSA,L,E]

# Catch 404 errors
ErrorDocument 404 /404.php

Share this post


Link to post
Share on other sites

gia' scaricata infatti, per ora la sto testando su un'altro spazio web che ho. Una sola curiosita'... ho visto che ci sono dei post che spiegano come trasferire il database degli oggetti... ma... si riescono anche a trasferire tutti gli utenti registrati ?

Share this post


Link to post
Share on other sites

htacess.txt e' questo qui :

# URL rewriting module activation
RewriteEngine on



Se attivi il friendly url su tophost devi aggiungere la direttiva RewriteBase, altrimenti non ti funziona es.

se hai installato tutto sotto root così


# URL rewriting module activation
RewriteEngine on
RewriteBase /



se invece tieni tutto in una cartella sotto root diventa così

# URL rewriting module activation
RewriteEngine on
RewriteBase /nome della cartella



Ciao

Share this post


Link to post
Share on other sites

gia' scaricata infatti, per ora la sto testando su un'altro spazio web che ho. Una sola curiosita'... ho visto che ci sono dei post che spiegano come trasferire il database degli oggetti... ma... si riescono anche a trasferire tutti gli utenti registrati ?



Il mio è completo: utenti! la cosa principale ;-)
http://www.prestamodules.com/prestashop/content/10-migrare-prestashop punto 2)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More