Jump to content

Recommended Posts

Yop,

 

Je viens ici poser une question qui me taraude concernant le versionning des releases prestashop.

 

Le 28/08/2013 , prestashop publie la version 1.5.5.0 de prestashop avec un beau panel de bugfixes et un changelog sympa.

 

Problème : a l'upgrade s'avère que cette version plante complètement le tunnel de commande.

J'ai une chance ce jour là : nous ne sommes pas le 28, j'ai téléchargé le fichier'archive un ou deux jours avant la maj. Je trouve donc assez rapidement un patch d'une des classes de swift qui corrige ce lamentable et inexorable plantage au moment de la validation de commande.

 

Je préviens mes clients que rapidement prestashop devrait sortir une nouvelle version , car il s'agit d'un bug majeur et ils ne sauraient rester statiques sur ce point.

 

Point n'en est : prestashop a d'ores et déja publié un correctif en mettant à jour son archive... mais sous le même numéro de version ... 1.5.5.0 .

 

J'ai des frissons à me demander combien de temps j'aurais pu chercher à débugguer ça si je n'avais pas été attentif, alors que chez d'autres qui avaient téléchargé cette version un jour plus tard n'avaient pas le bug. 

 

Je pose une vraie question : pourquoi ce choix ? 

Est-ce qu'on se dit que les quelques milliiers (je suppose) d'utilisateurs ayant downloadé cette version le jour de sa sortie sont somme toute négligeables ? Est-ce qu'on suppose qu'il suffit de dire que la maj n'a probablement pas été correctement faite , auquel cas bien évidemment , réuploader la 1.5.5.0 corrige le problème et hop : mais merde qu'est-ce que j'ai fais de travers ? 

Pourtant même si j'ai remarqué ce genre de pb sur des versions antérieures , ici c'est le pompon car absolument aucune possibilité de valider une commande (ceci me fais également m'interroger sur les méthodes de test de "l'équipe de test" dont on nous a assuré l'existence et le sérieux : comment peut on tester un logiciel e-commerce sans valider une commande?)

 

Bref la question est simple et j'espère que nous aurons une réponse : doit on considérer que le n° de version n'est qu'un stade et non une garantie que cette même version sera toujours la même ? Peut on nous expliquer quelle est la politique/méthode de Prestashop à ce sujet ? A mon sens c'est véritablement important que nous sachions qu'une x.y.z.r puisse évoluer dans le temps ... 

Car dans le cas contraire, si nous l'apprenons , c'est toujours à nos dépends.

 

 

 

  • Like 4

Share this post


Link to post
Share on other sites

Vraisemblablement c'est une pratique ouverte : 

http://www.prestashop.com/forums/topic/270964-erreur-500-depuis-maj-1550-lors-de-la-creation-dun-compte/?do=findComment&comment=1357154

 

Cf le commentaire de Xavier :  "Bien vu, et merci pour la remontée, on a corrigé ! Re-téléchargez la 1.5.5 et remplacez les fichiers, on a refait un Zip ! "

 

Ca ne répond toutefois pas aux questions que je me pose : je n'avais pas vu ce commentaire mais le patch uniquement : quid si je n'avais vu ni l'un ni l'autre? 

Et enfin , une x.y.z.r ne peut être différente d'une x.y.z.r ...

Share this post


Link to post
Share on other sites

Bonsoir,

Je pense effectivement (mais sous réserve) qu'il n'ont effectivement pas changé le N° de Version. En fait pour eux, la correction à dû être minime et ils ont donc refait un build.

Donc les version devraient être numérotées 1.5.5.0 Build 32456 par exemple et 1.5.5.0 Build 33454. etc...

Share this post


Link to post
Share on other sites

Merci Bro :) j'aime te lire ! moments rares ;)

 

Je crois qu'il y a eu aussi d'autres correctifs majeurs entre ces 2 versions. J'avais fait remonté un bug important lié à la prise en compte de methodes hook depuis Hook::getIdByName(), qui faisait du coup planter toutes les méthodes de modules.

 

Mon PR : https://github.com/PrestaShop/PrestaShop/pull/666

Le fix de Damien : https://github.com/PrestaShop/PrestaShop/commit/f24391be5ad33cef85111d6a35d7861aa9086dcc

 

Et ceci n'a pas non plus fait l'objet d'un changement de version.

 

A+

  • Like 1

Share this post


Link to post
Share on other sites

 

Et ceci n'a pas non plus fait l'objet d'un changement de version.

 

A+

 

Ah ben celui là je ne l'ai pas vu passer, beyondcompare sur toute l'arbo entre les deux archives que j'avais ne me retourne que le fix du header swift.

 

Je comprends parfaitement et je trouve même indispensable que l'on corrige l'archive avant qu'un bug ne puisse affecter un plus grand nombre de personnes. Seulement si rien ne nous permet de voir que l'archive a changé on debug comme des fous pour au final s'apercevoir qu'on a perdu notre temps parce que ça a été corrigé.

Le système de numérotation de build suggéré par vinum semble une belle alternative pour éviter un reversioning qui sort du roadmap et que ne semble pas aimer la team. 

Reste à croiser les doigts et espérer être entendu.

 

Build ou pas build désormais je serais de toute façon plus attentif, mais c'est pas simple de savoir en cas de bug chez un client , chez lesquels on a installé une version affectée ou non, c'est aussi cette notion de déploiement qui me chagrine: Même en connaissant la version exacte du presta de chacun de mes clients , je ne peux pas en déduire lesquels doivent être patchés ou non puisque pour deux version identiques le code est suceptible d'être différent.  

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour Eric,

 

De mon coté j'ai eu aussi des soucis assez serieux avec cette version avec entre autre un bug de la navigation à facette :

 

http://www.prestashop.com/forums/topic/275829-bug-navigation-%C3%A0-facette-pour-d%C3%A9plier-larborescence-cat%C3%A9gorie-dans-le-bo/

 

(il me reste d'ailleur un bug non résolu sur la navigation a facette si par hasard tu as la solution voir ici )

 

ou encore un bug avec la librairie swift que j'ai corrigé avec ce patch :

 

https://github.com/PrestaShop/PrestaShop/commit/ffdc7b51b7f07a1919cbaaafba5a5602671fb3a8

 

C'est inquiétant de constater que nous sommes a mis chemin entre la 1.5 et la 1.6 et qu'il y ai encore des bugs de ce type ...

 

PS : quel est la date de sortie de la version 1.5.5 "stable" ?

 

++ Thierry.

Edited by Thierry Création (see edit history)

Share this post


Link to post
Share on other sites

Ben le bug de la Librairie swift oui c'était ce dont le sujet faisait état , il a fort heureusement été corrigé le lendemain de la release , par Rémi Gaillard.

 

Pour ton bug avec le blocklayered, j'ai ma petite idée mais c'est à vérifier et ce n'est pas le sujet ici , je répondrais sur l'autre.

  • Like 1

Share this post


Link to post
Share on other sites

Surtout que ça ne coûte rien de passer de 1.5.5.0 à 1.5.5.1, c'est peut être pour éviter de charger le module autoupgrade en multipliant les versions.

 

Je pense oui que tu as mis le doigt dessus.

Une modif d'une ligne c'est surement un bazar pas possible à gérer derrière pour autoupgrade.

Plus que jamais la notion de build suggérée par Vinum a son sens.

Share this post


Link to post
Share on other sites

PS : quel est la date de sortie de la version 1.5.5 "stable" ?

 

++ Thierry.

Salut,

 

Bon post de Broceliande, j'avoue avoir été dans des cas similaires sur certaines fonctions... Tout celà doit être plus transparent pour les devs, un numéro de révision ne coute presque rien (pourquoi ne pas en faire un warning dans le back-office, sur certaines solutions/logiciels il y a des mises à jour tous les jours et ça ne choque personne).

 

Sinon pour rebondir sur le quote, ayant été voir les conférences de Prestashop au salon de l'e-commerce hier, la 1.6 sera là avant d'avoir stabilisé la 1.5.5 comme il se doit ^^

Edited by Whoami (see edit history)

Share this post


Link to post
Share on other sites

oui c'est un problème, il y a plusieurs versions 1.5.5, j'avais déjà souligné ce problème : http://www.prestashop.com/forums/topic/266719-prestashop-155-version-test-disponible/page-2?do=findComment&comment=1356062 pour moi la 1.5.5 était une version test (http://www.prestashop.com/forums/topic/266719-prestashop-155-version-test-disponible/?view=findpost&p=1331615) et elle est passé en version stable mais sans changement de numéro de version, non seulement ça prête à confusion mais en plus il ne faut pas se tromper dans les versions installées sur son ordi

Share this post


Link to post
Share on other sites

j'ai une petite question car j'aimerais maintenant passer à la 1.5 (je suis en 1.4.9 actuellement)

 

j'ai vu sur le forum anglais que cette version était pleine de bugs :

http://www.prestashop.com/forums/topic/278027-155-bugs-roll-up-patches/

 

donc j'aimerais savoir si ca vaut le coup de changer maintenant.

 

est ce que qqun a cette version en prod et rencontre t il des pb.

j'ai fait la maj en utilisant un doublon de ma boutique sur un sous domaine et pour le moment je ne constate pas de pb majeur, cependant j'aimerais avoir d'autres avis avant de me lancer car une fois que c'est fait c'est le bazar si y a des pb.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More