Jump to content

Fordítás módosítása


zoli27
 Share

Recommended Posts

Sziasztok!

 

Tudnátok abban segíteni, hogy a kosár tartalmának megtekintésekor azt írja ki, hogy ingyenes szállítás van, de csak is ott, a többi helyen már átírtam a fájlokban, de ezt valahogy nem találom.

 

szallitas_www.kepfeltoltes.hu_.jpgPrestashop 1.5.4.0
www.tabletennis.extra.hu

Előre is köszönöm a segítséget! :)

Share this post


Link to post
Share on other sites

  • 1 month later...

Sziasztok!

Tudja esetleg valaki, hogy a new_order.html email template tárgyát merre lehet lefordítani? A fordítások között erre nincs lehetőség, talán valahol máshol kell keresnem. Rendeléskor a tárgyban "New order - 000001" jelenik meg és bár nincs jelentősége, de marhára zavar. :)

PS version 1.5.6

Share this post


Link to post
Share on other sites

Én nem néztem meg hogy valóban itt kell-e átírni, csak utánakerestem a fájlok között és ez volt a legvalószínűbb:

/modules/mailalerts/mailalerts.php

 

398-as sor:

sprintf(Mail::l('New order - #%06d', $id_lang), $order->id),

Nézd meg... ha nem az akkor majd jobban utánanézek.

Share this post


Link to post
Share on other sites

Sajnos ezzel sem megy... A fordítóban majdnem minden email sablon tárgya szerkeszthető, a new_order.html-hez ez van írva: No Subject was found for new_order in the database

A Rendelések > Állapotok alatt szintén szerkeszthetők az email értesítők tárgyai, de ez itt sem található.

Edited by kutyi (see edit history)

Share this post


Link to post
Share on other sites

  • 2 months later...

Sziasztok,
 
Azt szeretném kérdezni, hogy a presta frissítése után a mező nevek fordítsához nem lehet hozáférni, mert nem is látszik. A többi oké, de ez valamiért nem. Nem én frissítettem, és ez sajnos így maradt...
1.4.7.3.

Share this post


Link to post
Share on other sites

Valószínű, mert a korábbi verziónál is előfordult más modul telepítésekor, de akkor én voltam és tudtam melyik okozta. A developer módot nem tudom hogyan kell bekapcsolni, mert nem vagyok programozó, de ha lépésről lépésre leírod, megpróbálom :)))

Share this post


Link to post
Share on other sites

1.5.6.1 magyarítás finomhangolásába kezdtem bele. A legtöbb szükséges változtatást a modulok translation/hu.php fájljaiban megcsináltam. Van viszont, amit nem találok. Tudnátok ebben segíteni:

"Fiókom" bejelentkezésnél a cím "Authentication"

"Fiókom" bejelentkezésnél a gomb neve nekem "Authentication"
"Fiók" létrehozásánál a megszólítás: "Mr és "Mrs" ezeket

"Fiók" létrehozásánál hol tudom megcserélni a keresztnevet és a vezetéknevet (hogy ne ez legyen a megszólítás: "Tisztelt Pál Kiss!"

Egeret a Kosár fölé mozgatva: "View my shopping cart"

Tudnátok segíteni, hol tudom ezeket átírni?

Share this post


Link to post
Share on other sites

Denes =>

miért nem admin felületen csinálod? Ott nem jó?

 

Valamint azért nem találod mert ezek modulfordítások. Vagy a /modules/ mappában van a nyelvi file az adott modulnál (például blockmyaccount) vagy inkább a /themes/tetemad/modules/ -ben kell kikeresned az adott rész moduljának fordítását.

Share this post


Link to post
Share on other sites

pattila01 =>

 

Köszönöm, ezt olvastam, de nem értem :) Nekem ez kínai :))

Ha tudod, légyszi, akkor lépésről lépésre...C panel, file-ok...Vagy nem így? Mert így nem találtam...

 

config/defines.inc.php => 28.-as sor:

define('_PS_MODE_DEV_', false);

rakd true-ra:

define('_PS_MODE_DEV_', true);

és nézd meg van-e hibaüzenet.

Share this post


Link to post
Share on other sites

lacish =>

 

FTP kapcsolatod van? Ha igen, nyisd meg a tárhelyedet, keresd meg a public_html mappát (vagy web mappa, eltérő lehet szolgáltatónként) és azon belül lesz egy config mappa, abban pedig egy defines.inc.php fájl.

Azt töltsd le, nyisd meg, a 28-as sor végén lévő "false" értéket írd át "true"-ra, majd töltsd vissza a szerverre felülírva a régit.

Share this post


Link to post
Share on other sites

Denes =>

miért nem admin felületen csinálod? Ott nem jó?

 

Valamint azért nem találod mert ezek modulfordítások. Vagy a /modules/ mappában van a nyelvi file az adott modulnál (például blockmyaccount) vagy inkább a /themes/tetemad/modules/ -ben kell kikeresned az adott rész moduljának fordítását.

 

Adminban ezt az üzenetet kapom: Figyelmeztetés, a szolgáltatód a suhosin PHP patch-et használja, ami maximalizálja a kitöltendő mezőket 1000 suhosin.post.max_vars. 

A szolgáltató ezt nem változtatja meg a kedvemért.

 

A blockmyaccount nyelvi fájljában nem találtam pl. az authentication -ra megoldást. A themes\default\modules\blockmyaccount -ban nálam csak egy blockmyaccount.tpl

Share this post


Link to post
Share on other sites

Semmi... akkor sajnos a rosszabbik fajta. Végig kéne menni a fájlokon, okoskodni, ötletelni mitől lehet. Nehézkes.

 

Mindenesetre a fájlt írd vissza false-ra és töltsd vissza a helyére.

 

Amit megpróbálnék: csinálnék egy klónt, elkészíteném localhoston és megnézném ott működik-e.

Ha igen, akkor lehet ötletelni, ha nem akkor frissítenék a következő verzióra, az biztos megoldaná a problémát.

Share this post


Link to post
Share on other sites

Denes =>

miért nem admin felületen csinálod? Ott nem jó?

 

Valamint azért nem találod mert ezek modulfordítások. Vagy a /modules/ mappában van a nyelvi file az adott modulnál (például blockmyaccount) vagy inkább a /themes/tetemad/modules/ -ben kell kikeresned az adott rész moduljának fordítását.

Köszönöm Attila, a segítségeddel már nyomon vagyok, bár nincs még jó megoldás a "Bejelentkezés" gombra.

A themes\default\lang\hu.php-ban minden le van szépen fordítva magyarra, a "Bejelentkezés" is, nekem mégis "Authentication" maradt a gomb neve, egészen addig, míg a themes\default\authentication.tpl-ben át nem írtam az összes "Authentication"-t "Bejelentkezés" re és így a Gomb neve is megváltozott. A gondom csak az, hogy ezzel az angol nyelvű bejelentkezést is átírtam Bejelentekzésre...

Nem tudom, mit rontok el...

Share this post


Link to post
Share on other sites

Denes =>

 

 

A blockmyaccount nyelvi fájljában nem találtam pl. az authentication -ra megoldást. 

 

Ez csak egy példa volt részemről... a dolog tematikájára hívtam fel a figyelmet. Default témáról van szó ugye?

 

Igen, ha átírod a tpl-ben akkor mindenhol átíródik. Hirtelen nem tudom megmondani hol van, de ha megmondod milyen verziójú Ps-ed van és default a téma, akkor megnézem.

 

Egyébként meg a suhosin korlátot meg lehet kerülni általánosságban. Írtunk már erről itt egy párszor.

Edited by pattila01 (see edit history)

Share this post


Link to post
Share on other sites

Denes =>

 

Ez csak egy példa volt részemről... a dolog tematikájára hívtam fel a figyelmet. Default témáról van szó ugye?

 

Igen, ha átírod a tpl-ben akkor mindenhol átíródik. Hirtelen nem tudom megmondani hol van, de ha megmondod milyen verziójú Ps-ed van és default a téma, akkor megnézem.

 

Egyébként meg a suhosin korlátot meg lehet kerülni általánosságban. Írtunk már erről itt egy párszor.

Az 1.5.6.1 amit használok (legfrissebb). Igen, egyelőre a default témát próbálom alakítgatni és mindenek előtt a főbb funkciókat ellenőrzöm és közben látom a fordítási problémákat. A suhosinra én nem találtam megoldást, mikor belefutottam, majd akkor utána nézek megint.

Share this post


Link to post
Share on other sites

készíts egy php.ini filet, amit elhelyezel az admin mappádban.

 

Tartalma első körben ez legyen:

max_input_vars = 5000

Ha megvan, nézd meg a fordításokat. Ha mennek, akkor jó, ha nem akkor próbáld meg a lenti kódrészletet beilleszteni a fájlba és úgy megpróbálni.

[PHP]

; Enable the PHP scripting language engine under Apache.
; http://php.net/engine
engine = On

; How many GET/POST/COOKIE input variables may be accepted
max_input_vars = 10000

; Maximum amount of memory a script may consume (128MB)
; http://php.net/memory-limit
memory_limit = 256M

; Whether or not to register the EGPCS variables as global variables.  You may
; want to turn this off if you don't want to clutter your scripts' global scope
; with user data.
; You should do your best to write your scripts so that they do not require
; register_globals to be on;  Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
; http://php.net/register-globals
register_globals = Off

; Magic quotes are a preprocessing feature of PHP where PHP will attempt to
; escape any character sequences in GET, POST, COOKIE and ENV data which might
; otherwise corrupt data being placed in resources such as databases before
; making that data available to you. Because of character encoding issues and
; non-standard SQL implementations across many databases, it's not currently
; possible for this feature to be 100% accurate. PHP's default behavior is to
; enable the feature. We strongly recommend you use the escaping mechanisms
; designed specifically for the database your using instead of relying on this
; feature. Also note, this feature has been deprecated as of PHP 5.3.0 and is
; scheduled removed in PHP 5.4.
; Default Value: On
; Development Value: Off
; Production Value: Off
; http://php.net/magic-quotes-gpc
magic_quotes_gpc = Off

; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
; http://php.net/magic-quotes-runtime
magic_quotes_runtime = Off

; Use Sybase-style magic quotes (escape ' with '' instead of \').
; http://php.net/magic-quotes-sybase
magic_quotes_sybase = Off

; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
; http://php.net/allow-url-fopen
allow_url_fopen = On

; Whether to allow include/require to open URLs (like http:// or ftp://) as files.
; http://php.net/allow-url-include
allow_url_include = Off

Share this post


Link to post
Share on other sites

pattila01

 

Azért köszönöm! :)

 

"Semmi... akkor sajnos a rosszabbik fajta. Végig kéne menni a fájlokon, okoskodni, ötletelni mitől lehet. Nehézkes.

 

Mindenesetre a fájlt írd vissza false-ra és töltsd vissza a helyére.

 

Amit megpróbálnék: csinálnék egy klónt, elkészíteném localhoston és megnézném ott működik-e.

Ha igen, akkor lehet ötletelni, ha nem akkor frissítenék a következő verzióra, az biztos megoldaná a problémát."

Share this post


Link to post
Share on other sites

Denes,

 

sikerült megoldani a gomb problémát?

 

Talán ez a pár kép segíthet:

http://leafant.hu/forum/auth1.jpg - ott van az a fordításoknál

http://leafant.hu/forum/auth2.jpg - a tpl filében NE ÍRD át az angolt (bekarikázva)

mivel a nyelvi filében ennek az md5 hash-jára hivatkozik

http://leafant.hu/forum/auth3.jpg - Szerintem alapból ez a sor hiányzik a filéből, csak akkor íródik hozzá a BO felületen kitöltöd a fordítást

Share this post


Link to post
Share on other sites

Szia bolhaugrik!

Most éppen romokban hever az oldal, így nem tudom próbálgatni, de azt látom, hogy igazad van. A themes\default\lang\hu.php -ban a 60. sor nekem hiányzik:

$_LANG['address_c9cc8cce247e49bae79f15173ce97354'] = 'Mentés';
           !!!!!!!!! itt kellene lennie a soromnak, ez hiányzik !!!!!!!!!!!!!!
$_LANG['authentication_5bef23eb7efff2736c5583bda59e5eb7'] = 'Fiók létrehozása';
$_LANG['authentication_2fdfd506efea08144c0794c32ca8250a'] = 'Fiók létrehozása';
 
De mi ez a sor és nekem miért hiányzik?
Kösz!!!

Share this post


Link to post
Share on other sites

Szerintem nem ott...

 

úgy működik a template rendszer hogy a template filéba van minden látható elemnél egy alap szöveg pl {l s="Authentication"} ami a te esetedben a gomb value értéke.

Ennek az idézőjelben lévő szöveg md5 hash-jával azonosítja a nyelvi filében hogy a fordításnak hol kell majd megjelennie.

Ha nincs erre hivatkozás a lang filébe akkor a BO felületen a fordítások kezelésénél pirossal jelenik meg a form, de ha kitöltöd akkor szépen beíródik a megfelelő sor a lang filébe.

Tehát a BO-n célszerű szerkesztgetni a fordítást, majd ott a program kikeresi hogy neked mik hiányoznak.

  • Like 1

Share this post


Link to post
Share on other sites

Szerintem nem ott...

 

úgy működik a template rendszer hogy a template filéba van minden látható elemnél egy alap szöveg pl {l s="Authentication"} ami a te esetedben a gomb value értéke.

Ennek az idézőjelben lévő szöveg md5 hash-jával azonosítja a nyelvi filében hogy a fordításnak hol kell majd megjelennie.

Ha nincs erre hivatkozás a lang filébe akkor a BO felületen a fordítások kezelésénél pirossal jelenik meg a form, de ha kitöltöd akkor szépen beíródik a megfelelő sor a lang filébe.

Tehát a BO-n célszerű szerkesztgetni a fordítást, majd ott a program kikeresi hogy neked mik hiányoznak.

Aha. Csak a BO-s szerkesztgetést nem tudom csinálni suhosin limit miatt (ezt a szolgáltató biztonsági okok miatt nem hajlandó megnövelni és sajnos pattila01 php.ini módszerével nekem nem sikerült). Akkor kénytelen leszek localhostra feltenni előbb és ott babrálni a fordításokat, ugye?

Share this post


Link to post
Share on other sites

Itt a hu.php file /webáruház fordítások - default/ amiben az összes sor már benne van, de nem mind van lefordítva. átneveztem .txt-re

 

http://leafant.hu/forum/hu.php.txt

Nagyon köszönöm! Feltettem, de sajnos nem működik így sem. Nem értem. Főleg azt nem, hogy miért csak nekem okoz ez problémát.

A legutóbbi PS-t használom a legutóbbi fordítással, csak hu.php bem írtam át néhány fordítást (az authentication.tpl-t visszaírtam az eredetire) máshoz nem nyúlta. Igaz BO-ból nem érem el a fordításokat... Nem tudod, nem tudjátok, ezt az "Authentication"-t nektek át kellett admin BO-ban "Bejelentkezésre"?. Lehet, hogy mégis saját gépen kell a fordításokat BO-ban átnéznem. Ezt szerettem volna kihagyni és nem vagyok biztos benne, hogy ezzel tényleg megoldódik a problémám. Ha van további ötletet, írjatok, hamegoldódik, közzéteszem a megoldást.

Share this post


Link to post
Share on other sites

Légyszi dobj már egy oldal URL-t hogy megleshessem.

fakez.webpaletta.hu. Most próbálkoztam egy php.ini -vel és az oldal eltűnt. Legalábbis nekem. lehet, hogy a szolgáltató letíltotta az IP címem...

Share this post


Link to post
Share on other sites

Nem érhető el most.

Aha, úgy látom valami szerver probléma van. Ja igen, most villant be hogy írták a napokban, hogy 15-én szerver karbantartás lesz, valószínűleg ez az oka. Már azt hittem én rogyasztottam össze a rendszert :)

Share this post


Link to post
Share on other sites

Nos,

 

nekem soha nem volt még ilyen gondom. Ha volt suhosin korlát megemeltettem, ha nem emelték meg megkerültem (amit fent írtam) ha úgy sem sikerült akkor váltottam szolgáltatót... valamint én nem építettem shopot default templattel.

 

Én áttenném localhostra ahogyan említettem, ott nem probléma a suhosin. Bár ezek után nem tudom működne-e ott, hiszen a lang fájlba írással mennie kéne. Nem tudom milyen anomália ez Nálad.

 

Hm... most néztem utána, ahol ezek vannak a /themes/default/lang/hu.php-ben:

$_LANG['authentication-choice_2fdfd506efea08144c0794c32ca8250a'] = 'Fiók létrehozása';
$_LANG['authentication-choice_0b2c9f6cb541db5d223143a645492ddd'] = 'A fiók létrehozásához írd be az e-mail címed';
$_LANG['authentication-choice_b357b524e740bc85b9790a0712d84a30'] = 'E-mail cím';
$_LANG['authentication-choice_db879b00e657fc85f7873343f11df21c'] = 'Már regisztráltál?';
$_LANG['authentication-choice_dc647eb65e6711e155375218212b3964'] = 'Jelszó';
$_LANG['authentication-choice_01a569ddc6cf67ddec2a683f0a5f5956'] = 'Elfelejtetted a jelszavadat?';
$_LANG['authentication-choice_99dea78007133396a7b8ed70578ac6ae'] = 'Bejelentkezés';

Ott írd át az utolsó részt, tehát ezt illeszd be:

$_LANG['authentication-choice_99dea78007133396a7b8ed70578ac6ae'] = 'Bejelentkezés';

vagy nézd meg, lehet már ott van.

 

Egyébként a shop angolul is működni fog? Mert amennyiben nem, "tökéletes" megoldás az hogy tpl-ben átírod angolról magyarra.

Edited by pattila01 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Nos,

 

nekem soha nem volt még ilyen gondom. Ha volt suhosin korlát megemeltettem, ha nem emelték meg megkerültem (amit fent írtam) ha úgy sem sikerült akkor váltottam szolgáltatót... valamint én nem építettem shopot default templattel.

 

Én áttenném localhostra ahogyan említettem, ott nem probléma a suhosin. Bár ezek után nem tudom működne-e ott, hiszen a lang fájlba írással mennie kéne. Nem tudom milyen anomália ez Nálad.

 

Hm... most néztem utána, ahol ezek vannak a /themes/default/lang/hu.php-ben:

$_LANG['authentication-choice_2fdfd506efea08144c0794c32ca8250a'] = 'Fiók létrehozása';
$_LANG['authentication-choice_0b2c9f6cb541db5d223143a645492ddd'] = 'A fiók létrehozásához írd be az e-mail címed';
$_LANG['authentication-choice_b357b524e740bc85b9790a0712d84a30'] = 'E-mail cím';
$_LANG['authentication-choice_db879b00e657fc85f7873343f11df21c'] = 'Már regisztráltál?';
$_LANG['authentication-choice_dc647eb65e6711e155375218212b3964'] = 'Jelszó';
$_LANG['authentication-choice_01a569ddc6cf67ddec2a683f0a5f5956'] = 'Elfelejtetted a jelszavadat?';
$_LANG['authentication-choice_99dea78007133396a7b8ed70578ac6ae'] = 'Bejelentkezés';

Ott írd át az utolsó részt, tehát ezt illeszd be:

$_LANG['authentication-choice_99dea78007133396a7b8ed70578ac6ae'] = 'Bejelentkezés';

vagy nézd meg, lehet már ott van.

 

Egyébként a shop angolul is működni fog? Mert amennyiben nem, "tökéletes" megoldás az hogy tpl-ben átírod angolról magyarra.

Igen, az egyik webshopnak angolul is mennie kell, ezért is küzdök még vele. A hu.php-ban nekem is ott van a 'Bejelentkezés' sor.

Viszont ami érdekes, hogy az en.php -ban az authentication-choice-ból csak 3 sor van és a 'Bejelentkezés' -nek megfelelő sor 'Login', és nem 'Authentication' (ha minden jól működne, akkor angolra váltva a Login feliratú gombnak kellene megjenenie, vagy nem??):

 

$_LANG['authentication-choice_b357b524e740bc85b9790a0712d84a30'] = 'Email address';
$_LANG['authentication-choice_01a569ddc6cf67ddec2a683f0a5f5956'] = 'Forgot your password?';
$_LANG['authentication-choice_99dea78007133396a7b8ed70578ac6ae'] = 'Login';
 
Gondolkodom a szolgáltató váltáson, de más (joomlás) oldalam is van a mostani kedvező árú szolgáltatónál és azok jól működnek, valamint nem nagyon költözködnék velük. A suhosint is megróbálom még egyszer, hátha... Asszem a  Wampserverrel is elkezdek foglalkozni, bár marhára nem akartam most abba is belekezdeni nulláról. Minden esetre kösz a segítséget!

Share this post


Link to post
Share on other sites

Ha windowsod van akkor XAMPP-ot ajánlok.

 

Az en.php-s válaszodra igen a válasz, de megnézted a hu.php-det annak fényében amit küldtem?

Ja igen, a hu.php-ben ott van:

$_LANG['authentication-choice_99dea78007133396a7b8ed70578ac6ae'] = 'Bejelentkezés';

 

Kösz, elfogadom a javaslatot. Kipróbálom a XAMPP-ot!

Share this post


Link to post
Share on other sites

figyu, közben megnéztem az egyik szerón lévő, admin mappában lévő php.ini-met, kicsit más mint amit dobtam az előző oldalon, egy próbát megér (bár nem sokban különbözik az előzőtől):

[PHP]

; Enable the PHP scripting language engine under Apache.
; http://php.net/engine
engine = On

default_charset = "UTF-8"

; How many GET/POST/COOKIE input variables may be accepted
max_input_vars = 10000

; Maximum amount of memory a script may consume (128MB)
; http://php.net/memory-limit
memory_limit = 256M

; Whether or not to register the EGPCS variables as global variables.  You may
; want to turn this off if you don't want to clutter your scripts' global scope
; with user data.
; You should do your best to write your scripts so that they do not require
; register_globals to be on;  Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
; http://php.net/register-globals
register_globals = Off

; Magic quotes are a preprocessing feature of PHP where PHP will attempt to
; escape any character sequences in GET, POST, COOKIE and ENV data which might
; otherwise corrupt data being placed in resources such as databases before
; making that data available to you. Because of character encoding issues and
; non-standard SQL implementations across many databases, it's not currently
; possible for this feature to be 100% accurate. PHP's default behavior is to
; enable the feature. We strongly recommend you use the escaping mechanisms
; designed specifically for the database your using instead of relying on this
; feature. Also note, this feature has been deprecated as of PHP 5.3.0 and is
; scheduled removed in PHP 5.4.
; Default Value: On
; Development Value: Off
; Production Value: Off
; http://php.net/magic-quotes-gpc
magic_quotes_gpc = Off

; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
; http://php.net/magic-quotes-runtime
magic_quotes_runtime = Off

; Use Sybase-style magic quotes (escape ' with '' instead of \').
; http://php.net/magic-quotes-sybase
magic_quotes_sybase = Off

; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
; http://php.net/allow-url-fopen
allow_url_fopen = On

; Whether to allow include/require to open URLs (like http:// or ftp://) as files.
; http://php.net/allow-url-include
allow_url_include = Off

extension=php_mbstring.dll


Share this post


Link to post
Share on other sites

 

figyu, közben megnéztem az egyik szerón lévő, admin mappában lévő php.ini-met, kicsit más mint amit dobtam az előző oldalon, egy próbát megér (bár nem sokban különbözik az előzőtől):

[PHP]

; Enable the PHP scripting language engine under Apache.
; http://php.net/engine
engine = On

default_charset = "UTF-8"

; How many GET/POST/COOKIE input variables may be accepted
max_input_vars = 10000

; Maximum amount of memory a script may consume (128MB)
; http://php.net/memory-limit
memory_limit = 256M

; Whether or not to register the EGPCS variables as global variables.  You may
; want to turn this off if you don't want to clutter your scripts' global scope
; with user data.
; You should do your best to write your scripts so that they do not require
; register_globals to be on;  Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
; http://php.net/register-globals
register_globals = Off

; Magic quotes are a preprocessing feature of PHP where PHP will attempt to
; escape any character sequences in GET, POST, COOKIE and ENV data which might
; otherwise corrupt data being placed in resources such as databases before
; making that data available to you. Because of character encoding issues and
; non-standard SQL implementations across many databases, it's not currently
; possible for this feature to be 100% accurate. PHP's default behavior is to
; enable the feature. We strongly recommend you use the escaping mechanisms
; designed specifically for the database your using instead of relying on this
; feature. Also note, this feature has been deprecated as of PHP 5.3.0 and is
; scheduled removed in PHP 5.4.
; Default Value: On
; Development Value: Off
; Production Value: Off
; http://php.net/magic-quotes-gpc
magic_quotes_gpc = Off

; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
; http://php.net/magic-quotes-runtime
magic_quotes_runtime = Off

; Use Sybase-style magic quotes (escape ' with '' instead of \').
; http://php.net/magic-quotes-sybase
magic_quotes_sybase = Off

; Whether to allow the treatment of URLs (like http:// or ftp://) as files.
; http://php.net/allow-url-fopen
allow_url_fopen = On

; Whether to allow include/require to open URLs (like http:// or ftp://) as files.
; http://php.net/allow-url-include
allow_url_include = Off

extension=php_mbstring.dll


Sajna, ezzel is suhosin probléma lép fel. Azért nagyon köszönöm!

Azon gondolkodom, hogy felteszek egy új prestashopot a szerverre és próbálom, az elejéről. Bár most kettő fent van (1.5.6.1 és egy 1.5.5.0-ás) és mindkettőnél ugyanez a probléma. Miért is lenne jobb a helyzet. Talán valami beállítást elrontok az elején? Már nem is emlékszem, hogy a magyar fordításokat hogyan adtam hozzá... de szerintem BO-ban... lehet, hogy egy próbát megér. 

Share this post


Link to post
Share on other sites

Újra feltettem a shopot a szerverre és még mielőtt adminba beléptem volna kipróbáltam a belépést a "fiókom" ba. A "Bejelentkezés" gomb így is "Authentication". Marad a localhost kipróbálása, hogy adminból megnézzem a fordításokat.

Share this post


Link to post
Share on other sites

Sziasztok!

 

Az Universal Payment modul fordításában kellene segítség. A fizetés kiválasztása oldalon a "Erősítse meg rendelését..." szöveget és az alatta megjelenő gomb feliratot szeretném lefordítani magyarra.

Ehhez bemenetem a modul translation mappájába, majd  a nyelvekhez létrehoztam egy hu.php-t (az en.php-ból másoltam). Az olasz nyelvből kimásoltam azt a két sort ami szerintem az adott szövegre és a gombra hivatkozik, majd beleraktam a hu.php-ba, az olasz szöveget átírtam magyarra. Meg is jelenik a magyar szöveg, de az ékezetek nem, helyette szimbólumok. Kódolást kell átállítani, vagy mit?

Ezen kívül még azt sem találtam meg, hogy a fejlécben megjelenő Home, Specials, Top Sellers feliratokat hogy lehetne lefordítani, plusz a kapcsolat és oldaltérkép is kis betüvel van írva (hogy néz már ki!)!

Köszönöm előre is.

Üdv.

Edited by balyil (see edit history)

Share this post


Link to post
Share on other sites

Balyil => ha nem mondod meg milyen témát használsz (motor verziószám sem volna rossz) akkor nem tudunk segíteni a fejlécfordításban.

 

A karakterkódoláshoz: a php-t mentsd el UTF-8-al és nézd meg mit mutat.


Denes => most már én is meg fogom nézni ezt localhoston (nem tudom fejből mivel nem foglalkozom default témával). Te mikor nézed meg?

Share this post


Link to post
Share on other sites

Balyil => ha nem mondod meg milyen témát használsz (motor verziószám sem volna rossz) akkor nem tudunk segíteni a fejlécfordításban.

 

A karakterkódoláshoz: a php-t mentsd el UTF-8-al és nézd meg mit mutat.

Denes => most már én is meg fogom nézni ezt localhoston (nem tudom fejből mivel nem foglalkozom default témával). Te mikor nézed meg?

 

Attila, A localhoston (xampp) BO fordításoknál megint ez fogad (nem suhosin, csak így simán):

 

Warning! Your PHP configuration limits the maximum number of fields allowed in a form 1000 for max_input_vars.

Please ask your hosting provider to increase the this limit to 1441 at least or edit the translation file manually.

 

Ez normális, vagy én vagyok megátkozva? Most éppen keresem, hogy ezt hol tudom beállítani. Egyébként "természetesen" a telepítést követően bejelentkezéskor "Bejelentkezés" helyett a gomb: "Authentication"

 

Felraktam a php.ini-t, amit javasoltál és amiben ez a sor szerepel:

 

00011: max_input_vars = 10000
 
Semmi javulás.

Share this post


Link to post
Share on other sites

oks, ide menj:

/xampp/php/php.ini

 

nyisd meg

 

keresd meg benne ezt:

max_input_vars = 600000000

 

és tedd az értéket annyira amennyire szeretnéd, én mondjuk 5000-re lőném be. Nálam viccből van 600000000, így tuti nem fogy el soha :D

 

ha módosítottad mentsd el és indítsd újra a xampp ban lévő apache-ot és mysql-t.

  • Like 1

Share this post


Link to post
Share on other sites

oks, ide menj:

/xampp/php/php.ini

 

nyisd meg

 

keresd meg benne ezt:

max_input_vars = 600000000

 

és tedd az értéket annyira amennyire szeretnéd, én mondjuk 5000-re lőném be. Nálam viccből van 600000000, így tuti nem fogy el soha :D

 

ha módosítottad mentsd el és indítsd újra a xampp ban lévő apache-ot és mysql-t.

 

Köszönöm Attila, köszönöm, köszönöm! Ezzel localhoston már megvan! ahogy Bolhaugrik is írta: http://www.prestashop.com/forums/topic/276066-fordítás-módosítása/?p=1524967

Itt localhoston kitöltöttem a hiányzó mezőt, ezek után majd megnézem mi a különbség az eredeti, és a BO-ban módosított hu.php között. Most, hogy már hozzáférek, nagy kéjjel fogom átnézni a BO fordítási lehetőségeit :) Még egyszer nagyon köszönöm nektek!

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 3 months later...

Sziasztok!

Tudja esetleg valaki, hogy a new_order.html email template tárgyát merre lehet lefordítani? A fordítások között erre nincs lehetőség, talán valahol máshol kell keresnem. Rendeléskor a tárgyban "New order - 000001" jelenik meg és bár nincs jelentősége, de marhára zavar. :)

PS version 1.5.6

 

Szia Kutyi!

 

Fordítások - Email sablon fordítások és ott a rendszer üzenetek sorra kell kattintani és legördül az összes fordítható email.

Share this post


Link to post
Share on other sites

 

Attila, A localhoston (xampp) BO fordításoknál megint ez fogad (nem suhosin, csak így simán):

 

Warning! Your PHP configuration limits the maximum number of fields allowed in a form 1000 for max_input_vars.

Please ask your hosting provider to increase the this limit to 1441 at least or edit the translation file manually.

 

Ez normális, vagy én vagyok megátkozva? Most éppen keresem, hogy ezt hol tudom beállítani. Egyébként "természetesen" a telepítést követően bejelentkezéskor "Bejelentkezés" helyett a gomb: "Authentication"

 

Felraktam a php.ini-t, amit javasoltál és amiben ez a sor szerepel:

 

00011: max_input_vars = 10000
 
Semmi javulás.

 

 

Csak azoknak van egy tippem, akik a Hostgatoron üzemeltetik oldalukat. Nem kevés időmbe telt... 

A CPanelen van egy lehetőség: php.ini Quick Config  itt engedélyezni kell a változtatást és utána megnyílik az összes állítható opció. Itt már megtalálod ezt a sort és teszés szerint beállíthatod az értéket.

 

Gábor

Share this post


Link to post
Share on other sites

max_input_vars 1000 problémára:

 

segítség csak azoknak, akik a hostgatoron lógnak. Cpanel, php.ini Quick Config gomra kattintva engedélyezd a változtattást és utána megjelennek a beállítható adat sorok. Itt átállíthatod az értéket szükség szerint.

 

Gábor

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Megvan a megoldás!

mails/hu/lang.php utolsó sorába beírtam a következőt:

$_LANGMAIL['New order - #%06d'] = 'Új megrendelés - #%06d';

 

Sziasztok! Nekem sajnos egyik verzió sem működik, nem olyan eget rengető dolog, de azért jó volna! Van esetleg egyéb ötlet? Köszi! :* Enikő

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More