Jump to content

Recommended Posts

Bonjour,

 

Viens de passer à la 0.9.1 du 14/12, avec une nouvelle base de données. Ai un problème majeur : erreur 500 sur n'importe quel .php de la vision "acheteur". L'Admin fonctionne très bien mais impossible de visualiser le shop. N'avait pourtant pas de problème avec la 0.9 jusqu'au remplacement complet ce matin ...

 

Auriez-vous une piste à suivre ? Merci ...

 

Benjamin

Share this post


Link to post
Share on other sites

Bonjour Mathieu,

 

Ai essayé sans le .htaccess, rien à faire, console admin toujours ok mais pas de shop visiteur.

 

Le .htaccess contenait :

  php_flag register_globals off

 

Le htaccess.txt contient (standard installation) :

  # URL rewriting module activation

  RewriteEngine on

  # URL rewriting rules

  RewriteRule ^([0-9]+)-([a-zA-Z0-9-]*).html(.*)$ product.php?id_product=$1$3 [L,E]

  RewriteRule ^([0-9]+)-([a-zA-Z0-9-]*)(.*)$ category.php?id_category=$1$3 [L,E]

  # Catch 404 errors

  ErrorDocument 404 /404.php

 

Ai essayé avec/sans le paramètre des url simplifiées et avec/sans le .htaccess ou .txt ...

 

Merci pour vos idées,

Benjamin

Share this post


Link to post
Share on other sites

Bonjour,

 

Il me semble que nous avons placé plusieurs .htaccess afin d'empêcher les robots de voir/voler vos images notamment. Par conséquent, si votre hébergeur n'autorise pas les .htaccess (ou si la directive concernant le DirectoryListing n'est pas autorisée) il faut les retirer dans leur ensemble.

 

Peut-être qu'il vaudrait mieux placer un index.php dans ces répertoires et envoyer le code d'erreur via la fonction header().

 

Cordialement,

Bruno Lévêque

Share this post


Link to post
Share on other sites

Bonjour,

 

L'hébergeur (Infomaniak) autorise les .htaccess, l'admin fonctionne ... et le shop 0.9 fonctionnait bien.

 

Je m'y perd, que devrait être la configuration standard :

- avec / sans rewrite dans les paramètres du shop ?

- avec / sans htaccess.txt ?

- avec / sans .htaccess ?

- quel(s) contenu(s) pour ces fichiers ?

 

Devrais-je remettre une 0.9 complète pour tester dans un autre dossier ?

 

Merci d'avance.

Benjamin

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More