Jump to content

De Prestashop 1.4.11 vers 1.5.5


Recommended Posts

Suite a une mise à jour effectué avec succès de la 1.4.11 vers 1.5.5 je me retrouve avec deux problèmes :

 

1/ Le mode de réécriture d'URL (mod_rewrite) n'est pas activé sur votre serveur, ou il est impossible de vérifier la configuration. Pour utiliser les URLs réécrites, vous devez activer ce mode.

"J'ai beau désactiver ou activer rien ne change" 

 

Ayant vue cela j'ai activer le mode débug dans config --> defines.inc.php

Je me retrouve donc avec aucun accès a ma boutique et l'erreur suivante est affiché ..

 



Strict Standards: Declaration of FrontController::displayHeader() should be compatible with that of FrontControllerCore::displayHeader() in /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php on line 241

Strict Standards: Declaration of FrontController::displayFooter() should be compatible with that of FrontControllerCore::displayFooter() in /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php on line 241

Fatal error: Cannot redeclare class Mobile_Detect in /homez.403/teramer/www/complements-alimentaires/tools/mobile_Detect/Mobile_Detect.php on line 34


 

C'est dommage pour le coup car la MAJ c'était plutôt bien passé… De la 1.4.11 à la 1.5.5 … Avec la dernière version du module 1-Click Upgrade

 

J'ai à mon niveau supprimer le module thème mobile pensant que c'était lui le problème mais j'ai tirs la même erreur …

 

Quelqu'un connait t'il le problème ou des idées de pistes !! 

Merci de votre soutien

Share this post


Link to post
Share on other sites

Et si je désactive le mode réécriture d'url j'obtiens des erreurs de plus : 

Strict Standards: Declaration of FrontController::displayHeader() should be compatible with that of FrontControllerCore::displayHeader() in /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php on line 241

Strict Standards: Declaration of FrontController::displayFooter() should be compatible with that of FrontControllerCore::displayFooter() in /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php on line 241

Warning: Cannot modify header information - headers already sent by (output started at /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php:241) in /homez.403/teramer/www/complements-alimentaires/classes/controller/FrontController.php on line 631

Warning: Cannot modify header information - headers already sent by (output started at /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php:241) in /homez.403/teramer/www/complements-alimentaires/classes/controller/FrontController.php on line 632

Warning: Cannot modify header information - headers already sent by (output started at /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php:241) in /homez.403/teramer/www/complements-alimentaires/classes/Tools.php on line 130

Si des fois cela peut permettre de mieux comprendre l'erreur !! 

Car moi je suis perdu dans ce charabiaaa  :wacko:

Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

A priori il y a un module qui a installé une surcharge qui effectivement pose problème.

 

Pour le mod_rewrite, on parle d'activer ou non un module Apache au niveau hébergement afin de vérifier si la re ecriture est possible. C'est un avertissement concernant l’impossibilité de verifier si mod_rewrite est bien présent. Mais ce champ en back office active ou non la re écriture d'url, mais pas le mod_rewrite sur le serveur.

 

Cordialement

  • Like 1

Share this post


Link to post
Share on other sites

Yop, 

 

Merci de vos réponses rapide... 

Bon jsuis confronté à un nouveau problème avant de pouvoir continuer à régler celui ci ...

 

Alors vue que que la PrestaTeam me répond et j'apprécie je vais poster ici mon nouveau problème !! 

 

Bon comme la MAJ avait pas fonctionné j'ai voulu revenir en 1.4.11 et depuis j'ai ca qui apparait quand je veux me connecter ou à la boutique ou à la partie admin .... Jpeux donc rien faire 

 

Ce qui est en rouge veux dire quoi ? 

Il faut le supprimer pour que la boutique refonctionne ? je comprend pas l'erreur !! 

 

[PrestaShopDatabaseException]
Table 'teramerboutik.ps_shop_url' doesn't exist
 
607.             WebserviceRequest::getInstance()->setError(500, '
 '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);
608.         }
609.         else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS'))
610.         {
611.             if ($sql)
612.                 throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');
613.             throw new PrestaShopDatabaseException($this->getMsgError());
614.         }
615.     }
616.
617.     /**
 
 
Et encore des fichier php avec des lignes en rouge 
 
DbCore->displayError - [line 313 - classes/db/Db.php] - [1 Arguments]
DbCore->query - [line 488 - classes/db/Db.php] - [1 Arguments]
DbCore->executeS - [line 315 - classes/shop/Shop.php] - [1 Arguments]
ShopCore::initialize - [line 95 - config/config.inc.php] - [0 Argument]
require - [line 30 - admin13Odontella13/index.php] - [1 Arguments]

 

 

 

Merci de me dire quoi faire et encore merci de votre soutien 

Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

La restauration n'a pas marché. classes/db/Db.php signifie que vous utilisez des fichiers 1.5 sur une base de données 1.4.

 

Si vous me faites des accès FTP temporaires et pĥpmyadmin je peux vous donner un coup de main ce soir. Le plus rapide est de passer _PS_VERSION_ à l'ancienne version dans /config/settings.inc.php puis d'appeler /install/upgrade/upgrade.php pour entamer une mise à jour manuelle.

 

Cordialement

Edited by Gregory Roussac (see edit history)

Share this post


Link to post
Share on other sites

Ola, 

 

Je viens juste de rentrer et je comprend pas trop la manipulation 

Le plus simple est de passer _PS_VERSION_ à l'ancienne version dans /config/settings.inc.php puis d'appeler /install/upgrade/upgrade.php pour entamer une mise à jour manuelle

 

Si il y a encore quelqu'un par ici peut être je peux profiter du coup de main et donner des accès en MP ...  Ou si je comprend mieux la manip le faire moi même....  B) 

Au choix et merci de m'avoir répondu car ma boutique n'est plus en production ... sniiiifff  :blink: 

Share this post


Link to post
Share on other sites

La restauration n'a pas marché. classes/db/Db.php signifie que vous utilisez des fichiers 1.5 sur une base de données 1.4.

 

Si vous me faites des accès FTP temporaires et pĥpmyadmin je peux vous donner un coup de main ce soir. Le plus simple est de passer _PS_VERSION_ à l'ancienne version dans /config/settings.inc.php puis d'appeler /install/upgrade/upgrade.php pour entamer une mise à jour manuelle.

 

 

 

 

Pour mettre dans config/settings.inc.php  _PS_VERSION_ en 1.4.11 au lieu de 1.5.5.0 comme c'est actuellement dans mon fichier pas de problème ...
Mais je n'ai pas le fichier install/upgrade/upgrade.php ... Il faut que je le prenne dans la version de Prestashop 1.4.11 de base ou le Prestashop 1.5.5 ??
 
Merci de votre soutien !  
Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

Il me faut mettre tout le dossier install de la version 1.5.5 sur mon FTP et de renommer _PS_VERSION_ en 1.4.11 au lieu de 1.5.5.0 ?

 

Et ensuite apeler le fichier /install/upgrade/upgrade.php dans le navigateur ?? 

 

Est ce que j'ai bien compris ? 

Share this post


Link to post
Share on other sites

Oui

 

Si vous avez bien les fichiers d'une 1.5 sur le ftp et une base 1.4 ou mal migrée oui. Sinon le module autoupgrade le fait aussi si vous y avez encore accès mais d'abord il s'occupe des fichiers aussi. Si on ne veut mettre à jour que la base ( et que tout est bien backupé) on peut passer par la méthode manuelle donc en appelant ce fichier

Share this post


Link to post
Share on other sites

Si vous avez des produits téléchargeables, vous pouvez aussi prendre le dossier d'install de la version de développement https://github.com/PrestaShop/PrestaShop/archive/development.zip qui corrige un problème avec ceux ci lors de la mise à jour d'une 1.4, peut etre y est vous confronté. Regardez bien vos logs Apache après une mise à jour manuelle.

 

Cordialement,

Share this post


Link to post
Share on other sites

Si je n'y arrive pas un coup de main ne sera pas de refus !! 

 

Lorsque j'appelle le fichier install/upgrade/upgrade.php  que ce passe t'il ? l'installation se fait sur le FTP ?

 

Car je viens de rencontrer une erreur en faisant la manip j'ai du mal mis prendre... 

 

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<action result="fail" error="28"/>

Share this post


Link to post
Share on other sites

Heuu jme demande ...

Le problème 'est que quand j'etais en 1.4.11 et que j'ai fais la MAJ en 1.5.5 du coup sur mon FTP j'ai un melange de la 1.4 et de la 1.5 non fini .... 

Car ma BDD elle etant sauvegardé bien avant que je fasse toute les manip elle concerne que la version 1.4.11

 

Donc si je supprime tout le FTP sur le serveur et que je le remet d'une sauvegarde que j'ai en local ... Ca serais pas le mieux pour revenir sur une base propre et de retenter la mise a jour avec 1click update 

Share this post


Link to post
Share on other sites

J'ai changer la version 1.4.11.0 et  appelé le fichier upgrade.php 

 

J'ai cette erreur : 

Fatal error: Call to undefined method Configuration::updateGlobaleValue() in /homez.403/teramer/www/complements-alimentaires/install/upgrade/php/fix_download_product_feature_active.php on line 30

J'ai l'impresion que c'est sans fin tous ses problème ... Je ne sais meme pas comment vous arrivez à comprendre ce chinois  B)

Share this post


Link to post
Share on other sites

Bon je vais tenter de virer tout le ftp sur réseau ou il y a donc eu des fichier de la MAJ 1.5.5 non reussi et de remettre celui que j ai en local qui est de la version 1.4.11 ... 

Avec la bonne BDD Version 1.4.11 sur PhpMyAdmin 

 

Si je rencontre des difficultés je reviendrais vers vous pour un coup de pouce ... 

Share this post


Link to post
Share on other sites

Ok donc vous avez des produits dématérialisés désolé.

 

Refaites la manipulation avec le dossier de ce zip s'il vous plait, cette erreur a été corrigée depuis.

 

https://github.com/PrestaShop/PrestaShop/archive/development.zip

 

- re uploadez le contenu de install-dev dans install

- remettez 1.4.11.0 dans le settings

- appelez la mise à jour

 

Ensuite promis c'est la fin. J'aurais du vous faire prendre ce dossier d'installation directement désolé, mal joué.

 

Cordialement

Share this post


Link to post
Share on other sites

Est ce qu'il me faudrait pas des fois aussi vider le cache et les fichiers compil ...

Ainsi que cache navigateur une fois que le fichier install sera réuploadé avant que j'appelle le fichier install/upgrade/upgrade.php

 

Ca peut pas faire de mal allez vous sans doute me dire!!  B)

Share this post


Link to post
Share on other sites

Si vous refaites le test en local, prenez le module 1.1.4 publié ce matin, http://addons.prestashop.com/en/administration-tools-prestashop-modules/5496-1-click-upgrade-autoupgrade.html vous n'aurez normalement plus le problème que vous avez rencontré.

 

Cordialement


 

Ainsi que cache navigateur une fois que le fichier install sera réuploadé avant que j'appelle le fichier install/upgrade/upgrade.php

Pas avant, après.

Share this post


Link to post
Share on other sites

Pas de problème de ce coté la quand j'ai fais la mise à jour de la 1.4.11 vers la 1.5.5 

 

J'ai justement télécharger et installé la dernier version du Module 1-Click Upgrade avant de lancer la MAJ 

 

Je me suis retrouvé avec aucune erreur d'après Module 1-Click Upgrade 

 

Seulement une fois que j'ai voulu aller sur la boutique j'avais l'erreur indiqué dans le post 1 

J'avais encore accès a l'administration 

C'est a ce moment que j avais essayé de désinstaller le module mobile et thème mobile croyant que l erreur était la !! 

Share this post


Link to post
Share on other sites

Oui surement possible car je suis un vrai poissard de toute facon !!

Mais le module 1click update est bien le bon pourtant :

<displayName><![CDATA[1-click Upgrade]]></displayName>

<version><![CDATA[1.1.4]]></version>

 

Bon sinon la en appelant le fichier install/upgrade/upgrade.php cette fois j'ai toute une page XML très longue  .... J'ai pas encore reactualisé ou quoi que ce soit ... Pour voir si la boutique apparait 

 

 

J'ai tenté d'accéder a l'admin de la boutique et ça me dit cette fois :

 

Pour des raisons de sécurité, vous ne pouvez pas vous connecter tant que vous n'avez pas :
supprimé le dossier /install

 

Donc ya déjà un petit changement 

 

Je supprime le dossier install du FTP ? 

Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

Pfiiouu quand je veux acceder a mon site ca me met l'erreur que j avais eu dans le post 1 

Strict Standards: Declaration of FrontController::displayHeader() should be compatible with that of FrontControllerCore::displayHeader() in /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php on line 241

Strict Standards: Declaration of FrontController::displayFooter() should be compatible with that of FrontControllerCore::displayFooter() in /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php on line 241

Fatal error: Cannot redeclare class Mobile_Detect in /homez.403/teramer/www/complements-alimentaires/tools/mobile_Detect/Mobile_Detect.php on line 34

Que faire a ce niveau ? 

Share this post


Link to post
Share on other sites

Vous avez de surcharges dans le dossier override, mon soutien la dessus va s'arreter la. Il faut faire un autre post sur ce sujet.

 

A priori il y a un module tiers qui pose problème, il faut le désactiver. L'admin doit être accessible non ?

 

EDIT

 

Fatal error: Cannot redeclare class Mobile_Detect in /homez.403/teramer/www/.../tools/mobile_Detect/Mobile_Detect.php on line 34 c'est bizarre. Il faut désactiver tout ce qui est module mobile de la 1.4 et resinstaller le thème module mobile de la 1.5.

Edited by Gregory Roussac (see edit history)

Share this post


Link to post
Share on other sites

Bon oupss j'ai déjà supprimé le dossier install du ftp, c'est déjà de l'histoire ancienne ...

 

Sinon j'ai essayé d'acceder a la partie admin et mon identifiant et mon pass me permette pas d'accéder il y a une erreur 

 

Details: Error thrown: [object Object]
Text status: parsererror
 
Avec toujours les erreurs php suivante bien affiché sur la page de connexion : 
 
Strict Standards: Declaration of FrontController::displayHeader() should be compatible with that of FrontControllerCore::displayHeader() in /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php on line 241

Strict Standards: Declaration of FrontController::displayFooter() should be compatible with that of FrontControllerCore::displayFooter() in /homez.403/teramer/www/complements-alimentaires/override/classes/FrontController.php on line 241
Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

Pour l'admin je peux y accéder désormais ....

 

 

Le principal est là. Il va falloir récupérer le front en analysant chaque erreur. Normalement ce travail doit être préparé sur un serveur de test avant c'est plus simple ensuite de le faire en ligne.

 

Cordialement

Oulaa

 

Regarder les log apache mais quel est ce language de Sioux 

Je ne sais pas faire a ce niveau ... Ni même ou regarder et quoi regarder .... 

Demandez à votre hébergeur de vous expliquer ou google vous aidera. Toutes les erreurs que vous avez eu y sont consignées.

Share this post


Link to post
Share on other sites

C'est sur OVH qu'il faut regarder ?? 

Je comprend pas que ça soit si compliqué pour remettre ma boutique en production ?? 

 

Car la j'ai pas le choix que de remettre ma boutique en version 1.4.11 avec ma BDD sauvegardé et virer tout le FTP pour n'avoir que l'ancienne sauvegarde FTP sans aucun fichier de la 1.5.5 

 

J'aurais ainsi une 1.4.11 stable et en production 

 

Car la j'ai l'impression que les erreurs devienne de plus en plus technique non ?? 

Share this post


Link to post
Share on other sites

Dans /config/settings.inc.php vous n'auriez pas

/* PrestaShop Mobile */ if ((isset($_GET['ps_mobile_site']) && $_GET['ps_mobile_site'] == 1) || !isset($_GET['ps_full_site']) || (!isset($_GET['ps_full_site']) && $_SERVER['HTTP_HOST'] == 'm.debby')) { include(dirname(__FILE__).'/../modules/mobile_theme/Mobile_Detect.php'); $mobile_detect = new Mobile_Detect(); define('_PS_MOBILE_TABLET_', 0); define('_PS_MOBILE_PHONE_', isset($_GET['ps_mobile_site']) ? 1 : (int)$mobile_detect->isMobile()); } else { define('_PS_MOBILE_TABLET_', 0); define('_PS_MOBILE_PHONE_', 0); } define('_PS_MOBILE_', _PS_MOBILE_PHONE_ || _PS_MOBILE_TABLET_); if (_PS_MOBILE_) define('_THEME_NAME_', 'prestashop_mobile'); else

Supprimez cette exacte partie svp et rechargez votre front.

 

Vous pouvez restaurer en 1.4 avec le module d'upgrade en back office et refaire une mise à jour avec le nouveau module (remis à jour encore une fois car sinon ce sera une ancienne version, celle du back up hors il faut la version 1.1.4) car vous une mise à jour manuelle peut être longue effectivement.

 

Cordialement

Share this post


Link to post
Share on other sites

Merci de votre soutien et de votre temps ...

 

J'ai décidé de repartir sur une bonne base 

 

FTP Local 1.4.11 sauvegardé avant MAJ 1.5.5

BDD PhpMyAdmin sauvegardé avant MAJ 1.5.5

 

La je suis en train de remettre les dossiers de ma boutique via FTP... 

 

Si tout va bien ma boutique devrais refonctionner .... Si tel est le cas, vue que je suis un lâche rien, je vais mettre le module à jour 1Click AutoUpgrade et faire une nouvelle tentative de MAJ pour voir ou sont tous les problèmes réels et surtout si je rencontre les même ... 

 

Je suivrais aussi votre conseil en supprimant la ligne PrestaShop Mobile dans /config/settings.inc.php  si je voie cette ligne 

 

 J'ai l'impression que pas mal de module ne fonctionnant pas sous Prestashop 1.5.5 foute le bronx ... 

Lors de l'installe est ce qu'il serait pas mieux de demander à les désactiver il me semble que l'option est possible non ? 

 

 

Et en tout cas encore merci de prendre ce temps précieux sur mon problème ... 

Edited by lokiiy (see edit history)

Share this post


Link to post
Share on other sites

  • 4 weeks later...

Bonjour à tous

J'ai lu ce qu'il y avait avant mais ne semble pas y trouver mon bonheur.

 

Voici ce que j'ai fait :

Mise à jour de 1.4.2.5 vers 1.4.11 avec le module AutoUpdate -> aucun soucis.

 

Mise à jour de 1.4.11 vers 1.5.0 toujours avec le même module et en cours de mise à jour :

Tous les fichiers ont été mis à jour. La mise à jour de la base de données va commencer. Cette opération peut prendre quelques minutes, selon la taille de votre base et la puissance de votre serveur.
Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:" " jqXHR: " "

 

Je suis resté un bon moment devant cette fenêtre mais bon il ne se passait plus rien, donc j'ai quitté la mise à jour, résultat :

- Une bonne partie des textes du backoffice sont en anglais (bon... pourquoi pas à la limite)

- Plus aucune image produit en frontoffice (même après une regénération des vignettes)

- Plus d'accès possible aux modules dans le backoffice : page blanche...

 

Aie aie aie...

 

Merci de votre aide.

> le site http://www.brindidee.com

 

EDIT : je viens de restaurer en 1.4.11 car je ne pouvais laisser le site en l'état.

Maintenant si on pouvait me guider ou me dire pourquoi j'ai eu tout ces problèmes avat de recommancer...

Merci

Edited by pako69 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Il faut restaurer votre shop en 1.4.11. Si vous avez une popup avec jax / Server Error cela ne sert à rien d'attendre, il faut la fermer et restaurer.

 

Dans les options avancées du module vous pouvez choisir le canal local. Dezippez une 1.5.5.0 dans le dossier /admin/autoupgrade/latest/prestashop. Dans ce dossier vous allez remplacer le contenu du dossier /install/ par le contenu du dossier /install-dev/ de cette archive https://github.com/PrestaShop/PrestaShop/archive/master.zip

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

Il faut restaurer votre shop en 1.4.11. Si vous avez une popup avec jax / Server Error cela ne sert à rien d'attendre, il faut la fermer et restaurer.

 

Dans les options avancées du module vous pouvez choisir le canal local. Dezippez une 1.5.5.0 dans le dossier /admin/autoupgrade/latest/prestashop. Dans ce dossier vous allez remplacer le contenu du dossier /install/ par le contenu du dossier /install-dev/ de cette archive https://github.com/PrestaShop/PrestaShop/archive/master.zip

 

Cordialement

 

Bonjour et merci pour votre aide.

Je veux bien à nouveau tenter l'expérience mais ce "patch" Github va t'il résoudre le problème des images produits qui ne sont absolument pas migrées ?

Je vous pose cette question car sur une autre boutique que j 'ai migré d'une 1.3x vers 1.5.x toujours avec le module AutoUpdate, le symptôme des images non migrées existe toujours...

 

Merci

Share this post


Link to post
Share on other sites

Remplacez ce fichier sur votre 1.5.5.0

 

https://github.com/PrestaShop/PrestaShop/blob/development/controllers/admin/AdminImagesController.php

 

En bas de l'onglet images vous pourrez migrer. Sinon attendez la prochaine version.

 

Cordialement

 

A nouveau merci pour toutes ces précisions.

En fait si je m'arrache les cheveux avec ces histoires c'est que j'héberge 3 Prestashop ( deux 1.4.x et une 1.3.x) et sachant que mon serveur va migrer en PHP 5.3 j'avais peur que ces anciennes version ne me posent des problèmes...

Share this post


Link to post
Share on other sites

  • 1 month later...

Bonsoir, au vu de ces discussions est-il opportun de migrer une boutique 1.4.11 vers une 1.5.x ? L'histoire ne nous dit pas si les tentatives des uns et des autres ont finalement été couronnées de succès, et s'il vécurent heureux et eurent beaucoup de clients ?

Car malgré le dévouement extraordinaire de Grégory, que j'aurais des scrupules à solliciter, (et que je préfèrerais ne pas avoir à solliciter) on reste inquiet sur le sort de la mise à jour ! Et pourtant les fonctionnalités de l'1.5.x et ses templates donnent envie de tenter l'aventure. Est-ce que cette aventure est maintenant bien maîtrisée techniquement, et ne prend-on pas de risques inconsidérés à la tenter ? (sauf à être un technicien hors pair). Merci d'avance pour vos avis.

(Car on voit beaucoup de problèmes exposés, mais - et c'est l'application du principe qui veut que les gens heureux n'ont pas d’histoire, ceux qui n'en ont pas (de problèmes), ne se manifestent pas).

Cordialement.

Share this post


Link to post
Share on other sites

Bonsoir, au vu de ces discussions est-il opportun de migrer une boutique 1.4.11 vers une 1.5.x ? L'histoire ne nous dit pas si les tentatives des uns et des autres ont finalement été couronnées de succès, et s'il vécurent heureux et eurent beaucoup de clients ?

Car malgré le dévouement extraordinaire de Grégory, que j'aurais des scrupules à solliciter, (et que je préfèrerais ne pas avoir à solliciter) on reste inquiet sur le sort de la mise à jour ! Et pourtant les fonctionnalités de l'1.5.x et ses templates donnent envie de tenter l'aventure. Est-ce que cette aventure est maintenant bien maîtrisée techniquement, et ne prend-on pas de risques inconsidérés à la tenter ? (sauf à être un technicien hors pair). Merci d'avance pour vos avis.

(Car on voit beaucoup de problèmes exposés, mais - et c'est l'application du principe qui veut que les gens heureux n'ont pas d’histoire, ceux qui n'en ont pas (de problèmes), ne se manifestent pas).

Cordialement.

Bonjour

 

Il ne faut pas lire que les topic où la mise à jour échoue :) j'ai fait une mise à jour réussie pour un client de la 1.4.9 vers la 1.5.6

ce que j'ai fait de suite c'est télécharger le dernier prestashop.zip et je l'ai déposé dans le dossier /admin/autoupgrade/download/

et dans le module 1click upgrade j'ai pris le mode expert et sélectionné archive local automatiquement on tombe sur le fichier prestashop.zip puis "pour mettre à jour vers la version" vous mettez 1.5.6

 

Pour info c'est sur un serveur qui n'est pas surcharger où tournent plusieurs prestashop.

 

J'ai eu un problème mais dû à ce que des modules n'étaient pas de base de prestashop. Donc tous les modules non natifs les désactivés ou désinstaller.

Edited by Oron (see edit history)

Share this post


Link to post
Share on other sites

Hi,

 

Oron tu sais il n'est pas forcement nécessaire de passer par le canal archive.

 

En fait c'est surtout que des fois on les fait passer par le canal répertoire, après avoir mis a jour le dossier install. Pour avoir les dernières corrections et que l'upgrade se passe mieux. Mais sinon en CURL et un minimum de mémoire sur le serveur pour télécharger 20Mo, il télécharge sans trop de soucis l'archive.

 

Bon week end.

Share this post


Link to post
Share on other sites

Hi,

 

Oron tu sais il n'est pas forcement nécessaire de passer par le canal archive.

 

Bonjour

 

J'ai tester ça, l'upgrade s'est bien passé donc je continue a faire ce qui fonctionne bien et selon sa connexion (4mega) c'est mieux de transférer un fichier zip que tous les dossiers fichiers dézipper.   :)

Share this post


Link to post
Share on other sites

Hello,

I am working on this idea of udating , with the zip file in /httpdocs/admin-escale/autoupgrade/latest/prestashop

all unzips but then things go wrong:

 

/prestashop_1.5.6.1.zip copié.

 

/install/upgrade/php directory is missing in archive or directory

 

Utilisation de la classe ZipArchive

 

11073 fichier(s) seront supprimés avant la restauration des fichiers

 

/admin-escale/Install_PrestaShop.html non supprimé

 

 

Any ideas?

TIA

Share this post


Link to post
Share on other sites

Thank you

Using oneclic

I have arrived at a point where all of the new version is in the directory admin/autoupgrade/latest in unzipped form.

All goes well untoil updating files stops with message:

 Forbidden You don't have permission to access Web Server at domainname

 

I have had rights conflicts , with ssh I temporariliy put all dirs and contents on 777.

I recorrect all after upgrade

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More