Jump to content
Becky Hayes

[SOLVED] Upgrade Fatal Error "Internal Server Error " jqXHR"

Recommended Posts

I clicked on the 1-click upgrade and get the following 2 error messages:

 

(1) Analyzing the situation ...Shop deactivated. Now downloading (this can takes some times )...

 

[Ajax / Server Error for action download] textStatus: "error " errorThrown:" " jqXHR: " "

 

(2) downloading from https://www.prestashop.com/download/releases/prestashop_1.5.5.0.zip

 

md5 will be checked against 88718d04b515f634ed0363c5053c1215

 

 

Yes, I backed up my database before trying.

Yes, I am logged into my account.

Yes, I used the module 1-click upgrade.

 

Things finally stop and nothing is happening. Tried 2 times.

  • Like 1

Share this post


Link to post
Share on other sites

I got the same error

Ajax / Server Error for action download] textStatus: "error " errorThrown:" " jqXHR: " "

 

Had about 7500 files left to upgrade it said. Hope there is a solution soon. I have clean instal of 1.5.4. Im on dedicated server but still used low setting. Backup files enabled and pic.

Share this post


Link to post
Share on other sites

I got the exact same error;

 

Analyzing the situation ...Shop deactivated. Now downloading (this can takes some times )...[Ajax / Server Error for action download] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

 

Nick

Share this post


Link to post
Share on other sites

The same situation. On the remote host does not work but instead in local yes.

Share this post


Link to post
Share on other sites

heres my error Analyzing the situation ...Shop deactivated. Now downloading (this can takes some times )...

 

Download complete. Now extracting

 

[Ajax / Server Error for action unzip] textStatus: "error " errorThrown:"Service Unavailable " jqXHR: " "

 

if i dont get any help to sort oit from presta shop am gonna change to another system

Share this post


Link to post
Share on other sites

Heres my error...

 

All files will be upgraded. Now updating database. This process can take a while...

[Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

 

Update process start with this:

 

downloading from https://www.prestashop.com/download/releases/prestashop_1.5.5.0.zip

md5 will be checked against 88718d04b515f634ed0363c5053c1215
Edited by JRos (see edit history)

Share this post


Link to post
Share on other sites

I'm using 1 Click upgrade and I'm receiving the below error.  I'm upgrading from 1.5.4.1 .   Can anyone help?

 

 

Analyzing the situation ...Shop deactivated. Now downloading (this can takes some times )...[Ajax / Server Error for action download] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

Share this post


Link to post
Share on other sites

I'm using 1 Click upgrade and I'm receiving the below error.  I'm upgrading from 1.5.4.1 .   Can anyone help?

 

 

Analyzing the situation ...Shop deactivated. Now downloading (this can takes some times )...[Ajax / Server Error for action download] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

 

Hi xmitman, this is usually caused by a permissions error on the server. It seems like it is not allowing you to download the latest version which will start the upgrade process. I suggest that you contact your hosting provider and see if this is something that can be fixed on their end. Keep us posted!

  • Like 1

Share this post


Link to post
Share on other sites
I updated. To do this, unpack the new version of prestashop in public_html \ admin \ autoupgrade \ latest \ prestashop \

In 1-click-upgrade module selected channel "local directory".

PS: make backups :)

Share this post


Link to post
Share on other sites

Well, I have to say I was dealing with the same problem in the last few days. Finally found a solution and managed to upgrade to 1.5.5.0.
 
This issue was discussed in:
http://forge.prestashop.com/browse/PSCFV-10295?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel#issue-tabs
 
and solved by changes in the following 2 files in:
 
https://github.com/PrestaShop/PrestaShop/commit/c6d2e1252e1757478339009ec7b48320b1ccd92a
 
I was not sure when/if autoupgrade uses already created folders and files and that is why decided to make changes only in archive (prestashop.zip) What I did is:

= In my 1clickupgrade module I set (in Expert Mode) the option to use Local Archive and use file prestashop.zip file to upgrade to v. 1.5.5.0;
= Download locally the prestashop.zip archive and unzip it;
= open folder (exact path is specific for you) and find the two files: 
/var/www/ps/admin/autoupgrade/latest/prestashop/install/upgrade/php/fix_download_product_feature_active.php
and
/var/www/ps/admin/autoupgrade/latest/prestashop/install/upgrade/php/block_category_1521.php
= replace code  as recommended and save in each file;
= zip and upload prestashop.zip to ../admin/autoupgrade/download/prestashop.zip
= run the 1 click upgrade.

 

That is all. Hope this would save much time to everyone.

(in /autoupgrade there is a file error_log . It is worth reading it to check what exactly is wrong during your upgrade).

Share this post


Link to post
Share on other sites

es una verguenza, yo no soy tonto del todo y llevo como 50 intentos de actualizar una web de la version 1.4.9 a cualquier MIERDA de 1.5, en local, en un servidor en otro, aumentando el tiempo de ejecucion, etc y siempre este mismo puto problema,

 

[Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " "

 

veo que no soy el unico imbecil que tiene ese problema, cada vez que sale una nueva version, la misma promesa, no mse colgara en la actualización, ¿como cojones es posible? ¿como no se puede hacer con un proceso manual? francamente desesperante, ingrato, denigrante y sobre todo poco profesional, no por prestashop por mi parte, que debo ser idiota.

 

 

alquien puede poner la configuracion de servidor necesaria para poder hacer esta actualizacion, por favor, estoy ya desquiciado, no es normal.

 

cuando digo 50 intentos, son 50 intentos y sus horas correspondientes, mirar en foros, cambiar normas del servidor, configurar uno limpio, vamos que solo se deberia actualizar sin mas, como lo hace de la 1.4.9 a la 1.4.10 o entre las propias 1.5, pero que no tengamos otra alternativa...no es normal.

Edited by enkacom (see edit history)
  • Sad 1

Share this post


Link to post
Share on other sites

 

I updated. To do this, unpack the new version of prestashop in public_html \ admin \ autoupgrade \ latest \ prestashop \
In 1-click-upgrade module selected channel "local directory".
PS: make backups :)

 

Thanks Legakh!!! This worked for me, too. Finally I'm up to date. :D

Share this post


Link to post
Share on other sites

Hi Benjamin,

 

How can I solve this issue, I'm a newbie user I don't understand at all this "solution"

 

 

Enkacom...

No eres el único, yo también las paso canutas cada vez, y soy un novato de narices en este tema.

En cambio tu creo que dominas, así que pocas esperanzas le veo al tema de los autoUpdates.

Share this post


Link to post
Share on other sites

Hi Nikolaik

 

I don't think it is a good idea to upgrade this way.  I tried it and I received a huge list of errors.

 

[ERROR] /modules/addshoppers/ has not been unzipped[ERROR] /modules/addshoppers/static/ has not been unzipped[ERROR] /modules/addshoppers/static/css/ has not been unzipped[ERROR] /modules/addshoppers/static/css/fonts/ has not been unzipped[ERROR] /modules/addshoppers/static/img/ has not been unzipped[WARNING] error when trying to upgrade module addshoppers.[ERROR] /modules/addshoppers/ has not been unzipped[ERROR] /modules/addshoppers/static/ has not been unzipped[ERROR] /modules/addshoppers/static/css/ has not been unzipped[ERROR] /modules/addshoppers/static/css/fonts/ has not been unzipped[ERROR] /modules/addshoppers/static/img/ has not been unzipped[WARNING] error when trying to upgrade module addshoppers.[ERROR] /modules/cashondelivery/ has not been unzipped[WARNING] error when trying to upgrade module cashondelivery.[ERROR] /modules/cashondelivery/ has not been unzipped[WARNING] error when trying to upgrade module cashondelivery.[ERROR] /modules/fedexcarrier/ has not been unzipped[ERROR] /modules/fedexcarrier/backward_compatibility/ has not been unzipped[ERROR] /modules/fedexcarrier/img/ has not been unzipped[WARNING] error when trying to upgrade module fedexcarrier.[ERROR] /modules/fedexcarrier/ has not been unzipped[ERROR] /modules/fedexcarrier/backward_compatibility/ has not been unzipped[ERROR] /modules/fedexcarrier/upgrade/ has not been unzipped[ERROR] /modules/fedexcarrier/img/ has not been unzipped[WARNING] error when trying to upgrade module fedexcarrier.[ERROR] /modules/gamification/ has not been unzipped[ERROR] /modules/gamification/classes/ has not been unzipped[ERROR] /modules/gamification/translations/ has not been unzipped[ERROR] /modules/gamification/data/ has not been unzipped[ERROR] /modules/gamification/views/ has not been unzipped[ERROR] /modules/gamification/views/templates/ has not been unzipped[ERROR] /modules/gamification/views/templates/hook/ has not been unzipped[ERROR] /modules/gamification/views/templates/admin/ has not been unzipped[ERROR] /modules/gamification/views/templates/admin/gamification/ has not been unzipped[ERROR] /modules/gamification/views/templates/admin/gamification/helpers/ has not been unzipped[ERROR] /modules/gamification/views/templates/admin/gamification/helpers/view/ has not been unzipped[ERROR] /modules/gamification/views/css/ has not been unzipped[ERROR] /modules/gamification/views/jquerybubblepopup-themes/ has not been unzipped[ERROR] /modules/gamification/views/jquerybubblepopup-themes/black/ has not been unzipped[ERROR] /modules/gamification/views/jquerybubblepopup-themes/black/ie/ has not been unzipped[ERROR] /modules/gamification/views/img/ has not been unzipped[ERROR] /modules/gamification/views/js/ has not been unzipped[ERROR] /modules/gamification/controllers/ has not been unzipped[ERROR] /modules/gamification/controllers/admin/ has not been unzipped[WARNING] error when trying to upgrade module gamification.[ERROR] /modules/gamification/ has not been unzipped[ERROR] /modules/gamification/upgrade/ has not been unzipped[ERROR] /modules/gamification/classes/ has not been unzipped[ERROR] /modules/gamification/translations/ has not been unzipped[ERROR] /modules/gamification/data/ has not been unzipped[ERROR] /modules/gamification/views/ has not been unzipped[ERROR] /modules/gamification/views/templates/ has not been unzipped[ERROR] /modules/gamification/views/templates/hook/ has not been unzipped[ERROR] /modules/gamification/views/templates/admin/ has not been unzipped[ERROR] /modules/gamification/views/templates/admin/gamification/ has not been unzipped[ERROR] /modules/gamification/views/templates/admin/gamification/helpers/ has not been unzipped[ERROR] /modules/gamification/views/templates/admin/gamification/helpers/view/ has not been unzipped[ERROR] /modules/gamification/views/css/ has not been unzipped[ERROR] /modules/gamification/views/jquerybubblepopup-themes/ has not been unzipped[ERROR] /modules/gamification/views/jquerybubblepopup-themes/black/ has not been unzipped[ERROR] /modules/gamification/views/jquerybubblepopup-themes/black/ie/ has not been unzipped[ERROR] /modules/gamification/views/img/ has not been unzipped[ERROR] /modules/gamification/views/js/ has not been unzipped[ERROR] /modules/gamification/controllers/ has not been unzipped[ERROR] /modules/gamification/controllers/admin/ has not been unzipped[WARNING] error when trying to upgrade module gamification.[ERROR] /modules/ganalytics/ has not been unzipped[ERROR] /modules/ganalytics/backward_compatibility/ has not been unzipped[WARNING] error when trying to upgrade module ganalytics.[ERROR] /modules/ganalytics/ has not been unzipped[ERROR] /modules/ganalytics/backward_compatibility/ has not been unzipped[WARNING] error when trying to upgrade module ganalytics.[ERROR] /modules/gsitemap/ has not been unzipped[ERROR] /modules/gsitemap/backward_compatibility/ has not been unzipped[ERROR] /modules/gsitemap/upgrade/ has not been unzipped[ERROR] /modules/gsitemap/tpl/ has not been unzipped[ERROR] /modules/gsitemap/img/ has not been unzipped[ERROR] /modules/gsitemap/translations/ has not been unzipped[WARNING] error when trying to upgrade module gsitemap.[ERROR] /modules/gsitemap/ has not been unzipped[ERROR] /modules/gsitemap/backward_compatibility/ has not been unzipped[ERROR] /modules/gsitemap/upgrade/ has not been unzipped[ERROR] /modules/gsitemap/tpl/ has not been unzipped[ERROR] /modules/gsitemap/img/ has not been unzipped[ERROR] /modules/gsitemap/translations/ has not been unzipped[WARNING] error when trying to upgrade module gsitemap.[ERROR] /modules/paypal/ has not been unzipped[ERROR] /modules/paypal/backward_compatibility/ has not been unzipped[ERROR] /modules/paypal/integral_evolution/ has not been unzipped[ERROR] /modules/paypal/mails/ has not been unzipped[ERROR] /modules/paypal/mails/pt/ has not been unzipped[ERROR] /modules/paypal/mails/de/ has not been unzipped[ERROR] /modules/paypal/mails/es/ has not been unzipped[ERROR] /modules/paypal/mails/en/ has not been unzipped[ERROR] /modules/paypal/mails/it/ has not been unzipped[ERROR] /modules/paypal/mails/br/ has not been unzipped[ERROR] /modules/paypal/mails/fr/ has not been unzipped[ERROR] /modules/paypal/upgrade/ has not been unzipped[ERROR] /modules/paypal/css/ has not been unzipped[ERROR] /modules/paypal/img/ has not been unzipped[ERROR] /modules/paypal/img/bo-cards/ has not been unzipped[ERROR] /modules/paypal/img/default_logos/ has not been unzipped[ERROR] /modules/paypal/img/logos/ has not been unzipped[ERROR] /modules/paypal/img/logos/express_checkout_mobile/ has not been unzipped[ERROR] /modules/paypal/express_checkout/ has not been unzipped[ERROR] /modules/paypal/views/ has not been unzipped[ERROR] /modules/paypal/views/templates/ has not been unzipped[ERROR] /modules/paypal/views/templates/front/ has not been unzipped[ERROR] /modules/paypal/views/templates/back/ has not been unzipped[ERROR] /modules/paypal/views/templates/back/admin_order/ has not been unzipped[ERROR] /modules/paypal/views/templates/hook/ has not been unzipped[ERROR] /modules/paypal/controllers/ has not been unzipped[ERROR] /modules/paypal/controllers/front/ has not been unzipped[ERROR] /modules/paypal/api/ has not been unzipped[WARNING] error when trying to upgrade module paypal.[ERROR] /modules/paypal/ has not been unzipped[ERROR] /modules/paypal/backward_compatibility/ has not been unzipped[ERROR] /modules/paypal/integral_evolution/ has not been unzipped[ERROR] /modules/paypal/mails/ has not been unzipped[ERROR] /modules/paypal/mails/pt/ has not been unzipped[ERROR] /modules/paypal/mails/de/ has not been unzipped[ERROR] /modules/paypal/mails/es/ has not been unzipped[ERROR] /modules/paypal/mails/en/ has not been unzipped[ERROR] /modules/paypal/mails/it/ has not been unzipped[ERROR] /modules/paypal/mails/br/ has not been unzipped[ERROR] /modules/paypal/mails/fr/ has not been unzipped[ERROR] /modules/paypal/upgrade/ has not been unzipped[ERROR] /modules/paypal/css/ has not been unzipped[ERROR] /modules/paypal/img/ has not been unzipped[ERROR] /modules/paypal/img/bo-cards/ has not been unzipped[ERROR] /modules/paypal/img/default_logos/ has not been unzipped[ERROR] /modules/paypal/img/logos/ has not been unzipped[ERROR] /modules/paypal/img/logos/express_checkout_mobile/ has not been unzipped[ERROR] /modules/paypal/express_checkout/ has not been unzipped[ERROR] /modules/paypal/views/ has not been unzipped[ERROR] /modules/paypal/views/templates/ has not been unzipped[ERROR] /modules/paypal/views/templates/front/ has not been unzipped[ERROR] /modules/paypal/views/templates/back/ has not been unzipped[ERROR] /modules/paypal/views/templates/back/admin_order/ has not been unzipped[ERROR] /modules/paypal/views/templates/hook/ has not been unzipped[ERROR] /modules/paypal/controllers/ has not been unzipped[ERROR] /modules/paypal/controllers/front/ has not been unzipped[ERROR] /modules/paypal/api/ has not been unzipped[WARNING] error when trying to upgrade module paypal.[ERROR] /modules/prestafraud/ has not been unzipped[WARNING] error when trying to upgrade module prestafraud.[ERROR] /modules/prestafraud/ has not been unzipped[WARNING] error when trying to upgrade module prestafraud.[ERROR] /modules/shoppingfluxexport/ has not been unzipped[ERROR] /modules/shoppingfluxexport/screens/ has not been unzipped[WARNING] error when trying to upgrade module shoppingfluxexport.[ERROR] /modules/shoppingfluxexport/ has not been unzipped[ERROR] /modules/shoppingfluxexport/screens/ has not been unzipped[WARNING] error when trying to upgrade module shoppingfluxexport.[ERROR] /modules/themeinstallator/ has not been unzipped[ERROR] /modules/themeinstallator/backward_compatibility/ has not been unzipped[ERROR] /modules/themeinstallator/export/ has not been unzipped[ERROR] /modules/themeinstallator/import/ has not been unzipped[WARNING] error when trying to upgrade module themeinstallator.[ERROR] /modules/themeinstallator/ has not been unzipped[ERROR] /modules/themeinstallator/backward_compatibility/ has not been unzipped[ERROR] /modules/themeinstallator/export/ has not been unzipped[ERROR] /modules/themeinstallator/translations/ has not been unzipped[ERROR] /modules/themeinstallator/import/ has not been unzipped[WARNING] error when trying to upgrade module themeinstallator.

Share this post


Link to post
Share on other sites

Good for you is that error is no more "Internal Server Error " jqXHR"  :) 

 

Obviously for some reason your "/modules" archive folder can not be unzipped. Please check locally if you can unzip it and if folder location looks ok. The remote unzip procedure throws errors in /modules subfolder only, so you should focus your efforts there....

Share this post


Link to post
Share on other sites

JRos realmente no se que pensar, tengo varios servidores, alojamientos compartidos, y soy incapaz de actualizar la version, 1.4.10 a la MIERDA de 1.5, ya llevan no se cuantas actualizaciones, en todas te promenten lo mismo, han resuelto 400 problemas, 400 por dios, yo lo siento pero no me atrevo a vender prestashop en estas condiciones, antes todavia tenias una posibilidad, pero ahora es una MIERDA,  si no se puede actualizar o hay que ser ingeniero para hacerlo, esto no es un sistema para el publico en general, yo sinceramente no lo entiendo, pues de la anterios a la 1.4.10 sin problema, las que empece en 1.5 hasta ahorra tampoco, realmente tampoco entiendo esta politica de actualizaciones.......donde se machacar todo no seria mejor crear solo el parche, tipo joomla....y solo machacar los ficheros correguidos, no 25.436...........acabo de actualizar 1.5.4.1...mismo servidor sin problemas, soy incapaz de entenderlo

Share this post


Link to post
Share on other sites

When I named my admin, I gave it another name.  I've learned that 1-click ugprade doesnt work because of memory issues so I am uploading it directly to my server and extracting.  Unfortunatley, I cant get it to work because Prestashop is looking for these folders admin/autoupgrade/download directory.  How can I get around this?

Share this post


Link to post
Share on other sites

Hi, this issue has been solved by our team. If you are having this error, please try the upgrade again using the latest version of the 1-click upgrade module. You can download it here, http://addons.prestashop.com/en/administration-tools-prestashop-modules/5496-1-click-upgrade-autoupgrade.html

 

You can delete the old module and upload this new module in the Back-Office.

 

Then you can proceed with the Upgrade as normal. Please make sure to always backup. Thank you!

Share this post


Link to post
Share on other sites

Hi, this issue has been solved by our team. If you are having this error, please try the upgrade again using the latest version of the 1-click upgrade module. You can download it here, http://addons.prestashop.com/en/administration-tools-prestashop-modules/5496-1-click-upgrade-autoupgrade.html

 

You can delete the old module and upload this new module in the Back-Office.

 

Then you can proceed with the Upgrade as normal. Please make sure to always backup. Thank you!

 

I came a bit longer this time, but ended up here - in the backup process

 

Analyzing the situation ...Shop deactivated. Now downloading (this can takes some times )...

 

Download complete. Now extracting

 

Extract complete. removing sample files...

 

All sample files removed. Now backup files.

 

Backup files in progress. 10267 files left

 

Backup files in progress. 9867 files left

 

Backup files in progress. 9067 files left

 

[Ajax / Server Error for action backupFiles] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: "

 

Error 500: Internal Server Error

The server encountered an unexpected condition which prevented it from fulfilling the request.

The problem is on the server side, not with your browser or the address. Most probably, a certain service (e.g., Tomcat engine) is down. Please contact your webmaster.

 

 

 

 

 

And this was the last lines:

 

img/l/it-default-home.jpg added to archive. 8671 left.

 

img/l/it-default-large.jpg added to archive. 8670 left.

 

img/l/it-default-large_scene.jpg added to archive. 8669 left.

 

img/l/it-default-medium.jpg added to archive. 8668 left.

 

img/l/it-default-small.jpg added to archive. 8667 left.

 

Edited by yquem (see edit history)

Share this post


Link to post
Share on other sites

Second time i tried the upgrade i got the same result as above

 

A little information about my shop

PS: 1.5.2.0

1-click: 1.1.4

Not a tailored PS and with standard template

Share this post


Link to post
Share on other sites

HI yquem, have you contacted your host about this issue? They may be able to give you more information or change server configuration settings that will allow you to upload. 

Share this post


Link to post
Share on other sites

 

I updated. To do this, unpack the new version of prestashop in public_html \ admin \ autoupgrade \ latest \ prestashop \
In 1-click-upgrade module selected channel "local directory".
PS: make backups :)

 

I don't find there is method to select local directory, how did you do that?

Share this post


Link to post
Share on other sites

I'm still having this same problem with using 1-Click upgrade.Does anyone have any other suggestions on this? None of these fixes have worked for me.

Any help appreciated. 
Thanks

Share this post


Link to post
Share on other sites

Why is this marked "SOLVED"? I installed 1-Click upgrade TODAY (so one would hope it is the latest since I installed via the dashboard "Modules" tab), configured it (I think) successfully (no red X's in the Pre-Install checklist, just green checks). My web server has write access to the entire /var/www/prestashop subdirectory tree.

 

I am very frustrated with solutions like "upgrade the GitHub". What the heck does that mean? I can edit a file, but when I look for the files referenced they do no exist on my server (for example fix_download_product_feature_active.php). Also, how can the problem be caused by files in the download .zip file itself if it wasn't even downloaded (there is nothing in the autoupgrade/download directory)?

 

The proposed "Fixes" (not!) sound like the only way to use 1-Click automatic upgrade is to do a manual upgrade!

 

I really would appreciate some help here!

Share this post


Link to post
Share on other sites

Update: I downloaded prestashop_1.5.6.0.zip and copied it to autoupgrade/download. I selected "More options(Expert mode)" from the 1-Click Upgrade page in the backend, then selected "* Local archve". The .zip file appears in the "Archive to use" drop down list (so it sees it). I selected it and clicked "Save".

 

Where it says "to upgrade for version" I wasn't sure whether to enter the old or the new version (I don't understand why it can't figure out for itself) so I tried both (first 1.5.6.0 then 1.5.3.1, my current version).

 

I get the assinine message "You come from the future! You are using a newer version than the latest available!". WTF?

 

It also says "Your current prestashop version 1.5.3.1" and "Latest official version for channel archive N/A".

 

There is a "Check if a new version is available" button, but if I click it, it just returns to the same page with the archive no longer selected in "expert mode" (though channel is still set to "*Local archive").

 

Am I missing something obvious here? I am new to Prestashop so please be patient with me. I can't commit to the platform if I can never upgrade so if this step fails it will be a show stopper and I will find another platform. I have to 5 PM today to resolve (3 more hours).

Share this post


Link to post
Share on other sites

Hello  Please follow these instructions. Make sure to BackUp Everything manually first. (Read here for instructions) and Read here for Important Upgrade Tips

 

1) Download 1.5.6
 
2) Via FTP or your CPanel go to your CURRENT stores directory, add this Zip file that contains version of PrestaShop 1.5.6 to admin/autoupgrade/latest 
 
3) Go to your Back-Office/Modules/1-click Upgrade and click Configure
 
4) Find the button that says "More options (Expert mode)" and click on it.
 
5) Change the channel to Local Directory and input 1.5.6 in the blank field that says "The directory /admin/autoupgrade/latest/prestashop/ will be used for upgrading to version" -- Then click save, the page will reload.
 
6) Finally, please run the 1-click upgrade.

Share this post


Link to post
Share on other sites

Hello Benjamin,

 

No luck.

 

I assume you meant to copy the unzipped files (NOT the .zip archive) to autoupgrade/latest (though I tried both ways and both failed), and that you must press "Save" after changing the channel.

 

Here's what I did: download and unzip the archive. Copy the files to autoupgrade/latest. Made sure files were owned by www-data (the server). Changed channel to "Local directory". Set version to 1.5.6. Clicked "Save". Clicked "Upgrade Prestashop Now". It just tries to do the download (does not use the "latest" directory) and so fails in the same way.

 

Any more suggestions?

Share this post


Link to post
Share on other sites

Sorry, that was from another post. You don't need to unzip any files. Just place the ZIP file into the admin/autoupgrade/latest 


By the way, what version of the autoupgrade module do you have? 

Share this post


Link to post
Share on other sites

Benjamin,

 

I have autoupgrade version 1.2.4 installed. I discovered why the upgrade from a local directory or archive failed (probably not the cause of the original "Internal server error" problem, however).

 

I was accessing the backend on a Windows XP machine running Internet Explorer 8 (which is the latest and last available version for Windows XP) and it is getting a scripting error ("Object doesn't support this property or method") when I press "Save" which is preventing the settings from being applied. I did not notice the tiny "Error on page" notification at the bottom of the page (it seems to always be there!).

 

Running F12 developer tools I found the line where the error occurs reads "directory_num = $("input[name=directory_num]").val();". I grepped the archive found this statement at line 5274 of AdminSelfUpgrade.php. directory_num is a text input object and, apparently, its val() method is not supported. I do not have enough knowledge of scripting to figure out how this can happen.

 

When I ran the upgrade from Firefox it succeeded. So I can move on.

 

Thank you for your help. I will continue to monitor this thread. If you determine what caused this error please post it. I am curious.

Share this post


Link to post
Share on other sites

Benjamin,

 

More information.

 

When I continued after the "Object does not support this property or method" error, it encountered a syntax error:

 

"Syntax error  jquery-1.7.2.min.js, line 2 character 10807"

 

This code in this file is densly packed but the following (in red) was highlighted in the debugger:

 

if(a.JSON&&a.JSON.parse)return a.JSON.parse(B);

 

After this, it throws an error.

Share this post


Link to post
Share on other sites

Hi,


Same issue updating to 1.5.6.1


 


After reinstalling 1-click upgrade manually, I uploaded the zip for the new Prestashop version to "admin/autoupgrade/latest" but proving I'm no expert, I could not find where to select the option to use Local Archive after opening 'More Options (expert mode)' in 1-click upgrade.


 


So, I think I may have to to the upgrade Prestashop manually and hope that this issue is fixed with version 1.5.6.1.


 


Thanks

Share this post


Link to post
Share on other sites

Hello,

 

I see A ERROR when i want to upgrade my prestashop. 

From 1.5.6.0 to 1.5.6.1
 

Here my screen whet i see when i want to upgrade, hope that he give no problem in my shop now:

Schermafbeelding%202013-11-22%20om%2014.

 

Who can help me to solve this problem so i can upgrade again and good.

I have put the 1.5.6.1.zip to my server and try to install, but i get the same problem, it is not working :(
 

Please help me.

 

Hans

Edited by HansNL (see edit history)

Share this post


Link to post
Share on other sites

I'm also finding it impossible to upgrade from 1.4.9 to 1.5.6 using 1 Click Upgrade on MAMP and installing from a local directory. I'm using V1.2.5 of the upgrade module, which already has the mods, but am getting the following errors that are causing the upgrade to abort. I can only assume there would be errors with other modules if the statsgeolocation module didn't exist.

 

"error for copying /modules/statsgeolocation/config.php

error when trying to upgrade /modules/statsgeolocation/config.php

2129 files left to upgrade."

 

Any suggestions? I'm considering Cart2Cart to migrate the data to a fresh installation but surely it must be possible to upgrade!

Edited by goosedesign (see edit history)

Share this post


Link to post
Share on other sites

I had the same problem too.  You cant depend on the 1-click upgrade right now.  Learn how to do it manually.  My latest attempt at 1.5.6.1 also shut down my store.  It kept trying to rollback the store because it couldnt upgrade the database and now I can't access the admin.   In search of a solution!

Share this post


Link to post
Share on other sites
I solved this problem. I upgraded from 1.5.5 to 1.5.6.2 on a Zeus webserver. This is what you need to do:

 

(Make sure you have put your shop into Maintenance mode)

 

1) Download the 1.5.6.2 zip file to your computer.

 

2) Unzip it on your computer. The unzipping process will create a folder called "prestashop 1.5.6.2", and inside there will be another folder called "prestashop".  This is the folder you need to copy to your "admin/autoupgrade/latest" folder via FTP. It's more than 5000 files and will take some time, so be patient.

 

Once you have done this, your "latest" folder should contain a folder called "prestashop" which has all of the 1.5.6.2 files.

 

3) Go to the configuration page for the 1-Click Upgrade module, and in the Expert options, select "Local Directory" as the channel, and in the version text box, type "1.5.6.2"  (without the quotation marks).

 

4) Save the configuration.

 

5) Click the Upgrade button.

 

 

My shop is working fine ever since the upgrade. I hope this helps you all.

Edited by MeeM (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

 

I solved this problem. I upgraded from 1.5.5 to 1.5.6.2 on a Zeus webserver. This is what you need to do:
 
(Make sure you have put your shop into Maintenance mode)
 
1) Download the 1.5.6.2 zip file to your computer.
 
2) Unzip it on your computer. The unzipping process will create a folder called "prestashop 1.5.6.2", and inside there will be another folder called "prestashop".  This is the folder you need to copy to your "admin/autoupgrade/latest" folder via FTP. It's more than 5000 files and will take some time, so be patient.
 
Once you have done this, your "latest" folder should contain a folder called "prestashop" which has all of the 1.5.6.2 files.
 
3) Go to the configuration page for the 1-Click Upgrade module, and in the Expert options, select "Local Directory" as the channel, and in the version text box, type "1.5.6.2"  (without the quotation marks).
 
4) Save the configuration.
 
5) Click the Upgrade button.
 
 
My shop is working fine ever since the upgrade. I hope this helps you all.

 

 

Thank you for your explanation. That is an alternate way to use the auto-upgrade module, some servers have restrictions that cause the autoupgrade module to not be used unless the entire module and update is located on the FTP, which you just described. 

Share this post


Link to post
Share on other sites

Hi!

 

I'm trying to upgrade from 1.4.10.0 to a more recent version, and it has been a complete nightmare.

 

As I've progressed, I'm trying to make thoughtful notes and paste them here, so everybody could take advantage of my experience, if any.

 

=============

1st attempt: Since upgrading from 1.4.10.0 to any 1.6.x version seems impossible, I've decided to take baby steps.

 

a) In my Linux PC, I've installed VMWare and created an Ubuntu Server 12.04 fresh, clean installation.

B) I've selected LAMPP (https://www.apachefriends.org) to keep things simple. My version is 1.8.3

c) After all installations, I downloaded from my site both a fresh copy of my MySQL database and a .tar.gz containing all my files.

d) Installed everything in my Virtual Server, tested it and now I'm ready to go.

 

I've downloaded Prestashop  1.4.11.0 first. After Unzipping it in my local machine, FTP'd to the /store/admin/autoupgrade/latest/ folder. Also, I've downloaded and installed the 1.3.11 version of the 1-click upgrade.

 

Then, I attempted to do the upgrade using the Expert Option / Local Directory, and....

 

It Worked! Now, my store is Updated to the 1.4.11.0 version of Prestashop.

 

=============

2nd attempt: Upgrading from 1.4.11.0 to 1.5.0.1 version.

 

Started with a full backup of my site (just in case). Then, I've downloaded Prestashop  1.5.0.1 and Unzipped it in my local machine, FTP'd to the /store/admin/autoupgrade/latest/ folder.

 

Attempted to do the upgrade using the Expert Option / Local Directory, and....

 

·$%·%·!!! It doesn't worked at all!  The process ended up with the 

"Internal Server Error " jqXHR"

=============

3rd attempt: Upgrading from 1.4.11.0 to 1.5.0.2 version.

 

Restored my site using the backup made at 2nd attempt, just to make sure everything wordked fine using 1.4.11.0.

 

Then, I've downloaded Prestashop  1.5.0.2 and Unzipped it in my local machine, FTP'd to the /store/admin/autoupgrade/latest/ folder.

 

Attempted to do the upgrade using the Expert Option / Local Directory, and....

 

Once again, ·$%·%·!!! It doesn't worked at all!  The process ended up with the 

"Internal Server Error " jqXHR"

Should I embrace a 4th attempt?

Share this post


Link to post
Share on other sites

Nobody? Really? :wacko:

 

 

Hi!

 

I'm trying to upgrade from 1.4.10.0 to a more recent version, and it has been a complete nightmare.

 

As I've progressed, I'm trying to make thoughtful notes and paste them here, so everybody could take advantage of my experience, if any.

 

=============

1st attempt: Since upgrading from 1.4.10.0 to any 1.6.x version seems impossible, I've decided to take baby steps.

 

a) In my Linux PC, I've installed VMWare and created an Ubuntu Server 12.04 fresh, clean installation.

B) I've selected LAMPP (https://www.apachefriends.org) to keep things simple. My version is 1.8.3

c) After all installations, I downloaded from my site both a fresh copy of my MySQL database and a .tar.gz containing all my files.

d) Installed everything in my Virtual Server, tested it and now I'm ready to go.

 

I've downloaded Prestashop  1.4.11.0 first. After Unzipping it in my local machine, FTP'd to the /store/admin/autoupgrade/latest/ folder. Also, I've downloaded and installed the 1.3.11 version of the 1-click upgrade.

 

Then, I attempted to do the upgrade using the Expert Option / Local Directory, and....

 

It Worked! Now, my store is Updated to the 1.4.11.0 version of Prestashop.

 

=============

2nd attempt: Upgrading from 1.4.11.0 to 1.5.0.1 version.

 

Started with a full backup of my site (just in case). Then, I've downloaded Prestashop  1.5.0.1 and Unzipped it in my local machine, FTP'd to the /store/admin/autoupgrade/latest/ folder.

 

Attempted to do the upgrade using the Expert Option / Local Directory, and....

 

·$%·%·!!! It doesn't worked at all!  The process ended up with the 

"Internal Server Error " jqXHR"

=============

3rd attempt: Upgrading from 1.4.11.0 to 1.5.0.2 version.

 

Restored my site using the backup made at 2nd attempt, just to make sure everything wordked fine using 1.4.11.0.

 

Then, I've downloaded Prestashop  1.5.0.2 and Unzipped it in my local machine, FTP'd to the /store/admin/autoupgrade/latest/ folder.

 

Attempted to do the upgrade using the Expert Option / Local Directory, and....

 

Once again, ·$%·%·!!! It doesn't worked at all!  The process ended up with the 

"Internal Server Error " jqXHR"

Should I embrace a 4th attempt?

Share this post


Link to post
Share on other sites

Nobody? Really? :wacko:

 

You should look in the Apache Error Logs for more information about this error. From there, we can move forward with troubleshooting. :)

Share this post


Link to post
Share on other sites

I downloaded and installed the latest 1-click upgrade module and I too am getting this error on our store.  I am trying to upgrade from 1.6.0.6 to 1.6.0.8

 

My error reads as follows:

 

[Ajax / Server Error for action backupDb] textStatus: "error " errorThrown:"Forbidden " jqXHR: "
Forbidden
 
You don't have permission to access /admin***/autoupgrade/ajax-upgradetab.php on this server.
 
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
 
"
 
The apache log reads as follows:
[error] [client xxx.xxx.xxx.22] File does not exist: /home/sitename/public_html/403.shtml, referer: https://www.mysite.com/admin***/index.php?controller=AdminSelfUpgrade&token=7672837052c6400033c6f0634d27cd2b
 
How is this marked as solved?  I still see many people are having this same issue.  Any help would be appreciated.
 
Thanks in advance!

Share this post


Link to post
Share on other sites

Hi all.

 

I'm trying to upgrade from 1.6.0.6 to 1.6.0.8 and get the same error...

I have tryied to unisntall / Re-install 1 click upgrade but not better.

 

Can you help ?

 

Regards,

Laurent (France).

Share this post


Link to post
Share on other sites

Update:  I just updated the 1-Click Upgrade module and then ran it again.  It worked!  Woohoo!  Now my store is updated at 1.6.0.8  

 

Thanks for the module upgrade!

Share this post


Link to post
Share on other sites

Resolved !

 

Concerning my problem, it was a server side issue... Disks were too slow and update could not process correctly.

 

My provider migrate my site to a powerfull server and it worked !

Share this post


Link to post
Share on other sites

Hello, I am trying to upgrade from 1.5.3.1 to 1.6.1.1. I have tried all of the suggestions in this post including the github changes. I still get the jQXHR error. I have tried with the files zipped an unzipped in the "latest" folder and the "download" folder. I would appreciate any help that is available, I also wonder why this problem hasn't been fixed in 2 years.

 

Randy

  • Like 1

Share this post


Link to post
Share on other sites

Hello, I am trying to upgrade from 1.5.3.1 to 1.6.1.1. I have tried all of the suggestions in this post including the github changes. I still get the jQXHR error. I have tried with the files zipped an unzipped in the "latest" folder and the "download" folder. I would appreciate any help that is available, I also wonder why this problem hasn't been fixed in 2 years.

 

Randy

 

Hi - I had this problem and this is how I fixed it after a fair bit of googling around.

 

I have a VPS and therefore access to SSH with root access. My server is running cPanel

 

1. I checked my log file for errors:

 

tail -500 /usr/local/apache/logs/error_log

 

2. I found the culprit which was fast-cgi timing out whilst trying to upgrade the database:

 

mod_fcgid: process 3371 graceful kill fail, sending SIGKILL

 

3. Using puTTY (SSH) I logged into my server and edited the php configuration file

 

  1. su
  2. cd /usr/local/apache/conf/
  3. nano php.conf
  4. Add this command 'FcgidIOTimeout 300' (without the quotes)
  5. Save the file

4. I then logged onto cPanel WHM and restarted apache

 

Voila! This worked for me

 

Edited by skinnybloke (see edit history)

Share this post


Link to post
Share on other sites

Hello all,

 

my prestashop installation is also hosted bei strato.

I tried all the tipps in this article but I still get this error:

 

[Ajax / Server Error for action backupFiles] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: "

 

My current version is 1.5.3.1 and I want to upgrade to 1.6.1.3

 

Any other solutions or experiences???

 

Best regards

Andreas

 

Share this post


Link to post
Share on other sites

Problem is solved.

It was 'only' a backup problem. I skipped backup options and use the adapted files from above and it worked.

 

Best regards

Andreas

Share this post


Link to post
Share on other sites

Problem is solved.

It was 'only' a backup problem. I skipped backup options and use the adapted files from above and it worked.

 

Best regards

Andreas

 

Hi Andreas

 

 

Maybe I have the same problem as you have too, but it doesn't work, and I need a help to solve it.

Share this post


Link to post
Share on other sites

Hi Shab,

 

from Strato Support I got this message:

disable 'guestbook spam filter' at the server site security.

 

I don't know if this would work because I had run my update before I received this message. But you can try.

 

Good luck

Best regards

Andreas

Share this post


Link to post
Share on other sites

Problem is solved.

It was 'only' a backup problem. I skipped backup options and use the adapted files from above and it worked.

 

Best regards

Andreas

 

No, a problem in something another. I yes without creation of a backup copy have this mistake. In what there can be a problem?

PS. I have dedizierte Server ,and for some years of such problem never arose.

post-800174-0-77584700-1453396077_thumb.jpg

Edited by fsnsem (see edit history)

Share this post


Link to post
Share on other sites

Hi,

 

i've this problem everytime I try to update from ps 1.7.0 to 1.7.0.2

 

[Ajax / Server Error for action download] textStatus: "error " errorThrown:" " jqXHR: " "

 

If I try to do a manual update i've an php error.

 

Can somebody help me, please?

Share this post


Link to post
Share on other sites

This is getting really frustrating now, Ive trawled the internet to try and find a resolution for this issue and have found nothing that works.

 

I am trying to upgrade from 1.6.1.10 to 1.6.1.11 using 1-click Upgrade v1.6.7

 

I kept getting the error 

 

Now extracting...

 

[Ajax / Server Error for action unzip] textStatus: "error " errorThrown:"Bad Gateway " jqXHR: " "

 

So i followed the instructions from the forums and tried disabling backup. still the same error.

 

So i then downloaded the update file and uploaded it to autoupgrader/latest and in back office went into auto upgrader expert and changed the  channel to my local directory.

 

I seemed to make progress with this and it began to run through the files. After a while it stopped and gave me a new error

 

[ERROR] /hermes/bosnaweb24a/b34/ipg.XXXXXXX/XXXXXXXXX/adminXXXXXXXXX/autoupgrade/latest/prestashop does not exist or is not a directory.

 

Any Ideas?

Edited by Lorna Love (see edit history)

Share this post


Link to post
Share on other sites

Hi, i got a similar problem also:

Fatal error: Uncaught --> Smarty Compiler: Syntax error in template "/home/sites/riversoft.com.mk/public_html/admin397ebpwvj/themes/default/template/header.tpl" on line 256 "headers: {"cache-control": "no-cache"}," - Unexpected ": ", expected one of: "}" <-- thrown in /home/sites/riversoft.com.mk/public_html/tools/smarty/sysplugins/smarty_internal_templatecompilerbase.php on line 256


Anyone had any experience with it?

Thanks in advance.

 

Best, Dejan

Share this post


Link to post
Share on other sites

Still no solution? 

I tried to upgrade my shop version 1.7.0.0 to version 1.7.1.2 with 1-click upgrade.

The 1-click upgrade runs until the end of process with one warning ([WARNING] Error when trying to upgrade module ps_linklist.). After that I rollback my previous database with my backup.

But when I reload the page and empty the cache now, my shop is still at version 1.7.0.0

Debug-Mode doesn't report any issues while this process but the console says "jquery-1.11.0.min.js:4 GET https://www.wir-sind-dach.info/admin676zt3m9f/index.php?controller=AdminLogin&redirect=/admin676zt3m9f/ajax.php?rand=1499595243610 500 (Internal Server Error)"

Also i don't have to log-in after refreshing the page like 1-click upgrade is telling me. 

 

No solution I find could help me so far.

 

Share this post


Link to post
Share on other sites

have the same problem when try 1click upgrade from 1.7.1.1 to 1.7.1.2

 

Also, may somebody help... during upgrade from 1.6.14 to 1.7.1.1 1click upgrade hang on "enabling modules..." and after a while I got 504 error... Now my admin panel looks like this: https://www.screencast.com/t/oubOb76Q

 

Can I manualy run part of autoupgrade to "enable modules" ? Or how to fix this broken upgrade? It because timeout of my server or "enabling modules" should not work for ~5 minutes?

Share this post


Link to post
Share on other sites
On 9/5/2013 at 9:46 AM, enkacom said:

JRos realmente no se que pensar, tengo varios servidores, alojamientos compartidos, y soy incapaz de actualizar la version, 1.4.10 a la MIERDA de 1.5, ya llevan no se cuantas actualizaciones, en todas te promenten lo mismo, han resuelto 400 problemas, 400 por dios, yo lo siento pero no me atrevo a vender prestashop en estas condiciones, antes todavia tenias una posibilidad, pero ahora es una MIERDA,  si no se puede actualizar o hay que ser ingeniero para hacerlo, esto no es un sistema para el publico en general, yo sinceramente no lo entiendo, pues de la anterios a la 1.4.10 sin problema, las que empece en 1.5 hasta ahorra tampoco, realmente tampoco entiendo esta politica de actualizaciones.......donde se machacar todo no seria mejor crear solo el parche, tipo joomla....y solo machacar los ficheros correguidos, no 25.436...........acabo de actualizar 1.5.4.1...mismo servidor sin problemas, soy incapaz de entenderlo

 

Esto sucede hasta para pasar de 1.4.6.2 a la 1.4.11.1 ... es una puta vergüenza. Lo mejor de todo es que días antes en unas pruebas funcionó, y ahora me vienen con cuentos de que hay que hacerlo parcialmente a mano, como si finalizar el proceso fuera ni mínimamente una garantía de que va a funcionar.

 

No hay mas que ver las estadísticas de Prestashop vs Woocomerce para ver la cagada que han ido amasando desde que sacaron la flamante version 1.4.

 

Del amor al odio hay un paso y la misma intensidad. Y digo yo, si ya han arreglado el problema, ¿Por que cojones no viene la descarga parcheada? No me digas mas! ya lo se... es más comodo tocarse los cojones y esperar que los demás lo hagan todo.

 

DECEPCIONADO se queda corto, porque como dice el amigo enkakom aqui, se nos van las putas horas de vida haciendo el gilipollas. Y ya para rematar, en este foro cuando pulso editar me hace scroll la página hacia arriba en vez de hacia abajo. Lo dicho, una p basura.

Edited by wippa (see edit history)

Share this post


Link to post
Share on other sites

Hello,

I think this really is a shame from Prestashop developers to cause such diffused and frequent issues just for a platform update from 1.7.1 to 17.2.

Please guys let's try to fix this ridiculous thing.

Thanks

Share this post


Link to post
Share on other sites

i disabled backup options and then it upgraded from older versions to 1.6.16  havent tried upgrading to 1.7.x

 

Share this post


Link to post
Share on other sites

[SOLVED] - For me, as for others here, the solution was local directory upgrade.

I had to upgrade locally (MAMP) from v1.6.1.12 to 1.6.1.18. I manually downloaded v1.6.1.18, unzipped it, moved the inner 'prestashop' folder to admin/autoupgrade/latest. Then from the module, choose other options > local directory, compile  the fields, than upgrade.

 

Share this post


Link to post
Share on other sites
On 9/4/2013 at 12:16 PM, compulandia said:

Thanks Legakh!!! This worked for me, too. Finally I'm up to date. :D

i am having http 500 error when trying to login in to admin pannel/bachoffice, then how can i upgrade it after extraxting prestashop in upgrade folder?? kindly help me step by step.

i am getting this error everywhere in website after upgrading to 1.6

image.thumb.png.3d91eb11e25bed201000a9c49cdc532b.png

Share this post


Link to post
Share on other sites
On 12/1/2017 at 3:04 AM, DigitalManager said:

Hello,

I think this really is a shame from Prestashop developers to cause such diffused and frequent issues just for a platform update from 1.7.1 to 17.2.

Please guys let's try to fix this ridiculous thing.

Thanks

agreed. i have lost my store after upgrading to 1.6. i am going to commit suicide :'(

Share this post


Link to post
Share on other sites

quando da l'errore: [Ajax / Server Error for action download] textStatus: "error " errorThrown:" " jqXHR: " "

Vi basta tornare indietro in impostazioni avanzate scegliere directory locale, inserire la versione di Prestashop che volete installare (sarebbe la versione di Prestashop che avete tentato di installare in automatico) e proseguire.

 

Non c'è nessun bisogno di scaricare, scompattare e caricare la cartella in Latest, Prestashop durante il tentativo di aggiornamento automatico che è fallito, ha già scaricato e scompattato la cartella.

Share this post


Link to post
Share on other sites

This is not technically a PrestaShop issue, though it would be nice if PrestaShop added a more detailed error with the following suggestion:

     Make sure zip is enabled in your PHP settings.

By default on Godaddy, for example, zip is NOT enabled in PHP. 

1. Install the zip plugin to PHP in cpanel:

     In cpanel, click on "PHP PEAR Packages"

     Under "Find" type zip and click "Go"

     Click "Install" next to the package

2. Enable zip support:

     In cpanel, click "Select PHP Version"

     check the box marked "zip" in the right column. 

     Click "Save"

Once I did these two things I had no further errors. Of course if you don't have a cpanel host the instructions will differ.

 

Share this post


Link to post
Share on other sites

Hello,

I was trying upgrade from 1.7.4.2 to 1.7.5.0 and I got the same error "[Ajax / Server Error for action download] textStatus: "error " errorThrown:" " jqXHR: " .

I tried in 1-click upgrade several options, the recommneded option, the local file option, the local directory option, I changed the server configuration too and the result was the same, copied some files and then Error.

After two days tried I found a solution for me and I hope it can help somebody, the problem for me was in the Multiviews configuration.

Process:

1º Copy the prestashop files uncompress in /Backoffice/autoupgrade/latest/

2º Go to /Backoffice/autoupgrade/latest/admin/ and open .htaccess 

3º Comment the below code

<IfModule mod_negotiation.c>
    Options -MultiViews
</IfModule>
#<IfModule mod_negotiation.c>
#    Options -MultiViews
#</IfModule>

4º Upgrade with 1-Click Upgrade with the local directory option.

Regards

Edited by astenoth (see edit history)

Share this post


Link to post
Share on other sites

Hello 

I have very similar problem. Tried to upgrade from 1.6 to 1.7.5 and getting this error

[Ajax / Server Error for action upgradeDb] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: "
500 Server Error

Upgrade from 1.6.1.22 to 1.6.1.23 was ok. 

I tried the same store at two hosting providers. One was smooth to upgrade, the other one failed. I am trying to figure out wat is wrong with the other one.

Can you help?

 

Thanks

 

Edited by zsedc (see edit history)

Share this post


Link to post
Share on other sites
On 12/23/2018 at 7:08 PM, astenoth said:

Hello,

I was trying upgrade from 1.7.4.2 to 1.7.5.0 and I got the same error "[Ajax / Server Error for action download] textStatus: "error " errorThrown:" " jqXHR: " .

I tried in 1-click upgrade several options, the recommneded option, the local file option, the local directory option, I changed the server configuration too and the result was the same, copied some files and then Error.

After two days tried I found a solution for me and I hope it can help somebody, the problem for me was in the Multiviews configuration.

Process:

1º Copy the prestashop files uncompress in /Backoffice/autoupgrade/latest/

2º Go to /Backoffice/autoupgrade/latest/admin/ and open .htaccess 

3º Comment the below code


<IfModule mod_negotiation.c>
    Options -MultiViews
</IfModule>

#<IfModule mod_negotiation.c>
#    Options -MultiViews
#</IfModule>

4º Upgrade with 1-Click Upgrade with the local directory option.

Regards

I did this and it worked for me. Upgraded from 1.7.3.3 to 1.7.5.2 successfully. 

Thank you 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More