Jump to content

Migrating a store from 1.3 to 1.5


xxmayankxx
 Share

Recommended Posts

Hello all,

 

I know there are already enough posts on migration, but I couldn't find the right information on what I wanted to do.

 

Here's the link to store: http://999designs.in/store/

 

It was made in 1.3. Now, my job is to migrate it to 1.5.

 

My question:

1) Any automated tool that can do this? Because, plugin for upgrading store won't work with 1.3.

 

2) If I have to do manually, am I following the right steps?

Step 1: Back everything up on a different location

Step 2: Install PS 1.5, and migrate databse from the old PS and replace all the styling files from the older version.

Will this work or any other method to do this?

 

Link to store: 999designs.in/store

 

Regards,

Mayank

Share this post


Link to post
Share on other sites

You see read the upgrade guide (developers guide) located in the resource menu here on the PS website. Read through the entire guide so you understand what must be accomplished before you start.

 

You might also do better doing the upgrade from 1.3 to 1.4.11, and then upgrade a second time from 1.4.11 to 1.5.4.1

 

Most likely any custom theme and module will not work in the new PS v1.5.4.1, so they will need to be upgraded

Then any core coding customizations that may have been made to the v1.3 store will be lost, and will need to be reapplied. (database changes like new tables and new columns will be maintained during the upgrade)

Share this post


Link to post
Share on other sites

Hello, I did follow all the steps as mentioned. And tried to upgrade to 1.4. However, it shows that installation is complete but it just doesnt show the store. It shows Server Error when I try to access the store. Same error comes up when I try to access to backoffice. :( :(

 

"The website encountered an error while retrieving http://mydomain.com/prestashop/. It may be down for maintenance or configured incorrectly.

Error code: 500"

 

I tried googling but couldn't find any help.

 

 

Please help me.

Edited by xxmayankxx (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More