Jump to content
Lorem Ipsum

Pris à 0€ dans liste produit mais correct dans le détail

Recommended Posts

Bonjour,

 

J'ai un problème récurrent sur mon site, certain produit que je met en ligne apparaissent avec un prix à 0€ dans la liste produit mais le bon prix apparaît bien dans le détail du produit.

Pour corriger ce problème je dois changer la déclinaison par défaut puis remettre celle que je désire. Sachant que les déclinaisons en question n'ont pas d’influence sur le prix du produit.

Un exemple :

http://www.approach-outdoor.com/498-arc-teryx-hiver-1314 le produit ATOM LT VEST doudoune (4eme en partant de la fin) apparait à 0€

et le détail de ce produit : http://www.approach-outdoor.com/498-arc-teryx-hiver-1314 au bon prix.

 

J'ai cherché mais je n'ai pas trouvé d'autre rapport de bug du même type, je suis le seul à qui ça arrive?

 

Romain.

Share this post


Link to post
Share on other sites

Hello,

 

Peut être qu'il affiche la première déclinaison comme étant celle par défaut mais il n'a peut etre pas l'info en base et prend la première "par défaut d'information" en back office donc, juste pour l'affichage....

 

C'est un import de données ? à part re sélectionner la déclinaison par défaut je ne vois pas grand chose a faire, ou des requêtes sql un peu lourdes.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai le meme probleme, dans l'affichage de la catégorie il affiche le produit (avec deux déclinaison)  à 0 euro, mais dnas le détails de la fiche pas de soucis j'ai bien le bon prix...

 

Pas contre je ne comprend pas pourquoi il ne le fais que sur 2 de mes produits et pas sur les autres ...

 

Une idée ?

Share this post


Link to post
Share on other sites

Bonjour,

 

Essayez de re cocher sur les déclinaisons (coche verte) par défaut en back office des produits qui posent souci. Sinon cela peut être un souci de template.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

Même soucis sur mon site des produits au départ créé avec des déclinaisons puis suppression des déclinaison pour crée des page produit indépendante.

 

Résultat prix à 0 € en liste produit et pas moyen de commander.

 

Y a t'il un moyen de réinitialisé l'état déclinaison ?

 

Cordialement,

Share this post


Link to post
Share on other sites

Bonjour,

 

Je remonte ce post car j'ai le même problème, suite à une suppression de mes déclinaisons dans un produit, dans la liste des produits, le prix est à 0 mais dans le détail produit, le prix est correct.

 

Comment peut-on corriger ce problème ?

 

Cordialement

Anne

Share this post


Link to post
Share on other sites

Bonjour,

 

Problème résolu, en fait, il y a quelques temps, j'avais supprimé des déclinaisons alors qu'elles étaient liées à certains articles et apparemment ce problème serait lié à ça, car quand j'ai supprimé tous les produits qui avaient ces déclinaisons "fantômes", et ensuite recréer les articles, je n'ai plus eu ce problème.

 

Cordialement

Anne

Share this post


Link to post
Share on other sites

Pour ceux qui rencontrent ce bug, vous pouvez également supprimer cette ligne dans le fichier product.js du dossier js de votre thème.

$ ('# Our_price_display') texte (our_price).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More