Jump to content
diurno

Google indexing deactivated languages

Recommended Posts

Hello guys,

 

I'm getting loads of 'Not Found' errors in google as it is looking for "es/" and other languages which have been disabled long ago.

 

How do I tell google to stop looking for these long disabled languages?

 

Many thanks

Share this post


Link to post
Share on other sites

I've done that, I've also checked the sitemap which I posted, one generated by xmlsitemaps and there's no mention of any language in it.

 

It's confusing?!

Share this post


Link to post
Share on other sites

this is (I think) exactly the problem I had. Google was looking for an /en/ folder even though I had set my site to just one language. It caused me a massive loss in Google ranking. I'm really annoyed actually that it didn't handle this situation better.

Share this post


Link to post
Share on other sites

Anyone got any solutions for this?

 

I've resubmitted my sitemap many times and the problem is still present! Any help would be appreciated!

Share this post


Link to post
Share on other sites

<bump> 

 

I have that same issue. I did generate a new sitemap (and told bing and google the location and have them read the sitemap), but somehow bing and google keep trying to index those disabled urls for these disabled languages, resulting in 404 errors. The disabled languages are not mentioned in the sitemap.

 

Does anybody have a clue why this happens and how this can be solved?

Share this post


Link to post
Share on other sites

You can submit as many sitemaps as you want, it won't change anything, because sitemaps just tells Google which URL to crawl. If you deactivate some languages, then those URLs are not available anymore but old URLs are still indexed. You should have inserted a "noindex" tag in those languages pages before !

One of the solutions is to insert permanent redirections in your .htaccess file :

RedirectPermanent /es /
RedirectPermanent /es/ /

The first line will redirect the spanish homepage to your new homepage if only 1 language now (otherwhise change the final '/' to '/en' for example)

The second line with redirect /es/xxx to /xxx

And of course, the permanent redirection will tell Google "the redirected url doesn't exists anymore, so remove it from your index" 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×