Jump to content

Recommended Posts

Ds_Terminal:001;

Ds_Response:0000;

Ds_Amount:600;

Ds_SecurePayment:1;

Ds_Card_Country:724;

Ds_Card_Brand:1;

Ds_ConsumerLanguage:1;

Ds_Date:19/06/2019;

Ds_MerchantData:5c101434cf3d8aa847203c3cad314c90e9ad841e;

Ds_Order:000000000016;

Ds_MerchantCode:348759135;

Ds_TransactionType:0;

Ds_Hour:19:58;

Ds_AuthorisationCode:324918;

Ds_Currency:978;

Server URL: sis-t.redsys.es

 

Esto es lo que me sale en el email de confirmacion

El ficherlo log de redsys esta vacio no tiene nada

Share this post


Link to post
Share on other sites

Sale todo en verde. Todo OK

te pongo la url por si quieres ver algo en concreto

www.verdesentido.es

 

Share this post


Link to post
Share on other sites

Es un problema de certificado. o eso parece

Necesitas tener alguno de estos "cipher suites" activos, si no los tienes, insiste al hospedaje que te activen alguno de ellos. Estos son los cifrados que eran necesarios cuando se escribió el texto. 

  • TLS_RSA_WITH_AES_128_CBC_SHA (0x002F)
    TLS_RSA_WITH_AES_256_CBC_SHA (0x0035)
    TLS_RSA_WITH_AES_128_CBC_SHA256 (0x003C)
    TLS_RSA_WITH_AES_256_CBC_SHA256 (0x003D)
    TLS_RSA_WITH_AES_128_GCM_SHA256 (0x009C)
    TLS_RSA_WITH_AES_256_GCM_SHA384 (0x009D)
  •  
  • Puedes comprobarlo aqui : https://www.sslshopper.com/ssl-checker.html

https://www.ssllabs.com/ssltest/analyze.html?d=verdesentido.es&hideResults=on

en cambio si lo pruebo con otro dominio que si que se que funciona

image.png.d3249d86eefa10e88b0cdd1c8e2c63e2.png

con otro dominio

image.png.04e19328f6b0879c4bfe2c88a00f846b.png

Pide al hospedaje que te activen alguno de los chiper

Share this post


Link to post
Share on other sites

He hablado con el hosting y me comentan que eso esta todo ok. Alguna sugerencia mas?

Share this post


Link to post
Share on other sites
hace 1 hora, manuel-241 dijo:

He hablado con el hosting y me comentan que eso esta todo ok. Alguna sugerencia mas?

1- pues le envias el enlace y le preguntas por que no salen los cifrados que pide Redsys

2- compra un certificado de pago y lo instalas.

https://www.ssls.com/

 

3- al hospedaje se lo compras y que lo instalen.

No hay otra cosa que hacer

 

 

Share this post


Link to post
Share on other sites

Buenas.
Hemos actualizado a la versión 1.7.6.0 beta y nos ha dejado de funcionar el modulo de redsys, nos da el siguiente error:

SIS0027 => «Error Moneda enviada por el comercio es diferente a la que tiene asignada para ese terminal»

He revisado las monedas, solo esta EURO, antes habia mas pero las he borrado incluso a nivel de BBDD y nada, sigue fallando.

Alguna idea?

Saludos

Share this post


Link to post
Share on other sites
hace 1 hora, AsesvalIntSer dijo:

Buenas.
Hemos actualizado a la versión 1.7.6.0 beta y nos ha dejado de funcionar el modulo de redsys, nos da el siguiente error:

SIS0027 => «Error Moneda enviada por el comercio es diferente a la que tiene asignada para ese terminal»

He revisado las monedas, solo esta EURO, antes habia mas pero las he borrado incluso a nivel de BBDD y nada, sigue fallando.

Alguna idea?

Saludos

Es cosa del Prestashop y del modulo ->

Breaking or risky changes

  • The Currency ObjectModel is now multilingual

---

Vuelve a la version 1.7.5.2 

Hasta que no saquen una actualizacion del modulo no funcionara, y tardaran bastante.

 

Nunca actualices una versión Beta en sistemas y tiendas en producción

 

 

Share this post


Link to post
Share on other sites
8 minutes ago, gusman126 said:

Es cosa del Prestashop y del modulo ->

Breaking or risky changes

  • The Currency ObjectModel is now multilingual

---

Vuelve a la version 1.7.5.2 

Hasta que no saquen una actualizacion del modulo no funcionara, y tardaran bastante.

 

Nunca actualices una versión Beta en sistemas y tiendas en producción

¿Y como vuelvo? Creo que es casi mejor esperar a la stable.

 

 

Share this post


Link to post
Share on other sites

Supongo que hiciste una copia de seguridad antes, o comprueba si el servidor tiene alguna del dia mismo o del anterior a la actualización

Share this post


Link to post
Share on other sites

Buenas de nuevo. La cuestion es que hablando con mi proveedor de hosting hemos hecho algunas pruebas que comento y sigue sin funcionar, por lo que deducimos que el problema es del modulo de redsys o de prestashop 1.7.5.1

Hemos creado un servidor de pruebas y el problema sigue siendo el mismo no llegan los pedidos ni vacia el carrito, por otro lado he instalado en servidor local wampserver el prestashop e instalado el modulo de redsys sobre la plantilla y al hacer el pago hace exactamente lo mismo. con lo cual creo que queda descartado problema del hosting.

Que decís? Alguna idea mas?

Saludos

Share this post


Link to post
Share on other sites

En local nunca te va a funcionar porque la notificación no llega.

Share this post


Link to post
Share on other sites

Eso mismo pensaba yo pero por probar solo pierdo un poco de tiempo. Alguna idea?

Gracias

Share this post


Link to post
Share on other sites
hace 10 minutos, manuel-241 dijo:

Eso mismo pensaba yo pero por probar solo pierdo un poco de tiempo. Alguna idea?

Gracias

Los certificados SSL que piden los de Redsys ya te salen?

ese servidor de pruebas? es en el mismo hosting? o es el local que dices. 

Si es el mismo hosting, puede que siga siendo los SSL , busca un hosting donde puedas pagar 1 mes, copia todo alli, activa el lets encrypt y prueba, si funciona o no ya tendras la respuesta.

Si me envias un mp, hablamos

Share this post


Link to post
Share on other sites

Hola! 

¿sabéis alguno cómo hacer para que redsys redirija automaticamente a mi página de Ok?

SE me queda bloqueado aquí después de pagar... y a veces mis clientes no vuelven a mi tienda, adjunto pantallazo de ejemplo.

image.thumb.png.7009244803989b42d47e947f5d3d9d1b.png

Share this post


Link to post
Share on other sites
hace 58 minutos, MrViSiOn dijo:

Hola! 

¿sabéis alguno cómo hacer para que redsys redirija automaticamente a mi página de Ok?

SE me queda bloqueado aquí después de pagar... y a veces mis clientes no vuelven a mi tienda, adjunto pantallazo de ejemplo.

image.thumb.png.7009244803989b42d47e947f5d3d9d1b.png

Llamando a Redsys y que todos los clientes llamen a ver si pueden obligar a poner un contador de -10 segundos como hacen otras pasarelas de pago, 

Tu no puedes hacer nada, solo quejarte y decir que es un fallo grave

 

Share this post


Link to post
Share on other sites
39 minutes ago, gusman126 said:

Llamando a Redsys y que todos los clientes llamen a ver si pueden obligar a poner un contador de -10 segundos como hacen otras pasarelas de pago, 

Tu no puedes hacer nada, solo quejarte y decir que es un fallo grave

 

Jovar... es que no puedo integrar con funnels de analytics ... :( 

Vale muchas gracias... qué lata...

Share this post


Link to post
Share on other sites
hace 31 minutos, MrViSiOn dijo:

Jovar... es que no puedo integrar con funnels de analytics ... :( 

Vale muchas gracias... qué lata...

Si es algo que sigo pensando que es un gran fallo que no implementan , lo fácil que sería añadir un cuenta atrás para que siempre se volviera a la tienda.

Aunque es muy raro que la gente no termine y vuelva a la web.

Puede que añadiendo un evento en el tagmanager a la URL que llama redsys para confirmar el pedido, hiciera que se registrará en analytics.

 

 

Edited by gusman126 (see edit history)

Share this post


Link to post
Share on other sites
20 hours ago, gusman126 said:

Si es algo que sigo pensando que es un gran fallo que no implementan , lo fácil que sería añadir un cuenta atrás para que siempre se volviera a la tienda.

Aunque es muy raro que la gente no termine y vuelva a la web.

Puede que añadiendo un evento en el tagmanager a la URL que llama redsys para confirmar el pedido, hiciera que se registrará en analytics.

 

 

Pues programaré el objetivo de analytics en el callback de redsys... 

Gracias por la respuesta!

Share this post


Link to post
Share on other sites

Redsys & Prestashop 1.7.6

Los que hayan actualizado a 1.7.6 PS que comprueben si el modulo de Redsys le esta funcionando, por que yo me he enterado que no funcionaba por un cliente que me lo ha dicho.

El modulo oficial no funciona con la ultima actualizacion.

Share this post


Link to post
Share on other sites
hace 36 minutos, joseantgv dijo:

No funciona, no.

Que errores salen? 

Share this post


Link to post
Share on other sites
hace 1 hora, gusman126 dijo:

Que errores salen? 

El pedido se queda sin estado, los correos no se envían.

  • Like 1

Share this post


Link to post
Share on other sites

Para que se envíen los correos hay que cambiar manualmente el estado del pedido a Pago aceptado, y es un poco incomodo para el cliente estar así... a ver si ven una solución... y a su vez si cancelan el pago lleva a una pagina en blanco en lugar de a la tienda.

Edited by Cafe (see edit history)

Share this post


Link to post
Share on other sites
hace 2 horas, Jamones P. Castaño dijo:

Se sabe cuando arreglaran el problema?

A mi aparte de salirme el error que se ve, el importe no corresponde con el precio real del carrito.

error.jpg

Esa captura de pantalla es debido a que no tienes bien puestos los datos de configuración de la clave 256 o de otro dato

Actualizar el modulo de Redsys a PS 1.7.6 ? a saber, ultimamente suele actualizar el modulo en un tiempo razonable, pero a saber

 

Share this post


Link to post
Share on other sites
39 minutes ago, gusman126 said:

Esa captura de pantalla es debido a que no tienes bien puestos los datos de configuración de la clave 256 o de otro dato

Actualizar el modulo de Redsys a PS 1.7.6 ? a saber, ultimamente suele actualizar el modulo en un tiempo razonable, pero a saber

 

No he cambiado nada, solo actualice la semana pasada y hoy no funcionaba.

Probare a coger el modulo de alguna copia de seguridad que tenga anterior.

Share this post


Link to post
Share on other sites

Actualizaste? Comprueba que no hay 2 módulos diferentes, una de las "actualizaciones" hacia que se instalará como independiente

Share this post


Link to post
Share on other sites
8 minutes ago, gusman126 said:

Actualizaste? Comprueba que no hay 2 módulos diferentes, una de las "actualizaciones" hacia que se instalará como independiente

No, solo tengo paypal y redsys como formas de pago.

He desinstalado e instalado poniendo mis mismos datos y lo mismo, bueno casi lo mismo, sigue sin funcionar pero con mas errores.

 

error.jpg

Share this post


Link to post
Share on other sites
2 hours ago, gusman126 said:

Esa captura de pantalla es debido a que no tienes bien puestos los datos de configuración de la clave 256 o de otro dato

Actualizar el modulo de Redsys a PS 1.7.6 ? a saber, ultimamente suele actualizar el modulo en un tiempo razonable, pero a saber

 

Las cosas de palacio van despacio, si estas esperando que lo arreglen te puedes cansar, a lo mejor ni se han enterado que no funciona. Busca otras soluciones si quieres seguir recibiendo pagos.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Jamones P. Castaño said:

Se sabe cuando arreglaran el problema?

A mi aparte de salirme el error que se ve, el importe no corresponde con el precio real del carrito.

error.jpg

Las cosas de palacio van despacio, si estas esperando que lo arreglen te puedes cansar, a lo mejor ni se han enterado que no funciona. Busca otras soluciones si quieres seguir recibiendo pagos.

Share this post


Link to post
Share on other sites

Buenos dias

Hablando con ellos mediante mail me han mandado un nuevo zip con el problema resuelto. Supuestamente es una version de redsys ya corregida.

Os comento que tal funciona los próximos días ya que por ahora funciona todo correcto.

Gracias

Share this post


Link to post
Share on other sites
On 7/24/2019 at 12:34 PM, Jamones P. Castaño said:

Buenos dias

Hablando con ellos mediante mail me han mandado un nuevo zip con el problema resuelto. Supuestamente es una version de redsys ya corregida.

Os comento que tal funciona los próximos días ya que por ahora funciona todo correcto.

Gracias

Buenos dias, como lo llevas?? Funciona bien?

 

Share this post


Link to post
Share on other sites

Alguien ha conseguido arreglar el problema de Prestashop 1.7.6 con la última versión de Redsys 3.0.2?

Share this post


Link to post
Share on other sites
1 hour ago, Kiwop said:

Alguien ha conseguido arreglar el problema de Prestashop 1.7.6 con la última versión de Redsys 3.0.2?

On 7/22/2019 at 11:47 AM, Jamones P. Castaño said:

Se sabe cuando arreglaran el problema?

A mi aparte de salirme el error que se ve, el importe no corresponde con el precio real del carrito.

error.jpg

Las cosas de palacio van despacio, si estas esperando que lo arreglen te puedes cansar, a lo mejor ni se han enterado que no funciona. Busca otras soluciones si quieres seguir recibiendo pagos.

Share this post


Link to post
Share on other sites

Yo he comprado un modulo a un programador de confianza y desde entonces ya no tengo problemas.

Share this post


Link to post
Share on other sites

En Addons tienes módulos que le dan mil vueltas a nivel de funcionalidades y con soporte, que desde el primer día han solucionado el problema que ha habido con PS 1.7.6.

Claro, son de pago, pero no vas a tener la tienda sin poder recibir pagos a saber cuántos días 😥

Edited by joseantgv (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Correcto, ese es el tema. lo que dice joseantgv, no vas a estar esperando a que lo arreglen sin vender y sin recibir pagos.

Porque como decia yo antes las cosas de palacio van despacio y no se van a dar prisa en arreglarlo, de todos modos es la unica plataforma pagos online que hay en España, han conseguido quedarse con todo, asi que, ajo y agua

Es lo que tienen los monopolios.

Share this post


Link to post
Share on other sites
En 22/7/2019 a las 4:02 PM, Jamones P. Castaño dijo:

No, solo tengo paypal y redsys como formas de pago.

He desinstalado e instalado poniendo mis mismos datos y lo mismo, bueno casi lo mismo, sigue sin funcionar pero con mas errores.

 

error.jpg

El pedido era de 91€ o de 910€ ?

 

  • Like 1

Share this post


Link to post
Share on other sites

Segun el soporte de redsys:

En el archivo redsysoficial.php

Hay que modificar la siguiente linea(linea797):
        $moneda = $currency->iso_code_num;

por:
        $moneda = 978;

 

Gracias por el enlace a la solucion de los decimales gusman126

Edited by Un_Tal_Iban (see edit history)

Share this post


Link to post
Share on other sites

Hola a todos,

¿alguna solución al problema de que no se envíen los emails ni se actualice el estado del envío?

versiones:

Prestashop: 1.7.6.0              

Redsys: 3.0.4

 

Un saludo.

Share this post


Link to post
Share on other sites
hace 1 hora, cimillas dijo:

Hola a todos,

¿alguna solución al problema de que no se envíen los emails ni se actualice el estado del envío?

versiones:

Prestashop: 1.7.6.0              

Redsys: 3.0.4

 

Un saludo.

Con el módulo gratuito de momento no hay actualización por parte de Redsys

Share this post


Link to post
Share on other sites

Hola! Sabeis si este módulo cumple con la nueva normativa SCA(Strong Customer Authentication) que entra en septiembre? 

He visto por su web que tienen 3D Secure, pero en teoría para la nueva normativa haría falta 3D Secure 2. Pero no encuentro nda sobre eso en la web de redsys.

Gracias!

Share this post


Link to post
Share on other sites
hace 57 minutos, Un senor dijo:

Hola! Sabeis si este módulo cumple con la nueva normativa SCA(Strong Customer Authentication) que entra en septiembre? 

He visto por su web que tienen 3D Secure, pero en teoría para la nueva normativa haría falta 3D Secure 2. Pero no encuentro nda sobre eso en la web de redsys.

Gracias!

Supongo que es algo que debe hacer la pasarela de pago, por lo que deberias llamar a Redsys o por su twitter y preguntar, si te contestan pon la respuesta por aqui

Share this post


Link to post
Share on other sites

Si preguntais a los de redsys, te envian un modulo provisional que esta de prueba, no se hasta que punto habran podido solucionar los problemas. Yo creo que me pasare a una opcion de pago porque asi no se puede andar.

Edited by Un_Tal_Iban (see edit history)

Share this post


Link to post
Share on other sites
2 hours ago, Un_Tal_Iban said:

Si preguntais a los de redsys, te envian un modulo provisional que esta de prueba, no se hasta que punto habran podido solucionar los problemas. Yo creo que me pasare a una opcion de pago porque asi no se puede andar.

A mi no me deja ni subir el zip...

Asi que tela

Share this post


Link to post
Share on other sites

A mi si, y funciona, pero a medias, exactamente igual que el que fallaba 😂

Ya he comprado un modulo de pago, que es mas barato que perder las horas que se pierden con estas mier***

Share this post


Link to post
Share on other sites
12 hours ago, Un_Tal_Iban said:

A mi si, y funciona, pero a medias, exactamente igual que el que fallaba 😂

Ya he comprado un modulo de pago, que es mas barato que perder las horas que se pierden con estas mier***

Buenos dias

Cual si no es mucho preguntar?

Share this post


Link to post
Share on other sites

Me han respondido que eso tengo que preguntárselo al banco con el que contrato el tpv virtual, que ellos al ser simplemente la pasarela no tienen nada que ver e eso.

Edited by Un senor (see edit history)

Share this post


Link to post
Share on other sites
On 8/14/2019 at 8:05 AM, Jamones P. Castaño said:

Buenos dias

Cual si no es mucho preguntar?

Que modulo he comprado?

Despues de hablar con algunos desarrolladores, hemos optado por este, los habia mas caros y mas baratos, pero es el que nos han recomendado (habiamos puesto el ojo en uno que era mas caro pero incluso el propio desarrollador nos dijo que no merecia la pena, que era mejor el siguiente mas barato). 

Esta listo para la nueva ley que se empezara a aplicar en breve de DSP2

Es muy sencillo y tiene algunas caracteristicas muy buenas.

Por cierto, como casi todos los modulos, esta mas barato en la pagina del desarrollador que en la de prestashop...

Share this post


Link to post
Share on other sites

Hola a todos.

¿Ha aparecido alguna solución a este problema? Nos está afectando en 3 tiendas desde que actualizamos el Prestashop.

Saludos

Share this post


Link to post
Share on other sites
On 8/28/2019 at 10:58 PM, Rafael said:

Hola a todos.

¿Ha aparecido alguna solución a este problema? Nos está afectando en 3 tiendas desde que actualizamos el Prestashop.

Saludos

Buenas tardes,

Nada sigue igual. Comprar el de pago y 0 problemas.

Share this post


Link to post
Share on other sites

Buenas tardes,

Al recibir pago por redsys en lugar de pago aceptado, no muestra ningun estado en la sección de pedidos. Si miro dentro del pedido, pone Cancelado. El pago sin embargo llega perfectamente.

¿Alguien me podría ayudar con esto para que ponga pago aceptado?

Gracias

 

image.png.dd91a0fc197bbbf3bc4b1394ff043856.png

 

image.png.15dcdb1fd2aa00709e6c094430432230.png

Share this post


Link to post
Share on other sites

Tenemos el mismo problema tras hacer update de Prestashop 1.7.5.1 ----> 1.7.6.1 el modulo redsys no funciona correctamente.

El pedido se realiza, se vacía el carrito, se realiza la transaccion en el banco, se genera le pedido.... PERO en lugar de "estado pagado" el pedido se queda sin estado. 

Vamos a probar con un modulo gratuito que teoricamente esta validado para 1.7.6.X y si funciona os lo enlazo...

 

Share this post


Link to post
Share on other sites
hace 20 horas, Antakarana dijo:

Tenemos el mismo problema tras hacer update de Prestashop 1.7.5.1 ----> 1.7.6.1 el modulo redsys no funciona correctamente.

El pedido se realiza, se vacía el carrito, se realiza la transaccion en el banco, se genera le pedido.... PERO en lugar de "estado pagado" el pedido se queda sin estado. 

Vamos a probar con un modulo gratuito que teoricamente esta validado para 1.7.6.X y si funciona os lo enlazo...

 

 

Share this post


Link to post
Share on other sites

Gracias por tu respuesta gusman126,

También uso Plesk y en ese dominio uso 7.2.22 Aplicación FPM con Apache. Intl estaba ya activado así que no me sirve como solución, pero gracias. Imagino que los de redsys tendran que actualizar el módulo.

Ahora con la directiva PSD2 no tendrían que darse un poco de prisa?

Gracias

Share this post


Link to post
Share on other sites
hace 2 minutos, malcolmxtc dijo:

Gracias por tu respuesta gusman126,

También uso Plesk y en ese dominio uso 7.2.22 Aplicación FPM con Apache. Intl estaba ya activado así que no me sirve como solución, pero gracias. Imagino que los de redsys tendran que actualizar el módulo.

Ahora con la directiva PSD2 no tendrían que darse un poco de prisa?

Gracias

ok, yo tenia la version 7.2.xx y la cambie a la 7.3 y funciono correctamente, prueba a ver si puedes subirla

Share this post


Link to post
Share on other sites
On 9/14/2019 at 12:57 PM, gusman126 said:

ok, yo tenia la version 7.2.xx y la cambie a la 7.3 y funciono correctamente, prueba a ver si puedes subirla

Pues no, a mí no me ha funcionado subirla a la 7.3, qué raro.

Share this post


Link to post
Share on other sites
En 15/10/2019 a las 12:17 PM, carambandombolas dijo:

Hola!

A mi me ocurre el mismo problema, que no asigna estado y no envía los correos. ¿Alguien ha encontrado una solución?

Hola

Teníamos el mismo problema que tú y probamos este modulo gratuito que funciona perfectamente desde el primer día:

https://modulos-prestashop.com/analisis-modulo-redsys-la-version-prestashop-1-7

Un saludo

Share this post


Link to post
Share on other sites

Hi all. I have downloaded the version mentioned by Antakarana above but when I go to install I get an error message that I cannot upload the file type which is a .rar file. 

I even unzipped and then zipped to a .zip file but then I get an error saying "This file does not seem to be a valid module zip".

FRUSTRATING. 

Any ideas on how to install the module? 

Thanks,
Jeremy...

Edited by FIXGEAREU
add info (see edit history)

Share this post


Link to post
Share on other sites

Perdona. No me había dado cuenta que el hilo está en Español.

He descargado el modulo mencionado por Antakarana arriba pero al intetnar instalarlo (arrastrando y soltando en mi back office), me sale un error que no se puede instalar este tipo de archivo, es un .rar

Haste he pensado que aceptaría un archivo ZIP así que he descomprimido y vuelto a comprimir como .zip pero me sale un error que no parece ser un módulo zip válido". 

¿Alguna idea de cómo instalarlo? 

Mil gracias, estoy frustrado.

Saludos,
Jeremy...

Share this post


Link to post
Share on other sites
On 1/14/2020 at 12:39 PM, FIXGEAREU said:

Perdona. No me había dado cuenta que el hilo está en Español.

He descargado el modulo mencionado por Antakarana arriba pero al intetnar instalarlo (arrastrando y soltando en mi back office), me sale un error que no se puede instalar este tipo de archivo, es un .rar

Haste he pensado que aceptaría un archivo ZIP así que he descomprimido y vuelto a comprimir como .zip pero me sale un error que no parece ser un módulo zip válido". 

¿Alguna idea de cómo instalarlo? 

Mil gracias, estoy frustrado.

Saludos,
Jeremy...

Prueba a descargar de nuevo el módulo: ahora está en ZIP (download the module again, I just fixed rar issue).

Si no te funciona, puedes subir por ftp el módulo. (If the upload isn't working, try to upload by ftp to modules folder).

Regards

Share this post


Link to post
Share on other sites

Uuuufff. Madre mía. 

Al intentar realizar una compra de prueba, se me llava a https://sis.redsys.es/sis/realizarPago/utf-8 y me sale error como los que otros han puesto arriba (adjunto "ERROR REDSYS.png").

Luego desinstalé y volví a instalar el módulo y me sale el mismo error pero sin ni número de pedido ni cantidad (adjunto "ERROR REDSYS2.png").

No sé lo que estoy haciendo mal.

Adjunto también "CONFIIG.png" que es mi configuración del módulo. 
 
He visto las sugerencias en este hilo para solucionar este problema como la de Un_Tal_Iban que dice...

--------------------------------------------------------------------------

Segun el soporte de redsys:

En el archivo redsysoficial.php

Hay que modificar la siguiente linea(linea797):
        $moneda = $currency->iso_code_num;

por:
        $moneda = 978;

--------------------------------------------------------------------------

...PERO ese archivo redsysoficial.php no existe en el módulo que he bajado e instalado. 

Porfa, ayudaaaaa. 

Gracias,
Jeremy...

ERROR REDSYS.png

ERROR REDSYS2.png

CONFIG.png

Share this post


Link to post
Share on other sites

Actualizo...

Encontré esa línea de código en "includes-->Redsys17Signature.php" y lo modifiqué como ha sugerido Un_Tal_Iban arriba pero me da el mismo error al intentar hacer un pedido de prueba.


¿ideas?

GRacias,

Jeremy...

ERROR REDSYS2.png

Share this post


Link to post
Share on other sites

¿Alguna solución a este problema que no sea pagar 39€ por el modulo de pago? 

Gracias,

Jeremy...

Share this post


Link to post
Share on other sites

Por cierto, el módulo de pago que comenta Un_Tal_Iban arriba...
 

Quote

Por cierto, como casi todos los modulos, esta mas barato en la pagina del desarrollador que en la de prestashop...

... sólo es un ahorro de 1,60€ porque en la tienda de PrestaShop vale 49,99€ CON IVA y en la del desarollador el precio de 39,99€ es SIN IVA así que sale por 48,39€.

Saludos,

Jeremy..-

Share this post


Link to post
Share on other sites

Yo recomiendo usar el oficial, aunque ultimamente falla como una escopeta de feria, van solucionando los problemas, el problema esta en que actualices prestashop sin ver o comprobar si funciona bien, para que el oficial se actualice puede pasar 1 mes o mas.

Asi que si puedes esperar a que otros hagamos pruebas con versión oficial y digamos cuando se ha solucionado usa el oficial.

Si no quieres arriesgarte a problemas y fallos , haz la compra, siempre sera mas rentable que los quebraderos de cabeza que tenemos alguno cuando falla el oficial, ya que el de pago lo debe actualizar mucho antes

Share this post


Link to post
Share on other sites

HE comprado el módulo de IdNovate. La verdad es que son muy buenos y atentos a sus clientes. Ya me está funcionando la pasarela. 

Para que conste, el error que me salía se debía a que mi clave secreto/Encryption Key /SHA-256 me la había cambiado mi banco y no me avisaron. Por eso tanta queja de compradores que no podían pagar, uuuuuffff. 

Las claves han pasado de tener 16 a 32 cifras y es lo que me fallaba. Lo descubrí gracias al soporte técnico de los de IdNovate (desarrolladores del módulo de pago RedSys y muchos más). 

Saludos,
Jeremy...

  • Like 1

Share this post


Link to post
Share on other sites

Al instalar redsys (archivo descargado en su página oficial) da error al subir el módulo. Sale error de que no es un archivo .zip válido. Alguien sabe porque? Prestashop 1.7.4.3

image.png.ebbd1218b5960bc950de11b4e1f0a722.png

Edited by Adrian (see edit history)

Share this post


Link to post
Share on other sites

Descomprime en carpeta, comprime la carpeta redsysoficial en zip y prueba

Share this post


Link to post
Share on other sites

Igual, me sigue saliendo el mensaje

Share this post


Link to post
Share on other sites
13 hours ago, Adrian said:

Igual, me sigue saliendo el mensaje

Hola. Yo al final compré en módulo de pago a los de id_novate que me compensaba en vez de tirarme de los pelos durante horas y horas que el tiempo es money. 

De todas formas, mira tu clave encriptada (clave secreta) en ese campo de configuaración del módulo porque antes las claves eran de 16 cifras y ahora son de 32. Mi banco La Caixa nunca me avisó del cambio y así tuve el problema de fallos en la pasarela. 

Saludos, 
Jeremy..

Share this post


Link to post
Share on other sites

Y si descomprimo la carpeta y la subo a la carpeta módulos mediante ftp?

Share this post


Link to post
Share on other sites

Vale, solucionado. Soy tonto. En lugar de subir el redsys.zip que hay dentro de redsys_prestashop.zip, estaba subiendo el redsys_prestashop.zip directamente y claro, pues no funcionaba xD

Share this post


Link to post
Share on other sites

Hola,

Desde hace unos días los pedidos pagados con tarjeta de crédito a través del TPV Virtual de Redsys no aparecen en los Pedidos de Prestashop (con los de PayPal no hay problema).

Vimos en las notificaciones del TPV Virtual primero lo siguiente:

http://12pulgadasbcn.com/index.php?fc=module&module=redsys&controller=ipn 301

El problema está en que la url de retorno del pago desde Redsys es HTTP y no HTTPS, pero no sé cómo modificarlo.

Encontré en unos artículos de internet que pruebe a desinstalar el módulo de terceros que tenía instalado para Redsys, e instale el módulo gratuito oficial. Hice la prueba con un pago de tarjeta y tampoco funcionó, pero las notificaciones mostraron lo siguiente:

https://12pulgadasbcn.com/index.php?fc=module&module=redsysoficial&controller=validation -1 Server returned HTTP response code: 500 for URL: https://12pulgadasbcn.com/index.php?fc=module&module=redsysoficial&controller=validation

Alguien me podría guiar sobre cómo cambiar esa URL porfa?? Gracias!!

PS: Tengo Prestashop version 1.7.3.2 y Redsys módulo versión 3.0.5

Share this post


Link to post
Share on other sites

Como estás en la versión 3.0.5 de redsys si aun van por la 3.0.2 en la página oficial?

Share this post


Link to post
Share on other sites
Posted (edited)

Hola,

tenia problemas tras actualizar a PS 1.7.6.3

no me mandaba email ni dejaba estado del pedido, a pesar de recibir correctamente el pago...

leyendo la documentacion oficial de Redsys, dicen bien claro, desactivar y BORRAR el módulo anterior, descargar la nueva versión 3.0.4 y reconfigurar...

así lo hice y ahora FUNCIONA todo correctamente!!!

saludos, espero ayudaros, ya perdí unas horas...

 

PS: He observado que lo que cambia internamente es la URL de notificación del pago OK a DOMINIO/index.php?fc=module&module=redsysoficial&controller=validation

 

Cuando antes lo hacía a modules/redsysoficial/validation.php

Por lo que al no recibir el ok desde la pasarela, no cambiaba el estado ni procesaba el pedido, sin mandar el email...

Edited by Siraper777 (see edit history)

Share this post


Link to post
Share on other sites

¿Alguien podría decir como hacer que aparezca un logo VISA/MASTERCARD o similar?

Share this post


Link to post
Share on other sites
hace 20 horas, Aldeag dijo:

¿Alguien podría decir como hacer que aparezca un logo VISA/MASTERCARD o similar?

Donde?

Share this post


Link to post
Share on other sites
hace 18 horas, gusman126 dijo:

Donde?

Perdón. Pienso las cosas y creo que me léen la mente.

Tengo dos métodos de pago. Pago con tarjeta y Paypal. Cuando hago una compra e introduzco los datos de cliente nuevo  o invitado, al ir a la forma de pago me aparecen los dos. Pero el pago con tarjeta es un simple "Pagar con tarjeta" y el de Paypal es más atractivo, con su logo Paypal y además cuando lo seleccionas sale un desplegable indicando las ventajas de Paypal. Mucho más atractivo todo pero menos interesante para mí, pues el banco lleva menos comisión que Paypal.

Y ya puestos me gustaría que apareciera en primer lugar, y en Posiciones, Métodos de Pago, no aparece.

Pues eso, me gustaría que al menos hubiera un logo de tarjetas al lado del "Pago con Tarjeta"

Captura de pantalla 2020-03-21 a las 14.02.50.png

Captura de pantalla 2020-03-21 a las 14.02.37.png

Share this post


Link to post
Share on other sites

Buenas, tengo prestashop 1.7.4.2 y la plantilla warehouse. He probado varias versiones de redsys pero unas me dicen que hay que actualizar y no actualizan,otra la 3.0.6 que no me deja instalarla, me da mensaje servidor codigo 0 , la 3.0.0 me dice que la clave no es correcta y la 3.0.2 me da un warning al entrar en la configuración. Al tener algún modulo de estos instalados,al ir al carrito y llegar a los modos de pago ,no me sale ninguno pero si desactivo el redsys ya si me salen los demás sistemas de pago en el carrito. Estoy un poco desesperado. Muchas gracias.

 

 

Un saludo.

Share this post


Link to post
Share on other sites
On 1/28/2020 at 5:56 PM, Adrian said:

Vale, solucionado. Soy tonto. En lugar de subir el redsys.zip que hay dentro de redsys_prestashop.zip, estaba subiendo el redsys_prestashop.zip directamente y claro, pues no funcionaba xD

me pasa lo mismo, pero dentro de redsys_prestashop.zip se me abren; guia de integración y redsysoficial, esta ultima comprimida en zip, pero no me deja ni arrastrarla y seleccionarla cunado quiero subir un modulo nuevo, el archivo redsys.zip como tal no lo encuentro??

Share this post


Link to post
Share on other sites

Alguien sabe decirme la solucion para el error 500 con el codigo de error de 0180 debido a una operación denegada.

Me devuelve el error adjunto en la imagen. El modulo es el 3.0.6 y mi prestashop es el 1.7.6.4.

No entiendo que con las operaciones aceptadas devuelve correctamente, perro en las denegadas no.

cap.png

Share this post


Link to post
Share on other sites
Posted (edited)

Algo nuevo que me esta pasando con un cliente.

Alguien le esta añadiendo "ceros" a la compra total del pedido, si son 10€, le quiere cobrar 1000?

Solucionado, problema con versión y moneda no leia el EUR

 

Edited by gusman126 (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More