Jump to content
Sign in to follow this  
bork

Categories block only showing categories on the sitemap page?

Recommended Posts

I've recently upgraded to 1.2.2.0 and have noticed a problem that has been introduced.

Although the Categories Block heading is displaying on all pages, it doesn't actually list the categories available. It is showing no categories at all.

The only exception to this rule is on the "sitemap" page, where the Categories Block displays correctly.

http://ukbouldering.com/shop

Does anyone have an ideas about this problem?

Thanks :)

Share this post


Link to post
Share on other sites

1.1.0.1 then to 1.2.1.0 but the same problem was there in 1.2.1.0 as well.

Share this post


Link to post
Share on other sites

what ever you do, make a backup not only for the database but a full backup so you can put things back in case.

have checked the option under preference in the back office (the last one in the bottom of the page to make it compatible with 1.1 themes?
Another suggestion, is to copy the blockcategory module from the installation 1.2.2 over and remove the old one... (make back up before you try anything).

Share this post


Link to post
Share on other sites
have checked the option under preference in the back office (the last one in the bottom of the page to make it compatible with 1.1 themes?


Excellent - that has sorted the problem out; thankyou :)



Why does 1.2 ship with a 1.1 theme? I assumed that the theme would be upgraded along with the rest of the shop software?

Share this post


Link to post
Share on other sites

well no, the 1.2 comes with 1.2 themes, but yours is 1.1 theme which was not compatible.

I am glad that your problem is fixed now.

Share this post


Link to post
Share on other sites
but yours is 1.1 theme which was not compatible.


No it's not, i'm just using the standard theme that is supplied with 1.2.2.

When I upgraded I overwrote my entire installation with the new 1.2.2 files.

I'm not using a custom theme or anything.

Share this post


Link to post
Share on other sites
what ever you do, make a backup not only for the database but a full backup so you can put things back in case.

have checked the option under preference in the back office (the last one in the bottom of the page to make it compatible with 1.1 themes?
Another suggestion, is to copy the blockcategory module from the installation 1.2.2 over and remove the old one... (make back up before you try anything).


Thank you for the tip, it worked for me, I do agree with Bork though, that as I am using the original theme used with PS 1.2, I should not need the compatible option. Anyway, the most important is it works, that's enough for me :)

Share this post


Link to post
Share on other sites

good again that it worked, but did you upgrage from previous versions or it is a fresh install with 1.2.2 theme?
I doubt it.

Share this post


Link to post
Share on other sites

that sounds a bit strange, if it is a fresh install with 1.2.x theme, then you should not have problems..

Share this post


Link to post
Share on other sites

Yesterday, I have downloaded the 1.2 version. I have uploaded it to my site in a separate folder, I have copied the config file accros the new shop and run the upgrade tool. The shop is working fine. I then go into the BO, in "Preference", remove the compatibility option, the category problem comes back. I haven't touched anything on the theme whatsoever. I just went into preference... I guess this is a bug recognising 1.2 theme or with the original theme itself.

I have tried to do a fresh install on a local server, but as I have posted in an other post, I am struggling with the setting up of the server...

Share this post


Link to post
Share on other sites

yes but that means you are doing an upgrade. it is not a complete fresh install. maybe that is why.

Fresh install does not have any issues with categories appart from the category restrictions for groups that does not work as it supposed to and prestateam keep ignoring it.

Share this post


Link to post
Share on other sites

I guess you have a point, I have done a completely new installation of the latest PS, 1.2.3 - are upgrade always so regular ( I have installed 3 in 4 days!). All this to say that it jsut works perfectly and I have no problem with the theme. My bad

Share this post


Link to post
Share on other sites

Sorry I am back. It is not major, but I would like to understand.

I have been tinckering with the BO. Changing the position of the module, removing some and so on. Honestly, nothing else, I haven't touched anything on my theme file. The problem is back! I have moved the category module around through the back office, as it should be done. I have removed some module that I didn't need, could it be linked with another module.

I now have to use the compatibility mode again. To be honest, it doesn't bother me, but I would like to understand why this happens?

Share this post


Link to post
Share on other sites

ok, try this: uninstall and then reinstall the Quick Search module!

Does it still need the compatibility mode on?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More