Jump to content
benja6551

[Résolu] page blanche accès back office après transfert local>seveur

Recommended Posts

Bonsoir,

Après avoir cherché sur tout le forum je n'arrive pas à trouver de solution à mon problème.

Je m'explique :

je souhaite créer une boutique sur le modèle d'une boutique déjà existante est installée chez ovh.

J'ai transféré en local et cela fonctionne sous wamp.

J'ai transféré sur le 2ème hébergeur (one.com) ainsi que les tables (shop, shop_url), j'ai modifié settings.inc avec les nouvelles valeurs de connection.

En final lorsque je tape l'adresse du nouveau site (servant d'essai actuellement) j'ai la page de maintenance, normal.

Par contre quand je veux accéder au back office page blanche.

En lisant les autres tutos j'ai donc fait un nettoyage du cache smarty/cache et smarty/compile, mais rien ne change.

J'ai essayé sur IE et cela m'indique http500 erreur interne au seveur.

Sauriez-vous me dire ce que je dois modifier car je ne sais plus où aller.

Merci d'avance de votre aide

Edited by benja6551 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour Gregory,

Dans defines.inc.php j'ai mis en on.

Ensuite en suivant le lien j'ai fais la modif dans ps_lang.

Le français étant déjà existant je l'ai modifié sur le modèle suivant :

  • id_lang -> 1
  • name -> Français (France)
  • active -> 1
  • iso_code -> fr
  • language_code -> fr
  • date_format_lite -> Y-m-d
  • date_format_full -> Y-m-d H:i:s
  • is_rtl -> 0

En id-lang le fr est en 1 et le en est en 2.

 

Voilà l'erreur qui s'affiche maintenant dans la page blanche :

Parse error: syntax error, unexpected $end, expecting ']' in /customers/e/b/3/liegeois.dk/httpd.www/translations/en/admin.php on line 1822

J'ai activé et désactivé le en mais cela ne change rien ?

 

Cordialement,

JL

Share this post


Link to post
Share on other sites

Bonjour,

 

Désolé je n'ai pas compris pourquoi vous touchez à la base mais comme vous voulez.

/translations/en/admin.php à a priori une erreur de syntaxe dedans. Un retour à la ligne inopportun a priori.

 

Vous pouvez mettre à jour le pack de langue en back office, dans Localisation > Traductions > Import/export de traductions / Mettre à jour une langue. Cela va retelecharger le pack de langue. Sinon les pack sotn telechargeables ici http://www.prestashop.com/fr/traductions.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

Désolé pour moi je n'ai pas du comprendre le message d'erreur que j'ai eu la première fois (avant modifs) :

Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting ']' in /customers/e/b/3/liegeois.dk/httpd.www/translations/fr/admin.php on line 1407

 

J'ai donc remis le ps_lang tel qu'il était et j'ai donc le message identique (ci-dessus).

 

Je ne peux pas accéder au front office, puisque j'ai ce message en page blanche.

 

J'ai fait la modif suite à la consultation de la page suivante :

 

http://doc.prestashop.com/pages/viewpage.action?pageId=15925413

 

Merci d'avance de votre aide,

 

Cordialement,

JL

Share this post


Link to post
Share on other sites

Re-bonjour,

Je viens de changer le fichier admin.php et cela refonctionne à nouveau.

Je vais juste vérifier si cela fonctionne correctement au niveau des traductions.

Merci encore de votre aide

Cordialement,

JL

Share this post


Link to post
Share on other sites

Bonsoir,

Je continue à avoir des pages blanches dans le back office. Je ferme ce post car ce n'est plus le même sujet. Je vais chercher dans le forum sinon j'ouvrirai un nouveau post.

Cordialement,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More