Jump to content
  • 0
theboina

[SOLUCIONADO] Error SQL Link to database cannot be established: SQLSTATE[HY000] [2002]

Question

Al hacer una copia de un prestashop 1.5.4.1 a otro directorio, siguiendo los pasos de Victor Ródenas:

 

http://victor-rodena...-de-prestashop/

 

(cambio de bbdd, credenciales, etc..) obtengo el siguiente error:

 

Link to database cannot be established: SQLSTATE[HY000] [2002] No such file or directory

 

El usuario tiene accesos GRANT ALL y además he probado a enlazar como root de mysql (por si fuesen problemas con ese usuario) con el mismo resultado...

 

¿Alguna idea?

 

 

Gracias!!

Edited by theboina

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Me auto-contesto:

 

El problema viene al utilizar distintas versiones de PHP y al parecer está reconocido para versiones PHP 5.3.x

Se vuelve a dejar la misma versión que la original y ya no da error de conexion a BBDD.

 

Pero... ahora me devuelve una página en blanco.....

Share this post


Link to post
Share on other sites
  • 0

Me auto-contesto:

 

El problema viene al utilizar distintas versiones de PHP y al parecer está reconocido para versiones PHP 5.3.x

Se vuelve a dejar la misma versión que la original y ya no da error de conexion a BBDD.

 

Pero... ahora me devuelve una página en blanco.....

 

Ok.

 

Y ahora con la pantalla en blanco que comentas que te sale, si habilitas el reporte de errores, como comento aqui: http://www.prestashop.com/forums/index.php?/topic/232476-%c2%bfque-hacer-cuando-se-queda-la-pantalla-en-blanco-en-prestashop/ que te error te sale ¿?

Share this post


Link to post
Share on other sites
  • 0

Y me vuelvo a Auto-Responder.

 

Si habilitamos en config/defines.inc.php :

 

define('_PS_MODE_DEV_', false);

 

a

 

 

define('_PS_MODE_DEV_', true);

 

En lugar de la pantalla en blanco nos dice que no puede escribir en el directorio /cache/smarty/compile.....

 

Compruebo que en la web anterior si que tenía dichos permisos, se los doy y ale... a funcionar....

 

Thx!

Share this post


Link to post
Share on other sites
  • 0

Gracias Victor!!

 

nos hemos cruzado los mensajes... ;-)

 

tengo otro post abierto de la configuración de in-transit que no me sustituye las variables. ¿sabes algo de ello?

 

Gracias!

Share this post


Link to post
Share on other sites
  • 0

Y me vuelvo a Auto-Responder.

 

Si habilitamos en config/defines.inc.php :

 

define('_PS_MODE_DEV_', false);

 

a

 

 

define('_PS_MODE_DEV_', true);

 

En lugar de la pantalla en blanco nos dice que no puede escribir en el directorio /cache/smarty/compile.....

 

Compruebo que en la web anterior si que tenía dichos permisos, se los doy y ale... a funcionar....

 

Thx!

 

Ah pues entonces Perfecto !

 

Un placer ayudarte y servirte!

 

Si das el tema como solucionado, edita el titulo del tema, editando el primer mensaje, pulsando en editar, y después en "Usar editor completo", añadiendo la palabra "Solucionado" al titulo, esto ayudara, a mantener una mayor organización en el foro.

 

Un saludo y recuerda que estaremos en el foro, para guiarte por este mundo oscuro y tenebroso.

 

Gracias Victor!!

 

nos hemos cruzado los mensajes... ;-)

 

tengo otro post abierto de la configuración de in-transit que no me sustituye las variables. ¿sabes algo de ello?

 

Gracias!

 

El otro hilo que tienes abierto: http://www.prestashop.com/forums/topic/263909-codigo-de-tracking-en-envios/, es otro hilo, si consigo un hueco me pasare por el tema.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×