Jump to content

Recommended Posts

Bonjour à tous,

 

Je sais que ce post a déjà été vu quelques fois mais je n'arrive pas a trouver de solution à mon problème malgré mes recherches sur ce forum et sur d'autres sites.

 

Je suis sous Prestashop 1.5 et j'ai crée ma boutique en local. Je souhaiterais à présent la mettre en ligne. J'ai donc pris un hébergeur (HostPapa). J'ai transférer tout les fichiers de mon site sur le serveur via FilleZila, j'ai importer ma base de données que j'avais en local en créant une nouvelle base de données. Arrive le moment fatidique où je dois configurer le fichier settings.inc.php. Je crée donc un utilisateur sur ma base de données pour pouvoir rentrer certaines infos dans ce fichier et voilà ce que j'obtiens quand j'essaye de me connecter à ma boutique après avoir réalisé tout cela :

Link to database cannot be established: SQLSTATE[**000] [****] Access denied for user 'bouti***_******'@'localhost' to database 'bouti***_boutique-******'

 

J'ai fais de nombreux essais en changeant des éléments dans settings.inc.php sans aucun résultat. Je vous joint le code de ce fichier

 

<?php
define('_DB_SERVER_', 'localhost');
define('_DB_NAME_', 'bouti***_boutique-*******');	  (j'ai mis le nom de ma base de donnée)
define('_DB_USER_', 'bouti***_******');		(j'ai mis le nom d'utilisateur que j'ai crée)
define('_DB_PASSWD_', 'sh********');	   (j'ai mis le mot de passe du compte utilisateur de ma base de donnée)
define('_DB_PREFIX_', 'ps_');
define('_MYSQL_ENGINE_', 'InnoDB');
define('_PS_CACHING_SYSTEM_', 'CacheMemcache');
define('_PS_CACHE_ENABLED_', '0');
define('_MEDIA_SERVER_1_', '');
define('_MEDIA_SERVER_2_', '');
define('_MEDIA_SERVER_3_', '');
define('_COOKIE_KEY_', ******************************************************');
define('_COOKIE_IV_', 'TO******k');
define('_PS_CREATION_DATE_', '2013-05-07');
define('_PS_VERSION_', '1.5.4.1');
define('_RIJNDAEL_KEY_', 'A**************Qe9xUvxpYBpGT7u2c5a4');
define('_RIJNDAEL_IV_', 'OK*********L3aFDodt2mWA==');

 

Ce que je trouve bizarre, c'est que certaines informations ne sont pas présentes quand on compare ce code avec les codes présents sur différents tutos sur Internet.

 

Je vous remercie d'avance de m'aider à régler ce problème, je ne vois plus quoi faire...

Edited by FifiLaFife (see edit history)

Share this post


Link to post
Share on other sites

Réponse trouvée !

 

Il se trouvait que je n'avais pas associé la nouvelle URL de mon site à PrestaShop via la base de donnée. Il faut donc juste signaler à PrestaShop, par le biais de la base de donnée, que l'URL change.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More