Jump to content
Sign in to follow this  
mademoiselle

[Résolu]Problème après phase 5

Recommended Posts

Bonjour la communauté :)

Pas de réponse, semble-t-il dans le forum sur mon blème...

Je viens de finir l'installation complète et donc de renommer le dossier /admin et supprimer /install...je tombe désormais sur le panneau de connexion à ma boutique presta, etc : ok jusque là...

Mais une fois connecté à mon arrière boutique, tous les onglets "catalogue / commandes / clients / paiements / transports", etc sont bien là mais sans rien dedans !!! Sauf un message indiquant "Onglet inexistant " :bug: :gulp: :grrr:

La version presta "shopée" ;-P est la dernière téléchargeable actuellement, mon hébergeur est Planethoster en mutualisé

Qu'est-ce qui se passe ? Eclairez-moi, pleeaaaaase !!! :blank: :shut:

Merci.

Share this post


Link to post
Share on other sites

Bonjour,

apparement personne ne peut répondre a mon problème...
Je vais donc essayer de réinstaller tout...youpi !
Mais pourriez-vous me dire quels sont les dossiers/fichiers que doit supprimer car il y'en avait avant le transfert ftp mais je ne me souviens plus avec précision lesquels : je copie colle l'arborescence du gestionnaire de fichier dans un message suivant (ça ne rentre pas tout ici ),

Merci d'avance car j'aimerais vraiment réussir à l'installer,
Sidney

Share this post


Link to post
Share on other sites
de toute façon y a rien qui marche


C'est-à-dire ?

Share this post


Link to post
Share on other sites

Bonjour,
Ben que je suis néofite, que ça fait 3 jours que je fait en sorte que l'installe se passe bien en vérifiant 45 fois que tout est bien fait (chmod, php5, etc)...et depuis, comme indiquer dans le premier message de ce fil, ben mon back office est bien là mais désert sous i-e, firefox, chrome...donc c'est forcément de ma faute mais je ne trouve pas de réponse au problème sur le forum donc je vais désinstaller et réinstaller : apparement c'est ce que tout le monde fait quand il n'y a pas de solution...
Et je veux vraiment avoir ma boutique...!!!!
Le front office semble ok, je peux même changer des choses via client ftp...
www.mademoisellesemontre.com

Voilà,
je ne sais pas trop quoi faire d'autre...mais je suis preneuse de conseils...

Merci,
Sidney.

Share this post


Link to post
Share on other sites

Tu essayes d'installer où ? Local ou distant ?

Essaye peut-être de donner des détails.

Share this post


Link to post
Share on other sites
Tu essayes d'installer où ? Local ou distant ?

Essaye peut-être de donner des détails.

Je n'en sais rien....j'ai installer le contenu du dossier prestashop via filezilla dans le www. du gestionnaire de fichier de planethoster (hebergement mutualisé), et ils sont aussi dans public_html, cela permet que ce soit visible du web
J'ai simplement suivi les instructions prestashop lors de l'installation mais suis incapable de dire si c'est en local ou distant...
C'est dans le gestionnaire de fichier que j'ai changer les chmod puis renommer admin et supprimer install après avoir taper l'adresse /boutique/install ...
(J'ai conscience de ce que vaut cette réponse... :shut: )

Share this post


Link to post
Share on other sites

Local = sur ton ordinateur.
Distant = chez un hébergeur.

Personnellement je pense que tu devrais commencer par essayer d'installer Presta en local en utilisant Wamp ou EasyPHP qui regroupent Apache/MySQL/PHP.

Ca te permettra de te familiariser avec le produit plus facilement qu'en devant à chaque fois uploader les fichiers chez ton hébergeur avec tous les problèmes potentiels propres à chaque hébergeur.

Share this post


Link to post
Share on other sites

Personnellement je pense que tu devrais commencer par essayer d'installer Presta en local en utilisant Wamp ou EasyPHP qui regroupent Apache/MySQL/PHP.

Ca te permettra de te familiariser avec le produit plus facilement qu'en devant à chaque fois uploader les fichiers chez ton hébergeur avec tous les problèmes potentiels propres à chaque hébergeur.

Ok, je vais déjà aller dégrossir ce qu'est Wamp et appliquer cette solution.
Dois-je tout de même désinstaller les fichiers présents chez mon hébergeur ?
Y'a-t-il un "bon" tuto sur l'utilisation de Wamp de ta connaissance ? Sinon, je chercherais...

Je donne des nouvelles du résultat dès que c'est fini !
(ou qu'il y'a un nouveau problème... :shut: )

Merci Patric :)

Share this post


Link to post
Share on other sites

Non, tu peux laisser les fichiers chez l'hébergeur, ça devrait pas poser de problème.

Non, pour Wamp je ne connais pas de tuto, mais c'est assez intuitif, tu DL, tu installes, tu vérifies bien que les serveurs MySQL et Apache sont bien démarrés et tu accèdes au serveur local via l'adresse http://127.0.0.1/.

Ensuite tu crées un dossier à la racine de ton serveur, par exemple :
C:\wamp\www\myshop\
tu y copies les fichiers PrestaShop et tu lances l'installation :
http://127.0.0.1/myshop/

Share this post


Link to post
Share on other sites

tu y copies les fichiers PrestaShop et tu lances l'installation :
http://127.0.0.1/myshop/'>http://127.0.0.1/myshop/

Je viens de faire ça et à l'étape 3 de l'install prestashop, je lis :

Configuration de la base de données

Configurez votre base de données en remplissant les champs ci-dessous :

Serveur :localhost

Nom de la base :prestashop

Identifiant :root

Mot de passe :

Le serveur de bases de données n'a pas été trouvé, merci de vérifier vos identifiants ou le nom du serveur.

Dois-je créer au préalable une base de données sur http://127.0.0.1/ via phpmyadmin ?
Dois-je m'inquiéter du message en bas de page de phpmyadmin :
Votre fichier de configuration fait référence à l'utilisateur root sans mot de passe, ce qui correspond à la valeur par défaut de MySQL. Votre serveur MySQL est donc ouvert aux intrusions, et vous devriez corriger ce problème de sécurité.
Aucune création de mot de pass ne m'as été proposer à l'installation de wamp...est-ce "secure" ?
Sinon dois-je (et comment) créer un mot de pass pour wamp ?

Je voudrais éviter de faire une nouvelle boulette...

Merci,
Sidney

Share this post


Link to post
Share on other sites

Oui tu dois créer une base de données auparavant. Mais ce n'est pas le problème. Là il ne trouve pas le serveur pourtant les paramètres ont l'air bon. A moins que Wamp ait ajouté un mot de passe comme pour EasyPHP 3.

Vérifie que ton serveur MySQL est bien démarré.

Share this post


Link to post
Share on other sites


:-)
Youpi !!
:-)

J'ai réussie l'install mais en "distant" finallement, ce que je préfère, mais en reprenant tout de a à z : je donne l'info, si jamais ça peut servir à qlq'un hébergé chez Planethoster :
Mon erreur à été d'installer le contenu du dossier prestashop dans www. et non dans Public_html (www. est relié a public_html éffectivement puisque les dossiers mis là apparaissent bien dans public_html MAIS public_html est celui dans lequel il faut télécharger !!!!)
L'astuce aussi est de changer les chmod via le client ftp filezilla et non du gestionnaire de fichier de l'hébergeur : gain de temps phénoménal !!!!
Attention de bien vérifier l'intégralité du transfert également de tous les dossiers / sous-dossier comme ça semble arriver à pas mal de personne à cause des clients ftp que ce soit dreamweaver ou filezilla...j'ai du m'y reprendre à plusieurs fois aussi...
Attention aussi au mot de pass trop long de la base de donnée... :lol:

Euh ben voilà, je suis contente d'avoir mon backoffice et ma boutique !!! :coolsmile:
...et d'avoir appris des trucs ! :shut: :)
J'espère que ça pourra aider qlq'un !

Merci pour l'aide et les conseils Patric, ça m'aide à me former ;-) :)

*Happy Sidney* :-)

:red: Un dernier truc : je ne sais comment on passe le fil en "Résolu"... :-S

Bon week-end !

Share this post


Link to post
Share on other sites

:red: Un dernier truc : je ne sais comment on passe le fil en "Résolu"... :-S


Mettre [Résolu] au début du titre du topic en éditant ton premier post ! ;-)

Hop ! T'as encore appris un truc ! :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More