Jump to content
jeremiejad

Problème de base de données ?

Recommended Posts

Bonjour,

 

J'essaie de passer mon site en ligne, alors qu'il était en local.

Seulement, je bute à un endroit. J'ai eu beau faire des recherches, je ne trouve pas de solutions.

 

Voilà ou j'en suis :

 

-J'ai copié tous les fichiers et dossiers de prestashop sur l'hébergeur (Olympe Network)

-J'ai exporté la base de données de mon site local

-J'en ai créé une sur l'hébergeur :

captur10.png

 

-Je suis allé modifier le fichier setting.inc.php :

 

<?php
define('_DB_SERVER_', 'sql.olympe.in');
define('_DB_NAME_', '[color=#ff0000][modéré][/color]');
define('_DB_USER_', '[color=#ff0000][modéré][/color]');
define('_DB_PASSWD_', '*********');
define('_DB_PREFIX_', 'spa');
define('_MYSQL_ENGINE_', 'InnoDB');
define('_PS_CACHING_SYSTEM_', 'CacheMemcache');
define('_PS_CACHE_ENABLED_', '0');
define('_MEDIA_SERVER_1_', '');
define('_MEDIA_SERVER_2_', '');
define('_MEDIA_SERVER_3_', '');
define('_COOKIE_KEY_', [color=#ff0000][modéré][/color]');
define('_COOKIE_IV_', 't5uU0epq');
define('_PS_CREATION_DATE_', '2013-07-12');
define('_PS_VERSION_', '1.5.4.1');
define('_RIJNDAEL_KEY_', '[color=#ff0000][modéré][/color]');
define('_RIJNDAEL_IV_', [color=#ff0000][modéré][/color]');

 

-Je suis allé modifier la table "ps_shop_url" :

captur12.png

 

Normalement, tout devrait fonctionner ?

 

Eh bien non, lorsque je vais sur sur mon domaine : http://jeremiejad.olympe.in/, il s'affiche ça :

 

Link to database cannot be established: SQLSTATE[28000] [1045] Access denied for user 'jeremiejad'@'on-002' (using password: YES)

 

J'ai aussi essayé de changer "DB_SERVER" en mettant "localhost" : même chose.

 

Quelqu'un aurait une solution s'il vous plaît ?

Edited by Oron
Modération d'élément à ne pas afficher en public (see edit history)

Share this post


Link to post
Share on other sites

Bonjour

 

D'après le message d'erreur c'est votre accès qui n'est pas juste soit le login ou le mot de passe.

 

Vous avez créer vous même votre base de donnée ?

Share this post


Link to post
Share on other sites

Peut-être avez-vous mal interpréter un caractère mettez en time news roman on vois mieux la différence entre les i majuscule et les l miniscule et les 1 ainsi que les O et les zéro 0.

c'est juste une suggestion.

Share this post


Link to post
Share on other sites

Bonjour

 

Ce qui est sur que c'est un problème de login et mot de passe

Share this post


Link to post
Share on other sites

Si c'est vous qui avez créer la base, il faut peut être que vous rajoutiez l'utilisateur pour cette base.

Votre phpmyadmin peut avoir des identifiants d'accès, mais votre base peut avoir des utilisateurs différents.

A essayer...

 

Sinon, dans le message d'erreur, les guillemets me paraissent bizarre...

Le plus simple reste de contacter Olympe :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More