Jump to content
Sign in to follow this  
Marie

[RESOLU] Upgrade V1.1. => V1.2.1 Panier HS

Recommended Posts

Oups alors ça, c'est curieux.

1. Impossible d'ajouter le bloc panier, ni dans la colonne de droite, ni dans celle de gauche : au mieux il n'apparaît pas, au pire page blanche.

2. Pas de lien sur le "Panier" dans les informations clients.

En clair, le panier se rempli sans souci mais il est impossible d'y accéder.

Help please...

Marie

Share this post


Link to post
Share on other sites

Je précise, le panier ne fonctionne pas sur Firefox mais est ok sur IE !!!

Hey encore plus bizarre, d'habitude c'est FF qui assure bien ;)

Share this post


Link to post
Share on other sites

V1.2.1

Je confirme et j'en profite pour faire un UP.

Je ne peux pas greffer le module Panier :

- Si je le greffe en right column, c'est la colonne et le footer qui disparaissent.

- Si je le greffe en left column, là c'est la mega cata : page blanche, erreur 500 sur IE.

J'ai désactivé le module, réactivé le module. Rien n'y fait.

Si quelqu'un a un idée je prends bien volontiers, ça va faire 8 jours que ma boutique est en carafe et mon banquier va finir par faire la tronche.

Marie

Share this post


Link to post
Share on other sites

Bonjour, as-tu rencontré une erreur pendant la mise à jour?

As-tu bien remis l'ancien fichier de configuration à la place du nouveau lors de l'upload de la nouvelle version de prestashop?

Share this post


Link to post
Share on other sites

Merci Jordison de ton intervention.

Si j'ai rencontré une erreur pendant la mise à jour ? Euh comment dire, j'ai pas mal galéré et je me m'y suis remise à plusieurs fois pour que ça passe.

Au final l'install paraît correcte.

Soit près de 1500 produits et 21000 images, une dizaine de catégories et autant de sous catégories, le tout semble parfaitement relié, ça colle.

Tu parles du setting.inc.php ? oui je l'ai replacé, sans quoi je n'aurais pas récupéré mes produits, clients, etc...

C'est le thème qui pose problème et notamment ce foutu panier (je dirais même carrément le block informations clients "déconnexion, login") qui ne fonctionne pas sur Firefox mais est ok sur IE.

Le reste du thème sera du détail du moment que je peux remettre ma boutique en ligne ;)

Share this post


Link to post
Share on other sites

Hello

De loin comme cela ressemble à une erreur affichée dans la source mais que FF interprète mal et IE correctement.

Pas de migration en local avant mise en ligne ?

Share this post


Link to post
Share on other sites

Non Grégory, upgrade cash sur mon serveur.

Je viens de remettre ma boutique en ligne. Elle est visible ici : http://www.achateconomique.fr

Comment puis-je modifier cette erreur dans la source ?

Share this post


Link to post
Share on other sites

C'est pas très feng Shui l'upgrade sans filet.

Non il faut trouver l'erreur, la source éventuellement brouillée c'est le symptôme, désolé !

Share this post


Link to post
Share on other sites
C'est pas très feng Shui l'upgrade sans filet.

Non il faut trouver l'erreur, la source éventuellement brouillée c'est le symptôme, désolé !


:))))) j'ai tenté la solution suggérée par Alekhine mais bloquée par l'import de ma base sur 1and1 je n'ai pas pu faire autrement.

Crois moi, si j'avais pu j'aurais pris le temps d'upgrader tranquille sur une url à part ou en local.

Je n'ai pas eu vraiment le choix, mais je reste très "japonisante", je l'ai fait façon samouraï sur ce coup ;)

Sérieux, euh oui trouver l'erreur ? Je ne sais même pas par où commencer ?

Share this post


Link to post
Share on other sites

Et bien il faudrait être en mesure d'afficher les éventuelles erreurs php ou smarty ou js et/ou regarder dans la source de la page rendue sans le footer par exemple voir pourquoi le rendu est incomplet ou mal formé avec Firebug.

Déjà passer les affichages des erreurs en prod à 'on' si ce n'est fait. Ligne 4 du fichier config.inc.php de la config.

Share this post


Link to post
Share on other sites

J'ai modifié le config.inc.php, il est sur "on" (ce n'était pas fait).

Bon j'ai l'impression que c'est le header.tpl qui met le bazar.

Je le mets en pj, vous pouvez me dire ce que vous en pensez ?

Marie

headertpl.txt

Share this post


Link to post
Share on other sites

Je me suis dépatouillée avec mon header.tpl.

Presque tout est maintenant rentré dans l'ordre.

Toutefois et c'est la condition indispensable pour que ma boutique fonctionne bien, j'ai complétement désactivé le module "Panier", sans quoi :

Fatal error: Smarty error: [in /homepages/41/d181552722/htdocs/haeco121/modules/blockcart/blockcart.tpl line 44]: syntax error: unrecognized tag 't' (Smarty_Compiler.class.php, line 590) in /homepages/41/d181552722/htdocs/haeco121/tools/smarty/Smarty.class.php on line 1095


Allez je file, je continue à bosser pour remettre mon thème tel qu'il était avant ;)

Marie

Share this post


Link to post
Share on other sites

Mais je n'ai jamais ouvert ce fichier, comment ça se fait ???

Je vais voir... je reviens

Share this post


Link to post
Share on other sites

lol, il y a des "t" partout sur ce fichier !!

exemple :

<!-- MODULE Block cart -->
<div id="cart_block" class="block exclusive">
<h4>
<a href="{$base_dir_ssl}order.php">{l s='Cart' mod='blockcart'}</a>
{if $ajax_allowed}
<span id="block_cart_expand" {if $colapseExpandStatus eq 'expanded'}class="hidden"{/if}> </span>
<span id="block_cart_collapse" {if $colapseExpandStatus eq 'collapsed' || !isset($colapseExpandStatus)}class="hidden"{/if}> </span>
{/if}
</h4>
<div class="block_content">
<!-- block summary -->
<div id="cart_block_summary" class="{if $colapseExpandStatus eq 'expanded' || !$ajax_allowed}collapsed{else}expanded{/if}">
<span class="ajax_cart_quantity">{if $cart_qties > 0}{$cart_qties}{/if}</span>
<span class="ajax_cart_product_txt_s{if $cart_qties < 2} hidden{/if}">{l s='products' mod='blockcart'}</span>
<span class="ajax_cart_product_txt{if $cart_qties != 1} hidden{/if}">{l s='product' mod='blockcart'}</span>
<span class="ajax_cart_total">{if $cart_qties > 0}{if $priceDisplay == 1}{convertPrice price=$cart->getOrderTotal(false)}{else}{convertPrice price=$cart->getOrderTotal(true)}{/if}{/if}</span>
<span class="ajax_cart_no_product">{if $cart_qties == 0}{l s='(empty)' mod='blockcart'}{/if}</span>



et ça sur 122 lignes ! :)))

Je n'ai pas plus vite fait de prendre le blockart.tpl de la V1.2.1 toute vierge planquée dans un coin de mon pc ?

Share this post


Link to post
Share on other sites

A priori votre fichier de config smarty.config.inc.php n'est pas à jour. Il manque un alias de fonction 't' qui a été rajouté pour re coder les truncate de Smarty.

Share this post


Link to post
Share on other sites
:))))))))))))))

Ma boutique en V1.1 était fermée pour cause de panier hs.
Je viens de, courageusement, upgrader en V1.2.1.

Je dors très peu depuis huit jours.

Autant vous dire Grégory que
A priori votre fichier de config smarty.config.inc.php n’est pas à jour. Il manque un alias de fonction ‘t’ qui a été rajouté pour re coder les truncate de Smarty.


m'a fait éclater de rire parce que je suis explosée de fatigue et que je n'y comprend rien.

Je reste de bonne composition donc que dois-je faire pour avoir un Smarty qui va bien ?

Share this post


Link to post
Share on other sites

Eh bien c'est bien là souvent mon problème. J'essaie de temps en temps d'aider quand j'ai des éléments de réponse. Mais si il faut répondre sans rentrer dans le détail....C'est aussi pour le coté didactique bref....

En gros dans le dossier config le fichier smarty.config.inc.php n'est apparemment pas à jour, c'est surement l'ancienne version. Remplacé par le nouveau fichier cela permettrait peut être au bloc panier de retrouver ses petits.

Share this post


Link to post
Share on other sites


Ma boutique en V1.1 était fermée pour cause de panier hs.
Je viens de, courageusement, upgrader en V1.2.1.


Et donc ce n'est pas l'upgrade qui a posé problème si il était déjà hs. Le titre le laissait penser.

Share this post


Link to post
Share on other sites

Mais où êtiez-vous pendant 8 jours ???

Bon sang, d'un coup d'un seul voilà c'est réparé. J'en suis à me demander si ma boutique en V1.1 ne refonctionnerait pas ?

Bravo Grégory, chapeau bas, vous avez toute ma gratitude, mon panier fonctionne !

:kiss:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More