Jump to content

Kloejność wyświetlania slajdów w homeslider


Recommended Posts

Witam,

tak jak w temacie. Używam Prestashop w wersji 1.5.4. Korzystam z domyślnego pluginu ze sliderem zdjęć na stronie głównej, w panelu administracyjnym chciałem zmienić kolejność wyświetlanych slajdów jednak przeciąganie ich nie działa. Czy ktoś miał może taki problem? Jak zmienić kolejność nie wgrywając ponownie wszystkich slajdów?

Share this post


Link to post
Share on other sites

problem może być związany z błędami js (javascript)

o ile to możliwe, włącz proszę konsolę przeglądarki (ctrl+shift+J) w chrome i spróbuj zmienić pozycję slajdu. Obserwuj czy w konsoli nie wyświetlają się żadne błędy. Być może również być tak, że błędy pojawiają się tam zanim spróbujesz zmienić pozycję slajdu.

 

jak coś tam jest nie tak, wklej proszę kod błędu

Share this post


Link to post
Share on other sites

Dzięki za odpowiedź.

Wywala mi następujący błąd:

 

Uncaught TypeError: Object function (e,t){return new v.fn.init(e,t,n)} has no method 'curCSS' jquery.ui.core.min.js:12
a jquery.ui.core.min.js:12
(anonymous function) jquery-1.7.2.min.js:2
v.extend.grep jquery-1.7.2.min.js:2
ft jquery-1.7.2.min.js:2
v.fn.extend.filter jquery-1.7.2.min.js:2
c.fn.extend.scrollParent jquery.ui.core.min.js:12
d.widget._mouseStart jquery-ui.will.be.removed.in.1.6.js:228
c.widget._mouseMove jquery-ui.will.be.removed.in.1.6.js:48
_mouseMoveDelegate jquery-ui.will.be.removed.in.1.6.js:47
v.event.dispatch jquery-1.7.2.min.js:2
o.handle.u

Edited by Filips (see edit history)

Share this post


Link to post
Share on other sites

to może być związane z tym: http://bugs.jquery.com/ticket/11921

z błędy który przytoczyłeś wynika jednak, że korzystasz z wersji 1.7.2 więc problemu nie powinno być. Może się jednak zdarzyć, że masz zainstalowany jakiś moduł, który wykorzystuje najnowszą bibliotekę jquery i nadpisuje 1.7.2 (najprościej rzecz ujmując efekt jest taki, że wykorzystywana jest wersja nowsza)

 

Masz jakieś moduły zainstalowane (z tych niestandardowych) które mogą wykorzystywać tę nową bibliotekę?

Share this post


Link to post
Share on other sites

To ja musiałem wprowadzić ten chaos :). Podczas kodowania szablonu nadpisałem wersję jquery bo była mi do czegoś potrzebna nowa i później zapomniałem ją zmienić na starszą.

Share this post


Link to post
Share on other sites

 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More