Jump to content

Recommended Posts

Beste PS mensen,

Een tijde terug had ik in m'n theme, thr00027r, de top layout aangepast, global.css en enkele bloks.

Dit heeft een hele poos keurig blijven werken, totdat ik gisteren merkte dat de layout door elkaar stond.

Diep zuchtend opnieuw de layout aangepast van het betreffende theme.

 

Als weinig inzicht hebbende van de werking van PS, dacht ik dat de instellingen bij bv een module update van PS, de theme layout er ook door aangepast worden..

 

Wat betreft de map override.

Is het de bedoeling dat je hier bv de aangepaste files van je theme plaatst?

 

Mvg,

Generaal

Share this post


Link to post
Share on other sites

Beste PS mensen,

Een tijde terug had ik in m'n theme, thr00027r, de top layout aangepast, global.css en enkele bloks.

Dit heeft een hele poos keurig blijven werken, totdat ik gisteren merkte dat de layout door elkaar stond.

Diep zuchtend opnieuw de layout aangepast van het betreffende theme.

 

Als weinig inzicht hebbende van de werking van PS, dacht ik dat de instellingen bij bv een module update van PS, de theme layout er ook door aangepast worden..

 

Wat betreft de map override.

Is het de bedoeling dat je hier bv de aangepaste files van je theme plaatst?

 

Mvg,

Generaal

Nee, de override folder is enkel voor Core script files zoals de classes en controllers.

Overrides op bijvoorbeeld css en template files van modules zet je in de /themes/thr00027r/modules (voor templates en js) en /themes/thr00027r/css/modules (voor css)

Share this post


Link to post
Share on other sites

Beste scorpionsworld,

zo heb ik het ook gedaan, enkel de files aangepast die in het theme zaten.

Ondertussen nog maar wat stoeien met de layout, zodat die weer terug op punt staat.

 

MVG,

Generaal

Share this post


Link to post
Share on other sites

Beste scorpionsworld,

zo heb ik het ook gedaan, enkel de files aangepast die in het theme zaten.

Ondertussen nog maar wat stoeien met de layout, zodat die weer terug op punt staat.

 

MVG,

Generaal

Dan zou de layout ook niet door elkaar mogen geraken tenzij er iets gewijzigd is.

Share this post


Link to post
Share on other sites

Beste scorpionworld,

Ik vermoed dat er een of andere geïnstalleerde module dit veroorzaakt heeft.

Zoals ik al in 'n ander topic schreef, zit er iets niet goed met de zoekbalk, als ik deze uitschakel, zit m'n layout weer goed, heb de module en de betreffende mappen al eens verwijderd en de mappen van de PS install configuratie terug gezet, maar het blijft ergens fout zitten.

Als ik bij Google dev tools kijk, zie ik wel een fout staan: GET http://mijn website.be/font.swf 404 ( Not Found) of dit de oorzaak kan zijn, weet ik niet.

Heb hiervoor al via Google gezocht:

www.google.com/fonts/

www.templatemonster.com/help/prestashop-how-to-change-a-Google-web-font.html

 

Het probleem hier is, dat ik nog niet de juiste omschrijving van dit aangeroepen fonts ken, de info die ik via Google dev zie is niet voldoende.

 

Verder merk ik dat het verdomd moeilijk is om de juiste file te vinden in dev tools, om de gevonden zaken aan te passen, in dev tools heb ik de instellingen wel snel gevonden, en het leuke is, dat deze dan verwijst naar een cache bestand met het leuke achtervoegsel: all.css. Natuurlijk maak ik de cache map van het betreffende theme leeg, maar hij maakt meteen 'n nieuwe aan.

Dus deze file bv gaan opslaan na veranderingen in dev tools en dan uploaden heeft geen zin.

Uit die cache file raak je het spoor helemaal bijster!

Dus het blijft ff zoeken naar de juiste css file.

 

Maar nogmaals, ik zal nog steeds niet voldoende doorzicht hebben in de structuur.

 

Mvg,

Generaal

Share this post


Link to post
Share on other sites

Beste scorpionworld,

Ik vermoed dat er een of andere geïnstalleerde module dit veroorzaakt heeft.

Zoals ik al in 'n ander topic schreef, zit er iets niet goed met de zoekbalk, als ik deze uitschakel, zit m'n layout weer goed, heb de module en de betreffende mappen al eens verwijderd en de mappen van de PS install configuratie terug gezet, maar het blijft ergens fout zitten.

Als ik bij Google dev tools kijk, zie ik wel een fout staan: GET http://mijn website.be/font.swf 404 ( Not Found) of dit de oorzaak kan zijn, weet ik niet.

Heb hiervoor al via Google gezocht:

www.google.com/fonts/

www.templatemonster.com/help/prestashop-how-to-change-a-Google-web-font.html

 

Het probleem hier is, dat ik nog niet de juiste omschrijving van dit aangeroepen fonts ken, de info die ik via Google dev zie is niet voldoende.

 

Verder merk ik dat het verdomd moeilijk is om de juiste file te vinden in dev tools, om de gevonden zaken aan te passen, in dev tools heb ik de instellingen wel snel gevonden, en het leuke is, dat deze dan verwijst naar een cache bestand met het leuke achtervoegsel: all.css. Natuurlijk maak ik de cache map van het betreffende theme leeg, maar hij maakt meteen 'n nieuwe aan.

Dus deze file bv gaan opslaan na veranderingen in dev tools en dan uploaden heeft geen zin.

Uit die cache file raak je het spoor helemaal bijster!

Dus het blijft ff zoeken naar de juiste css file.

 

Maar nogmaals, ik zal nog steeds niet voldoende doorzicht hebben in de structuur.

 

Mvg,

Generaal

Om de fout te achterhalen is het wellicht even handig de CCC optie in Performance even uit te schakelen, dan blijven de CSS bestanden even gescheiden en worden niet gecombineerd in de all.css.

Share this post


Link to post
Share on other sites

Bedankt voor de tip, scorpionworld.

Ik heb intussen al alle hoeken van het schem gezien!

 

Mvg,

Generaal

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More