Jump to content

Blok kontaktu


Recommended Posts

Witam mam problem z blokiem kontaktu.

Mianowicie na wszystkich stronach sklepu wyświetla się dobrze tj. nr tel i e-mail, a na stronie produktowej zamiast adresu e-mail jest jedynka a nr tel. już dobrze się wyświetla.

 

Czy jest mi w stanie ktoś pomóc.

Share this post


Link to post
Share on other sites

sprawa może być powiązana z:

  1. cache sklepu, jeżeli jest taka możliwośc - wyczyśc cache sklepu.
  2. modyfikacjami wykonanymi dla kontrolera products i/lub z modyfikacjami pliku product.tpl

 

ps korzystasz z defaultowego template? czy może jakieś niestandardowe rozwiązanie?

Share this post


Link to post
Share on other sites

cache wyczyszczony,

Pliki podmieniłem na orginalne, bo na localhoscie dział wszystko dobrze a w sieci już nie,

podminiłem tylko pliki product.tpl i ProductController lecz nadal nic nie daje, zastanawiam się czy nie przekopiować wszystkich plików z localhosta na serwer, tylko czy mi się nic nie rozsypie?

Share this post


Link to post
Share on other sites

moduł o ktorym mowa wykorzystuje zmienną:

{$telnumber} do prezentacji numeru

 

z tego co mówisz, wynika, że coś nadpisuje tą zmienną na stronie produktów, może to być jakiś moduł dostępny wyłącznie na tej stronie. Jeżeli jest tak jak mówię, można to obejść. otwórz plik blockcontact.tpl zlokalizowany w katalogu z modułem (jeżeli masz go w themes/default/modules/blockcontact/ to zmiany wstaw tam)

 

to co musisz zrobić to podmienić:

{$telnumber|escape:'htmlall':'UTF-8'}

na

{Configuration::get('blockcontact_telnumber')}

 

daj znać czy cokolwiek się zmieniło (nie zapomnij włączyć wymuszenia kompilacji w preferences > performance)

 

jeżeli nie, to problem jest gdzieś indziej

Share this post


Link to post
Share on other sites

zatem przepraszam za pomyłkę, nie zwróciłem dokładnie uwagi o czym piszesz.

Wszystko co mówiłem jest nadal aktualne, ale dotyczy zmiennej {$email}

 

zatem otwórz ten sam plik i zamień :

{$email|escape:'htmlall':'UTF-8'}

na

{Configuration::get('blockcontact_email')}

Share this post


Link to post
Share on other sites

Małe szczegóły jak np: na karcie produktu kolor fontu ile szt. dostępnych jest i breadcrumb (nie patrzyłem czy na wszystkich stronach) oraz napis netto w Ilość zamawianych par,

ale już sobie pozmieniałem, nie wiem czemu ale wcześniej było białe zmieniło się na szare ale znów zmieniłem na białe.

 

Może to być też to że podmianiałem wcześniej pliki na orginalne i może dopiero potem się pozmieniały kolory po paru odświeżeniach.

Share this post


Link to post
Share on other sites

najwazniejsze, że problem rozwiązany. jakiś moduł musi nadpisywać tę zmienną, trudno powiedzieć jaki nie mając dostępu do sklepu, nie ma co drążyć tematu ;P chyba, że chcesz ;)

Share this post


Link to post
Share on other sites

No najważniejsze że działa dobrze jeszcze raz dzięki za pomoc,

a drążyć na razie nie ma co szykuje się na wyjazd,

aczkolwiek troche dziwne bo na localhoscie działało bez problemu.

Share this post


Link to post
Share on other sites

 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More