Jump to content
Sign in to follow this  
Bgiv

[Résolu]Trouve pas le fichier htaccess

Recommended Posts

Bonjour à tous,

Je viens de télécharger la dernière version de ps, mais des la page install j'ai le fameux message :
install/classes/LanguagesManager.php on line 7

j'ai vu sur le forum qu'il fallait modifier le fichier "htaccess" dans le dossier install mais je ne le trouve pas.

Pouvez-me venir en aide pour le trouver ou comment en créer un.
De plus comment le configurer pour php5 en sachant que mon hébergeur est serieone.

Merci d'avance de votre aide
;-)

Share this post


Link to post
Share on other sites

y'en a plus ! il faut le generer dans le BO de la boutique

Share this post


Link to post
Share on other sites

Merci pour ce début de réponse mais pourriez-vous m'expliquer un peu plus en détail, je suis novice, je viens de creload oscommerce et j'aimerai faire mon sie avec ps.

Share this post


Link to post
Share on other sites

Hop ! et bienvenue ! ;-)
Panneau d'administration >> Outils >> Générateurs

Share this post


Link to post
Share on other sites

Bonsoir,

Oui mais avant de pouvoir aller au menu admin faut-il que je puise installer PS et je suis toujours bloqué au tout début de l'install avec le message d'erreur :install/classes/LanguagesManager.php on line 7

Pourriez-vous m'expliquer en détail où trouver le fichier htaccess et comment le figurer pour mon hébergeur serieone qui utilise pas php5 mais PHP 4.3.3 et Mysql 4.0.15.

Je vous remercie d'avance ;-)

Share this post


Link to post
Share on other sites

Pour la façon d'activer PHP5 chez ton hébergeur, essaye une recherche sur le forum ou sur le Web ou demande à ton hébergeur.

Si ça passe par un fichier .htaccess, tu dois simplement le créer à la main.

Share this post


Link to post
Share on other sites

Bonjour à tous les membres de Prestashop,

Après 24 heures de tentatives pour tenter d'installer PS je jette l'éponge car je suis toujours bloqué au tout début de l'install. Je vais retourner avec regret à oscommerce que je maitrise nettement mieux. Merci à Patric et Jolvil d'avoir essayé de m'aider, mais je ne dois pas être doué. J'aurai vraiment aimé utiliser Prestashop qui d'après la démo me semble vraiment une réussite, félicitations aux développeurs !

Share this post


Link to post
Share on other sites

l'installation est une des plus facile qui existe, il cependant que l'hebergeur propose le php5.
Celui ci peut etre appellé par une ligne de code dans le .htaccess, le code peut etre different selon l'hebergeur.
En général cela ne pose pas de probleme, il faut contacter l'hebergeur au sujet de php5 ou changer d'hebergeur.

Share this post


Link to post
Share on other sites

Merci Jolvil pour cette réponse rapide j'ai créé un fichier HTACCESS que j'ai mis dans le dossier install de PS et quand je fais "monsite/install cela me crée un fichier install que dois je faire de ce dossier et est-ce que le fichier HTACCESS que j'ai crée dois-je bien le mettre dans le dossier install de PS ? Sinon quel hébergeur me conseillez-vous pour que je puisse utiliser PS sans souci ? Par avance merci

Share this post


Link to post
Share on other sites

Tu veux pas faire un essai d'install en local plutôt que de te prendre la tête avec un hébergeur (transferts de fichiers, spécificités propres à chacun, etc.) ?

Share this post


Link to post
Share on other sites

Patric, je te remercie pour ce conseil et je vais donc tenter d'installer PS en local en utilisant easyphp1.7, ensuite il faudra que je trouve un hébergeur acceptant le php5.

Share this post


Link to post
Share on other sites

Heu, avec EasyPHP 1.7 je pense que tu n'iras pas bien plus loin, je doute (de mémoire) qu'il propose PHP5. Il me semble que la première version qui la proposait était la 2.0, mais je peux me tromper. Vérifie avant dans le panneau d'admin.

Share this post


Link to post
Share on other sites

Suis-je sur la bonne direction ??? Je reprends espoir !!!

Dans install de PS j'ai créé un fichier htaccess et dans celui-ci j'ai mis la ligne de code : AddHandler php-fastcgi5 .php
(il n'y a pas d'autres ligne de code dans mon fichier htaccess) ensuite j'ai fais monsite/install et là j'ai un écran fond rouge (je pense que c'est le menu d'install de PS) avec tout en haut ceci : getIncludeTradFilename()) include_once($lm->getIncludeTradFilename()); ?>

sur le menu PS fond rouge il y a un rectangle blanc voilà !! Est-ce que c'est un début de solution à mon problème ou ais-je oublier une ligne de code ? car je suis bloqué à ce niveau

Rappel mon hébergeur est serieone

Merci d'avance !

Share this post


Link to post
Share on other sites

je progresse !!! j'ai réussi (enfin) à entrer dans le menu install mais je suis bloqué au niveau du test sql de la configuration de la base j'ai ce message :

"Le serveur de bases de données est disponible mais la base de données n'a pas été trouvée"

J'ai bien indiqué le nom de ma base le mot de passe et l'utilisateur et à serveur j'ai mis localhost
où est mon erreur merci d'avance

Share this post


Link to post
Share on other sites

Tout semble bien fonctionner, cela venait de mon hébergeur qui ne prenait pas le php5. Merci encore à Patric et Jovil. Conclusion je ne regrette pas d'avoir persévéré car vraiment j'ai failli abandonner !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More