Jump to content

Bug Chiffre d'affaire compté en double


Recommended Posts

Je ne comprends pas sur les satistiques de la page d'accueils et certaines fiches clients le montant du chiffre d'affaire est le double que celuis vraiment réalisé.

 

Exemple j'ai eu une commande aujourd'hui d'un montant de :

j7ey.jpg

 

Mais sur les satistiques affiché, cela indique le double :

 

qyjg.jpg

 

Quelqu'un aurait il une idée de ce qu'il se passe ?

Share this post


Link to post
Share on other sites

Bonjour,

 

Quelle version vous utilisez ? Je ne reproduis pas sur la 1.5.4.1.

 

Cordialement

 

Je n'ai pas compris votre phrase.

 

Je suis sur 1.5.4.1

 

Je suis le seul au monde avec ce problème ?

Share this post


Link to post
Share on other sites

Exemple un nouveau client passe commande d'une commande de 42€ dans son fichier client il y a marqué:

"total payé depuis la création du compte 84€"

 

Je sais pas d’où ça vient, mon webmaster est perdu, je sais pas trop quoi faire.

Share this post


Link to post
Share on other sites

J'ai cherché sur les forums pas de réponse

J'ai posté un topic pas de réponse

J'ai écris 4 fois a Préstashop, pas de réponse

 

A part si je prends un ticket a 100€ j'ai pas l’impression que quelqu'un va m'aider.

 

Appel d'offre donc, qui veut combien pour trouver l'erreur ?

Share this post


Link to post
Share on other sites

Bonjour,

J'ai aussi le même problème sur PS 1.5.4.1

 

Bonjour,

 

Pouvez vous me faire des accès back office temporaire par mail svp ?

 

Peut être ce fix ? https://github.com/PrestaShop/PrestaShop/commit/82c7e3eeff78f01f05d897029730f045c7a943ae

 

Merci. Cordialement.

Edited by Gregory Roussac (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Le CA est double dans la base de données pour cette commande (total_paid_real est doublé). Cette ligne est insérée par le module de paiement.

 

C'est le module Paypal à priori pour cette commande, y'a t'il le cas sur un autre type de paiement ?

 

La version utilisée est 3.4.5, la dernière version à jour est 3.5.5.

 

Je suis désolé ce n’est pas un problème du cœur de PrestaShop mais d'un module Partenaire. Je vous invite à installer la dernière version depuis le back office et je déplace votre sujet dans la partie Paypal.

 

Cordialement

Share this post


Link to post
Share on other sites

Bonjour,

 

C'est quelqu'un de chez Paypal qui m'a dit d'utiliser ce module car votre module a jour provoque sans cesse des problèmes d'appel API.

Je me retrouve avec de l'argent dans mon Paypal mais pas de commande sur le back office.

Depuis que j'ai remis cet ancien module je n'ai plus de problème.

 

Mon problème de CA doublé par client est valalble avec tout les clients qu'ils utilise Paypal, Hipay, Chèque ou Virement, le probleme ne vient donc pas de Paypal.

 

ps: merci d'attendre une confirmation avant de déplacer le topic ailleur.

Je vais surement recréer le meme topic ou il etait avant donc.

 

Merci pour votre aide

 

Je suis toujours au point de départ.

  • Like 1

Share this post


Link to post
Share on other sites

Rebonjour,

 

Dans la classe Order, je n'ai pas le meme code que les sources de PrestaShop.

 

La fonction generateReference a été modifiée par rapport à l'original par exemple. Vous avez fait des modifications à même le cœur ? Les références de commandes sont alphabétiques dans PrestaShop et non numériques comme chez vous, et il y a des vérifications qui sont faites lors des paiements sur cette référence. La table ps_order_payement a systématiquement un doublon, avec une référence numérique qui ne correspond à rien, d’où le chiffre doublé.

 

Il y a eu des modifications hasardeuses sur votre PrestaShop. Je ne peux pas prendre en charge le debug de celles-ci.

 

Bien cordialement !

Share this post


Link to post
Share on other sites

  • 2 months later...

En tout cas ils sont sympa chez Prestashop - 5 mails 0 réponse.

Ca donne envie !

 

....

 

ps: merci d'attendre une confirmation avant de déplacer le topic ailleur.

Je vais surement recréer le meme topic ou il etait avant donc.

 

Je suis toujours au point de départ.

 

Est ce que ce post est résolu ?

 

Cordialement

Share this post


Link to post
Share on other sites

  • 1 year later...

Bonjour 

Je profite de ce forum pour relancer ... car je rencontre un probleme quasi similaire sur une V1.6.11 ( mise a jour depuis 1.3) ici :

www.lentrepot-du-chauffage.com

Dans le back office après chaque changement de status d'une commande le montant du CA est cumulé et affiche une alerte !

dans tous les modes de paiement ...
Bien sur les stats sont faussées ... etc

Si quelqu'un a une idée pour résoudre ..
 

Merci

Share this post


Link to post
Share on other sites

OUPS !!! Merci

Oui effectivement les factures étaient desactivées .... :(

 

comprends pas pourquoi car j'avais bien contrôlé ... peut etre pas enregistré ... du coup j'ai une dizaine non générées .. .comment les générer ?

Share this post


Link to post
Share on other sites

Quiproquo, ce bug était reproduit quand les factures sont desactivées. Je voulais juste voir si c'etait bien la meme description que le bug http://forge.prestashop.com/browse/PSCSX-4331 et il me semble que ça l'est.

 

Il faut essayer de les repasser à nouveau dans un statut qui à une facture associée mais je ne suis pas sur que cela marche.

 

Cordialement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More