Jump to content

Hiba telepítés közben


katalin89
 Share

Recommended Posts

Sziasztok!

 

A segítségeteket szeretném kérni.

Már egy ideje nem jelenik meg a honlap, ahová a boltomat telepítettem. Arra gyanakodtam, hogy a szolgáltatóval van valami és idővel helyre jön, de nem jött helyre. Elmentettem az adatbázist, majd kitöröltem mindent és megpróbáltam újratelepíteni azt a verziót. A telepítés során azt írta ki, hogy a nyelvet nem tudta telepíteni, vagy ilyesmi. Hiába próbálta akármit, nem sikerült a telepítés.

Ezek után regisztráltam egy másik tárhelyre (hátha mégis a tárhellyel van a gond), de ugyanez volt a probléma. Aztán egy későbbi verziót próbáltam telepíteni. Telepítés közben nem jelzett semmi hibát a telepítő, viszont amikor meg akarom nyitni az oldalt, akkor ugyanaz a hiba jelenik meg, mint az elején a másik tárhelyen (amikor nem jelent meg a boltom).

 

"A webhely problémába ütközött a(z) http://xyz.com/ http://xyz.com/ lekérése során. Lehetséges, hogy karbantartás miatt nem működik, vagy helytelenül van konfigurálva."

500 HTTP hiba (Internal Server Error): Váratlan feltétel merült fel, miközben a szerver megpróbált eleget tenni a kérésnek.

 

Mi lehet a gond? Miért nem jelenik meg a boltom egyik tárhelyen sem? Vagy miért nem engedi, hogy egy újabb verziós PrestaShop-ot telepítsek??

 

Jelenleg az 1.4.7.3-as verzió van fent.

 

Ha valaki tud, kérem segítsen!

Share this post


Link to post
Share on other sites

Szerintem nem lesz itt nagy gond. Talán valamelyik modul.

Ki kell deríteni!

Ha 1.4.x-es a motorod, akkor így kapcsoljuk be a developer/fejlesztő módot (hogy lássuk mi is a hiba pontosan, ki okozza):

 

config/config.inc.php-ben az @ini_set('display_errors', 'off'); => sornál kell “on“-ra tenni, így:

@ini_set('display_errors', 'on');

 

Ha ezt megcsináltad, hívd be újra a shopodat és látni fogod mi a pontos hibaüzenet. Ez alapján már ki tudjuk deríteni ki a ludas.

Share this post


Link to post
Share on other sites

Most ezt a hibaüzenetet írja ki:

Fatal error: Access to undeclared static property: Smarty::$_CHARSET in /srv/disk3/1442533/www/unnie.co.nf/tools/smarty/plugins/modifiercompiler.escape.php on line 30

Share this post


Link to post
Share on other sites

Sajnos ez nem sokat segít rajtam, mivel nem tudok belépni az admin felületre. Vagy lehet, hogy mégsem fejeződött be akkor rendesen a telepítés? Amikor be akarok lépni az admin email címmel és jelszóval, akkor azt írja, hogy nincsen olyan felhasználó.

 

Ha esetleg az újabb verzió telepítési hibájában tudnál segíteni, az is jó lenne. Próbáltam azt, amit az angol fórumokon írnak, hogy hosszú prefixet adok meg (vagy a ps_-től eltérőt) de ez nem oldotta meg a problémát :(

Share this post


Link to post
Share on other sites

Öööö...

 

Kanyarodjunk vissza egy percre.

Volt egy telepítésed. Ezzel mit is csináltál mielőtt teljesen törölted?

Lementetted ugye? És remélem hogy nem csak az adatbázist mentetted le hanem a fájlokat is... ugye?

 

Ha csak az adatbázist mentetted le, de a fájlokat nem az nem túl jó. A kettőt egyszerre kell menteni.

 

Új telepítéséhez nem tudnál létrehozni inkább egy másik adatbázist és azt felhasználni?

Share this post


Link to post
Share on other sites

Sajnos csak az adatbázist mentettem el :( az eszembe sem jutott, hogy esetleg a fájolkat is kellene, pedig hát gondolhattam volna rá... Az új telepítésnél pedig nem a régi adatbázist használom, mert előbb azt akarom látni, hogy így simán hogyan működik. Az sem lenne baj, ha nem használhatnám a régi adatbázist, csak már valahogy működjön ez az egész :S

Share this post


Link to post
Share on other sites

Értem.

Akkor először is a legfrissebb Prestashop motorral próbálkozz.

Másodszor hozz létre egy új adatbázist és abba próbáld meg telepíteni a shopot.

Ha béreltél máshol is (és ott ugye nem sikerült) akkor törölj onnan mindent (fájlok + adatbázis) és próbáld meg oda feltelepíteni.

Ha elakadsz valahol akkor print screen-eld le, vagy írd fel a pontos hibaüzenetet és akkor azon már tovább tudunk lépni.

  • Like 1

Share this post


Link to post
Share on other sites

  • 1 month later...

Értem.

Akkor először is a legfrissebb Prestashop motorral próbálkozz.

Másodszor hozz létre egy új adatbázist és abba próbáld meg telepíteni a shopot.

Ha béreltél máshol is (és ott ugye nem sikerült) akkor törölj onnan mindent (fájlok + adatbázis) és próbáld meg oda feltelepíteni.

Ha elakadsz valahol akkor print screen-eld le, vagy írd fel a pontos hibaüzenetet és akkor azon már tovább tudunk lépni.

 

Szia, nekem is meggyűlt a bajom a telepítéssel... Feltöltöm, kicsomagalom a tárhelyen, aldomain alatt indítom a telepítőt. És IGEN, indul. bejön az első slide, English nyelven hagyom és rányomok a NEXT gombra és kész. Ezt kapom:

 

"Not Found

The requested URL /presta/install/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

 

Próbáltam máshogy:

 

- más nyelvvel

- más subdomain alól

- gépen kicsomagolva

- tárhelyen kicsomagolva

- kávé előtt és kávé után

- WAMP, ott indul, ott adatbázist nem tudok alkotni, mert új WAMP-ot szedtem le és nem enged be phpmyadmin alá. :)

- egyébként 1.5.4.1. ver.

 

Köszönöm a segítségedet, mert nagyon ígéretesnek tartom egyébként a PrestShop-ot és inkább én ezt használnám, mint egy free CMS alatt futó webshop plugin-t.

 

Köszi,

 

Bagoly

Share this post


Link to post
Share on other sites

Kedves Bagoly,

 

a subdomain lesz a gondja. Wamp-ot dobd ki, tölts le xampp-ot, ott jó lesz.

telepítsd fel, ha localhost alatt így jó akkor költöztesd át subdomain alá.

 

A szerveren nincs lehetőség rendes domain alá telepíteni?

Ha ott akarod mindenképp végezni és nincs lehetőséged rendes domain alá telepíteni akkor próbáld meg egy mappába telepíteni, miután telepítetted azt a mappát CPANEL-en (szolgáltatófüggő) állítsd be subdomain-nek.

Tehát először a mappát csinálod meg és aztán alakítod át subdomain-né.

Share this post


Link to post
Share on other sites

  • 2 years later...

Sziasztok,

 

Nekem a következő adatbázis hibám van és nem tudom mi lehet az oka mikor a jelszót és a felh.nevet is jól írtam be. Még teljesen Prestashop kezdő vagyok. :)

Xampp programot használom és annak az adatbázis kezelőjét. Köszönöm szépen választ.

 

Hiba üzi:

 

Link to database cannot be established: SQLSTATE[28000] [1045] Access denied for user 'megfejtes'@'localhost' (using password: YES)

Share this post


Link to post
Share on other sites

biztos, hogy a jó felhasználónevet, jelszót és adatbázisnevet adtad meg? a host is jó (localhost)?

 

Esetleg lehet, hogy portszámot is meg kell adnod.

 

Ha xampp-ozol akkor megmondhatod az adatokat.

Share this post


Link to post
Share on other sites

  • 4 months later...

Sziasztok!

 

A következő gondom van:

 

Évek óta működik egy boltom1.3.... valami verzióval.

 

Korábban -kb. egy éve már- feltettem egy új verziót egy külön mappába egy külön adatbázissal. (azt hiszem 1.5 valami volt, mindegy)

A mappa neve new volt.

 

Mindkét bolt ment párhuzamosan. boltom/hu és boltom.hu/new. A new végződés csak teszt üzem volt, lássam hogyan működik a másik motor.

 

Aztán később ezt a new mappát és a hozzá tartozó adatbázist töröltem.

 

A régi bolt remekül működött a mai napig.

 

 

Mindeközben egy második tárhelyen feltettem az 1.6.1.5 verziót és elkezdtem kialakítani egy új szisztéma szerint az új shopot.

Mikor ezzel pár napja végeztem, letöltöttem minden file-t és az adatbázist is.

 

Feltöltöttem mindent a régi tárhelyemre, és meglepetésként most minden hivatkozásom duplán van meg, és így néz ki: boltom.hu/boltom.hu/new.

Fogalmam sincs hol keressem a hibát, a .htaccess is ki van cserélve, át van írva.

 

Mindeközben egy harmadik tárhelyre feltöltöttem a teljes új boltot (1.6.1.5) és ott minden remekül muzsikál. Tehát a 2. fejlesztői és 3. teszt tárhely OK (mind más-más domain)

 

Csak a lényeg, az egyes nem megy.

Mi lehet ez a dupla hivatkozás? 

Van tippetek hol keressem a hibát?

Share this post


Link to post
Share on other sites

  • 1 month later...

Sziasztok!

 

Első alkalommal telepítenék Prestashop-ot. (1.6.1.7 verzió) A Telepítési Asszisztenssel eljutottam az utolsó lépésig, a Bolt telepítésig. A "settings.inc fájl létrehozása" OK, "Adatbázis táblák létrehozása OK", majd az hibával leáll az  "Alapértelmezett bolt és nyelv létrehozása" közben a "Magyar (Hungarian)" nyelv telepítése sikertelen jelzéssel.

Próbáltam újra indítani, úgy is hogy az adatbázis táblákat töröltem, de mindig ugyanúgy történik.

 

Hogyan tovább?

 

Segítséget előre is köszönöm,
József

Share this post


Link to post
Share on other sites

:(
Akkor még csak egy véleményt/javaslatot szeretnék kérni. A domaint az itthoni 3in1 Hosting-nál (megacp.com) intéztem. A tárhelyet is előfizetném náluk. A kínálatukban van Interworx és Cpanel tárhely. Melyiket válasszam, hogy a PS hibátlaul működjön?

A másik kérdésem pedig a tárhely méretére vonatkozik. A PS-ben idővel kb 2-300 termékem lesz. Ennek mekkora tárhely kell?
(500 M, 1500 Mb vagy inkább 3 Gb -ra lesz szükségem?)

 

De ha van más javaslat a tárhelyre vonatkozóan (akár saját érdekeltségű is), szívesen veszem.

Share this post


Link to post
Share on other sites

Bármit, csak ne a 3in1-et. Sokáig lehetne mesélni róluk de nem akarok sarat dobálni. Bárki mást csak ne őket. Iszonyat ami ott megy. Nincs még egy ilyen trehány szolgáltató mint Ők, ennek tetejébe pedig úgy fognak beszélni Veled mint egy utolsó kapcaronggyal. 

 

A saját szolgáltatásunk a PrestawebSpace, de mi magasabb színvonalú szolgáltatást nyújtunk a magyar átlagnál nagyobb shopoknak, árban lehet Neked sok kicsit. Minden hozzászólásom alján ott a link, ha érdekel.

 

Ezen kívül ha olcsót keresel akkor jó lehet a médiacenter vagy a tarhely.eu.

 

2-300 termékhez általában elég szokott lenni 3 GB, de ha egy termékhez több képed van mint 1 akkor lehet, hogy kevés. PS-nek ne válassz 500 mb-ot de még 1,5 gb-osat se, mert hamar betelhet.

Share this post


Link to post
Share on other sites

Az megint csak attól függ, hogy milyen látogatottságú lesz a shop és mennyi terméket (tulajdonképp írott információt) viszel fel.

 

Időnként (ha a látogatottság megugrik) ki kell majd takarítani a db statisztikai tábláit, különben képes lesz átlépni a kvótát.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Tisztelt Attila,
most már a MediaCenter tárhelyén próbálkozom a telepítéssel. Náluk a Prestashop 1.6.1.8-ast nem kellett ftp-vel feltöltenem sem, elég volt a CMS-telepítőt kiválasztanom.
Elindítottam a Prestashop telepítőt, és pontosan ugyanúgy jártam, mint a múltkor az ingyenes tárhelyen. Az adatbázis kapcsolat rendben, settings.inc fájl létrehozása OK, Adatbázis táblák létrehozása megvan, majd leáll, az "Alapértelmezett bolt és nyelv létrehozása" hiba: 1. "Magyar (Hungarian)" nyelv telepítése sikertelen".

 

Mit javasolsz, hogyan tovább?

József

Share this post


Link to post
Share on other sites

Megtettem: letöltöttem az 1.6.1.8-at (zip), feltöltöttem a tárhelyre, kicsomagoltam. Adatbázist töröltem, létrehoztam egy újat más néven. Elindítottam a PS telepítést, és minden pontosan úgy történik, mint korábban, ugyanazzal a hibával leáll. Vagy valamit következetesen rosszul csinálok, vagy a telepítővel valami nincs rendben. Javaslat?

 

Share this post


Link to post
Share on other sites

Köszönöm az eddigi segítséget, tippeket!

Hozzám hasonló amatőröknek okulásul:
A szolgáltató(m)nál van egy kapcsoló a PHP beállításoknál, hogy biztonságos vs. teljes jogú futtatás. Itt kell engedélyezni az utóbbit. Így lefut a telepítő végig.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More