Jump to content

Recommended Posts

Estou tentando efetuar a atualização da minha loja que esta em 1.4.1 para 1.5.4.1 mais estou recebendo erros. Já tentei atualizar via modulo e manual mais sempre da erro. Já tentei atualizar para outras versões como 1.4.10 e 1.5.0 mais todas da o mesmo erro.

 

Alguém consegue me ajudar?

 

[ERROR] SQL 1.4.5.0 1054 in UPDATE `ps3__order_detail` SET `product_price` = `product_price` /( 1-(`group_reduction`/100)): Unknown column 'group_reduction' in 'field list'

[ERROR] SQL 1.4.5.0 1146 in ALTER TABLE `ps3__store` CHANGE `latitude` `latitude` DECIMAL(10, NULL DEFAULT NULL: Table 'multivideo.ps3__store' doesn't exist

[ERROR] SQL 1.4.5.0 1146 in ALTER TABLE `ps3__store` CHANGE `longitude` `longitude` DECIMAL(10, NULL DEFAULT NULL: Table 'multivideo.ps3__store' doesn't exist

[ERROR] SQL 1.4.5.0 1054 in INSERT INTO `ps3__hook` (`name`, `title`, `description`, `position`, `live_edit`) VALUES ('attributeGroupForm', 'Add fields to the form "attribute group"', 'Add fields to the form "attribute group"', 0, 0), ('afterSaveAttributeGroup', 'On saving attribute group', 'On saving attribute group', 0, 0), ('afterDeleteAttributeGroup', 'On deleting attribute group', 'On deleting "attribute group', 0, 0), ('featureForm', 'Add fields to the form "feature"', 'Add fields to the form "feature"', 0, 0), ('afterSaveFeature', 'On saving attribute feature', 'On saving attribute feature', 0, 0), ('afterDeleteFeature', 'On deleting attribute feature', 'On deleting attribute feature', 0, 0), ('afterSaveProduct', 'On saving products', 'On saving products', 0, 0), ('productListAssign', 'Assign product list to a category', 'Assign product list to a category', 0, 0), ('postProcessAttributeGroup', 'On post-process in admin attribute group', 'On post-process in admin attribute group', 0, 0), ('postProcessFeature', 'On post-process in admin feature', 'On post-process in admin feature', 0, 0), ('featureValueForm', 'Add fields to the form "feature value"', 'Add fields to the form "feature value"', 0, 0), ('postProcessFeatureValue', 'On post-process in admin feature value', 'On post-process in admin feature value', 0, 0), ('afterDeleteFeatureValue', 'On deleting attribute feature value', 'On deleting attribute feature value', 0, 0), ('afterSaveFeatureValue', 'On saving attribute feature value', 'On saving attribute feature value', 0, 0), ('attributeForm', 'Add fields to the form "feature value"', 'Add fields to the form "feature value"', 0, 0), ('postProcessAttribute', 'On post-process in admin feature value', 'On post-process in admin feature value', 0, 0), ('afterDeleteAttribute', 'On deleting attribute feature value', 'On deleting attribute feature value', 0, 0), ('afterSaveAttribute', 'On saving attribute feature value', 'On saving attribute feature value', 0, 0): Unknown column 'live_edit' in 'field list'

[ERROR] SQL 1.4.5.0 1054 in ALTER TABLE `ps3__employee` ADD `bo_show_screencast` TINYINT(1) NOT NULL DEFAULT '1' AFTER `bo_uimode`: Unknown column 'bo_uimode' in 'ps3__employee'

[ERROR] SQL 1.4.5.0 1054 in ALTER TABLE `ps3__lang` ADD `date_format_lite` char(32) NOT NULL DEFAULT 'Y-m-d' AFTER language_code: Unknown column 'language_code' in 'ps3__lang'

[ERROR] SQL 1.4.5.0 1054 in ALTER TABLE `ps3__lang` ADD `date_format_full` char(32) NOT NULL DEFAULT 'Y-m-d H:i:s' AFTER date_format_lite: Unknown column 'date_format_lite' in 'ps3__lang'

[ERROR] SQL 1.4.5.0 1054 in UPDATE `ps3__lang` SET `date_format_lite` = 'd/m/Y' WHERE `iso_code` IN ('fr', 'es', 'it'): Unknown column 'date_format_lite' in 'field list'

[ERROR] SQL 1.4.5.0 1054 in UPDATE `ps3__lang` SET `date_format_full` = 'd/m/Y H:i:s' WHERE `iso_code` IN ('fr', 'es', 'it'): Unknown column 'date_format_full' in 'field list'

[ERROR] SQL 1.4.5.0 1054 in UPDATE `ps3__lang` SET `date_format_lite` = 'd.m.Y' WHERE `iso_code` = 'de': Unknown column 'date_format_lite' in 'field list'

[ERROR] SQL 1.4.5.0 1054 in UPDATE `ps3__lang` SET `date_format_full` = 'd.m.Y H:i:s' WHERE `iso_code` = 'de': Unknown column 'date_format_full' in 'field list'

[ERROR] SQL 1.4.5.0 1054 in UPDATE `ps3__lang` SET `date_format_lite` = 'm/d/Y' WHERE `iso_code` = 'en': Unknown column 'date_format_lite' in 'field list'

[ERROR] SQL 1.4.5.0 1054 in UPDATE `ps3__lang` SET `date_format_full` = 'm/d/Y H:i:s' WHERE `iso_code` = 'en': Unknown column 'date_format_full' in 'field list'

[ERROR] SQL 1.4.5.0 1146 in ALTER IGNORE TABLE `ps3__specific_price_priority` ADD UNIQUE (`id_product`): Table 'multivideo.ps3__specific_price_priority' doesn't exist

[ERROR] SQL 1.4.6.0 1146 in ALTER TABLE `ps3__compare_product` DROP `id_compare_product` , DROP `id_guest` , DROP `id_customer`: Table 'multivideo.ps3__compare_product' doesn't exist

[ERROR] SQL 1.4.6.0 1146 in ALTER TABLE `ps3__compare_product` ADD `id_compare` int(10) unsigned NOT NULL, ADD PRIMARY KEY(`id_compare`, `id_product`): Table 'multivideo.ps3__compare_product' doesn't exist

[ERROR] SQL 1.4.6.0 1146 in ALTER TABLE `ps3__store` CHANGE `latitude` `latitude` DECIMAL(11, NULL DEFAULT NULL: Table 'multivideo.ps3__store' doesn't exist

[ERROR] SQL 1.4.6.0 1146 in ALTER TABLE `ps3__store` CHANGE `longitude` `longitude` DECIMAL(11, NULL DEFAULT NULL: Table 'multivideo.ps3__store' doesn't exist

[ERROR] SQL 1.4.6.0 1146 in ALTER TABLE `ps3__address_format` ADD PRIMARY KEY (`id_country`): Table 'multivideo.ps3__address_format' doesn't exist

[ERROR] SQL 1.4.6.0 1146 in ALTER TABLE `ps3__address_format` DROP INDEX `country`: Table 'multivideo.ps3__address_format' doesn't exist

[ERROR] SQL 1.4.7.0 1054 in INSERT INTO `ps3__hook` (`name`, `title`, `description`, `position`, `live_edit`) VALUES ('frontCanonicalRedirect', 'Front Canonical Redirect', 'Check for 404 errors before canonical redirects', 0, 0): Unknown column 'live_edit' in 'field list'

[ERROR] SQL 1.4.9.0 1091 in ALTER TABLE `ps3__category_product` DROP INDEX `category_product_index`, ADD PRIMARY KEY (`id_category`, `id_product`): Can't DROP 'category_product_index'; check that column/key exists

[ERROR] SQL 1.4.9.0 1146 in ALTER TABLE `ps3__cms_category_lang` DROP INDEX `category_lang_index`, ADD PRIMARY KEY (`id_cms_category`, `id_lang`): Table 'multivideo.ps3__cms_category_lang' doesn't exist

[ERROR] SQL 1.4.9.0 1060 in ALTER TABLE `ps3__order_tax` ADD `id_order_tax` INT UNSIGNED NOT NULL AUTO_INCREMENT PRIMARY KEY FIRST: Duplicate column name 'id_order_tax'

[ERROR] SQL 1.4.9.0 1072 in ALTER TABLE `ps3__category` ADD INDEX nleftrightactive (`nleft`, `nright`, `active`): Key column 'nleft' doesn't exist in table

[ERROR] SQL 1.4.9.0 1072 in ALTER TABLE `ps3__category` ADD INDEX nright (`nright`): Key column 'nright' doesn't exist in table

[ERROR] SQL 1.4.9.0 1072 in ALTER TABLE `ps3__category` ADD INDEX nleft (`nleft`): Key column 'nleft' doesn't exist in table

[ERROR] SQL 1.4.9.0 1146 in ALTER TABLE `ps3__specific_price` ADD INDEX from_quantity (`from_quantity`): Table 'multivideo.ps3__specific_price' doesn't exist

[ERROR] SQL 1.4.9.0 1054 in UPDATE `ps3__country` SET `zip_code_format` = 'NNNNN' WHERE `iso_code` = 'MC' LIMIT 1: Unknown column 'zip_code_format' in 'field list'

[ERROR] SQL 1.4.9.0 1146 in UPDATE `ps3__county_zip_code` SET `to_zip_code` = `from_zip_code` WHERE `to_zip_code` = 0: Table 'multivideo.ps3__county_zip_code' doesn't exist

[ERROR] SQL 1.4.10.0 1146 in ALTER TABLE `ps3__county_zip_code` CHANGE `from_zip_code` `from_zip_code` VARCHAR( 12 ) NOT NULL , CHANGE `to_zip_code` `to_zip_code` VARCHAR( 12 ) NOT NULL: Table 'multivideo.ps3__county_zip_code' doesn't exist

Warning detected during upgrade.

Share this post


Link to post
Share on other sites

Não são erros, mas warnings. Vc. deve deletar todos os modulos extras que estava usando em PS 1.4. e não fazem parte do Prestashop pacote original. Estes modulos não mais funcionam com PS 1.5.

Share this post


Link to post
Share on other sites

como já disse säao warnings e näao erros e vejo um monte deles de uma tabela que nao é original Prestashop - 'multivideo.ps3. Deleta os módulos que näao sao originais, eles nao mais funcionam em PS 1.5..X.

Share this post


Link to post
Share on other sites

Eu exclui todos os módulos, e tentei fazer a atualização. Mas mesmo assim esta dando erro. No final da atualização o sistema não funciona corretamente e um alerta no final da atualizações é exibindo pedindo para restaurar para a versão anterior.

Edited by tiagoandre (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More