Jump to content

errore 500 internal server error. Ma non sempre.


draxamita
 Share

Recommended Posts

Buongiorno a tutti!

Ho installato nuovo di pacca il prestashop 1.5.4.1 mi sono installato il mio bel tema... tutto ok a parte due fastidiosi problemi.

 

Il primo è il famoso 500 internal server error quando clicco sulle categorie o a volte sul carrello. Il problema, che mi fa perdere la testa, è che l'errore non me lo dà sempre. Per ore può funzionare bene, poi faccio un click... ed eccolo!! E se aggiorno la pagina ecco l'errore sparisce come mai esistito.

 

Mi chiedo se qualcuno di voi abbia sperimentato una cosa del genere e da cosa può dipendere visto che, se dipendesse da un errore del sito, l'errore ci sarebbe sempre e non ogni tanto.

 

 

Il secondo errore (ma forse merita un topic a parte) è "impossible to add the product to the cart" ma questo almeno è un errore che dà soddisfazione perché appare sempre e credo sia dovuto al tema... quindi contatto il tizio da cui ho comprato il tema e risolvo... ma questo internal server error a momenti alternati mi lascia senza parole...

 

Qualcuno può aiutarmi o darmi qualche suggerimento? Secondo voi potrebbe essere dovuto ad un hosting scarsino?

 

Grazie per ogni consiglio o opinione.

Share this post


Link to post
Share on other sites

si

 

anche a me faceva impazzire

 

e' dovuto a un hosting non ottimizzato per Prestashop, con risorse molto limitate

 

Serve un hosting ottimizzato, la differenza di prezzo non e' molta

Share this post


Link to post
Share on other sites

draxamita, come ha suggerito stefa38 al 99% dipende dall'hosting.

Se vuoi puoi provare la tua attuale configurazione con la nostra offerta "try, smile and buy" per prestashop e valutarne le prestazioni.

Share this post


Link to post
Share on other sites

Stesso identico problema sul mio sito www.thebigsales.it ....ci sto impazzendo!

 

Su categorie e prodotti, ogni 2x3 restituisce 500 internal error

Speriamo che il mio provider risolva in fretta!

Share this post


Link to post
Share on other sites

Ciao, riguardo al problema sopra esposto, ho visto nel mio error log sul server una sfilza di questi errori:

 

"mod_fcgid: stderr: PHP Fatal error: Function name must be a string in /tools/smarty/sysplugins/smarty_internal_templatebase.php on line 281"

 

penso sia proprio l'errore che genera il 500 internal server quando si clicca su prodotti o categorie. Sapete come risolverlo?

 

Spero proprio di si! Grazie a tutti

Share this post


Link to post
Share on other sites

Riguardo al problema sopra citato, io ho risolto (almeno temporaneamente) commentando la riga 281, ovvero:

 

$_template->properties['unifunc']($_template);

 

in

 

//$_template->properties['unifunc']($_template);

 

così funziona perfettamente.

 

Spero che possa essere d'aiuto magari in attesa di una soluzione più professionale ;)

Share this post


Link to post
Share on other sites

  • 2 months later...

ciao a tutti

anche io ho lo stesso problema, ma si estende anche ad alcuni passaggi del pagamento!

Le pagine statiche invece non sembrano interessate.

Ho provato a commentare la riga 281, ma è sparito il box delle categorie.

Inoltre non riesco a modificare le traduzioni di un modulo direttamente modificandoi il file it.php e caricandolo via ftp: appena cambio anche solo 2 parole il modulo funziona correttamente ma la pagina dei moduli del back office si ritrova con il template stravolto senza le funzionalità dei menù e con la lista delle categorie dei moduli messe in cima sopra alle descrizioni dei moduli stessi.

Devo modificare il modulo COD (contrassegno) descrivendo che è necessario un acconto.

Possono essere problemi legati uno all'altro? Può essere anche questo un problema dell'hosting?

Ho letto delle "limitazioni alle query orarie" ed io stando su Aruba immagino avrò un mare di limitazioni su svariate cose...

Domani telefono ad Aruba e vedo che mi dicono.

Se nel frattempo qualche anima pia fosse in grado di aiutarmi, vi sarei immensamente grato.

A presto

Share this post


Link to post
Share on other sites

  • 1 year later...

Salve ragazzi, io ho lo stesso problema dopo aver aggiornato un modulo: watermark

 

Tutto il sito sia da lato amministratore che da lato cliente non funziona più con il solo messaggio:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

ecc ecc ecc

 

 

 

Ho provato a cancellare la cartella (filigrana) tramite FTP, ma nulla.

Tramite BO, non posso accedere, in quanto il sito non esiste più...

come si risolve?

  • Like 1

Share this post


Link to post
Share on other sites

  • 8 months later...

Ciao a tutti, navigando sul sito ogni tanto genera l'errore 500. l'eorre viene genrato a random e ricaricando la stessa pagina, successivamente non viene più mostrato l'errore.

post-1119372-0-24351600-1451300478_thumb.png
qualcuno che possa aiutarmi?
Edited by locen (see edit history)

Share this post


Link to post
Share on other sites

  • 8 months later...

ciao, io mi ritrovo con problema per certi versi simile, però solo da telefonino mobile, a volte navigando le pagine dei prodotti saltuariamente sembra inpuntarsi mi esce la scritta "la pagina www.due...." non funziona, salvo poi ricaricarsi da sola dopo qualche secondo,  e un problema con la pagina di ritorno paypal, dopo fatto il pagamento regolarmente, non riesce piu a indirizzare la pagina di conferma e a volte leggo problema 500 , questo solo e dico solo da telefonino da desktop tutto ok.... Non riesco a capirci niente,,,,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More